les " dans indirect...

Le
Misange
Hello,

J'ai la formule ci-dessous qui fonctionne très bien
=SOMMEPROD((pipe!I96:I100)*(pipe!I44:I48))
avec indirect :
=SOMMEPROD((INDIRECT("pipe!I96:I100"))*INDIRECT("pipe!I44:I48"))
ça roule toujours

Le jeu consiste à remplacer les pipe!i44:i48 par
ADRESSE(44;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(48;(COLONNE()-4)/3+1;2)
et idem pour les I96:i100

et là rien ne va plus, et je fatigue mes mirettes à ne pas voir ce qui
débloque dans mes " (je pense que l'erreur vient de là).
Qui me prète ses yeux ? :-)
merci !
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jps
Le #4852941
tu m'excuseras si je ne réponds pas à ta question, misange, mais s'agissant
de pipes, mon anti-spam a spontanément mis ton message dans les Eléments
supprimés
jps

"Misange"
Hello,

J'ai la formule ci-dessous qui fonctionne très bien
=SOMMEPROD((pipe!I96:I100)*(pipe!I44:I48))
avec indirect :
=SOMMEPROD((INDIRECT("pipe!I96:I100"))*INDIRECT("pipe!I44:I48"))
ça roule toujours

Le jeu consiste à remplacer les pipe!i44:i48 par
ADRESSE(44;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(48;(COLONNE()-4)/3+1;2)
et idem pour les I96:i100

et là rien ne va plus, et je fatigue mes mirettes à ne pas voir ce qui
débloque dans mes " (je pense que l'erreur vient de là).
Qui me prète ses yeux ? :-)
merci !
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net


Misange
Le #4852911
c'est vrai que depuis la loi anti tabac, le mot est devenu tabou :-P

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

tu m'excuseras si je ne réponds pas à ta question, misange, mais
s'agissant de pipes, mon anti-spam a spontanément mis ton message dans
les Eléments supprimés
jps

"Misange"
Hello,

J'ai la formule ci-dessous qui fonctionne très bien
=SOMMEPROD((pipe!I96:I100)*(pipe!I44:I48))
avec indirect :
=SOMMEPROD((INDIRECT("pipe!I96:I100"))*INDIRECT("pipe!I44:I48"))
ça roule toujours

Le jeu consiste à remplacer les pipe!i44:i48 par
ADRESSE(44;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(48;(COLONNE()-4)/3+1;2)

et idem pour les I96:i100

et là rien ne va plus, et je fatigue mes mirettes à ne pas voir ce qui
débloque dans mes " (je pense que l'erreur vient de là).
Qui me prète ses yeux ? :-)
merci !
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net





isabelle
Le #4852901
bonjour florence,

en cellule AB1

­RESSE(44;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(48;(COLONNE()-4)/3+1;2)

en cellule AB2

­RESSE(96;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(100;(COLONNE()-4)/3+1;2)

en cellule AC1

=SOMMEPROD((INDIRECT(AB2))*(INDIRECT(AB1)))

cela fonctionne .

mais si on essaie de remplcer dans la formule AB1 et AB2 par le contenu respectif de chaque cellule ça ne fonctionne pas,
probablement trop volatile..

il faudrait peut être nommer les plages
=INDIRECT(ADRESSE(96;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(100;(COLONNE()-4)/3+1;2))
=INDIRECT(ADRESSE(96;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(100;(COLONNE()-4)/3+1;2))
=SOMMEPROD((plg1)*(plg2))

isabelle

Hello,

J'ai la formule ci-dessous qui fonctionne très bien
=SOMMEPROD((pipe!I96:I100)*(pipe!I44:I48))
avec indirect :
=SOMMEPROD((INDIRECT("pipe!I96:I100"))*INDIRECT("pipe!I44:I48"))
ça roule toujours

Le jeu consiste à remplacer les pipe!i44:i48 par
ADRESSE(44;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(48;(COLONNE()-4)/3+1;2)
et idem pour les I96:i100

et là rien ne va plus, et je fatigue mes mirettes à ne pas voir ce qui
débloque dans mes " (je pense que l'erreur vient de là).
Qui me prète ses yeux ? :-)
merci !


jps
Le #4852891
:-))))
jps

"Misange" %
c'est vrai que depuis la loi anti tabac, le mot est devenu tabou :-P

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

tu m'excuseras si je ne réponds pas à ta question, misange, mais
s'agissant de pipes, mon anti-spam a spontanément mis ton message dans
les Eléments supprimés
jps

"Misange"
Hello,

J'ai la formule ci-dessous qui fonctionne très bien
=SOMMEPROD((pipe!I96:I100)*(pipe!I44:I48))
avec indirect :
=SOMMEPROD((INDIRECT("pipe!I96:I100"))*INDIRECT("pipe!I44:I48"))
ça roule toujours

Le jeu consiste à remplacer les pipe!i44:i48 par
ADRESSE(44;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(48;(COLONNE()-4)/3+1;2)
et idem pour les I96:i100

et là rien ne va plus, et je fatigue mes mirettes à ne pas voir ce qui
débloque dans mes " (je pense que l'erreur vient de là).
Qui me prète ses yeux ? :-)
merci !
--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net







Misange
Le #4852881
Hello mon ange,
Tu ne m'arranges pas du tout mais tu me rassures: ce n'est donc pas un
micro climat chez moi ! J'ai essayé dans tous les sens en ajoutant des "
simples, doubles, doubles doubles, triples et même quadruple ! ... en vain
Nommer les plages, je vais y songer mais le problème c'est que j'en ai
des paquets comme ça ! et je ne peux pas faire un tableau intermédiaire.
Mais va falloir ruser de toutes façons vu que j'ai besoin du résultat !

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

bonjour florence,

en cellule AB1

­RESSE(44;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(48;(COLONNE()-4)/3+1;2)


en cellule AB2

­RESSE(96;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(100;(COLONNE()-4)/3+1;2)


en cellule AC1

=SOMMEPROD((INDIRECT(AB2))*(INDIRECT(AB1)))

cela fonctionne .

mais si on essaie de remplcer dans la formule AB1 et AB2 par le contenu
respectif de chaque cellule ça ne fonctionne pas,
probablement trop volatile..

il faudrait peut être nommer les plages
=INDIRECT(ADRESSE(96;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(100;(COLONNE()-4)/3+1;2))

=INDIRECT(ADRESSE(96;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(100;(COLONNE()-4)/3+1;2))

=SOMMEPROD((plg1)*(plg2))

isabelle

Hello,

J'ai la formule ci-dessous qui fonctionne très bien
=SOMMEPROD((pipe!I96:I100)*(pipe!I44:I48))
avec indirect :
=SOMMEPROD((INDIRECT("pipe!I96:I100"))*INDIRECT("pipe!I44:I48"))
ça roule toujours

Le jeu consiste à remplacer les pipe!i44:i48 par
ADRESSE(44;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(48;(COLONNE()-4)/3+1;2)

et idem pour les I96:i100

et là rien ne va plus, et je fatigue mes mirettes à ne pas voir ce qui
débloque dans mes " (je pense que l'erreur vient de là).
Qui me prète ses yeux ? :-)
merci !




MichDenis
Le #4852861
| J'ai la formule ci-dessous qui fonctionne très bien
| =SOMMEPROD((pipe!I96:I100)*(pipe!I44:I48))
| avec indirect :
| =SOMMEPROD((INDIRECT("pipe!I96:I100"))*INDIRECT("pipe!I44:I48"))
| ça roule toujours

| Le jeu consiste à remplacer les pipe!i44:i48 par
| ADRESSE(44;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(48;(COLONNE()-4)/3+1;2)
| et idem pour les I96:i100

Je n'ai rien testé... mais pourquoi dans ton dernier énoncé,
tu n'as pas de point d'exclamation après le mot pipe ....parce qu'il est tabou ?
isabelle
Le #4852831
salut Denis,

c'est en texte,

ADRESSE(no_lig;no_col;no_abs;a1;feuille_texte)

isabelle




| J'ai la formule ci-dessous qui fonctionne très bien
| =SOMMEPROD((pipe!I96:I100)*(pipe!I44:I48))
| avec indirect :
| =SOMMEPROD((INDIRECT("pipe!I96:I100"))*INDIRECT("pipe!I44:I48"))
| ça roule toujours

| Le jeu consiste à remplacer les pipe!i44:i48 par
| ADRESSE(44;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(48;(COLONNE()-4)/3+1;2)
| et idem pour les I96:i100

Je n'ai rien testé... mais pourquoi dans ton dernier énoncé,
tu n'as pas de point d'exclamation après le mot pipe ....parce qu'il est tabou ?






Misange
Le #4852801
exactly...
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

salut Denis,

c'est en texte,

ADRESSE(no_lig;no_col;no_abs;a1;feuille_texte)

isabelle




| J'ai la formule ci-dessous qui fonctionne très bien
| =SOMMEPROD((pipe!I96:I100)*(pipe!I44:I48))
| avec indirect :
| =SOMMEPROD((INDIRECT("pipe!I96:I100"))*INDIRECT("pipe!I44:I48"))
| ça roule toujours

| Le jeu consiste à remplacer les pipe!i44:i48 par
|
ADRESSE(44;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(48;(COLONNE()-4)/3+1;2)

| et idem pour les I96:i100

Je n'ai rien testé... mais pourquoi dans ton dernier énoncé,
tu n'as pas de point d'exclamation après le mot pipe ....parce qu'il
est tabou ?








Jp Pradier
Le #4852591
Bonjour Misange

A priori, Sommeprod() ou les matricielles n'aiment pas indirect().
Tu peux contourner en utilisant Somme.si() :

=SOMME.SI(INDIRECT(ADRESSE(44;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(48;(COLONNE()-4)/3+1;2));12;INDIRECT(ADRESSE(96;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(100;(COLONNE()-4)/3+1;2)))

Ca a l'air de fonctionner avec ton exemple.

j-p
Misange
Le #4852481
Bravo !
Curieux cette 'incompatibilité entre sommeprod et indirect. Caela dit,
mes conditions étant encore un peu plus compliquées, je vais passer par
des plages nommées comme suggéré par Isabelle.
Merci en tous cas à tous !
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Bonjour Misange

A priori, Sommeprod() ou les matricielles n'aiment pas indirect().
Tu peux contourner en utilisant Somme.si() :

=SOMME.SI(INDIRECT(ADRESSE(44;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(48;(COLONNE()-4)/3+1;2));12;INDIRECT(ADRESSE(96;(COLONNE()-4)/3+1;2;;"pipe")&":"&ADRESSE(100;(COLONNE()-4)/3+1;2)))

Ca a l'air de fonctionner avec ton exemple.

j-p




Publicité
Poster une réponse
Anonyme