Debian GNU/Linux wireless dhclient dns routeur

Le
tatane
Bonjour,

Je viens de déménager, j'utilise pour le moment une connexion wi-fi
open pour aller sur le web (point d'accès D-Link DSL-G624T).

Mon problème et le suivant, lorsque je lance mon dhclient le fichier
resolv.conf s'enrichit avec l'ip du dns du routeur (192.168.1.1) ce
qui est normal. Cette adresse ne fonctionne pas avec ma Etch
pourquoi ? Si je remplace cette adresse par l'adresse du FAI du point
d'accès tout rentre dans l'ordre .. Ce qui est fâcheux, c'est que
cela fonctionne directement sous Vista avec 192.168.1.1 (que je ne
veux pas utiliser)

Comment fait-on simplement pour spécifier le dns du FAI après la
requête dhcp de manière transparente ?
Où alors comment fait-on pour que cela fonctionne avec l'adresse DNS
du point d'accès ?

Merci de vos idées.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
sansflotusspam
Le #1917798
tatane wrote:

Bonjour,

Je viens de déménager, j'utilise pour le moment une connexion wi-fi
open pour aller sur le web (point d'accès D-Link DSL-G624T).

Mon problème et le suivant, lorsque je lance mon dhclient le fichier
resolv.conf s'enrichit avec l'ip du dns du routeur (192.168.1.1) ce
qui est normal. Cette adresse ne fonctionne pas avec ma Etch
pourquoi ? Si je remplace cette adresse par l'adresse du FAI du
point d'accès tout rentre dans l'ordre ..... Ce qui est fâcheux,
c'est que cela fonctionne directement sous Vista avec 192.168.1.1
(que je ne veux pas utiliser)

Comment fait-on simplement pour spécifier le dns du FAI après la
requête dhcp de manière transparente ?
Où alors comment fait-on pour que cela fonctionne avec l'adresse DNS
du point d'accès ?

Merci de vos idées.


en mettant l'IP du routeur (192.168.1.1) comme Gateway de l'interface
ethernet reliée au routeur ?

Pascal Hambourg
Le #1917795
Salut,


Je viens de déménager, j'utilise pour le moment une connexion wi-fi
open pour aller sur le web (point d'accès D-Link DSL-G624T).

Mon problème et le suivant, lorsque je lance mon dhclient le fichier
resolv.conf s'enrichit avec l'ip du dns du routeur (192.168.1.1) ce
qui est normal. Cette adresse ne fonctionne pas avec ma Etch
pourquoi ?


Toi seul peux le déterminer. Qu'entends-tu exactement par "ne fonctionne
pas" ? Cette adresse est-elle joignable en ARP et IP, répond-elle aux
requêtes DNS, n'est-elle pas filtrée d'une façon ou d'une autre par ta
machine ?

Si je remplace cette adresse par l'adresse du FAI du point
d'accès tout rentre dans l'ordre ..... Ce qui est fâcheux, c'est que
cela fonctionne directement sous Vista avec 192.168.1.1 (que je ne
veux pas utiliser)


Même machine, avec la même adresse IP ?

Comment fait-on simplement pour spécifier le dns du FAI après la
requête dhcp de manière transparente ?


Cf. le fil "DNS manuel en DHCP (Debian)" commencé le 15 janvier 2008.
Mots-clés : dhclient.conf, domain-name-servers, supersede, prepend.

tatane
Le #1917777
On 20 fév, 10:49, sansflotusspam
tatane wrote:
Bonjour,

Je viens de déménager, j'utilise pour le moment une connexion wi-fi
open pour aller sur le web (point d'accès D-Link DSL-G624T).

Mon problème et le suivant, lorsque je lance mon dhclient le fichier
resolv.conf s'enrichit avec l'ip du dns du routeur (192.168.1.1) ce
qui est normal. Cette adresse ne fonctionne pas avec ma Etch
pourquoi ? Si je remplace cette adresse par l'adresse du FAI du
point d'accès tout rentre dans l'ordre ..... Ce qui est fâcheux,
c'est que cela fonctionne directement sous Vista avec 192.168.1.1
(que je ne veux pas utiliser)

Comment fait-on simplement pour spécifier le dns du FAI après la
requête dhcp de manière transparente ?
Où alors comment fait-on pour que cela fonctionne avec l'adresse DNS
du point d'accès ?

Merci de vos idées.


en mettant l'IP du routeur (192.168.1.1) comme Gateway de l'interface
ethernet reliée au routeur ?


Merci de votre réponse, j'ai bien comme route 192.168.1.1 et D.N.S.
mais le dns ne semble pas fonctionner correctement du moins je
pense ...


tatane
Le #1917776
On 20 fév, 11:37, Pascal Hambourg wrote:
Salut,




Je viens de déménager, j'utilise pour le moment une connexion wi-fi
open pour aller sur le web (point d'accès D-Link DSL-G624T).

Mon problème et le suivant, lorsque je lance mon dhclient le fichier
resolv.conf s'enrichit avec l'ip du dns du routeur (192.168.1.1) ce
qui est normal. Cette adresse ne fonctionne pas avec ma Etch
pourquoi ?


Toi seul peux le déterminer. Qu'entends-tu exactement par "ne fonctionne
pas" ? Cette adresse est-elle joignable en ARP et IP, répond-elle aux
requêtes DNS, n'est-elle pas filtrée d'une façon ou d'une autre par ta
machine ?


Ben si j'ai nameserver 192.168.1.1 dans mon resolv.conf, le point
d'acces semble me renvoyer systématiquement 1.0.0.0 pour toutes les
résolutions.
Je pense qu'il y ai le moindre filtre, mais je peux me tromper.
Un ping sur le 192.168.1.1 fonctionne parfaitement, je peux aller sur
internet si il n'y pas pas besoin de résolution de nom. par exemple :
wget toto.fr ne fonctionne pas mais wget 93.28.x.x sera fonctionnel
Donc une requête DNS sur le point d'accès ne fonctionne pas.

Si je remplace cette adresse par l'adresse du FAI du point
d'accès tout rentre dans l'ordre ..... Ce qui est fâcheux, c'est que
cela fonctionne directement sous Vista avec 192.168.1.1 (que je ne
veux pas utiliser)


Même machine, avec la même adresse IP ?
Effectivement, même machine et même adresse IP


Comment fait-on simplement pour spécifier le dns du FAI après la
requête dhcp de manière transparente ?


Cf. le fil "DNS manuel en DHCP (Debian)" commencé le 15 janvier 2008.
Mots-clés : dhclient.conf, domain-name-servers, supersede, prepend.



Merci de ta réponse


Fabien LE LEZ
Le #1917775
On Tue, 19 Feb 2008 20:19:31 -0800 (PST), tatane :

lorsque je lance mon dhclient


As-tu réellement besoin de DHCP ?

Si tu as un portable, et que tu dois te connecter sur plusieurs
réseaux, DHCP aide bien.
Si tu dois allouer des adresses IP à plusieurs dizaines de machines,
DHCP est là aussi une bonne solution.

Si tu as un petit nombre de machines fixes, DHCP apporte beaucoup plus
de problèmes qu'il n'en résoud.

Pascal Hambourg
Le #1917773

Toi seul peux le déterminer. Qu'entends-tu exactement par "ne fonctionne
pas" ?


Ben si j'ai nameserver 192.168.1.1 dans mon resolv.conf, le point
d'acces semble me renvoyer systématiquement 1.0.0.0 pour toutes les
résolutions.


C'est original... Il me semble vaguement avoir déjà entendu parler d'un
cas similaire, mais impossible de me rappeler où. Il y aurait peut-être
une particularité dans les requêtes DNS du resolver de GNU/Linux qui
perturberait le relais DNS du routeur, ou vice versa. Que donnent des
outils d'interrogation DNS indépendants comme host, dig, nslookup ?


Pascal Hambourg
Le #1917772

Ben si j'ai nameserver 192.168.1.1 dans mon resolv.conf, le point
d'acces semble me renvoyer systématiquement 1.0.0.0 pour toutes les
résolutions.



Et que donnent les résolutions inverses adresse IP -> nom ?

C'est original... Il me semble vaguement avoir déjà entendu parler d'un
cas similaire, mais impossible de me rappeler où.


Ah si, je crois que je me souviens, c'était à cause des requêtes de type
AAAA (adresse IPv6) que fait le resolver quand l'IPv6 est activé sur la
machine. Je suppose que l'IPv6 est activé sur le Linux mais pas sur le
Windows ?

Il y aurait peut-être
une particularité dans les requêtes DNS du resolver de GNU/Linux qui
perturberait le relais DNS du routeur, ou vice versa. Que donnent des
outils d'interrogation DNS indépendants comme host, dig, nslookup ?


Si mon hypothèse est juste, des tests avec ces outils devraient le
confirmer.


Pascal Hambourg
Le #1917771

Ben si j'ai nameserver 192.168.1.1 dans mon resolv.conf, le point
d'acces semble me renvoyer systématiquement 1.0.0.0 pour toutes les
résolutions.



Ah si, je crois que je me souviens, c'était à cause des requêtes de type
AAAA (adresse IPv6) que fait le resolver quand l'IPv6 est activé sur la
machine. Je suppose que l'IPv6 est activé sur le Linux mais pas sur le
Windows ?


Cela semble se confirmer, voir au sujet d'un modem-routeur D-Link G604T, même marque donc. Le firmware
est-il à la dernière version ?



tatane
Le #1916638
On 20 fév, 23:50, Fabien LE LEZ
On Tue, 19 Feb 2008 20:19:31 -0800 (PST), tatane :

lorsque je lance mon dhclient


As-tu réellement besoin de DHCP ?

Si tu as un portable, et que tu dois te connecter sur plusieurs
réseaux, DHCP aide bien.
Si tu dois allouer des adresses IP à plusieurs dizaines de machines,
DHCP est là aussi une bonne solution.

Si tu as un petit nombre de machines fixes, DHCP apporte beaucoup plus
de problèmes qu'il n'en résoud.


Merci, mais le point d'accès où je suis connecté n'est pas à moi don c
je ne puis changer cela.
Par contre en principe, je suis toujours en static c'est vrai que
c'est mieux si le nombre de machines est restreint.


tatane
Le #1916637
On 21 fév, 10:46, Pascal Hambourg wrote:



Ben si j'ai nameserver 192.168.1.1 dans mon resolv.conf, le point
d'acces semble me renvoyer systématiquement 1.0.0.0 pour toutes les
résolutions.



Ah si, je crois que je me souviens, c'était à cause des requêtes d e type
AAAA (adresse IPv6) que fait le resolver quand l'IPv6 est activé sur l a
machine. Je suppose que l'IPv6 est activé sur le Linux mais pas sur le
Windows ?


Cela semble se confirmer, voir au sujet d'un modem-routeur D-Link G604T, même marque donc. Le firmware
est-il à la dernière version ?


Merci beaucoup pascal, tu as tapé dans le mille !
Effectivement, le problème vient bien ipv6. Sur la plate-forme windows
j'avais juste ipv4.
Sur la machine Debian, j'ai Blacklisté ipv6 et ça roule :)
Pour le firmware, je ne peu pas, l'AP n'est pas chez moi et pas il
n'est pas à moi. Mais je pourrai le faire, la personne qui le possède
n'a même pas pris le soin de changer le mot de passe par défaut. Je
profite de cette connexion le temps que Free active ma connexion DSL.

Merci encore !




Publicité
Poster une réponse
Anonyme