debian quelle version ?

Le
Frheremann
Quelle version préférer pour la debian actuelle: stable ? et puis ?

- stable-backports ?

- wheezy-backports ?

- stable updates ?


Y'a des conflits de partout dans les paquets, j'en peux plus, j'arrive
plus à upgrader debian depuis ma wheezy 7.5 en 64bit, par synaptic.

Je veux installer et pouvoir mettre à jour un maximum de programmes
_audio_ et _video_ (le reste je m'en fous :), ffmpeg audacious le
montage audio video la capture la conversion de formats etc

il me semblait que debian était la plus pratique des linux mais je
peux me tromper.

je veux installer par exemple les meilleurs players a/v (et si
possible jack en plus) et equalisers (comme le pulseaudio widescreen à
30 ? bandes )

depuis un certain temps je ne parvien plus à démarrer / ni à réinstaller
googleearth, je le fais tourner dans un virtualbox sur une kali ou
autre distrib 32 bits virtuelle, ça me pèle.

je n'ai qu'une contrainte c'est une carte ati radeon 5450, j'ai
besoin de sa sortie hdmi en 1080, je me méfie de ces
drivers qui parfois ne redémarrent plus après upgrade, quel driver
choisir le legacy ou le libre (de toutes façons il choisit lui-même
et je verrai bien après, jusqu'ici ça marchait mais quand j'upgrade,
le serveur X ne démarre plus, il parrait que je dois d'abord supprimer
la référence à fglrx de mon ixinit.conf (pas sur du nom exact du
fichier, peu importe), dois-je virer les deux occurences de fglrx
manuellement dans ce fichier ? J'ai pas essayé.

Debian, est-ce bien sérieux tous ces conflits de versions qui un
jour deviennent bloquants car les logiciels ne s'entendent plus avec
leur librairie, ou parce qu'un jour on a fait un upgrade sur une des
versions citées en haut ????
--
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal
Le #26334937
Le 20/01/2015 18:44, Frheremann a écrit :
Quelle version préférer pour la debian actuelle: stable ? et puis ?

- stable-backports ?

- wheezy-backports ?

- stable updates ?


Y'a des conflits de partout dans les paquets, j'en peux plus, j'arrive
plus à upgrader debian depuis ma wheezy 7.5 en 64bit, par synaptic.

Je veux installer et pouvoir mettre à jour un maximum de programmes
_audio_ et _video_ (le reste je m'en fous :), ffmpeg audacious le
montage audio video la capture la conversion de formats etc ...

il me semblait que debian était la plus pratique des linux mais je
peux me tromper.

je veux installer par exemple les meilleurs players a/v (et si
possible jack en plus) et equalisers (comme le pulseaudio widescreen à
30 ? bandes ) ...

depuis un certain temps je ne parvien plus à démarrer / ni à réinstaller
googleearth, je le fais tourner dans un virtualbox sur une kali ou
autre distrib 32 bits virtuelle, ça me pèle.

je n'ai qu'une contrainte c'est une carte ati radeon 5450, j'ai
besoin de sa sortie hdmi en 1080, je me méfie de ces
drivers qui parfois ne redémarrent plus après upgrade, quel driver
choisir le legacy ou le libre (de toutes façons il choisit lui-même
et je verrai bien après, jusqu'ici ça marchait mais quand j'upgrade,
le serveur X ne démarre plus, il parrait que je dois d'abord supprimer
la référence à fglrx de mon ixinit.conf (pas sur du nom exact du
fichier, peu importe), dois-je virer les deux occurences de fglrx
manuellement dans ce fichier ? J'ai pas essayé.

Debian, est-ce bien sérieux tous ces conflits de versions qui un
jour deviennent bloquants car les logiciels ne s'entendent plus avec
leur librairie, ou parce qu'un jour on a fait un upgrade sur une des
versions citées en haut ????



J'utilise sid (unstable) sans soucis
J'ai installé "apt-listbugs" pour surveiller si les mise à jour ne me
mettent pas trop de paquets bugués.
Jusqu'a aujourd'hui je n'ai pas trop à me plaindre
Franssoa
Le #26334948
Le 20. 01. 15 20:48, Pascal a écrit :
J'utilise sid (unstable) sans soucis
J'ai installé "apt-listbugs" pour surveiller si les mise à jour ne me
mettent pas trop de paquets bugués.
Jusqu'a aujourd'hui je n'ai pas trop à me plaindre



Sans vouloir trop polluer, j'ai une debian stable et je souhaiterai
passer à une instable, car je trouve que certains programmes sont dans
des versions trop anciennes. Est-ce douloureux comme manip ? Il y a-t-il
un guide de transition à me conseiller (hors www.google.com) ?

franssoa
yamo'
Le #26334950
Salut,

Franssoa a écrit le 20/01/2015 22:19 :
Le 20. 01. 15 20:48, Pascal a écrit :
J'utilise sid (unstable) sans soucis
J'ai installé "apt-listbugs" pour surveiller si les mise à jour ne me
mettent pas trop de paquets bugués.
Jusqu'a aujourd'hui je n'ai pas trop à me plaindre



Sans vouloir trop polluer, j'ai une debian stable et je souhaiterai
passer à une instable, car je trouve que certains programmes sont dans
des versions trop anciennes. Est-ce douloureux comme manip ? Il y a-t-il
un guide de transition à me conseiller (hors www.google.com) ?




Si tu veux réellement passer de stable à unstable.
Lire avant :
Je pense qu'il suffit de tripliquer tes entrées sauf celle en security
dans /etc/apt/sources.list avec testing et unstable puis le classique :
apt-get update && apt-get dist-upgrade

Et comme le dit Pascal apt-listbugs que j'installe aussi sur les
serveurs en debian stable peut éviter d'installer un paquet buggé mais
ce n'est pas une protection absolue.



Si tu veux juste quelques paquets plus à jour, il y a backport (seul le
paquet voulu et ses dépendances seront sur backport) :

Les paquets sont d'abord dans unstable puis testing et enfin backport. d


J'utilise testing depuis un moment (deux ans?) et à part qu'il faille
surveiller un peu lors des mises à jours, ça fonctionne bien mais c'est
pas nommé testing pour rien ;)


--
Stéphane
Passerelle web en version alpha :
Marc SCHAEFER
Le #26334985
Frheremann
Quelle version préférer pour la debian actuelle: stable ? et puis ?



Pour la vidéo wheezy + debian-multimedia.
Nicolas George
Le #26335032
Frheremann , dans le message
Quelle version préférer pour la debian actuelle: stable ? et puis ?



Ça dépend pour quoi faire.
Frheremann
Le #26335039
Marc SCHAEFER
Frheremann > Quelle version préférer pour la debian actuelle: stable ? et puis ?

Pour la vidéo wheezy + debian-multimedia.




Je suis passé en SID, mais ça ne me sert visiblement à rien, je ne suis
pas sur de pouvoir continuer. D'ailleurs il n'a pas vraiment upgradé,
1er exemple ffmpeg est resté en version 6, impossible d'upgrader, j'en
passe.

J'essaie d'installer listbugs, et ça recommence:

E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être
causé par les paquets devant être gardés en l'état. E: Erreur,
pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par
les paquets devant être gardés en l'état. E: Impossible de corriger les
dépendances E: Erreur, pkgProblem::Resolve a généré des ruptures, ce
qui a pu être causé par les paquets devant être gardés en l'état. E:
Impossible de corriger les dépendances

Auune expliquation ni solution, ça me dégoute, c'est toujours comme ça
que ça fini avec debian.

J'ai plus qu'à réinstaller, c'est pas sérieux. Je vais tenter le coup
en m'en tenant à SID et multimédia-sid, si ça ne marche pas je change
de cremerie. Le truc avec debian c'est que pour installer toutes les
applis voulues j'aurais besoin de deux ordis - et pour contenter ce
foutu google-earth je devrais même en avoir un en 32 bits, ça va pas
bien dans la tête chez ces gens là. Debian ça foire parce que des tordus
ne sont pas foutus de respecter les dependances et ce qui existe, et une
fois mal maj c'est foutu.
Frheremann
Le #26335042
Nicolas George
Frheremann , dans le message écrit :
> Quelle version préférer pour la debian actuelle: stable ? et puis ?

Ça dépend pour quoi faire.



Il me semble l'avoir dit: la carte écran Radeon 5450 pour deux écrans,
ensuite ffmpeg flash firefox streamtuner radiotray xbmc vlc audacious
audacity mhwave pulseaudio virtualbox libreoffice et .. google-earth,
j'en oublie, et peut-être jack, et wine et java mais ça je m'en fous, le
reste est passe-partout. Tout le basard audio-video conversion et
visionnage. J'ai l'habitude de visionner plein de trucs en même temps
avec radio ou tv en bruit de fond par streaming ... plus des webcam
(cheese, camorama) pour flasher toutes les X temps des trucs évolutifs
qui vivent dans ma cabine et en garder des planches contact (mes
poissons rouges).

Là je vais essayer kali, tango, en dur (pas virtuel), pourquoi pas.
Ubuntu c'est niet je ne suis pas fonctionnaire, et Mint j'ai pas
envie pour le reste je suis ... béant d'expectative.

Tous mes debian ont fini de la même façon, sur conflits de
dépendances, j'en ai marre.

J'en ai découvert une autre: le stream (radio, tv) sous kali ou tango en
virtuel fonctionne, mais une seule chaine à la fois sinon ça lagge, et
google-earth est horriblement lent, alors qu'avec une debian classique
en virtuel je n'ai aucune limite de //lélisme ni de perfs, rigolo.

Pour situer le matériel: dell dual-core intel 3ghz 4 gigas ram et pas
de tuning, juste un gros disque dur, ca fait une bonne bète flanquée de
cette très bonne ATI Radeon 5450, indispensable pour ma tv 1080 sans
scintillements ni lags, que du vieux et bon materiel.

Dis-moi .. Kali en multimédia ? Tango ça a de l'avenir ? Sinon
d'autres trucs à essayer ?

--
Frheremann
Le #26335061
Sergio
Le 21/01/2015 13:27, Frheremann a écrit :

> Je suis passé en SID, mais ça ne me sert visiblement à rien, je ne
> suis pas sur de pouvoir continuer. D'ailleurs il n'a pas vraiment
> upgradé, 1er exemple ffmpeg est resté en version 6, impossible
> d'upgrader, j'en passe.

C'est quoi cette version 6 ?

Chez moi :
$ ffmpeg -version
ffmpeg version 1.2.6-7:1.2.6-1~trusty1
built on Apr 26 2014 18:52:58 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)

récupéré sur le PPA (ça marche sous Debian ?) de Jon Severinsson
https://launchpad.net/~jon-severinsson

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org




J'en sais rien, c'est peut-être un reste de Lenny, debian 6 :-) :-)

Voilà, mais ne vous fatiguez pas c'est insoluble, il n .. y'a pas que
ffmpeg qui coince:

ffmpeg version 0.8.12-6:0.8.12-1, Copyright (c) 2000-2014 the Libav
developers built on Jun 1 2014 17:03:01 with gcc 4.7.2
*** THIS PROGRAM IS DEPRECATED ***
This program is only provided for compatibility and will be removed in
a future release. Please use avconv instead. ffmpeg 0.8.12-6:0.8.12-1
libavutil 51. 22. 2 / 51. 73.101
libavcodec 53. 35. 0 / 53. 35. 0
libavformat 53. 21. 1 / 53. 21. 1
libavdevice 53. 2. 0 / 53. 2. 0
libavfilter 2. 15. 0 / 2. 15. 0
libswscale 2. 1. 0 / 2. 1. 0
libpostproc 52. 0. 0 / 52. 0. 0

et sid me propose 10:2.5.3 -dmo1 mais ça ne passe pas, ffmpeg ça couche
avec trop de librairies genre libc6 ou que sais-je, merde le moteur
va encore tomber HS si je continue parce qu'après ca touche vite au
driver écran et là ça me bloque, ATI et fglrx sont trop sensibles.

... Et j'ai libavutil51 8:1.0.10-dmo1 (c'est sid), je ne sais pas si
ffmpeg est encore utilisé, je laisse comme ça, je vais purger pour
voir, et je vais faire des installs de quelques distribs ... kali,
tango, etc, ça peut marcher.

J'ai été induit en erreur dans les maj proposées pour wheezy (dans
synaptic), j'ai surement mis trop de depots au départ, je laisse tomber
pour cette erreur de la nature, j'aime plus Wheezy, Jessie ruleZ.
--
Christophe PEREZ
Le #26335060
Le Wed, 21 Jan 2015 12:50:39 +0000, Frheremann a écrit :

Tous mes debian ont fini de la même façon, sur conflits de dépendances,
j'en ai marre.



Ça n'apportera sans doute pas grand chose, et je n'ai jamais utilisé
debian, mais j'ai du mal à croire qu'un quelconque système de dépendance
s'y casse tout seul sans raison provenant de son usage.

J'avais eu ce genre de problèmes à mes débuts sous Mandrake, mais c'était
parce que je voulais installer des versions de softs plus récentes que ce
qui était proposé par la distribution, je prenais des packages à droite
et à gauche, et j'en faisait même moi-même. Forcément, au bout d'un
moment, tout explosait, et ma mandrake crevait de sa belle mort.

Les erreurs, ça arrive, mais ça ne doit arriver qu'une fois. On doit
tirer des leçons. Perso, je suis passé à Gentoo pour avoir une distrib en
perpétuelle évolution (au niveau des versions des softs), et je n'ai plus
JAMAIS eu ces problèmes. Depuis, je suis resté parfaitement fidèle à
Gentoo et n'ai jamais regretté mon choix.
Nicolas George
Le #26335429
mrr , dans le message écrit :
A propos de ffmpeg, j'ai entendu que ce ne serait pas présent dans la
prochaine version stable (en juin je crois, ce sera donc jessie), il y
aurait eu trop de bugs de sécurité non résolus...



L'histoire des bugs de sécurité est un prétexte.
Publicité
Poster une réponse
Anonyme