définir une cellule comme vide

Le
Jules
Bonjour à tous,

Une cellule contient un nombre réel. Je voudrais qu'une autre cellule
contienne ce nombre s'il est entier, et sinon que la cellule soit vide.
J'ai tenté (en supposant que A1 contienne le réel) :
= si (A1 = ent(A1) ; A1 ; ???)
Mais comment dire à Excel que, dans le deuxième cas, la cellule doit
être vide ?

d'avance merci
Jules
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #18130241
bonjour Jules,

=SI(MOD(A1;1)<>0;"";A1)

isabelle

Jules a écrit :
Bonjour à tous,

Une cellule contient un nombre réel. Je voudrais qu'une autre cellule
contienne ce nombre s'il est entier, et sinon que la cellule soit vide.
J'ai tenté (en supposant que A1 contienne le réel) :
= si (A1 = ent(A1) ; A1 ; ???)
Mais comment dire à Excel que, dans le deuxième cas, la cellule doit
être vide ?

d'avance merci
Jules


Patrick BASTARD
Le #18130231
Bonsoir, Jules.

Selon le précepte de Jacques II de Chabannes, une cellule contenant une
formule, quelle qu'elle soit, n'est pas vide.
;-)

Seule solution, àmha, passer par VBA.

--
L'alternative ne connait pas la solitude.
Bien ,

Patrick BASTARD
patrick.bastardchezdbmail.com

"Jules" news:
Bonjour à tous,

Une cellule contient un nombre réel. Je voudrais qu'une autre cellule
contienne ce nombre s'il est entier, et sinon que la cellule soit vide.
J'ai tenté (en supposant que A1 contienne le réel) :
= si (A1 = ent(A1) ; A1 ; ???)
Mais comment dire à Excel que, dans le deuxième cas, la cellule doit être
vide ?

d'avance merci
Jules



LSteph
Le #18130221
bonjour,

""

Cordialement.

--
lSteph

Jules a écrit :
Bonjour à tous,

Une cellule contient un nombre réel. Je voudrais qu'une autre cellule
contienne ce nombre s'il est entier, et sinon que la cellule soit vide.
J'ai tenté (en supposant que A1 contienne le réel) :
= si (A1 = ent(A1) ; A1 ; ???)
Mais comment dire à Excel que, dans le deuxième cas, la cellule doit
être vide ?

d'avance merci
Jules


StDonat
Le #18130211
bonjour
pour une cellule vide c'est: ""
dans ton cas cela donne:
= si (A1 = ent(A1) ; A1 ; "")

"Jules" wrote:

Bonjour à tous,

Une cellule contient un nombre réel. Je voudrais qu'une autre cellule
contienne ce nombre s'il est entier, et sinon que la cellule soit vide.
J'ai tenté (en supposant que A1 contienne le réel) :
= si (A1 = ent(A1) ; A1 ; ???)
Mais comment dire à Excel que, dans le deuxième cas, la cellule doit
être vide ?

d'avance merci
Jules



MV71
Le #18130191
Bonjour,
=SI(A1=ENT(A1);A1;"")
Salutations

"Jules" discussion :
Bonjour à tous,

Une cellule contient un nombre réel. Je voudrais qu'une autre cellule
contienne ce nombre s'il est entier, et sinon que la cellule soit vide.
J'ai tenté (en supposant que A1 contienne le réel) :
= si (A1 = ent(A1) ; A1 ; ???)
Mais comment dire à Excel que, dans le deuxième cas, la cellule doit être
vide ?

d'avance merci
Jules


LE TROLL
Le #18130341
Bonjour,

Je n'ai pas les commandes en tête, car ma tête est pleine, je ne peux
plus rien y entrer sans sortir autre chose, mais... il doit je crois y avoir
un truc qui te permet de faire un division dont tu récupère la partie
décimale, en tout cas ça existe en VB, alors si ta partie décimale est à 0
c'est que t'as un entier, mais teste avant que le nombre ne soit pas à 0,
car les ordinateurs n'aiment guère les division par 0 :o)

N'oublies pas d'aller voir mon site, pour Noël, pour mes oeuvres, mets
le son tu auras une musique qui détend...

Cordialement.

--
Merci beaucoup, au revoir et à bientôt :o)
------
Romans, logiciels, email, site personnel
http://irolog.free.fr/joe.htm
------------------------------------------------------------------------------------
"Jules"
| Bonjour à tous,
|
| Une cellule contient un nombre réel. Je voudrais qu'une autre cellule
| contienne ce nombre s'il est entier, et sinon que la cellule soit vide.
| J'ai tenté (en supposant que A1 contienne le réel) :
| = si (A1 = ent(A1) ; A1 ; ???)
| Mais comment dire à Excel que, dans le deuxième cas, la cellule doit
| être vide ?
|
| d'avance merci
| Jules
Yves73
Le #18130331
"Jules" news:
Bonjour à tous,

Une cellule contient un nombre réel. Je voudrais qu'une autre cellule
contienne ce nombre s'il est entier, et sinon que la cellule soit vide.
J'ai tenté (en supposant que A1 contienne le réel) :
= si (A1 = ent(A1) ; A1 ; ???)
Mais comment dire à Excel que, dans le deuxième cas, la cellule doit être
vide ?

d'avance merci
Jules



=si(A1 = ENT(A1);A1;"")
Je pense
Yves
Yves73
Le #18130491
"Yves73" news:
"Jules" news:
Bonjour à tous,

Une cellule contient un nombre réel. Je voudrais qu'une autre cellule
contienne ce nombre s'il est entier, et sinon que la cellule soit vide.
J'ai tenté (en supposant que A1 contienne le réel) :
= si (A1 = ent(A1) ; A1 ; ???)
Mais comment dire à Excel que, dans le deuxième cas, la cellule doit être
vide ?

d'avance merci
Jules



=si(A1 = ENT(A1);A1;"")
Je pense
Yves



Pour une fois que j'ai la solution !

Vous n'êtes pas sympas........

Yves
Publicité
Poster une réponse
Anonyme