Demande d'aide pour résoudre un bug d'affichage sur IE et sur Firefox

Le
fxbodin
Bonjour.

Avant de le résoudre j'aimerais déjà arriver à le reproduire sur une
autre machine que celle du client (et oui)

Il s'agit du site http://www.bordeaux-voiles.fr que je réalise sur une
base Wordpress.

J'ai mis en ligne (http://www.bordeaux-voiles.fr/bug.png) une copie
d'écran du problème sur Firefox, mais sur IE6 et sur IE7, c'est
rigoureusement pareil : la colonne de gauche (ici, contient une image
et une "petite" table bien pratique pour caler le contenu (oui, je
sais) cette colonne de gauche ne prend pas toute la place qu'elle
devrait.

J'ai testé de multiples configurations de IE 6 et 7, sur 2000, XP,
même Vista, et aussi sur FF PC et Mac (je travaille sur Mac) et
bien impossible de reproduire l'erreur : le site s'affiche
correctement, quelque soit la résolution d'écran (à partir de 800 de
large) Je me dis qu'elle peut venir du PC en question. Oui , mais
alors quoi ?

Merci d'avance à tous ceux que le cas intrigue assez pour s'y pencher.
--
François-Xavier Bodin


la feuille de style est là :
http://www.bordeaux-voiles.fr/wordpress/wp-content/themes/rouge/css/red.css
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
rm
Le #11064911
Le mardi 24 avril 2007 à 22:40, fxbodin a écrit :

Bonjour.



Salut,

Avant de le résoudre j'aimerais déjà arriver à le reproduire sur une
autre machine que celle... du client (et oui...)

Il s'agit du site http://www.bordeaux-voiles.fr que je réalise sur une
base Wordpress.

J'ai mis en ligne (http://www.bordeaux-voiles.fr/bug.png) une copie
d'écran du problème sur Firefox, mais sur IE6 et sur IE7, c'est
rigoureusement pareil : la colonne de gauche (ici, contient une image
et une "petite" table bien pratique pour caler le contenu (oui, je
sais...) cette colonne de gauche ne prend pas toute la place qu'elle
devrait.

J'ai testé de multiples configurations de IE 6 et 7, sur 2000, XP,
même Vista, et aussi sur FF PC et Mac (je travaille sur Mac)... et
bien impossible de reproduire l'erreur : le site s'affiche
correctement, quelque soit la résolution d'écran (à partir de 800 de
large...) Je me dis qu'elle peut venir du PC en question. Oui , mais
alors quoi ?

Merci d'avance à tous ceux que le cas intrigue assez pour s'y pencher.



menu Affichage > Taille du texte > normale
ou CTRL+0 pourrait améliorer les choses :)

Par contre sur mon IE7, le réglage de taille de texte n'a aucun effet sur
ce site alors que le zoom (texte+image) ne produit pas le "bug" décrit...

@+
--
rm - http://opera-fr.com
Cenekemoi
Le #11064861
Bonjour à rm
Le mardi 24 avril 2007 à 22:40, fxbodin a écrit :

Bonjour.



Salut,

Avant de le résoudre j'aimerais déjà arriver à le reproduire sur une
autre machine que celle... du client (et oui...)

Il s'agit du site http://www.bordeaux-voiles.fr que je réalise sur
une base Wordpress.

J'ai mis en ligne (http://www.bordeaux-voiles.fr/bug.png) une copie
d'écran du problème sur Firefox, mais sur IE6 et sur IE7, c'est
rigoureusement pareil : la colonne de gauche (ici, contient une image
et une "petite" table bien pratique pour caler le contenu (oui, je
sais...) cette colonne de gauche ne prend pas toute la place qu'elle
devrait.

J'ai testé de multiples configurations de IE 6 et 7, sur 2000, XP,
même Vista, et aussi sur FF PC et Mac (je travaille sur Mac)... et
bien impossible de reproduire l'erreur : le site s'affiche
correctement, quelque soit la résolution d'écran (à partir de 800 de
large...) Je me dis qu'elle peut venir du PC en question. Oui , mais
alors quoi ?

Merci d'avance à tous ceux que le cas intrigue assez pour s'y
pencher.



menu Affichage > Taille du texte > normale
ou CTRL+0 pourrait améliorer les choses :)

Par contre sur mon IE7, le réglage de taille de texte n'a aucun effet
sur ce site alors que le zoom (texte+image) ne produit pas le "bug"
décrit...

@+



Tu as raison, c'est bien la taille du texte qui crée le bug sous FF.

Toutefois, CTRL+0 n'est pas la bonne solution à terme. Il faudrait que
François-Xavier revoies un peu sa page d'accueil afin de supporter une
police plus grande par défaut : peut-être simplement un tableau à deux
colonnes sous le "div id=main_inner", ou bien peut-être plus simple :
enlever le "fixed" du même "div".

Tiens-nous au courant...

--
Cordialement, Thierry ;-)
fxbodin
Le #11064741
On 25 avr, 08:53, "Cenekemoi"
Bonjour à rm


> Le mardi 24 avril 2007 à 22:40, fxbodin a écrit :

>> Bonjour.

> Salut,

>> Avant de le résoudre j'aimerais déjà arriver à le reproduire s ur une
>> autre machine que celle... du client (et oui...)

>> Il s'agit du sitehttp://www.bordeaux-voiles.frque je réalise sur
>> une base Wordpress.

>> J'ai mis en ligne (http://www.bordeaux-voiles.fr/bug.png) une copie
>> d'écran du problème sur Firefox, mais sur IE6 et sur IE7, c'est
>> rigoureusement pareil : la colonne de gauche (ici, contient une image
>> et une "petite" table bien pratique pour caler le contenu (oui, je
>> sais...) cette colonne de gauche ne prend pas toute la place qu'elle
>> devrait.

>> J'ai testé de multiples configurations de IE 6 et 7, sur 2000, XP,
>> même Vista, et aussi sur FF PC et Mac (je travaille sur Mac)... et
>> bien impossible de reproduire l'erreur : le site s'affiche
>> correctement, quelque soit la résolution d'écran (à partir de 80 0 de
>> large...) Je me dis qu'elle peut venir du PC en question. Oui , mais
>> alors quoi ?

>> Merci d'avance à tous ceux que le cas intrigue assez pour s'y
>> pencher.

> menu Affichage > Taille du texte > normale
> ou CTRL+0 pourrait améliorer les choses :)

> Par contre sur mon IE7, le réglage de taille de texte n'a aucun effet
> sur ce site alors que le zoom (texte+image) ne produit pas le "bug"
> décrit...

> @+

Tu as raison, c'est bien la taille du texte qui crée le bug sous FF.

Toutefois, CTRL+0 n'est pas la bonne solution à terme. Il faudrait que
François-Xavier revoies un peu sa page d'accueil afin de supporter une
police plus grande par défaut : peut-être simplement un tableau à d eux
colonnes sous le "div id=main_inner", ou bien peut-être plus simple :
enlever le "fixed" du même "div".

Tiens-nous au courant...

--
Cordialement, Thierry ;-)




Merci à vous deux qui vous êtes penché sur mon pb.

Premier élément de solution : reproduire cet affichage invoulu.
J'ai trouvé. Dans la css, la taille de caractère était exprimée 1 ° en
fixe et 2° en pt. Ce qui explique que varier la taille du texte dans
le navigateur ne fonctionnait pas. Je suppose que, en plus, le
windows sur le PC de mon client, (mais alors pourquoi pas les
autres) ne reconnaît pas l'unité pt... ???

Bref, j'ai mis la police du body à 100% et là, le site s'affiche
partout avec le problème. Excellent début.

Puis j'ai crée une règle de taille pour le container principal : 0.75
em

Et voilà : il s'affiche (jusqu'à preuve du contraire) correctement sur
tous les navigateurs, y compris ceux de mon client !

Reste que, si l'utilisateur, s'il augmente maintenant la taille de la
police, va déterriorer l'affichage. La cause : l'élasticité de la
seule colonne de gauche... Encore une amélioration à trouver.

Encore merci.--
François-Xavier Bodin
Chef de produit Web / NTIC, Assistance à Maîtrise d'Ouvrage
http://www.fxbodin.com/fx/

9 rue Goubeau
33800 Bordeaux
06 62 33 52 74 - 05 56 91 33 82

Publicité
Poster une réponse
Anonyme