dependance de collectd

Le
Raphael Bauduin
--047d7b6d7cbcb1edd004eb86d061
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Bonjour,

lorsque j'ai voulu installer collectd ce matin sur un serveur wheezy, j'ai
eu comme liste de paquets à installer:

Les paquets supplémentaires suivants seront installés :
acl collectd-core colord consolekit dbus-x11 dconf-gsettings-backend
dconf-service fontconfig gconf-service gconf2 gconf2-common
hicolor-icon-theme libatk1.0-0 libatk1.0-data
libcairo-gobject2 libcairo2 libcanberra-gtk3-0 libcanberra-gtk3-module
libcanberra0 libck-connector0 libcolord1 libdatrie1 libdbi1
libdbus-glib-1-2 libdconf0 libesmtp6 libexif12
libfile-copy-recursive-perl libgconf-2-4 libgd2-xpm libgdk-pixbuf2.0-0
libgdk-pixbuf2.0-common libgphoto2-2 libgphoto2-l10n libgphoto2-port0
libgtk-3-0 libgtk-3-bin libgtk-3-common
libgudev-1.0-0 libgusb2 libhal1 libieee1284-3 libltdl7 liblua5.1-0
libmemcached10 libmodbus5 libmysqlclient18 libnotify4 libopenipmi0
liboping0 libpam-ck-connector libpango1.0-0
libperl5.14 libpolkit-agent-1-0 libpolkit-backend-1-0
libpolkit-gobject-1-0 libpq5 libprotobuf-c0 libpython2.7 librabbitmq0
librrd4 libsane libsane-common libsane-extras
libsane-extras-common libsensors4 libsnmp-base libsnmp15 libtdb1
libthai-data libthai0 libtokyocabinet9 libtokyotyrant3 libupsclient1
libv4l-0 libv4lconvert0 libvarnishapi1
libvorbisfile3 libxcb-render0 libxcb-shm0 libxcomposite1 libxcursor1
libxdamage1 libxfixes3 libxft2 libxinerama1 libxpm4 libxrandr2 libxrender1
mysql-common notification-daemon perl
perl-base perl-modules policykit-1 rrdtool sane-utils ttf-dejavu
ttf-dejavu-extra update-inetd


Comme cela me semblait beaucoup de paquet, j'ai un peu cherché, et notame=
nt
avec apt-rdepends qui affiche les dépendances de paquets (recursivement).
Or dans la liste donnée par apt-rdepends, il n'y a pas de trace de paquet
*canberra*:
apt-rdepends collectd | grep canberra
Idem pour libtokyocabinet9, libtokyotyrant3, libmysqlclient18, liblua5.1-0,
libprotobuf-c0, libgphoto2-2, etc,

Quelqu'un aurait-il une explication ou une suggestion quant à où cherch=
er?

Merci

Raphaël

--047d7b6d7cbcb1edd004eb86d061
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

<div dir="ltr">Bonjour,<br><br>lorsque j&#39;ai voulu installer collectd =
ce matin sur un serveur wheezy, j&#39;ai eu comme liste de paquets à inst=
aller:<br><br>Les paquets supplémentaires suivants seront installés :=
<br>  acl collectd-core colord consolekit dbus-x11 dconf-gsettings-backe=
nd dconf-service fontconfig gconf-service gconf2 gconf2-common hicolor-icon=
-theme libatk1.0-0 libatk1.0-data<br>
  libcairo-gobject2 libcairo2 libcanberra-gtk3-0 libcanberra-gtk3-module =
libcanberra0 libck-connector0 libcolord1 libdatrie1 libdbi1 libdbus-glib-1-=
2 libdconf0 libesmtp6 libexif12<br>  libfile-copy-recursive-perl libgconf=
-2-4 libgd2-xpm libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgphoto2-2 lib=
gphoto2-l10n libgphoto2-port0 libgtk-3-0 libgtk-3-bin libgtk-3-common<br>
  libgudev-1.0-0 libgusb2 libhal1 libieee1284-3 libltdl7 liblua5.1-0 libm=
emcached10 libmodbus5 libmysqlclient18 libnotify4 libopenipmi0 liboping0 li=
bpam-ck-connector libpango1.0-0<br>  libperl5.14 libpolkit-agent-1-0 libp=
olkit-backend-1-0 libpolkit-gobject-1-0 libpq5 libprotobuf-c0 libpython2.7 =
librabbitmq0 librrd4 libsane libsane-common libsane-extras<br>
  libsane-extras-common libsensors4 libsnmp-base libsnmp15 libtdb1 libtha=
i-data libthai0 libtokyocabinet9 libtokyotyrant3 libupsclient1 libv4l-0 lib=
v4lconvert0 libvarnishapi1<br>  libvorbisfile3 libxcb-render0 libxcb-shm0=
libxcomposite1 libxcursor1 libxdamage1 libxfixes3 libxft2 libxinerama1 lib=
xpm4 libxrandr2 libxrender1 mysql-common notification-daemon perl<br>
  perl-base perl-modules policykit-1 rrdtool sane-utils ttf-dejavu ttf-de=
javu-extra update-inetd<br><br><br>Comme cela me semblait beaucoup de paque=
t, j&#39;ai un peu cherché, et notament avec apt-rdepends qui affiche les=
dépendances de paquets (recursivement). Or dans la liste donnée par ap=
t-rdepends, il n&#39;y a pas de trace de paquet *canberra*:<br>
  apt-rdepends collectd | grep canberra<br>Idem pour libtokyocabinet9, li=
btokyotyrant3, libmysqlclient18, liblua5.1-0, libprotobuf-c0, libgphoto2-2,=
etc, <br><br>Quelqu&#39;un aurait-il une explication ou une suggestion =
quant à où chercher?<br>
<br>Merci<br><br>Raphaël<br></div>

--047d7b6d7cbcb1edd004eb86d061--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/CAONrwUHOQvPUDcDX5EDXJ=j93m+J9L9DNRNhPRUMoAjv1UbW1w@mail.gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain L. Sauvage
Le #25796702
Le mardi 19 novembre 2013 13:29:26 Raphael Bauduin a écrit :
Bonjour,



’jour,

lorsque j'ai voulu installer collectd ce matin sur un serveur
wheezy, j'ai eu comme liste de paquets à installer:
[…]
Comme cela me semblait beaucoup de paquet, j'ai un peu
cherché, et notament avec apt-rdepends qui affiche les
dépendances de paquets (recursivement). Or dans la liste
donnée par apt-rdepends, il n'y a pas de trace de paquet
*canberra*:
apt-rdepends collectd | grep canberra
Idem pour libtokyocabinet9, libtokyotyrant3, libmysqlclient18,
liblua5.1-0, libprotobuf-c0, libgphoto2-2, etc, ...

Quelqu'un aurait-il une explication ou une suggestion quant à
où chercher?



Pas une /suggestion/ mais une /recommandation/ : utiliser
l’option -fRecommends de apt-rdepends ou arrêter d’ installer
automatiquement les paquets /recommandés/ ;o)

(En clair : l’installation de libcanberra* vient d’un paquet
recommandé par une dépendance, pas d’une dépenda nce.)

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Raphael Bauduin
Le #25796692
--047d7b4721fe68c40704eb87e70b
Content-Type: text/plain; charset=windows-1252
Content-Transfer-Encoding: quoted-printable

2013/11/19 Sylvain L. Sauvage
Le mardi 19 novembre 2013 13:29:26 Raphael Bauduin a écrit :
> Bonjour,

’jour,

> lorsque j'ai voulu installer collectd ce matin sur un serveur
> wheezy, j'ai eu comme liste de paquets à installer:
>[…]
> Comme cela me semblait beaucoup de paquet, j'ai un peu
> cherché, et notament avec apt-rdepends qui affiche les
> dépendances de paquets (recursivement). Or dans la liste
> donnée par apt-rdepends, il n'y a pas de trace de paquet
> *canberra*:
> apt-rdepends collectd | grep canberra
> Idem pour libtokyocabinet9, libtokyotyrant3, libmysqlclient18,
> liblua5.1-0, libprotobuf-c0, libgphoto2-2, etc, ...
>
> Quelqu'un aurait-il une explication ou une suggestion quant à
> où chercher?

Pas une /suggestion/ mais une /recommandation/ : utiliser
l’option -fRecommends de apt-rdepends ou arrêter d’installer
automatiquement les paquets /recommandés/ ;o)

(En clair : l’installation de libcanberra* vient d’un paquet
recommandé par une dépendance, pas d’une dépendance.)




Exactement la réponse qu'il me fallait, merci!

Raph

--047d7b4721fe68c40704eb87e70b
Content-Type: text/html; charset=windows-1252
Content-Transfer-Encoding: quoted-printable

&gt; Bonjour,<br>
<div class="im"><br>
’jour,<br>
<br>
&gt; lorsque j&#39;ai voulu installer collectd ce matin sur un serveur<br>
&gt; wheezy, j&#39;ai eu comme liste de paquets à installer:<br>
</div>&gt;[…]<br>
<div class="im">&gt; Comme cela me semblait beaucoup de paquet, j&#39;ai un peu<br>
&gt; cherché, et notament avec apt-rdepends qui affiche les<br>
&gt; dépendances de paquets (recursivement). Or dans la liste<br>
&gt; donnée par apt-rdepends, il n&#39;y a pas de trace de paquet<br>
&gt; *canberra*:<br>
&gt;   apt-rdepends collectd | grep canberra<br>
&gt; Idem pour libtokyocabinet9, libtokyotyrant3, libmysqlclient18,<br>
&gt; liblua5.1-0, libprotobuf-c0, libgphoto2-2, etc, ...<br>
&gt;<br>
&gt; Quelqu&#39;un aurait-il une explication ou une suggestion quant à<br >
&gt; où chercher?<br>
<br>
</div>  Pas une /suggestion/ mais une /recommandation/ : utiliser<br>
l’option -fRecommends de apt-rdepends ou arrêter d’installer<br>
automatiquement les paquets /recommandés/ ;o)<br>
<br>
  (En clair : l’installation de libcanberra* vient d’un paquet<br>
recommandé par une dépendance, pas d’une dépendance.)<br>
<span class="HOEnZb"><font color="#888888"><br></font></span></blockquo te><div><br>Exactement la réponse qu&#39;il me fallait, merci!<br><br>Rap h<br></div></div><br></div></div>

--047d7b4721fe68c40704eb87e70b--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/CAONrwUHoLq_pVGHP2WrEkbîjjRdpSwKZGXLUVJd9+
Stéphane GARGOLY
Le #25798112
Bonjour à tous les utilisateurs et développeurs de Debian :

Le 19/11/2013, Raphael Bauduin
2013/11/19 Sylvain L. Sauvage
Le mardi 19 novembre 2013 13:29:26 Raphael Bauduin a écrit :
> lorsque j'ai voulu installer collectd ce matin sur un serveur
> wheezy, j'ai eu comme liste de paquets à installer:
>[…]
> Comme cela me semblait beaucoup de paquet, j'ai un peu
> cherché, et notament avec apt-rdepends qui affiche les
> dépendances de paquets (recursivement). Or dans la liste
> donnée par apt-rdepends, il n'y a pas de trace de paquet
> *canberra*:
> apt-rdepends collectd | grep canberra
> Idem pour libtokyocabinet9, libtokyotyrant3, libmysqlclient18,
> liblua5.1-0, libprotobuf-c0, libgphoto2-2, etc, ...
>
> Quelqu'un aurait-il une explication ou une suggestion quant à
> où chercher?

Pas une /suggestion/ mais une /recommandation/ : utiliser
l’option -fRecommends de apt-rdepends ou arrêter d’installer
automatiquement les paquets /recommandés/ ;o)

(En clair : l’installation de libcanberra* vient d’un paquet
recommandé par une dépendance, pas d’une dépendance.)




Exactement la réponse qu'il me fallait, merci!



Les Recommandations (ainsi que les Suggestions) ne sont pas
indispensables - contrairement aux "Dépendances" - pour le bon
fonctionnement du paquet qui les "demande".

Néanmoins, un petit conseil concernant les paquets recommandés : à mo ins
a) d'être à 100 % sûr qu'on n'ait pas besion des
fonctionnalités/extensions/documentations/etc offerts par chacune des
Recommandations (évidemment, il faut prendre le temps de lire la
description de ces paquets),
b) que une telle ou telle Recommandation est en conflit avec un autre
paquet déjà installé et jugé plus indispensable que la Recommandati on
en question et
c) qu'on ait un sérieux problème de place sur la partition oû sont
installés le paquets (en général, dans les répertoires /bin, /etc,
/lib, /sbin ou /usr),
je pense qu'il est préférable de les installer. ;-)

Cordialement et à bientôt,

Stéphane.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/CAAqHXE6VMmAhoaa1n+6f=SbJwtXRNPC=TWB=
Publicité
Poster une réponse
Anonyme