dépendances croisées insatisfaites sous Debian

Le
marc
Bonjour,

J'ai tenté d'installer NTFS-3G sur ma distribution Debian 4.0 r0.
L'installation échoue à cause d'une librairie ( libc6 )qui devrait être
en version >= 2.5-5 mais qui est en fait en version 2.3.6.ds1-13
Celle-ci ne peut être mise à jour à cause de tzdata qui crée des
dépendances et que je ne peux pas désinstaller.
A partir de là, j'ai un peu joué à l'apprenti sorcier :-(((

J'ai essayé de résoudre les problèmes de version des différentes
librairies et j'ai installé libgcc1 qui était nécessaire pour NTFS-3G.
Hors cette librairie, bien que maintenant mise à jour, provoque des
conflits de dépendance que je n'arrive pas à résoudre:
J'ai lancé apt-get check
et j'obtiens les messages suivants:

Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
libgcc1: Dépend: libc6 (>= 2.5-5) mais 2.3.6.ds1-13 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
PC-MARC:/home/marc# apt-get -f install
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
Correction des dépendances Fait
Les paquets suivants seront ENLEVÉS :
-
-
Là, je tronque car il m'indique que 497 paquets seront désinstallés.

A ce niveau là, je ne sais plus comment tout remettre au carré sans tout
réinstaller!

Merci d'avance de vos conseils
--

M@rc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas S.
Le #1895459
Bonjour,


Bonsoir,

J'ai essayé de résoudre les problèmes de version des différentes
librairies et j'ai installé libgcc1 qui était nécessaire pour NTFS-3G.
Hors cette librairie, bien que maintenant mise à jour, provoque des
conflits de dépendance que je n'arrive pas à résoudre:


http://www.commentcamarche.net/forum/affich-2751961-debian-driver-ntfs-3g

PC-MARC:/home/marc# apt-get -f install


[...]

Là, je tronque car il m'indique que 497 paquets seront désinstallés.

A ce niveau là, je ne sais plus comment tout remettre au carré sans tout
réinstaller!


Tu as exécuté l'apt-get ou pas?

--
Nicolas S.

marc T
Le #1895456
Bonjour,


Bonsoir,

J'ai essayé de résoudre les problèmes de version des différentes
librairies et j'ai installé libgcc1 qui était nécessaire pour NTFS-3G.
Hors cette librairie, bien que maintenant mise à jour, provoque des
conflits de dépendance que je n'arrive pas à résoudre:


http://www.commentcamarche.net/forum/affich-2751961-debian-driver-ntfs-3g



merci du lien, je vais l'étudier tranquillement.

Tu as exécuté l'apt-get ou pas?

oui mais je me suis arrêté avant la désinstallation de quasiment tout!


J'ai finalement réussi à tout remettre carré en recopiant les librairies
de mon disque de sauvegarde une par une.
Cela dit, maintenant ça marche, mais je n'ai pas installé NTFS-3G!


--




Sébastien Kirche
Le #1895430
Le 13 juillet 2007 à 19:51, marc T. a dit :

J'ai finalement réussi à tout remettre carré en recopiant les
librairies de mon disque de sauvegarde une par une.


Argl ! Et maintenant tu as le système de paquet en vrac. :(
Tu as des libs installées mais apt ne les connaît pas.

Cela dit, maintenant ça marche, mais je n'ai pas installé NTFS-3G!


Tu devrais relancer la commande pour l'installer, et remettre les
dépendances que tu as copié à la main.

--
Sébastien Kirche

LENHOF Jean-Yves
Le #1896651
Le Thu, 12 Jul 2007 19:21:54 +0200, marc a écrit:

Bonjour,

J'ai tenté d'installer NTFS-3G sur ma distribution Debian 4.0 r0.
L'installation échoue à cause d'une librairie ( libc6 )qui devrait être
en version >= 2.5-5 mais qui est en fait en version 2.3.6.ds1-13
Celle-ci ne peut être mise à jour à cause de tzdata qui crée des
dépendances et que je ne peux pas désinstaller.
A partir de là, j'ai un peu joué à l'apprenti sorcier :-(((


Une autre piste de réflexion...

http://www.debianhelp.org/node/8346

Je te conseille donc d'installer un kernel > 2.6.20.... make-kpkg est ton
ami... ou encore il semble exister un backport de cette version de kernel

Ensuite tu pourras essayer de backporter le package en le recompilant dans
ton environnement... ou au pire le compiler à partir des sources

Cordialement,

Publicité
Poster une réponse
Anonyme