Dernière ligne renseignée au dessus dans colonne

Le
David Vincent
Bonjour,

je voudrai renseigner A4 avec la dernière cellule renseignée en colonne H au
dessus de la ligne 4 (dans ce cas présent H1)

Mais voila, je ne trouve pas En fait présenté autrement je voudrai
reporter comme suit:

si (H4= 0;0;(formule pour retrouver H1))

A B C D E
F G H
01/01/2009 Dupond Location 523 800
02/01/2009 Vermeil Courtoisie
03/01/2009 Vermeil Courtoisie
04/01/2009 Vermeil Courtoisie 800 1 000


Merci d'avance pour votre aide

DV
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Misange
Le #18324151
Bonjour

pas sure d'avoir compris le pb
en A4: =si(H4= 0;0;H1) !
jouer avec les $ pour figer éventuellement les lignes et les colonnes
(ou les deux).

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

David Vincent a écrit :
Bonjour,

je voudrai renseigner A4 avec la dernière cellule renseignée en colonne H au
dessus de la ligne 4 (dans ce cas présent H1)

Mais voila, je ne trouve pas... En fait présenté autrement je voudrai
reporter comme suit:

si (H4= 0;0;(formule pour retrouver H1))

A B C D E
F G H
01/01/2009 Dupond Location 523 800
02/01/2009 Vermeil Courtoisie
03/01/2009 Vermeil Courtoisie
04/01/2009 Vermeil Courtoisie 800 1 000


Merci d'avance pour votre aide

DV




David Vincent
Le #18326271
Bonsoir Misange,

en fait le soucis est de trouver la formule remplaçant H1...

c'est à dire quand tu écris:
A4: =si(H4= 0;0;H1)

au lieu de H1, il me faut une formule qui est pour résultat la première
cellule non vide au dessus de H4 (dans le cas présent = H1)
Ca pourrait-être aussi bien H2 que H3...

Cordialement

DV
michdenis
Le #18326891
Tu veux quelque chose comme :

Validation matricielle : Ctrl + Maj + Enter
=SI(A4=0;0;INDIRECT(ADRESSE(MAX(SI(H4:H500<>"";LIGNE(H4:H500)));8)))



"David Vincent" news: 4964eaad$0$18381$
Bonsoir Misange,

en fait le soucis est de trouver la formule remplaçant H1...

c'est à dire quand tu écris:
A4: =si(H4= 0;0;H1)

au lieu de H1, il me faut une formule qui est pour résultat la première
cellule non vide au dessus de H4 (dans le cas présent = H1)
Ca pourrait-être aussi bien H2 que H3...

Cordialement

DV
David Vincent
Le #18327011
Bonsoir Michdenis

Je vais poser le pb de façon différente

En fait je veux reporter une cellule.

A B
1 100 200
2 Rien Rien
3 200 300

Donc si rien en colonne B alors rien en A
Si chiffre en B alors en A je reporte dernière cellule non vide en B mais au
dessus, dans le cas présent je reporte 200 en a3.

En espérant avoir été plus clair

Cordialement

DV
David Vincent
Le #18329561
Bonsoir Michdenis
Après 2 heures de galère j'ai compris
j'ai transformé comme suit et ça marche
En fait j'ai pas tout compris mais l'objectif est atteint...

=SI(F14=0;0;INDIRECT(ADRESSE(MAX(SI(F$6:F13<>"";LIGNE(F$6:F13)));6)))
avec CTRL MAJ Enter

MERCI

DV
Publicité
Poster une réponse
Anonyme