Deuuxième max

Le
Clochard
Bonjour,

Je cherche à inscrire le nom des trois meilleurs pointage d'un groupe

Avec cette formule j'obtiens le premier max dans une plage

=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);1));GRANDE.VALEUR((BK$22:BM$44);1);"")

Et avec celui-ci le deuxième
=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);2));GRANDE.VALEUR((BK$22:BM$44);2);"")

Ensuite avec celle-ci le nom de la personne du premier max

=SI(BL58="";"";INDEX($B$22:$B$44;MAX((Champ26=BL58)*LIGNE(Champ26))-LIGNE(Champ26)+1))--

Ma question est
Lorsque j'ai deux fois le même montant de max pour deux personnes
différentes j'arrive pas a obtenir le nom du deuxième max ma formule me
donne deux fois le nom de la première personne au plus haut pointage mais pas
la suivante que faire SVP
Clochard
Aimerais bien savoir.
Merci!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ellimac
Le #5389571
Bonjour,

Récupéré sur ce forum en sélectionnant la plage nécessaire
=SI(LIGNE()-1>SOMMEPROD((DECALER(Montants;;;;)=MAX(Montants))*1);"";INDEX(Noms;MIN(SI(Montants=MAX(Montants);INDEX(LIGNE(Montants);PETITE.VALEUR(SI(DECALER(Montants;;;;1)=MAX(Montants);1+LIGNE(Montants)-CELLULE("ligne";Montants));LIGNE()-1));""))-1))

A valider en matricielle

Camille


Bonjour,

Je cherche à inscrire le nom des trois meilleurs pointage d'un groupe

Avec cette formule j'obtiens le premier max dans une plage

=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);1));GRANDE.VALEUR((BK$22:BM$44);1);"")

Et avec celui-ci le deuxième...
=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);2));GRANDE.VALEUR((BK$22:BM$44);2);"")

Ensuite avec celle-ci le nom de la personne du premier max

=SI(BL58="";"";INDEX($B$22:$B$44;MAX((Champ26=BL58)*LIGNE(Champ26))-LIGNE(Champ26)+1))--

Ma question est
Lorsque j'ai deux fois le même montant de max pour deux personnes
différentes j'arrive pas a obtenir le nom du deuxième max... ma formule me
donne deux fois le nom de la première personne au plus haut pointage mais pas
la suivante... que faire SVP
Clochard
Aimerais bien savoir....
Merci!


Clochard
Le #5389551
Merci Ellimac

Je dois quitter mais à mon retour j't'en donne des nouvelles...
--
Clochard
Aimerais bien savoir....
Merci!



Bonjour,

Récupéré sur ce forum en sélectionnant la plage nécessaire :
=SI(LIGNE()-1>SOMMEPROD((DECALER(Montants;;;;)=MAX(Montants))*1);"";INDEX(Noms;MIN(SI(Montants=MAX(Montants);INDEX(LIGNE(Montants);PETITE.VALEUR(SI(DECALER(Montants;;;;1)=MAX(Montants);1+LIGNE(Montants)-CELLULE("ligne";Montants));LIGNE()-1));""))-1))

A valider en matricielle

Camille


Bonjour,

Je cherche à inscrire le nom des trois meilleurs pointage d'un groupe

Avec cette formule j'obtiens le premier max dans une plage

=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);1));GRANDE.VALEUR((BK$22:BM$44);1);"")

Et avec celui-ci le deuxième...
=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);2));GRANDE.VALEUR((BK$22:BM$44);2);"")

Ensuite avec celle-ci le nom de la personne du premier max

=SI(BL58="";"";INDEX($B$22:$B$44;MAX((Champ26=BL58)*LIGNE(Champ26))-LIGNE(Champ26)+1))--

Ma question est
Lorsque j'ai deux fois le même montant de max pour deux personnes
différentes j'arrive pas a obtenir le nom du deuxième max... ma formule me
donne deux fois le nom de la première personne au plus haut pointage mais pas
la suivante... que faire SVP
Clochard
Aimerais bien savoir....
Merci!




JB
Le #5389541
Bonjour,

-Sélectionner 3 cellules
=INDEX(nom;EQUIV(GRANDE.VALEUR(Ca-LIGNE(Ca)/10^10;{1;2;3});Ca-
LIGNE(Ca)/10^10;0))
-Valider avec Maj+Ctrl+Entrée

http://boisgontierjacques.free.fr/fichiers/Matriciel/Top5Egalite.xls

JB

On 1 déc, 16:22, Clochard
Bonjour,

Je cherche à inscrire le nom des trois meilleurs pointage d'un groupe

Avec cette formule j'obtiens le premier max dans une plage

=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);1));GRANDE.VALEUR((BK$22:BM$44);1 );"-")

Et avec celui-ci le deuxième...
=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);2));GRANDE.VALEUR((BK$22:BM$44);2 );"-")

Ensuite avec celle-ci le nom de la personne du premier max

=SI(BL58="";"";INDEX($B$22:$B$44;MAX((Champ26=BL58)*LIGNE(Champ26))- LIGNE(C-hamp26)+1))--

Ma question est
Lorsque j'ai deux fois le même montant de max pour deux personnes
différentes j'arrive pas a obtenir le nom du deuxième max... ma formul e me
donne deux fois le nom de la première personne au plus haut pointage mai s pas
la suivante... que faire SVP
Clochard
Aimerais bien savoir....
Merci!


Clochard
Le #5389221
Merci JB aussi,

Mais pour mieux expliquer mon problème j'ai joint un fichier exemple

http://cjoint.com/?mbwU1NpBMq
--
Clochard
Aimerais bien savoir....
Merci!



Bonjour,

-Sélectionner 3 cellules
=INDEX(nom;EQUIV(GRANDE.VALEUR(Ca-LIGNE(Ca)/10^10;{1;2;3});Ca-
LIGNE(Ca)/10^10;0))
-Valider avec Maj+Ctrl+Entrée

http://boisgontierjacques.free.fr/fichiers/Matriciel/Top5Egalite.xls

JB

On 1 déc, 16:22, Clochard
Bonjour,

Je cherche à inscrire le nom des trois meilleurs pointage d'un groupe

Avec cette formule j'obtiens le premier max dans une plage

=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);1));GRANDE.VALEUR((BK$22:BM$44);1);"-")

Et avec celui-ci le deuxième...
=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);2));GRANDE.VALEUR((BK$22:BM$44);2);"-")

Ensuite avec celle-ci le nom de la personne du premier max

=SI(BL58="";"";INDEX($B$22:$B$44;MAX((Champ26=BL58)*LIGNE(Champ26))-LIGNE(C-hamp26)+1))--

Ma question est
Lorsque j'ai deux fois le même montant de max pour deux personnes
différentes j'arrive pas a obtenir le nom du deuxième max... ma formule me
donne deux fois le nom de la première personne au plus haut pointage mais pas
la suivante... que faire SVP
Clochard
Aimerais bien savoir....
Merci!






Clochard
Le #5389201
Correction d'une cellule.... s'cusez....

http://cjoint.com/?mbw1azsUZX
--
Clochard
Aimerais bien savoir....
Merci!



Merci JB aussi,

Mais pour mieux expliquer mon problème j'ai joint un fichier exemple

http://cjoint.com/?mbwU1NpBMq
--
Clochard
Aimerais bien savoir....
Merci!



Bonjour,

-Sélectionner 3 cellules
=INDEX(nom;EQUIV(GRANDE.VALEUR(Ca-LIGNE(Ca)/10^10;{1;2;3});Ca-
LIGNE(Ca)/10^10;0))
-Valider avec Maj+Ctrl+Entrée

http://boisgontierjacques.free.fr/fichiers/Matriciel/Top5Egalite.xls

JB

On 1 déc, 16:22, Clochard
Bonjour,

Je cherche à inscrire le nom des trois meilleurs pointage d'un groupe

Avec cette formule j'obtiens le premier max dans une plage

=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);1));GRANDE.VALEUR((BK$22:BM$44);1);"-")

Et avec celui-ci le deuxième...
=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);2));GRANDE.VALEUR((BK$22:BM$44);2);"-")

Ensuite avec celle-ci le nom de la personne du premier max

=SI(BL58="";"";INDEX($B$22:$B$44;MAX((Champ26=BL58)*LIGNE(Champ26))-LIGNE(C-hamp26)+1))--

Ma question est
Lorsque j'ai deux fois le même montant de max pour deux personnes
différentes j'arrive pas a obtenir le nom du deuxième max... ma formule me
donne deux fois le nom de la première personne au plus haut pointage mais pas
la suivante... que faire SVP
Clochard
Aimerais bien savoir....
Merci!








Daniel.C
Le #5389151
Bonjour.
Regarde :
http://cjoint.com/?mcjoiGh5As
Cordialement.
Daniel
"Clochard"
Correction d'une cellule.... s'cusez....

http://cjoint.com/?mbw1azsUZX
--
Clochard
Aimerais bien savoir....
Merci!



Merci JB aussi,

Mais pour mieux expliquer mon problème j'ai joint un fichier exemple

http://cjoint.com/?mbwU1NpBMq
--
Clochard
Aimerais bien savoir....
Merci!



Bonjour,

-Sélectionner 3 cellules
=INDEX(nom;EQUIV(GRANDE.VALEUR(Ca-LIGNE(Ca)/10^10;{1;2;3});Ca-
LIGNE(Ca)/10^10;0))
-Valider avec Maj+Ctrl+Entrée

http://boisgontierjacques.free.fr/fichiers/Matriciel/Top5Egalite.xls

JB

On 1 déc, 16:22, Clochard
Bonjour,

Je cherche à inscrire le nom des trois meilleurs pointage d'un groupe

Avec cette formule j'obtiens le premier max dans une plage

=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);1));GRANDE.VALEUR((BK$22:BM$44);1);"-")

Et avec celui-ci le deuxième...
=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);2));GRANDE.VALEUR((BK$22:BM$44);2);"-")

Ensuite avec celle-ci le nom de la personne du premier max

=SI(BL58="";"";INDEX($B$22:$B$44;MAX((Champ26=BL58)*LIGNE(Champ26))-LIGNE(C-hamp26)+1))--

Ma question est
Lorsque j'ai deux fois le même montant de max pour deux personnes
différentes j'arrive pas a obtenir le nom du deuxième max... ma
formule me
donne deux fois le nom de la première personne au plus haut pointage
mais pas
la suivante... que faire SVP
Clochard
Aimerais bien savoir....
Merci!










Clochard
Le #5388891
Merci beaucoup Daniel

C'est exactement ce que je cherchais comme résultat...

C'est grandement apprécié
--
Clochard

Merci!



Bonjour.
Regarde :
http://cjoint.com/?mcjoiGh5As
Cordialement.
Daniel
"Clochard"
Correction d'une cellule.... s'cusez....

http://cjoint.com/?mbw1azsUZX
--
Clochard
Aimerais bien savoir....
Merci!



Merci JB aussi,

Mais pour mieux expliquer mon problème j'ai joint un fichier exemple

http://cjoint.com/?mbwU1NpBMq
--
Clochard
Aimerais bien savoir....
Merci!



Bonjour,

-Sélectionner 3 cellules
=INDEX(nom;EQUIV(GRANDE.VALEUR(Ca-LIGNE(Ca)/10^10;{1;2;3});Ca-
LIGNE(Ca)/10^10;0))
-Valider avec Maj+Ctrl+Entrée

http://boisgontierjacques.free.fr/fichiers/Matriciel/Top5Egalite.xls

JB

On 1 déc, 16:22, Clochard
Bonjour,

Je cherche à inscrire le nom des trois meilleurs pointage d'un groupe

Avec cette formule j'obtiens le premier max dans une plage

=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);1));GRANDE.VALEUR((BK$22:BM$44);1);"-")

Et avec celui-ci le deuxième...
=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);2));GRANDE.VALEUR((BK$22:BM$44);2);"-")

Ensuite avec celle-ci le nom de la personne du premier max

=SI(BL58="";"";INDEX($B$22:$B$44;MAX((Champ26=BL58)*LIGNE(Champ26))-LIGNE(C-hamp26)+1))--

Ma question est
Lorsque j'ai deux fois le même montant de max pour deux personnes
différentes j'arrive pas a obtenir le nom du deuxième max... ma
formule me
donne deux fois le nom de la première personne au plus haut pointage
mais pas
la suivante... que faire SVP
Clochard
Aimerais bien savoir....
Merci!















Clochard
Le #5388671
Salut JB et Daniel.C

Je tente d'adapter la formule suggérée dans l'exemple à mon vrai dossier et
j'obtiens #REF

=INDEX(NomsHommes;(GRANDE.VALEUR((Champ26);1)-GRANDE.VALEUR((Champ26)-LIGNE(2:8)/10;1))*10-1)

NomsHommes= B22:B44
Champ26= BK22:BM44

Qu'est-ce que je ne fais pas de correct...
--
Clochard
Aimerais bien savoir....
Merci!



Merci beaucoup Daniel

C'est exactement ce que je cherchais comme résultat...

C'est grandement apprécié
--
Clochard

Merci!



Bonjour.
Regarde :
http://cjoint.com/?mcjoiGh5As
Cordialement.
Daniel
"Clochard"
Correction d'une cellule.... s'cusez....

http://cjoint.com/?mbw1azsUZX
--
Clochard
Aimerais bien savoir....
Merci!



Merci JB aussi,

Mais pour mieux expliquer mon problème j'ai joint un fichier exemple

http://cjoint.com/?mbwU1NpBMq
--
Clochard
Aimerais bien savoir....
Merci!



Bonjour,

-Sélectionner 3 cellules
=INDEX(nom;EQUIV(GRANDE.VALEUR(Ca-LIGNE(Ca)/10^10;{1;2;3});Ca-
LIGNE(Ca)/10^10;0))
-Valider avec Maj+Ctrl+Entrée

http://boisgontierjacques.free.fr/fichiers/Matriciel/Top5Egalite.xls

JB

On 1 déc, 16:22, Clochard
Bonjour,

Je cherche à inscrire le nom des trois meilleurs pointage d'un groupe

Avec cette formule j'obtiens le premier max dans une plage

=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);1));GRANDE.VALEUR((BK$22:BM$44);1);"-")

Et avec celui-ci le deuxième...
=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);2));GRANDE.VALEUR((BK$22:BM$44);2);"-")

Ensuite avec celle-ci le nom de la personne du premier max

=SI(BL58="";"";INDEX($B$22:$B$44;MAX((Champ26=BL58)*LIGNE(Champ26))-LIGNE(C-hamp26)+1))--

Ma question est
Lorsque j'ai deux fois le même montant de max pour deux personnes
différentes j'arrive pas a obtenir le nom du deuxième max... ma
formule me
donne deux fois le nom de la première personne au plus haut pointage
mais pas
la suivante... que faire SVP
Clochard
Aimerais bien savoir....
Merci!

















JB
Le #5388641
Bonsoir

=INDEX(NomsHommes;(GRANDE.VALEUR(Champ26;1)-GRANDE.VALEUR(Champ22-
LIGNE(INDIRECT("1:"&LIGNES(Champ26)))/(10^10);1))*(10^10))

JB

On 2 déc, 21:13, Clochard
Salut JB et Daniel.C

Je tente d'adapter la formule suggérée dans l'exemple à mon vrai dos sier et
j'obtiens #REF

=INDEX(NomsHommes;(GRANDE.VALEUR((Champ26);1)-GRANDE.VALEUR((Champ26)-LI GNE-(2:8)/10;1))*10-1)

NomsHommes= B22:B44
Champ26= BK22:BM44

Qu'est-ce que je ne fais pas de correct...
--
Clochard
Aimerais bien savoir....
Merci!




Merci beaucoup Daniel

C'est exactement ce que je cherchais comme résultat...

C'est grandement apprécié
--
Clochard

Merci!



Bonjour.
Regarde :
http://cjoint.com/?mcjoiGh5As
Cordialement.
Daniel
"Clochard"
Correction d'une cellule.... s'cusez....

http://cjoint.com/?mbw1azsUZX
--
Clochard
Aimerais bien savoir....
Merci!





Merci JB aussi,

Mais pour mieux expliquer mon problème j'ai joint un fichier exem ple

http://cjoint.com/?mbwU1NpBMq
--
Clochard
Aimerais bien savoir....
Merci!






Bonjour,

-Sélectionner 3 cellules
=INDEX(nom;EQUIV(GRANDE.VALEUR(Ca-LIGNE(Ca)/10^10;{1;2;3});Ca-
LIGNE(Ca)/10^10;0))
-Valider avec Maj+Ctrl+Entrée

http://boisgontierjacques.free.fr/fichiers/Matriciel/Top5Egalite.x ls

JB

On 1 déc, 16:22, Clochard
Bonjour,

Je cherche à inscrire le nom des trois meilleurs pointage d'u n groupe

Avec cette formule j'obtiens le premier max dans une plage

=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);1));GRANDE.VALEUR((BK$ 22:BM$44);1);"--")

Et avec celui-ci le deuxième...
=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);2));GRANDE.VALEUR((BK$ 22:BM$44);2);"--")

Ensuite avec celle-ci le nom de la personne du premier max

=SI(BL58="";"";INDEX($B$22:$B$44;MAX((Champ26=BL58)*LIGNE (Champ26))-LIGNE(C--hamp26)+1))--

Ma question est
Lorsque j'ai deux fois le même montant de max pour deux perso nnes
différentes j'arrive pas a obtenir le nom du deuxième max.. . ma
formule me
donne deux fois le nom de la première personne au plus haut p ointage
mais pas
la suivante... que faire SVP
Clochard
Aimerais bien savoir....
Merci!- Masquer le texte des messages précédents -







- Afficher le texte des messages précédents -








Clochard
Le #5388561
Merci beaucoup de prendre le temps de me répondre JB... j'suis comblé de
t'avoir comme conseiller....

=INDEX(NomsHommes;(GRANDE.VALEUR(Champ26;2)-GRANDE.VALEUR(Champ26-LIGNE(INDIRECT("1:"&LIGNES(Champ26)))/(10^10);2))*(10^10))

Pourquoi que je n'arrive pas à avoir le deuxième meilleur pointage et le
troisième...
Pourtant je change le 1 pour un deux... suis-je tata à ce point....

--
Clochard
Aimerais bien savoir....
Merci!



Bonsoir

=INDEX(NomsHommes;(GRANDE.VALEUR(Champ26;1)-GRANDE.VALEUR(Champ22-
LIGNE(INDIRECT("1:"&LIGNES(Champ26)))/(10^10);1))*(10^10))

JB

On 2 déc, 21:13, Clochard
Salut JB et Daniel.C

Je tente d'adapter la formule suggérée dans l'exemple à mon vrai dossier et
j'obtiens #REF

=INDEX(NomsHommes;(GRANDE.VALEUR((Champ26);1)-GRANDE.VALEUR((Champ26)-LIGNE-(2:8)/10;1))*10-1)

NomsHommes= B22:B44
Champ26= BK22:BM44

Qu'est-ce que je ne fais pas de correct...
--
Clochard
Aimerais bien savoir....
Merci!




Merci beaucoup Daniel

C'est exactement ce que je cherchais comme résultat...

C'est grandement apprécié
--
Clochard

Merci!



Bonjour.
Regarde :
http://cjoint.com/?mcjoiGh5As
Cordialement.
Daniel
"Clochard"
Correction d'une cellule.... s'cusez....

http://cjoint.com/?mbw1azsUZX
--
Clochard
Aimerais bien savoir....
Merci!





Merci JB aussi,

Mais pour mieux expliquer mon problème j'ai joint un fichier exemple

http://cjoint.com/?mbwU1NpBMq
--
Clochard
Aimerais bien savoir....
Merci!






Bonjour,

-Sélectionner 3 cellules
=INDEX(nom;EQUIV(GRANDE.VALEUR(Ca-LIGNE(Ca)/10^10;{1;2;3});Ca-
LIGNE(Ca)/10^10;0))
-Valider avec Maj+Ctrl+Entrée

http://boisgontierjacques.free.fr/fichiers/Matriciel/Top5Egalite.xls

JB

On 1 déc, 16:22, Clochard
Bonjour,

Je cherche à inscrire le nom des trois meilleurs pointage d'un groupe

Avec cette formule j'obtiens le premier max dans une plage

=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);1));GRANDE.VALEUR((BK$22:BM$44);1);"--")

Et avec celui-ci le deuxième...
=SI(ESTNUM(GRANDE.VALEUR((BK$22:BM$44);2));GRANDE.VALEUR((BK$22:BM$44);2);"--")

Ensuite avec celle-ci le nom de la personne du premier max

=SI(BL58="";"";INDEX($B$22:$B$44;MAX((Champ26=BL58)*LIGNE(Champ26))-LIGNE(C--hamp26)+1))--

Ma question est
Lorsque j'ai deux fois le même montant de max pour deux personnes
différentes j'arrive pas a obtenir le nom du deuxième max.... ma
formule me
donne deux fois le nom de la première personne au plus haut pointage
mais pas
la suivante... que faire SVP
Clochard
Aimerais bien savoir....
Merci!- Masquer le texte des messages précédents -







- Afficher le texte des messages précédents -












Publicité
Poster une réponse
Anonyme