Deux colonnes à comparer sur deux feuilles différentes

Le
cegeffroy
Bonjour,

J'ai beau chercher mais la je bloque !

Je voudrais comparer deux colonnes sur deux feuilles différentes et si
les valeurs sont identiques, inscrire un "OUI" dans une colonne de la
seconde feuille.

Exemple :

Feuille 1
Colonne B
Truc
Machin
Bidule

Feuille 2
Colonne D
Machin
Bidule

donc en théorie, machin et bidule se trouve sur les deux feuilles
donc mettre un OUI en colonne E de la feuille 2

Je précise que les colonnes sont de types différentes

Je pense que c'est tout bête mais je bloque sur la macro donc si une
ame charitable pourrait m'aider

Merci d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jpmonnier
Le #16786691
Bonjour, une proc qui fonctionne sur 100 cellules de colonne A sur feuil2 et
feuil3
par contre les cellules vides sur les 2 renvoient également OUI

Sub Comparer()
'compare 2 col
x = 1
For Each n In Sheets("feuil2").[a1:a100]
If n = Sheets("feuil3").Cells(x, 1) Then
Sheets("feuil3").Cells(x, 2) = "OUI"
End If
x = x + 1
Next
End Sub

--
Cordialement


news:
Bonjour,

J'ai beau chercher mais la je bloque !

Je voudrais comparer deux colonnes sur deux feuilles différentes et si
les valeurs sont identiques, inscrire un "OUI" dans une colonne de la
seconde feuille.

Exemple :

Feuille 1
Colonne B
Truc
Machin
Bidule

Feuille 2
Colonne D
Machin
Bidule

donc en théorie, machin et bidule se trouve sur les deux feuilles
donc mettre un OUI en colonne E de la feuille 2

Je précise que les colonnes sont de types différentes

Je pense que c'est tout bête mais je bloque sur la macro donc si une
ame charitable pourrait m'aider...

Merci d'avance
Jacky
Le #16788221
Bonsoir,

En colonne E
Indifférent au texte/numérique
=SI(NB.SI(Feuil1!B:B;D2);"OUI";"")

Tient compte de la différence Num/texte
=SI(ESTERREUR(EQUIV(D2;Feuil1!B:B;0));"";"OUI")

Et tirer vers le bas aussi loin que besoin
--
Salutations
JJ



Bonjour,

J'ai beau chercher mais la je bloque !

Je voudrais comparer deux colonnes sur deux feuilles différentes et si
les valeurs sont identiques, inscrire un "OUI" dans une colonne de la
seconde feuille.

Exemple :

Feuille 1
Colonne B
Truc
Machin
Bidule

Feuille 2
Colonne D
Machin
Bidule

donc en théorie, machin et bidule se trouve sur les deux feuilles
donc mettre un OUI en colonne E de la feuille 2

Je précise que les colonnes sont de types différentes

Je pense que c'est tout bête mais je bloque sur la macro donc si une
ame charitable pourrait m'aider...

Merci d'avance
cegeffroy
Le #16788901
Merci pour vos réponses
Je ferai le test demain au boulot.

Juste une question, la macro est adaptable a 500 lignes je pense
Il suffit juste de mettre A500 à la place de A100 non ?



On 11 sep, 21:02, "Jacky"
Bonsoir,

En colonne E
Indifférent au texte/numérique
=SI(NB.SI(Feuil1!B:B;D2);"OUI";"")

Tient compte de la différence Num/texte
=SI(ESTERREUR(EQUIV(D2;Feuil1!B:B;0));"";"OUI")

Et tirer vers le bas aussi loin que besoin
--
Salutations
JJ


Bonjour,

J'ai beau chercher mais la je bloque !

Je voudrais comparer deux colonnes sur deux feuilles différentes et si
les valeurs sont identiques, inscrire un "OUI" dans une colonne de la
seconde feuille.

Exemple :

Feuille 1
Colonne B
Truc
Machin
Bidule

Feuille 2
Colonne D
Machin
Bidule

donc en théorie, machin et bidule se trouve sur les deux feuilles
donc mettre un OUI en colonne E de la feuille 2

Je précise que les colonnes sont de types différentes

Je pense que c'est tout bête mais je bloque sur la macro donc si une
ame charitable pourrait m'aider...

Merci d'avance


cegeffroy
Le #16789021
Bon il semblerait que la formule NB.SI fonctionne

Par contre autre question histoire de corser un peu le truc...

La feuille 2 contient dans les colonnes A, B et C des informations
A : Nom
B : Prénom
C : Date de naissance

Serait il possible de transférer les informations de la feuille 2 sur
la feuille 1 si bien la colonne B de la feuille 1 et la colonne D de
la feuille 2 contiennent les mêmes informations

Je sais pas si je suis clair dans ma question...

Merci d'avance
Jpmonnier
Le #16789011
Oui tu remplaces A100 par A500
--
Cordialement

news:
Merci pour vos réponses
Je ferai le test demain au boulot.

Juste une question, la macro est adaptable a 500 lignes je pense
Il suffit juste de mettre A500 à la place de A100 non ?



On 11 sep, 21:02, "Jacky"
Bonsoir,

En colonne E
Indifférent au texte/numérique
=SI(NB.SI(Feuil1!B:B;D2);"OUI";"")

Tient compte de la différence Num/texte
=SI(ESTERREUR(EQUIV(D2;Feuil1!B:B;0));"";"OUI")

Et tirer vers le bas aussi loin que besoin
--
Salutations
JJ


Bonjour,

J'ai beau chercher mais la je bloque !

Je voudrais comparer deux colonnes sur deux feuilles différentes et si
les valeurs sont identiques, inscrire un "OUI" dans une colonne de la
seconde feuille.

Exemple :

Feuille 1
Colonne B
Truc
Machin
Bidule

Feuille 2
Colonne D
Machin
Bidule

donc en théorie, machin et bidule se trouve sur les deux feuilles
donc mettre un OUI en colonne E de la feuille 2

Je précise que les colonnes sont de types différentes

Je pense que c'est tout bête mais je bloque sur la macro donc si une
ame charitable pourrait m'aider...

Merci d'avance


Jacky
Le #16789311
Re..
Bon il semblerait que la formule NB.SI fonctionne




Ah!
Par contre autre question histoire de corser un peu le truc...




Ceci n'a plus rien à voir avec la question initiale
Mais bon...
par exemple
=SI(OU(ESTNA(EQUIV(B2;Feuil2!D2:D500;0));B2="");"";INDEX(Feuil2!A2:A500;EQUIV(B2;Feuil2!D2:D500;0)))
voir ici un exemple simple
http://cjoint.com/?jlxhQfkRwt

--
Salutations
JJ



Bon il semblerait que la formule NB.SI fonctionne

Par contre autre question histoire de corser un peu le truc...

La feuille 2 contient dans les colonnes A, B et C des informations
A : Nom
B : Prénom
C : Date de naissance

Serait il possible de transférer les informations de la feuille 2 sur
la feuille 1 si bien la colonne B de la feuille 1 et la colonne D de
la feuille 2 contiennent les mêmes informations

Je sais pas si je suis clair dans ma question...

Merci d'avance
Jpmonnier
Le #16789391
je pense qu'un exemple sur cjoint.com serai plus explicite

--
Cordialement

news:
Bon il semblerait que la formule NB.SI fonctionne

Par contre autre question histoire de corser un peu le truc...

La feuille 2 contient dans les colonnes A, B et C des informations
A : Nom
B : Prénom
C : Date de naissance

Serait il possible de transférer les informations de la feuille 2 sur
la feuille 1 si bien la colonne B de la feuille 1 et la colonne D de
la feuille 2 contiennent les mêmes informations

Je sais pas si je suis clair dans ma question...

Merci d'avance
Jacky
Le #16789381
Re
Cet exemple est mieux
http://cjoint.com/?jlxp6ZtHAN
--
Salutations
JJ


"Jacky" %
Re..
Bon il semblerait que la formule NB.SI fonctionne




Ah!
Par contre autre question histoire de corser un peu le truc...




Ceci n'a plus rien à voir avec la question initiale
Mais bon...
par exemple
=SI(OU(ESTNA(EQUIV(B2;Feuil2!D2:D500;0));B2="");"";INDEX(Feuil2!A2:A500;EQUIV(B2;Feuil2!D2:D500;0)))
voir ici un exemple simple
http://cjoint.com/?jlxhQfkRwt

--
Salutations
JJ



Bon il semblerait que la formule NB.SI fonctionne

Par contre autre question histoire de corser un peu le truc...

La feuille 2 contient dans les colonnes A, B et C des informations
A : Nom
B : Prénom
C : Date de naissance

Serait il possible de transférer les informations de la feuille 2 sur
la feuille 1 si bien la colonne B de la feuille 1 et la colonne D de
la feuille 2 contiennent les mêmes informations

Je sais pas si je suis clair dans ma question...

Merci d'avance



Publicité
Poster une réponse
Anonyme