difficulte avec blender

Le
suchod
bonjour
je travaille avec Lenny. J ai commencé a utiliser Blender et tout
marchait bien.
J'ai du abandonner ces travaux pour me consacrer à d'autres et ce soir en
essayant de lancer Bender voici ce que j'obtiens :

<<<<<<<<<<
Compiled with Python version 2.5.2.
Checking for installed Python got it!
Xlib: extension "GLX" missing on display ":0.0".
intern/ghost/intern/GHOST_WindowX11.cpp:175: X11 glxChooseVisual()
failed for OpenGL, verify working openGL system!
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 18 (X_ChangeProperty)
Resource id in failed request: 0x0
Serial number of failed request: 11
Current serial number in output stream: 12
<<<<<<<<

Pour ma part je ne suis pas capable de savoir quoi faire a partir de ce
texte. Quelqu'un peut il
me dire quoi faire ??? Merci par avance
cordialement
jerome


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4C016F40.7030707@wanadoo.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Yves F. Barbier
Le #22187021
Le Sat, 29 May 2010 21:47:12 +0200,
suchod

Xlib: extension "GLX" missing on display ":0.0".



te dis que X n'a pas chargé l'extension GLX (openGL), en Gal, ça veut
dire que ta CG n'est plus accélérée

intern/ghost/intern/GHOST_WindowX11.cpp:175: X11 glxChooseVisual()



veut de l'openGL

failed for OpenGL, verify working openGL system!



apatrouvélenopengl

X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 18 (X_ChangeProperty)
Resource id in failed request: 0x0
Serial number of failed request: 11
Current serial number in output stream: 12



épakontendepaavoirtrouvélenopengl

tu dois avoir une CG qui nécessite soit une modif de xorg.conf, soit le
driver graphique n'a pas été recompilé lors d'un changement de kernel ou de
lib.

à vérifier avec 'glxinfo|grep rend' (qui devrait normalement ne p as dire que
la CG est accélérée.)

--
Kansas, where the men are men, the sheep are scared and the women are
grateful.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
suchod
Le #22190601
tu dois avoir une CG qui nécessite soit une modif de xorg.conf, soit le
driver graphique n'a pas été recompilé lors d'un changement de kernel ou de
lib.

à vérifier avec 'glxinfo|grep rend' (qui devrait normalement ne pas dire que
la CG est accélérée.)





bonsoir jean yves et merci pour l'info :

j ai installé mesa-utils puis fait "glxinfo | grep rend" et j 'ai
obtenu, comme
tu le prévoyais :

Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".

si tu me permets de te mettre encore a contribution :

-comment rétablir GLX la ou il le faut ??? (peut on le faire ???)

a te lire
cordialement
jerome



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Yannick Fouquet
Le #22192211
Bonjour,

Le 30/05/10 20:52, suchod a écrit :
-comment rétablir GLX la ou il le faut ??? (peut on le faire ???)



Pour ma part, 2 options :

1. réinstaller le pilote (dans mon cas nvidia).

2. # ln -s /usr/lib/xorg/modules/extensions/libglx.so.190.53
/usr/lib/xorg/modules/extensions/libglx.so
Où libglx.so.190.53 est le nom du fichier installé par nvidia (ici
version 190.53), et libglx.so a été effacé au préalable (pour ma part
déplacé en .old).

C'est l'inconvénient de ne pas utiliser le .deb...

Hope this helps.

Yannick.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
suchod
Le #22193231
Le 05/31/2010 09:19 AM, Yannick Fouquet a écrit :

Bonjour,

Le 30/05/10 20:52, suchod a écrit :
-comment rétablir GLX la ou il le faut ??? (peut on le faire ???)



Pour ma part, 2 options :

1. réinstaller le pilote (dans mon cas nvidia).

2. # ln -s /usr/lib/xorg/modules/extensions/libglx.so.190.53
/usr/lib/xorg/modules/extensions/libglx.so
Où libglx.so.190.53 est le nom du fichier installé par nvidia (ici
version 190.53), et libglx.so a été effacé au préalable (pour ma part
déplacé en .old).

C'est l'inconvénient de ne pas utiliser le .deb...

Hope this helps.

Yannick.



Bonjour Yannick

merci pour les infos, je vais essayer ton "2." .
Pourrais tu m'expliquer ce que tu veux dire par

"C'est l'inconvénient de ne pas utiliser le .deb..." ??

a te lire

salutations
jerome


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Yannick Fouquet
Le #22193391
Bonjour,

Le 31/05/10 13:01, suchod a écrit :
Le 05/31/2010 09:19 AM, Yannick Fouquet a écrit :
Le 30/05/10 20:52, suchod a écrit :
-comment rétablir GLX la ou il le faut ??? (peut on le faire ???)


Pour ma part, 2 options :
1. réinstaller le pilote (dans mon cas nvidia).
2. # ln -s /usr/lib/xorg/modules/extensions/libglx.so.190.53
/usr/lib/xorg/modules/extensions/libglx.so
Où libglx.so.190.53 est le nom du fichier installé par nvidia (ici
version 190.53), et libglx.so a été effacé au préalable (pour ma part
déplacé en .old).

C'est l'inconvénient de ne pas utiliser le .deb...



merci pour les infos, je vais essayer ton "2." .
Pourrais tu m'expliquer ce que tu veux dire par

"C'est l'inconvénient de ne pas utiliser le .deb..." ??



Utiliser le .run de nvidia, c'est devoir réinstaller le pilote à chaque
mise à jour de xorg, de mesa ou du noyau (en contrepartie, on a la
version que l'on veut), bref, de temps en temps çe ne marche plus et il
faut le réinstaller. Pour le cas du 2 par exemple, de temps en temps
(mise à jour), le libglx.so n'est plus un lien mais un fichier et compiz
ne marche plus du coup, d'où la manip préconisée pour obtenir à nouveau
un lien vers le libglx.so de nvidia.

Utiliser le .deb (donc pas toujours la dernière version du pilote),
c'est rentrer dans le système de dépendance et donc, normalement tout se
fait tout seul à la mise à jour.

J'espère avoir été clair.

@+
Yannick.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
suchod
Le #22196001
Utiliser le .run de nvidia, c'est devoir réinstaller le pilote à
chaque mise à jour de xorg, de mesa ou du noyau (en contrepartie, on a
la version que l'on veut), bref, de temps en temps çe ne marche plus
et il faut le réinstaller. Pour le cas du 2 par exemple, de temps en
temps (mise à jour), le libglx.so n'est plus un lien mais un fichier
et compiz ne marche plus du coup, d'où la manip préconisée pour
obtenir à nouveau un lien vers le libglx.so de nvidia.

Utiliser le .deb (donc pas toujours la dernière version du pilote),
c'est rentrer dans le système de dépendance et donc, normalement tout
se fait tout seul à la mise à jour.

J'espère avoir été clair.

parfaitement clair et merci encore.
salutations
jerome







--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme