DigiKam et base de données

Le
Robert LEFEVRE
Bonjour,
Je suis sous kubuntu 1210 et 1304 et utilise digikam depuis longtemps.
Je commence à avoir beaucoup de photos (+ de 10000) et le logiciel est
souvent très lent au démarrage. J'ai lu qu'avec mysql ce serait plus
rapide, j'ai donc installé les paquets nécessaires, vérifié que mysql
fonctionne et essayé de configurer digikam pour qu'il l'utilise.
Au dernier moment de la config, j'ai un message d'erreur comme quoi il
n'a pas accès à la BDD. En fait, j'ai lu plein de documents sur le web,
mais concrètement, je ne sais pas comment faire.
Pour l'instant, je suis revenu à SQLite et ça marche mais je reste sur
ma faim.
Je suis ignorant sur le sujet de digikam / mysql et si je pouvais
bénéficier d'un retour d'expérience à ce sujet, j'en serais bien content.
Merci et bonne journée, Robert.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
moi-meme
Le #25398872
Le Fri, 10 May 2013 11:39:56 +0200, Robert LEFEVRE a écrit :

Pour l'instant, je suis revenu à SQLite et ça marche mais je reste sur
ma faim.



Si c'est sqlite3 c'est comme sur firefox/mozilla/etc, il faut "purifier"
la base de données :
sqlite3 <base> 'VACUUM'
Robert LEFEVRE
Le #25399392
Le 11/05/2013 20:04, moi-meme a écrit :
Le Fri, 10 May 2013 11:39:56 +0200, Robert LEFEVRE a écrit :

Pour l'instant, je suis revenu à SQLite et ça marche mais je reste sur
ma faim.



Si c'est sqlite3 c'est comme sur firefox/mozilla/etc, il faut "purifier"
la base de données :
sqlite3 <base> 'VACUUM'



Bonjour,
Merci pour cette réponse. Je vais creuser un peu la question des BDD.
Pour ce qui est de MySQL, mon erreur était particulièrement bourrine, je
n'avais tout simplement pas crée les deux bases AVANT de configurer
digikam. Maintenant, ça fonctionne avec MySQL, mais je n'ai pas constaté
un démarrage plus rapide que sous sqlite.
Bonne journée, Robert.
Publicité
Poster une réponse
Anonyme