diviser selon le contenu

Le
marcus
Bonjour à vous tous
Voici mon problème. Dans la colonne D j'ai des nombres avec desfois le
nombre 0.
Ce que je veux, c'est de divisier une cellule avec la suivante qui ne
contient pas le chiffre 0.

Voici un exemple:
D1% dans la cellule E1 la formule devrait être D1/D3 puisque D2 contient 0
D2=0 dans la cellule E2, le chiffre devrait être 0, car il n'y a pas de
montant
D3=2 dans le cellule E3, la formule devrait être D3/D4, et ect.
D4=2

Le problème, c'est que les chiffres 0 ne sont pas dans une séquence fixe.
J'espère m'être assez bien exprimé, si c'est pas clair, dite le moi

Merci de votre aide

marcus
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
IMER09
Le #4973701
formule en E1

=SI(D1=0;0;SI(D2=0;SI(D3=0;SI(D4=0;SI(D5=0;SI(D6=0;SI(D7=0;SI(D8=0;;D1/D8);D1/D7);D1/D6);D1/D5);D1/D4);D1/D3);D1/D2))

le pb :Tu ne doit pas avoir plus de 8 zero qui ce suive

--
IMER09



Bonjour à vous tous
Voici mon problème. Dans la colonne D j'ai des nombres avec desfois le
nombre 0.
Ce que je veux, c'est de divisier une cellule avec la suivante qui ne
contient pas le chiffre 0.

Voici un exemple:
D1% dans la cellule E1 la formule devrait être D1/D3 puisque D2 contient 0
D2=0 dans la cellule E2, le chiffre devrait être 0, car il n'y a pas de
montant
D3=2 dans le cellule E3, la formule devrait être D3/D4, et ect.
D4=2

Le problème, c'est que les chiffres 0 ne sont pas dans une séquence fixe.
J'espère m'être assez bien exprimé, si c'est pas clair, dite le moi

Merci de votre aide

marcus


marcus
Le #4973641
Salut IMER09
on parle ici du vrai fichier qu'il y a 3000 lignes. J'ai aussi besoin de la
réponse en formule, svp, non un code vba

Merci de votre aide


formule en E1

=SI(D1=0;0;SI(D2=0;SI(D3=0;SI(D4=0;SI(D5=0;SI(D6=0;SI(D7=0;SI(D8=0;;D1/D8);D1/D7);D1/D6);D1/D5);D1/D4);D1/D3);D1/D2))

le pb :Tu ne doit pas avoir plus de 8 zero qui ce suive

--
IMER09



Bonjour à vous tous
Voici mon problème. Dans la colonne D j'ai des nombres avec desfois le
nombre 0.
Ce que je veux, c'est de divisier une cellule avec la suivante qui ne
contient pas le chiffre 0.

Voici un exemple:
D1% dans la cellule E1 la formule devrait être D1/D3 puisque D2 contient 0
D2=0 dans la cellule E2, le chiffre devrait être 0, car il n'y a pas de
montant
D3=2 dans le cellule E3, la formule devrait être D3/D4, et ect.
D4=2

Le problème, c'est que les chiffres 0 ne sont pas dans une séquence fixe.
J'espère m'être assez bien exprimé, si c'est pas clair, dite le moi

Merci de votre aide

marcus




IMER09
Le #4973561
Ce n'est pas un code vba il suffit d'ecrire cette formule ds la case E1 et de
la coller ds les 3000 suivantes
Le defaut: si il y a plus de 7 zero a la suite(oups non pas 8) la division
ne se fera pas avec la huitieme case et le resultat sera 0
si j'ai bien compris ton pb !
IMER09



Salut IMER09
on parle ici du vrai fichier qu'il y a 3000 lignes. J'ai aussi besoin de la
réponse en formule, svp, non un code vba

Merci de votre aide


formule en E1

=SI(D1=0;0;SI(D2=0;SI(D3=0;SI(D4=0;SI(D5=0;SI(D6=0;SI(D7=0;SI(D8=0;;D1/D8);D1/D7);D1/D6);D1/D5);D1/D4);D1/D3);D1/D2))

le pb :Tu ne doit pas avoir plus de 8 zero qui ce suive

--
IMER09



Bonjour à vous tous
Voici mon problème. Dans la colonne D j'ai des nombres avec desfois le
nombre 0.
Ce que je veux, c'est de divisier une cellule avec la suivante qui ne
contient pas le chiffre 0.

Voici un exemple:
D1% dans la cellule E1 la formule devrait être D1/D3 puisque D2 contient 0
D2=0 dans la cellule E2, le chiffre devrait être 0, car il n'y a pas de
montant
D3=2 dans le cellule E3, la formule devrait être D3/D4, et ect.
D4=2

Le problème, c'est que les chiffres 0 ne sont pas dans une séquence fixe.
J'espère m'être assez bien exprimé, si c'est pas clair, dite le moi

Merci de votre aide

marcus






Publicité
Poster une réponse
Anonyme