dois-je rebooter après une mise à jour mineure du noyau ?

Le
gnafou
Bonjour, Une question que je me pose : Je viens de mettre à jo=
ur une machine squeeze. ( apt-get update / upgrade ) La mise à jour=
a surtout consisté à une mise à jour mineure du noyau ( 2.6.26+1=
7+lenny1 ) vers ( 2.6.26-25lenny1 ) Tout ce passe correctement ma=
is . dois-je rebooter ? Merci Fred

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/509167.78348.qm@web29509.mail.ird.yahoo.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Xavier Oswald
Le #22627081
--HcAYCG3uE/tztfnV
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On 15:47 Wed 29 Sep , Erwan David wrote:
On Wed, Sep 29, 2010 at 03:45:45PM CEST, gnafou > Bonjour,
>
> Une question que je me pose :
>
> Je viens de mettre à jour une machine squeeze. ( apt-get update / upg rade )
>
> La mise à jour a surtout consisté à une mise à jour mineure du noyau
> ( 2.6.26+17+lenny1 ) vers ( 2.6.26-25lenny1 )
>
> Tout ce passe correctement ... mais .... dois-je rebooter ?

Personnellement je reboote après une mise à jour du noyau. Mais est-ce
toujours nécessaire ?



Le mieu est de voir le changelog d'une version à l'autre.

Si des fonctionnalités vous semblent nécessaires, le reboot est néces saire.
Sinon cela veut dire que tant qu'il n'y a pas reboot, le système utilise le code
du noyau sur lequel vous avez booté.

Dans le cas 2.6.26+17+lenny1 -> 2.6.26-25lenny1, on voit qu'il y a une
différence de 8 versions qui sont des modifs de Debian. On peut s'attendr e a des
security fix du fait de la présence +lenny1.


Amicalement,
--
Xavier Oswald GNU/Linux Debian Developer - http://www.debian.org/
GPG key ID: 0x464B8DE3

--HcAYCG3uE/tztfnV
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCAAGBQJMo023AAoJEIW5DSNGS43jQ68QAK86YXViS2FknyAHP01MivrY
+WDoeH/+ye/pzRxzM3mFndFS9P+rWVsEuRnb3Re5r6sibfkHbXx7pYuMRA1lMtXJ
xtAB9LQ4yJwjNPK51dekBJaU4wpQiX5SfxrB04348Shi+LrHqY2GTZyUyRi5nmvw
R3DEdd3U56eX5khvmX177ouMRvFxWh0oh+mhs9HUsIu/08GV2Aj9is/7QINJ78Lm
U4VTZSjL1MCgZ0g+A+D+rLQTudP5rDGKSDuUVFR/0+sL7in9cc8qr1gQ8PfIRqYB
j/8VpfdKk2la6/vSRDJ+ZO0EWPCshDOwPoXyXCYSSX37tX1ry4lwcBDUFxkzTN30
m7aScqL4fSaGluFrASW6d54bnePkF9DPC91Jp8bO0T/C2XMiBWSn1qduWwdvaaiK
5BFwVx7AbupOvdE5H0JBzeW+UEzbG6jE1R86mrTIhtgXcb6J/yIGs13zw2MUufG7
4CqSoE9IMubWbae1apiXIL7yKXrci7AU14LckETwr91BugnC0NdIcyaZT0xyaPO3
GvRbREXvv1IT6Q1IXgpSr4setiUgEuWn2FQjpFiG1A8LGJoUUTuEF+t6ZOSVmlT1
2bHfObjB+9gqECYoncfnUC1SCRYo+RhakuMpKR3kO14kiYoFd46mZNJXaLl6aOHd
/BLOdHgrWb25hlE0frZj
=N2rm
-----END PGP SIGNATURE-----

--HcAYCG3uE/tztfnV--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain L. Sauvage
Le #22627201
’jour,

Le mercredi 29 septembre 2010 à 16:31:19, Xavier Oswald a écrit
:
On 15:47 Wed 29 Sep , Erwan David wrote:
> On Wed, Sep 29, 2010 at 03:45:45PM CEST, gnafou <fmgre-


said:
[…]
> > Je viens de mettre à jour une machine squeeze. ( apt-get


^^^^^^^
> > update / upgrade )
> >
> > La mise à jour a surtout consisté à une mise à jo ur
> > mineure du noyau ( 2.6.26+17+lenny1 ) vers (
> > 2.6.26-25lenny1 )


^^^^^

Ya que moi qui voit un problème ?

Squeeze est en 2.6.32.

[…]
Si des fonctionnalités vous semblent nécessaires, le reboot
est nécessaire. Sinon cela veut dire que tant qu'il n'y a
pas reboot, le système utilise le code du noyau sur lequel
vous avez booté.



Faire attention aussi aux modules : le noyau en mémoire n’es t
plus en phase avec les modules sur le disque, donc une
incompatibilité est toujours possible au chargement de modules
après la màj (changement d’ABI).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Pascal Hambourg
Le #22627231
Salut,

Sylvain L. Sauvage a écrit :

Faire attention aussi aux modules : le noyau en mémoire n'est
plus en phase avec les modules sur le disque, donc une
incompatibilité est toujours possible au chargement de modules
après la màj (changement d'ABI).



Je me posais justement la question : cela peut-il vraiment arriver sans
changement de la version du noyau ni des options de configuration comme
c'est normalement le cas des noyaux Debian ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Xavier Oswald
Le #22627271
--HcAYCG3uE/tztfnV
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On 17:08 Wed 29 Sep , Pascal Hambourg wrote:
Salut,

Sylvain L. Sauvage a écrit :
>
> Faire attention aussi aux modules : le noyau en mémoire n'est
> plus en phase avec les modules sur le disque, donc une
> incompatibilité est toujours possible au chargement de modules
> après la màj (changement d'ABI).

Je me posais justement la question : cela peut-il vraiment arriver sans
changement de la version du noyau ni des options de configuration comme
c'est normalement le cas des noyaux Debian ?



On peut tagger un paquet pour que les MAJ ne soient pas active. Mais on doit
pouvoir s'en sortir a coup de pinning. Je ne sais pas la config qui est en place
sur cette machine. Mais avoir squeeze et un 2.6.26 avec udev, ca doit pas t rop
le faire. Je vais supposé une faute de frappe s/squeeze/lenny de l'auteur du
mail ;)

--
Xavier Oswald GNU/Linux Debian Developer - http://www.debian.org/
GPG key ID: 0x464B8DE3

--HcAYCG3uE/tztfnV
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCAAGBQJMo15TAAoJEIW5DSNGS43jw1IP/R/ptHqVcCNDsWiwbhK+u/vZ
5hHx7S/hkyKypIUqA8q1XtiA2WqyKgWvZhzmPfAsLhT7R8ccaK7FGXLUKNBGqQq9
qvXOyIwcepo6ulRYGUjwfL76qZyBJ91Qw5MY4PrrqrF19MT/iakMsHja3ZjT+RwD
+pMR3HWiwAdP7Xixg+TzzD5N4FweMMWjo+cNd5n/Yj2xYexBk4bPIWGlvNY6lwXp
1Hk25meitA8qJt8GrmeZ/2BRMokh/h7TImJOdYP7jX4QDgzmdWJTPZvEbB+ZdRmP
AD8mKBG/UaLxo49Iz37fq06z5W7vV3ZyBicfHkV9Bc1Ex9TieILd+a3tmAVAku+H
cWa+sIh3/5YvtIPX+8wMyNDU1DwSeI3yHNBw1z1Zp+I9lUDLRTIxvbFT2n5y80M6
XBCECfXZI4USdtOY0sr4OPkAt0YLVamunH8thOnNWQA0UDj8ZC7cbk0YaDcfr1Ho
kB1zMI8Q0dGZiIy3SLHqqAP7sMkd8KpPBYCFDpEahQilrz0pz7BkGN0lPLrijcLu
B1IcrhlBT05Uka117C1VS3uJkdPtnDor+Qf1gYyIYXwASXYZvN2cGDf+qTXtZhbQ
7mcX87Cb6gHGy6NBadeUl9bbVAvtANdiO7xAMdy/maXswawWDEZGdTK6Wyjuy1M0
I3AXzNgN/bj9YWEAMEMo
=DnaM
-----END PGP SIGNATURE-----

--HcAYCG3uE/tztfnV--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
gnafou
Le #22627331
On peut tagger un paquet pour que les MAJ ne soient pas active. Mais on doit
pouvoir s'en sortir a coup de pinning. Je ne sais pas la c onfig qui est en
place
sur cette machine. Mais avoir squeeze et un 2.6.26 avec udev, ca doit pas trop
le faire. Je vais supposé une faut e de frappe s/squeeze/lenny de l'auteur du
mail ;)



l'auteur rentre de vacances est prie la communauté de l excuser de la coquille
;-)

je suis effectivement en lenny .. et je voulais appliquer les security u pdates
.. il ne me reste plus qu à trouver le 'bon' moment pour reboot er

Merci

Fred




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain L. Sauvage
Le #22627411
Le mercredi 29 septembre 2010 à 17:08:04, Pascal Hambourg a
écrit :
[…]
> une incompatibilité est toujours possible au chargement de
> modules après la màj (changement d'ABI).

Je me posais justement la question : cela peut-il vraiment
arriver sans changement de la version du noyau ni des
options de configuration comme c'est normalement le cas des
noyaux Debian ?



Le numéro de version Debian inclut un numéro de version d†™ABI
(2.6.32-5 = 2.6.32, 5e ABI) donc les répertoires de modules sont
bien séparés. Donc les modules qui n’utilisent que les fo nctions
publiques ne devraient pas avoir de problème.
Ça, c’est si on n’utilise que les noyaux Debian, que des
modules sûrs et que l’on fait aveuglément confiance aux
mainteneurs pour ne pas laisser passer de changement d’ABI sans
changement de SONAME (je ne sais pas s’il y a un test
automatique à ce niveau).

Si on n’a pas 2 min pour redémarrer sa machine (dans un dà ©lai
raisonnable), autant ne pas changer le noyau en cours de route.
(Ou alors on s’amuse avec Ksplice…)

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Pascal Hambourg
Le #22627421
Xavier Oswald a écrit :
On 17:08 Wed 29 Sep , Pascal Hambourg wrote:

Sylvain L. Sauvage a écrit :
Faire attention aussi aux modules : le noyau en mémoire n'est
plus en phase avec les modules sur le disque, donc une
incompatibilité est toujours possible au chargement de modules
après la màj (changement d'ABI).



Je me posais justement la question : cela peut-il vraiment arriver sans
changement de la version du noyau ni des options de configuration comme
c'est normalement le cas des noyaux Debian ?



On peut tagger un paquet pour que les MAJ ne soient pas active. Mais on doit
pouvoir s'en sortir a coup de pinning.



Quel rapport avec ma question ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Xavier Oswald
Le #22627741
--DocE+STaALJfprDB
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On 18:15 Wed 29 Sep , Pascal Hambourg wrote:
Xavier Oswald a écrit :
> On 17:08 Wed 29 Sep , Pascal Hambourg wrote:
>>
>> Sylvain L. Sauvage a écrit :
>>> Faire attention aussi aux modules : le noyau en mémoire n'est
>>> plus en phase avec les modules sur le disque, donc une
>>> incompatibilité est toujours possible au chargement de modules
>>> après la màj (changement d'ABI).
>>
>> Je me posais justement la question : cela peut-il vraiment arriver sans
>> changement de la version du noyau ni des options de configuration comme
>> c'est normalement le cas des noyaux Debian ?
>
> On peut tagger un paquet pour que les MAJ ne soient pas active. Mais on doit
> pouvoir s'en sortir a coup de pinning.

Quel rapport avec ma question ?



Désolé. Erreur de mannip. Je voulais répondre à une autre partie:

> Je viens de mettre à jour une machine squeeze. ( apt-get
> update / upgrade )
>
> La mise à jour a surtout consisté à une mise à jour
> mineure du noyau ( 2.6.26+17+lenny1 ) vers (
> 2.6.26-25lenny1 )

Ya que moi qui voit un problème ?
Squeeze est en 2.6.32.



--
Xavier Oswald GNU/Linux Debian Developer - http://www.debian.org/
GPG key ID: 0x464B8DE3

--DocE+STaALJfprDB
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCAAGBQJMo3lSAAoJEIW5DSNGS43j+2AP/jhk3/2xjGzVqstKuFiTdCoh
Ty8AowmkC8TG/vFNqbx1Unn+4JweXXrrX6T3xxy0q/hDk76kWKrwaOuvNr3JR2a2
BdYwlCvaCgXR48cxIUMmY2O/SXiO4zGp3YSXcCvErCv+9Z9icvLOoUWHxZsvXNpm
1FEoYiiVmhaSYaoGBnomVJ9GS6eaGxcRm2IkLhN/IisGnl9EI8bUIz2ApOwMlI/W
lB0MK5lfdD18efV+r+VRXpB/HpBKCRc027eeWaVTvOllBsemVjDheSTn7XOjUa9o
6vlSgQemTZvbHzRCLuKb2EtqnSPBH3xJAOLF+4OAhh9ChbF4hJGMMLXlNc5MWwwG
udn6PlVJNYAKA5QrOtmJE76ZVAMIBryAF8HdQXfi08jQDwigKZFUM+EbAPOe3eOj
1usdlcXR1Sw9PSEFzx0zx/rkdsuID+pLyNMg6R5ZZ6POxQd1+tmYaZ9/HDQlGRSR
6uO0u3+N0Ea6XgFmY5tLvnaGX6lkS+PZLWqkI02haIKm0O3qcIy/qJAuP3rrHDHU
w3zOcL+BnhpyuX8cX/hDXaHjBeojP/IqrMYCgMLvOSwhUdb73Q8ku46ozTRDkxDN
u2N2DFGDkcO4ouRIaSaa+H9bxtBBTDjyGli7OTddrOwmjuyHMr3xMB3sk9iL1V7G
l5LIQo3+y3okBnvNKu0l
=O8as
-----END PGP SIGNATURE-----

--DocE+STaALJfprDB--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
gnafou
Le #22628771
A la suite des réponses d'hier ... serait-il opportun de déposer un
'enhancement request' ( ? ) auprès de debian afin qu'une petite phr ase du
genre ' you (will) need to reboot after the update' soit écrit e après les
apt-get update/upgrade où les noyaux / modules sont touc hés ?


Personnellement, à force de ne pas voir ce genre de mess age, j en étais venu à
me dire ' ils sont trop forts debian, il n'ya même plus besoin de rebooter ' :-)



F.




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Xavier Oswald
Le #22628981
--bg08WKrSYDhXBjb5
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On 07:36 Thu 30 Sep , gnafou wrote:
A la suite des réponses d'hier ... serait-il opportun de déposer un
'enhancement request' ( ? ) auprès de debian afin qu'une petite phra se du
genre ' you (will) need to reboot after the update' soit écrite aprè s les
apt-get update/upgrade où les noyaux / modules sont touchés ?


Personnellement, à force de ne pas voir ce genre de message, j en éta is venu à
me dire ' ils sont trop forts debian, il n'ya même plus besoin de reboo ter ' :-)



Je n'ai pas regardé les détails mais après update/upgrade du noyau, j 'ai un
message quand je me log en ssh qui me dit maintenant que ma machine doit être
rebooté. C'est peut-etre seulement effectif depuis squeeze.

Amicalement,
--
Xavier Oswald GNU/Linux Debian Developer - http://www.debian.org/
GPG key ID: 0x464B8DE3

--bg08WKrSYDhXBjb5
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCAAGBQJMpEj2AAoJEIW5DSNGS43j15kQALVoVLJ4SwK3Vpye4NAPDH7e
AGzEbXi/wAnpwvoNHyiCUHztdcBr0QnPm9MTPlI1ZfLZHRvMGUaYzGB2pPJYUUIG
WLeDyJMeVX9cMfEp0pg5kPuj0Y3ap3oNkcPrbHJPWuabPeYavNhr7piJEJEgjmMd
2URTMcZ5/VYYgXAt0AsWBITcJ5Em5FURvMtnM1C57Iid50JthL+wtH5XdUDfbj+a
WuXz+2WXl0rMOeoKUJfo5wQoXB+6Pn07UfoQbcz+svBkw7byjn0L1ZL73lKz5x38
JWdc7m9Nvs7qN+AvrZ7IK3TtXD9pL89M9xh5LLeZ9i70FzJ7b7b+stwYrhjoaEaG
S02zsdh+ioXuHKdE+duyDnUXDRVcFVbenBStTCz2AuTKwFZLzYN905B0eeQKMydq
7bKa+IVF7O8ocUJXm6ytpgZ2UvPBF2iRLG5m93+nGRsNuyZrG7IamZ326uGhfuSZ
70yw1moHFbX9gpn1cHcaV8LwNm3kcxURB6hGbfwuF5FnAvg0U3ZIcL77ruVF0ydf
3nwLNXS5bX92sB6tAB49JjLikqHOkoPk7In7iXS2fMBg1H7mFrME1SA/6Xoq7Xdm
e82hp6YEkJ8kxi4toROdDposQw2oG1Zk9AMensZlxXIq4d7PdKgL1x6FhVoUytdU
Zn1WakcctmaUDrJFKVkc
=BKWU
-----END PGP SIGNATURE-----

--bg08WKrSYDhXBjb5--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme