Double NAT avec routeur CISCO 2621 et IOS 12.3(26) possible ?

Le
Winston Smith
Bonjour,

Est il possible de faire du NAT sur la source et la destination en
traversant le routeur sus mentionné ?

Nous avons un réseau en adressage privé 10.75.0.0/16 divisé en divers
sous réseaux.

Nous avons plusieurs AliceBox pour l'accès Internet (en secours). Mais
les derniers modèles ne permettent même plus de changer les adresses IP.
Elle a donc l'adresse interne 192.168.1.1.

Nous avons donc ajouté entre cette AliceBox et notre réseau un routeur
CISCO 2621.

Pour accèder à l'Internet on NAT les flux venant d'un serveur proxy avec
une adresse dans le sous réseau de l'AliceBox et cela fonctionne.

Mais pour accèder à la page de configuration de AliceBox en HTTP, il
nous faut changer la source et la destination et la façon dont je tente
de le faire ne fonctionne pas.

Extrait de la conf.:
--
interface FastEthernet0/0
description *** Interface interne *** coté LAN
ip address 10.75.155.42 255.255.255.224
ip nat inside
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!

interface FastEthernet0/1
description *** Interface externe *** coté AliceBox
ip address 192.168.1.51 255.255.255.0
ip nat outside
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!

ip default-gateway 192.168.1.1

;(NAT pour la sortie du proxy qui fonctionne)

ip nat inside source static 10.75.1.43 192.168.1.53


; Essai qui ne fonctionne pas :

ip nat inside source static 10.75.72.2 192.168.1.54
ip nat outside source static 10.75.155.43 192.168.1.1

no ip http server
no ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 10.75.0.0 255.255.0.0 10.75.155.35 permanent

--
Le but serait de pouvoir contacter l'AliceBox depuis 10.75.72.2 en
visant l'adresse 10.75.155.43

Le routeur CISCO devrait remplacer la destination 10.75.155.43 en
192.168.1.1

et remplacer la source 10.75.72.2 en une adresse dans le réseau local de
l'AliceBox 192.168.1.54

Est ce possible dans ce cas ?

Merci d'avance.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
GuiGui
Le #18883091
Winston Smith a écrit :
Bonjour,

Est il possible de faire du NAT sur la source et la destination en
traversant le routeur sus mentionné ?

Nous avons un réseau en adressage privé 10.75.0.0/16 divisé en divers
sous réseaux.

Nous avons plusieurs AliceBox pour l'accès Internet (en secours). Mais
les derniers modèles ne permettent même plus de changer les adresses IP.
Elle a donc l'adresse interne 192.168.1.1.

Nous avons donc ajouté entre cette AliceBox et notre réseau un routeur
CISCO 2621.

Pour accèder à l'Internet on NAT les flux venant d'un serveur proxy avec
une adresse dans le sous réseau de l'AliceBox et cela fonctionne.

Mais pour accèder à la page de configuration de AliceBox en HTTP, il
nous faut changer la source et la destination et la façon dont je tente
de le faire ne fonctionne pas.

Extrait de la conf.:
-----------------------------------------------------------------
interface FastEthernet0/0
description *** Interface interne *** coté LAN
ip address 10.75.155.42 255.255.255.224
ip nat inside
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!

interface FastEthernet0/1
description *** Interface externe *** coté AliceBox
ip address 192.168.1.51 255.255.255.0
ip nat outside
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!

ip default-gateway 192.168.1.1

;(NAT pour la sortie du proxy qui fonctionne)

ip nat inside source static 10.75.1.43 192.168.1.53


; Essai qui ne fonctionne pas :

ip nat inside source static 10.75.72.2 192.168.1.54
ip nat outside source static 10.75.155.43 192.168.1.1

no ip http server
no ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 10.75.0.0 255.255.0.0 10.75.155.35 permanent

-----------------------------------------------------------------
Le but serait de pouvoir contacter l'AliceBox depuis 10.75.72.2 en
visant l'adresse 10.75.155.43

Le routeur CISCO devrait remplacer la destination 10.75.155.43 en
192.168.1.1

et remplacer la source 10.75.72.2 en une adresse dans le réseau local de
l'AliceBox 192.168.1.54

Est ce possible dans ce cas ?

Merci d'avance.



C'est possible mais pas comme ça.

ip nat outside -> translation de l'IP source externe.

ip nat outside source static 10.75.155.43 192.168.1.1 signifie :
tout paquet provenant de l'interface déclarée externe (celle comportant
la directive ip nat outside) à destination du cisco ayant pour adresse
source 10.75.155.43 sera translaté en adresse source 192.168.1.1.


Il faut utiliser un "ip nat inside destination" pour translater
10.75.155.43 en 192.168.1.1 et un "ip nat inside source" pour translater
10.75.72.2 en 192.168.1.54. pour le reste, je vous laisse chercher ;-)

La doc :
http://www.cisco.com/en/US/docs/ios/12_3t/ip_addr/command/reference/ip1_i2gt.html
Publicité
Poster une réponse
Anonyme