dpkg status corrompu

Le
zecho
Bonjoir la liste,

je lis souvent mais j'avais pas encore posé de question ici.


Du coup j'ai eu un soucis hier : apt-get ne marchait plus du tout (ni
update ni upgrade ni install). J'avais 4 lignes d'erreurs qui
apparaissaient disant en gros qu'il arrivait pas à lire le
fichier /var/lib/dpkg/status.

Du coup après une rapide recherche j'ai trouvé que la commande dpkg
--configure -a permettrait d'avoir des infos. Et effectivement ça me
donnait des numéros de lignes et des infos sur ce qui lui plaisait pas
trop. Et en fait, ce qui ne lui plaisait pas c'était juste qu'une bonne
partie du fichier était toute caca (pleins de caractères moches en
remplaçait d'autres d'une manière qui semblait plutôt aléatoire)

Au final j'ai résolu mon problème grâce aux fichiers de backup et
maintenant ça marche comme avant mais j'ai
absolument pas compris ce qu'il s'est passé ni pourquoi. Vu que
j'aimerais bien que ça ne se reproduise pas, je viens voir ici si
quelqu'un-e aurait une idée au sujet de ce qui a pu produire ce truc.

Je suis en stable et j'ai toujours une copie du fichier corrompu si ça
peut aider à comprendre le problème.

Merci d'avance.
Antoine.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: https://lists.debian.org/20140323223040.GB4944@riseup.net
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bzzz
Le #26049372
On Sun, 23 Mar 2014 23:30:41 +0100
zecho
j'aimerais bien que ça ne se reproduise pas, je viens voir ici si
quelqu'un-e aurait une idée au sujet de ce qui a pu produire ce
truc.



Sèpô, j'ai eu le PB une fois sous sid il y a 2 ans et je ne
sais tjrs pas pourquoi (connexions ok, onduleur ok, HDz ok, etc).

Exécutes un test SMART long sur le HD en question, au cas
où; mais ça n'est pas dit que ça t'apportera une répons e.

--
Kevin: nan mé serieux ske je lui é di CT pa 1 sultant
marmotte: ..... c'était un maharajah alors o/
Kevin: G pa compri

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
claude
Le #26049552
On 23/03/2014 23:40, Bzzz wrote:
On Sun, 23 Mar 2014 23:30:41 +0100
zecho
j'aimerais bien que ça ne se reproduise pas, je viens voir ici si
quelqu'un-e aurait une idée au sujet de ce qui a pu produire ce
truc.



Sèpô, j'ai eu le PB une fois sous sid il y a 2 ans et je ne
sais tjrs pas pourquoi (connexions ok, onduleur ok, HDz ok, etc).

Exécutes un test SMART long sur le HD en question, au cas
où; mais ça n'est pas dit que ça t'apportera une réponse.



Ca m'est arrivé aussi, une fois (y'a longtemps)... A l'époque, on
m'avait conseillé de tester la RAM : soit avec memtest, soit en
compilant un gros prog, style kernel.

--
Claude

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
zecho
Le #26056432
Ok, merci pour les réponses.

Du coup je vais surement faire les 2 tests sous peu pour voir ce qu'il
en est.

Antoine.


On Mon, Mar 24, 2014 at 08:30:42AM +0100, claude wrote:
On 23/03/2014 23:40, Bzzz wrote:
>On Sun, 23 Mar 2014 23:30:41 +0100
>zecho >
>>j'aimerais bien que ça ne se reproduise pas, je viens voir ici si
>>quelqu'un-e aurait une idée au sujet de ce qui a pu produire ce
>>truc.
>
>Sèpô, j'ai eu le PB une fois sous sid il y a 2 ans et je ne
>sais tjrs pas pourquoi (connexions ok, onduleur ok, HDz ok, etc).
>
>Exécutes un test SMART long sur le HD en question, au cas
>où; mais ça n'est pas dit que ça t'apportera une réponse.

Ca m'est arrivé aussi, une fois (y'a longtemps)... A l'époque, on
m'avait conseillé de tester la RAM : soit avec memtest, soit en
compilant un gros prog, style kernel.

--
Claude

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Publicité
Poster une réponse
Anonyme