Eclipse 3.6 et Squeeze

Le
Olivier
--20cf307ac087e15c7c04b09a9d9a
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Bonjour,

Je souhaite installer Eclipse et son plugin Maven sur une machine dotée d=
e
Squeeze.
Ce plugin exige une version 3.6 ou supérieure d'Eclipse.
Celle-ci est disponible en 3.7 dans le dépôt unstable.
Que me conseillez-vous ?

J'envisage les options suivantes :
1. Installer une machine virtuelle avec Debian unstable et partager
quelques répertoires avec la machine hote.
2. Installer Eclipse à partir des sources du projet.

Dans le 2ème cas, j'ignore les difficultés qui se poseront quand je dev=
rais
migrer à la version stable suivante de Debian.

Remarques et suggestions bienvenues.

Slts

--20cf307ac087e15c7c04b09a9d9a
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Bonjour,<br><br>Je souhaite installer Eclipse et son plugin Maven sur une m=
achine dotée de Squeeze.<br>Ce plugin exige une version 3.6 ou supérieu=
re d&#39;Eclipse.<br>Celle-ci est disponible en 3.7 dans le dépôt unsta=
ble.<br>

Que me conseillez-vous ?<br><br>J&#39;envisage les options suivantes :<br>1=
. Installer une machine virtuelle avec Debian unstable et partager quelques=
répertoires avec la machine hote.<br>2. Installer Eclipse à partir des=
sources du projet.<br>
<br>Dans le 2ème cas, j&#39;ignore les difficultés qui se poseront quan=
d je devrais migrer à la version stable suivante de Debian.<br><br>Remarq=
ues et suggestions bienvenues.<br><br>Slts<br>

--20cf307ac087e15c7c04b09a9d9a--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/CAPeT9jjADY6KCdGH50OSVr3wJmSxyK_By+dNUz+P=h3J7rcwyQ@mail.gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Olivier
Le #23923281
--20cf3078109029001d04b09be22c
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Le 31 octobre 2011 18:12, Bernard Schoenacker

Le Mon, 31 Oct 2011 17:20:27 +0100,
Olivier
> :


bonjour,


vous n'avez pas exploré la voie intermédiaire qui consiste
à employer :

-a) paquets deb existant en version stable
-a) paquets deb existant en version rétro-portée
-a) paquets deb existant en version unstable (pining)




slt
bernard




Que donnerait justement l'installation d'un paquet en version unstable sur
une machine en version stable (il n'existe pas de version rétro-portée pour
eclipse) pour un logiciel aussi "complet" qu'Eclipse ?
Celui-ci semble ne dépendre que de java, mais j'ai aussi besoin de son
extension maven.

Votre avis ?

--20cf3078109029001d04b09be22c
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Le Mon, 31 Oct 2011 17:20:27 +0100,<br>
Olivier &lt; <br>
&gt; : <br>
<br>
bonjour,<br>
<br>
<br>
       vous n&#39;avez pas exploré la voie intermédiaire qui c onsiste<br>
       à employer :<br>
<br>
       -a) paquets deb existant en version stable<br>
       -a) paquets deb existant en version rétro-portée<br>
       -a) paquets deb existant en version unstable (pining)<br>
<br>
<br>
<br>
<br>
       slt<br>
<font color="#888888">        bernard<br>
</font></blockquote></div><br>Que donnerait justement l&#39;installation d& #39;un paquet en version unstable sur une machine en version stable (il n&# 39;existe pas de version rétro-portée pour eclipse) pour un logiciel au ssi &quot;complet&quot; qu&#39;Eclipse ?<br>
Celui-ci semble ne dépendre que de java, mais j&#39;ai aussi besoin de so n extension maven.<br><br>Votre avis ?<br>

--20cf3078109029001d04b09be22c--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Michel OLTRA
Le #23923401
Bonjour,


Le lundi 31 octobre 2011, Olivier a écrit...


2. Installer Eclipse à partir des sources du projet.

Dans le 2ème cas, j'ignore les difficultés qui se poseront quand je devrais
migrer à la version stable suivante de Debian.

Remarques et suggestions bienvenues.



J'ai toujours installé Eclipse et ses plugins à partir des sources,
ainsi que la jvm qui fait tourner l'IDE. Ça ne pose pas de problème
particulier de maintenance, Eclipse ne sort pas une version tous les
jours (et je ne cours pas après non plus).

--
jm

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard Schoenacker
Le #23923391
Le Mon, 31 Oct 2011 18:51:07 +0100,
Olivier
Le 31 octobre 2011 18:12, Bernard Schoenacker

> Le Mon, 31 Oct 2011 17:20:27 +0100,
> Olivier >
> > :
>
>
> bonjour,
>
>
> vous n'avez pas exploré la voie intermédiaire qui cons iste
> à employer :
>
> -a) paquets deb existant en version stable
> -a) paquets deb existant en version rétro-portée
> -a) paquets deb existant en version unstable (pining)
>
>
>
>
> slt
> bernard
>

Que donnerait justement l'installation d'un paquet en version
unstable sur une machine en version stable (il n'existe pas de
version rétro-portée pour eclipse) pour un logiciel aussi "comp let"
qu'Eclipse ? Celui-ci semble ne dépendre que de java, mais j'ai aussi
besoin de son extension maven.

Votre avis ?




bonjour,


je ne donne pas d'avis du fait que ce sont les circonstances au
niveau applicatif qui dirigent le tout ...

liste des paquets dispos :

http://packages.debian.org/search?keywords=maven&searchon=names&suite =stable&section=all


autrement, via la modification du sources.list et en employant
la saveur wheezy (testing) en lieu et place de stable ...


d'autres personnes sont plus compétentes que moi pour la plateforme
eclipse et ses dépendances.


slt
bernard


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
jerome moliere
Le #23932631
Je donne ma vision des choses qui se rapproche de celle de Guillaume:
- les versions dans Squeeze sont obsolètes, c'est le prix pour la
stabilité de cette distribution
- des produits comme Eclipse savent se mettre ) jour de manière
autonome donc j'installe le binaire fourni sur le site eclipse et je
fais les MAJ dans mon coin machine/machine...
au niveau de JDK/JRE je passe par les binaires du site d'Oracle (au
revoir Sun) car je n''aime pas la mécanique d'alternatives et que je
préfère maîtriser mon JRE/JDK via JAVA_HOME

mais cela n'engage que moi ..
Jerome
J.MOLIERE - Mentor/J
auteur Eyrolles
blog: http://romjethoughts.blogspot.com

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme