Emacs de Cygwin à partir d'un terminal

Le
Sébastien Vauban
Bonjour,

Pour différentes raisons, je veux passer à l'Emacs de Cygwin (en =
mode
console), en lieu et place de EmacsW32.

Je le lance à partir d'un rxvt, ou urxvt, mais j'ai des tas de probl=
èmes :

- quand je tape "C-h" dans Emacs, cela fait un "DEL"

J'ai vu beaucoup de solutions pour l'inverse (ou pour rendre inambigue la
différence entre DEL et backspace), mais n'ai trouvé aucune doc=
sur ce
problème-ci.

Moi, seule chose qui marche : "DEL" fait "DEL" et "backspace" fait
"backspace"

- si je tape "élève", tout est sens dessus-dessous, le "é" =
étant interprété
comme TAB, le "è" comme "M-l", etc.

- si je presse "S-TAB", seul le "TAB" passe

- parfois, le "C-c" est vu comme un "C-g"

J'ai perdu toute ma journée à faire des tas de tests dans tous le=
s sens, en
mettant à jour le .inputrc et le .Xdefaults, mais rien n'y fait.

Quelqu'un peut-il juste me mettre sur la voie ?

Merci beaucoup,
Seb

--
Sébastien Vauban
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
pjb
Le #22735221
Sébastien Vauban
Bonjour,

Pour différentes raisons, je veux passer à l'Emacs de Cygwin (en mode
console), en lieu et place de EmacsW32.

Je le lance à partir d'un rxvt, ou urxvt, mais j'ai des tas de problèmes :



Si tu as X installé pour quoi ne pas utiliser emacs sur X?


- quand je tape "C-h" dans Emacs, cela fait un "DEL"

J'ai vu beaucoup de solutions pour l'inverse (ou pour rendre inambigue la
différence entre DEL et backspace), mais n'ai trouvé aucune doc sur ce
problème-ci.

Moi, seule chose qui marche : "DEL" fait "DEL" et "backspace" fait
"backspace"...



M-x normal-erase-is-backspace-mode RET


- si je tape "élève", tout est sens dessus-dessous, le "é" étant interprété
comme TAB, le "è" comme "M-l", etc.



Je ne connais pas rxvt, j'utilise seulement xterm. Avec xterm, on peut
configurer les codes envoyés par Control H, DEL, et faire en sorte que
Meta-x soit traduit par ESC x. Sinon, Meta positionne le 8e bit, ce qui
fait que les caractères ISO-8859 non ASCII sont pris pour des
combinaison Meta- au lieu de caractères ISO-8859.

Normalement, emacs prend en compte les variables d'environnement LC_*
pour configurer le système de codage des caractères du terminal.

export LC_CTYPE=en_US.ISO-8859-1

dans ~/.bashrc


Mais sinon, on peut aussi le configurer dans ~/.emacs:

(set-keyboard-coding-system 'iso-8859-1)
(set-terminal-coding-system 'iso-8859-1)



- si je presse "S-TAB", seul le "TAB" passe



C'est normal. Il n'existe aucun code ASCII ou ISO-8859-1 correspondant
à S-TAB. Si tu veux utiliser S-TAB, il faut utiliser X qui a un
protocole pour transmettre de telles combinaisons de touches.


- parfois, le "C-c" est vu comme un "C-g"...



Ou bien c'est un problème cygwin, ou bien ça dépend du mode. Il y a
certains modes qui configurent C-c C-c comme C-g.


J'ai perdu toute ma journée à faire des tas de tests dans tous les sens, en
mettant à jour le .inputrc et le .Xdefaults, mais rien n'y fait.



Si tu travailles dans le terminal, je ne vois pas bien l'impact que
.Xdefaults pourrait avoir...


Quelqu'un peut-il juste me mettre sur la voie ?



Utiliser emacs sur X!



--
__Pascal Bourguignon__ http://www.informatimago.com/
Luc.Habert.00__arjf
Le #22736081
Sébastien Vauban :

- quand je tape "C-h" dans Emacs, cela fait un "DEL"



Vérifie que le caractère erase du terminal est bien « ^? ». Ça se voit avec
« stty -a », et pour xterm, ça peut se régler avec

XTerm*ttyModes: erase ^?

dans le .Xresources.

- si je tape "élève", tout est sens dessus-dessous, le "é" étant interprété
comme TAB, le "è" comme "M-l", etc.



(set-input-mode nil nil 1)

- si je presse "S-TAB", seul le "TAB" passe



Dans un terminal, c'est normal. Le caractère TAB (i.e. ^I) n'a pas de version
shiftée.

- parfois, le "C-c" est vu comme un "C-g"...



J'ai eu ça. Je ne me rappelle plus comment je l'avais résolu, mais il me
semble que c'est un des N modes à la con d'xterm qui se retrouve activé via
une séquence d'échappement à la noix. Je te dirai comment je m'en suis sorti
quand je remettrai la main sur la machine où j'avais le bug.
Sébastien Vauban
Le #22753711
Bonjour Pascal,

Pascal J. Bourguignon wrote:
Sébastien Vauban
Je le lance à partir d'un rxvt, ou urxvt, mais j'ai des tas de prob lèmes :



Si tu as X installé pour quoi ne pas utiliser emacs sur X?



Pour une (très très) bête raison : quand je tapes "emac s", c'est cette
version-là qui se lance.[1]

De manière générale, je suis intéressé d'avoir une config qui marche dans
"tous les cas" : que je puisse utiliser mon .emacs (éventuellemen t, avec le
.Xdefaults) et avoir le même comportement sous différentes enviro nnements
(Windows, Ubuntu, terminal mode, etc.).


- quand je tape "C-h" dans Emacs, cela fait un "DEL"

J'ai vu beaucoup de solutions pour l'inverse (ou pour rendre inambigue la
différence entre DEL et backspace), mais n'ai trouvé aucune doc sur ce
problème-ci.

Moi, seule chose qui marche : "DEL" fait "DEL" et "backspace" fait
"backspace"...



M-x normal-erase-is-backspace-mode RET



Impeccable. Merci.


- si je tape "élève", tout est sens dessus-dessous, le "é " étant interprété
comme TAB, le "è" comme "M-l", etc.



Je ne connais pas rxvt, j'utilise seulement xterm. Avec xterm, on peut
configurer les codes envoyés par Control H, DEL, et faire en sorte q ue
Meta-x soit traduit par ESC x. Sinon, Meta positionne le 8e bit, ce qui
fait que les caractères ISO-8859 non ASCII sont pris pour des
combinaison Meta- au lieu de caractères ISO-8859.

Normalement, emacs prend en compte les variables d'environnement LC_*
pour configurer le système de codage des caractères du terminal.

export LC_CTYPE=en_US.ISO-8859-1

dans ~/.bashrc

Mais sinon, on peut aussi le configurer dans ~/.emacs:

(set-keyboard-coding-system 'iso-8859-1)
(set-terminal-coding-system 'iso-8859-1)



Les deux options marchent parfaitement. Merci.

D'un point de vue général, quelle serait l'approche recommandà ©e ? Y en a-t-il
une meilleure que l'autre ?


- si je presse "S-TAB", seul le "TAB" passe



C'est normal. Il n'existe aucun code ASCII ou ISO-8859-1 correspondant
à S-TAB. Si tu veux utiliser S-TAB, il faut utiliser X qui a un
protocole pour transmettre de telles combinaisons de touches.



OK. Tant pis...


- parfois, le "C-c" est vu comme un "C-g"...



Ou bien c'est un problème cygwin, ou bien ça dépend du mod e. Il y a
certains modes qui configurent C-c C-c comme C-g.



Je n'arrive plus à reproduire cela. Donc, résolu ;-)


J'ai perdu toute ma journée à faire des tas de tests dans tous les sens, en
mettant à jour le .inputrc et le .Xdefaults, mais rien n'y fait.



Si tu travailles dans le terminal, je ne vois pas bien l'impact que
.Xdefaults pourrait avoir...



Je peux, pourtant, t'affirmer qu'il est bien lu. J'y ai mis :

--8<---------------cut here---------------start------------->8---
rxvt.background: yellow
rxvt.foreground: black

! Backspace configuration
rxvt.backspacekey: ^?
--8<---------------cut here---------------end--------------->8---

et j'ai bien :

- un background en jaune
- le C-h qui marche *sans* devoir utiliser le mode
`normal-erase-is-backspace-mode' (c'est l'autre solution apportée ic i par
Luc).


Quelqu'un peut-il juste me mettre sur la voie ?



Utiliser emacs sur X!



Pourquoi pas... Mais, comme indiqué plus haut, je serais intéress é d'avoir une
config "terminal" qui marche aussi...

Un très grand merci pour l'aide !

Seb

Footnotes:
[1] En fait, j'avais oublié d'installer le package Cygwin emacs-X11...
--
Sébastien Vauban
Sébastien Vauban
Le #22753701
Bonjour Luc,

Luc Habert wrote:
Sébastien Vauban :

- quand je tape "C-h" dans Emacs, cela fait un "DEL"



Vérifie que le caractère erase du terminal est bien «  ^? ». Ça se voit avec
« stty -a », et pour xterm, ça peut se régl er avec

XTerm*ttyModes: erase ^?

dans le .Xresources.



Cela ne marche pas...

Par contre, indiquer "rxvt.backspacekey: ^?" marche...

Merci de m'avoir conduit sur la piste avec le "stty -a" que je ne connaissa is
pas du tout...


- si je tape "élève", tout est sens dessus-dessous, le "é " étant interprété
comme TAB, le "è" comme "M-l", etc.



(set-input-mode nil nil 1)



Marche. Merci. Sauf que, à l'affichage, je vois des "?" à la plac e des
accents. Pourtant les caractères sont bien les accents (contrôl é avec C-u C-x
=).


- si je presse "S-TAB", seul le "TAB" passe



Dans un terminal, c'est normal. Le caractère TAB (i.e. ^I) n'a pas d e version
shiftée.



OK.


- parfois, le "C-c" est vu comme un "C-g"...



J'ai eu ça. Je ne me rappelle plus comment je l'avais résolu, m ais il me
semble que c'est un des N modes à la con d'xterm qui se retrouve act ivé via
une séquence d'échappement à la noix. Je te dirai comment je m'en suis sorti
quand je remettrai la main sur la machine où j'avais le bug.



Si tu retrouves l'info, je suis toujours intéressé...

Merci,
Seb

--
Sébastien Vauban
Sébastien Vauban
Le #22753691
Bonjour,

Pour différentes raisons, je veux passer à l'Emacs de Cygwin (e n mode
console), en lieu et place de EmacsW32.

Je le lance à partir d'un rxvt, ou urxvt, mais j'ai des tas de probl èmes :



Un problème très embêtant, auquel je n'ai toujours pas de so lution :

- "S-F12" ne marche pas : si je fais "describe-key", Emacs m'affiche
"M-] 2 4 $". Très différent...

- Idem, bien que différent, pour "S-F10" par exemple : vu comme " F10"...

Merci pour votre aide,
Seb

--
Sébastien Vauban
Luc.Habert.00__arjf
Le #22754341
Sébastien Vauban :

XTerm*ttyModes: erase ^?

dans le .Xresources.



Cela ne marche pas...

Par contre, indiquer "rxvt.backspacekey: ^?" marche...



Oui, c'était pour xterm.

Marche. Merci. Sauf que, à l'affichage, je vois des "?" à la place des
accents. Pourtant les caractères sont bien les accents (contrôlé avec C-u C-x
=).



(set-terminal-coding-system "labonnevaleur parmi latin-1 et utf-8")

- parfois, le "C-c" est vu comme un "C-g"...







Apparament, j'avais modifié l'entrée xterm de terminfo. Je ne sais plus
quelle modif j'avais faite, je t'indique ci-dessous ce que j'ai
actuellement. C'est à compiler avec tic, et mettre le résultat dans
/lib/terminfo/x/xterm. Bon, c'est pour xterm. Pour rxvt, il va falloir jouer
avec /lib/terminfo/r/rxvt jusqu'à trouver le bon truc à changer. Tu fais un
"infocmp rxvt" pour extraire en un format éditable, puis tu modifies un
champ, recompile avec tic, et met le résultat dans le bon fichier. Pour ne
pas avoir à essayer tous les paramètres un par un, tu peux chercher les
différences avec les entrées d'xterm, il y a des chances qu'il n'y en aie
pas tant que ça. Tu peux aussi comparer la sortie d'"infocmp xterm" avec la
mienne pour voir ce que j'ai changé. Si tu trouves, ça m'intéresse que tu me
le dise.

xterm|X11 terminal emulator,
am, bce, km, mc5i, mir, msgr, npc, xenl,
colors#8, cols#80, it#8, lines#24, pairs#64,
acsc=``aaffggiijjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~,
bel=^G, blink=E[5m, bold=E[1m, cbt=E[Z, civis=E[?25l,
clear=E[HE[2J, cnorm=E[?12lE[?25h, cr=^M,
csr=E[%i%p1%d;%p2%dr, cub=E[%p1%dD, cub1=^H,
cud=E[%p1%dB, cud1=^J, cuf=E[%p1%dC, cuf1=E[C,
cup=E[%i%p1%d;%p2%dH, cuu=E[%p1%dA, cuu1=E[A,
cvvis=E[?12;25h, dch=E[%p1%dP, dch1=E[P, dl=E[%p1%dM,
dl1=E[M, ech=E[%p1%dX, ed=E[J, el=E[K, el1=E[1K,
flash=E[?5h$<100/>E[?5l, home=E[H, hpa=E[%i%p1%dG,
ht=^I, hts=EH, ich=E[%p1%d@, il=E[%p1%dL, il1=E[L,
ind=^J, indn=E[%p1%dS, invis=E[8m,
is2=E[!pE[?3;4lE[4lE>, kDC=E[3;2~, kEND=E[1;2F,
kHOM=E[1;2H, kIC=E[2;2~, kLFT=E[1;2D, kNXT=E[6;2~,
kPRV=E[5;2~, kRIT=E[1;2C, kb2=EOE, kbs7, kcbt=E[Z,
kcub1=EOD, kcud1=EOB, kcuf1=EOC, kcuu1=EOA,
kdch1=E[3~, kend=EOF, kent=EOM, kf1=EOP, kf10=E[21~,
kf11=E[23~, kf12=E[24~, kf13=EO2P, kf14=EO2Q,
kf15=EO2R, kf16=EO2S, kf17=E[15;2~, kf18=E[17;2~,
kf19=E[18;2~, kf2=EOQ, kf20=E[19;2~, kf21=E[20;2~,
kf22=E[21;2~, kf23=E[23;2~, kf24=E[24;2~, kf25=EO5P,
kf26=EO5Q, kf27=EO5R, kf28=EO5S, kf29=E[15;5~,
kf3=EOR, kf30=E[17;5~, kf31=E[18;5~, kf32=E[19;5~,
kf33=E[20;5~, kf34=E[21;5~, kf35=E[23;5~,
kf36=E[24;5~, kf37=EO6P, kf38=EO6Q, kf39=EO6R,
kf4=EOS, kf40=EO6S, kf41=E[15;6~, kf42=E[17;6~,
kf43=E[18;6~, kf44=E[19;6~, kf45=E[20;6~,
kf46=E[21;6~, kf47=E[23;6~, kf48=E[24;6~, kf49=EO3P,
kf5=E[15~, kf50=EO3Q, kf51=EO3R, kf52=EO3S,
kf53=E[15;3~, kf54=E[17;3~, kf55=E[18;3~,
kf56=E[19;3~, kf57=E[20;3~, kf58=E[21;3~,
kf59=E[23;3~, kf6=E[17~, kf60=E[24;3~, kf61=EO4P,
kf62=EO4Q, kf63=EO4R, kf7=E[18~, kf8=E[19~, kf9=E[20~,
khome=EOH, kich1=E[2~, kmous=E[M, knp=E[6~, kpp=E[5~,
mc0=E[i, mc4=E[4i, mc5=E[5i, meml=El, memu=Em,
op=E[39;49m, rcè, rev=E[7m, ri=EM, rin=E[%p1%dT,
rmacs=E(B, rmam=E[?7l, rmcup=E[?1049l, rmir=E[4l,
rmkx=E[?1lE>, rmso=E[27m, rmul=E[24m, rs1ì,
rs2=E[!pE[?3;4lE[4lE>, scç, setab=E[4%p1%dm,
setaf=E[3%p1%dm,
setb=E[4%?%p1%{1}%=%t4%e%p1%{3}%=%t6%e%p1%{4}%=%t1%e%p1%{6}%=%t3%e%p1%d%;m,
setf=E[3%?%p1%{1}%=%t4%e%p1%{3}%=%t6%e%p1%{4}%=%t1%e%p1%{6}%=%t3%e%p1%d%;m,
sgr=E[0%?%p6%t;1%;%?%p2%t;4%;%?%p1%p3%|%t;7%;%?%p4%t;5%;%?%p7%t;8%;m%?%p9%tE(0%eE(B%;,
sgr0=E[mE(B, smacs=E(0, smam=E[?7h, smcup=E[?1049h,
smir=E[4h, smkx=E[?1hE=, smso=E[7m, smul=E[4m,
tbc=E[3g, u6=E[%i%d;%dR, u7=E[6n, u8=E[?1;2c, u9=E[c,
vpa=E[%i%p1%dd
Luc.Habert.00__arjf
Le #22754361
Sébastien Vauban :

- "S-F12" ne marche pas : si je fais "describe-key", Emacs m'affiche
"M-] 2 4 $". Très différent...



Les touches de fonction, shiftées ou non, son traduites en séquences de
touches commençant par echap. Emacs se débrouille plus ou moins bien pour
les retraduire en sens inverse. Tu peux l'aider soit en éditant la terminfo
comme expliqué dans mon autre message (man 5 terminfo pour savoir quel champ
modifier) de manière à ce que ça matche la traduction effectuée par rxvt,
soit avec :

(define-key function-key-map [27 ?] ?2 ?4 ?$] 'S-F12)

- Idem, bien que différent, pour "S-F10" par exemple : vu comme "F10"...



Là, c'est peut-être la faute du terminal qui traduit les deux pareils. Pour
en avoir le coeur net, tu tapes ^Q avant le F10 ou S-F10, et tu vois ce que
ça sort. Si c'est la même chose, il faut aller voir dans la config d'rxvt
pour changer ça.
pjb
Le #22754551
Sébastien Vauban
Bonjour Pascal,

Pascal J. Bourguignon wrote:
Sébastien Vauban
Je le lance à partir d'un rxvt, ou urxvt, mais j'ai des tas de problèmes :



Si tu as X installé pour quoi ne pas utiliser emacs sur X?



Pour une (très très) bête raison : quand je tapes "emacs", c'est cette
version-là qui se lance.[1]



Si je me souviens bien, dans le setup de Cygwin, on a le choix entre
emacs-nox et emacs-x11. Il faut choisir la version x11.


Sinon, vérifier que la variable d'environnement DISPLAY est correctement
ajustée.

echo $DISPLAY

Normalement elle doit valoir :0.0, faire:

export DISPLAY=:0.0

pour la régler.



D'un point de vue général, quelle serait l'approche recommandée ? Y en a-t-il
une meilleure que l'autre ?



Ça dépend des circonstances. Normalement les variable d'environnements
LC_* devraient être meilleure car elle s'applique à tout les programmes.
Mais c'est souvent plus simple de régler emacs directement. De toutes
façons, c'est à peut près le seul programme qu'on utilise, non?

Le système (MS-Windows, or Linux), et xterm servent uniquement à fournir
les pilotes et à booter emacs.
http://www.informatimago.com/linux/emacs-on-user-mode-linux.html
;-)



J'ai perdu toute ma journée à faire des tas de tests dans tous les sens, en
mettant à jour le .inputrc et le .Xdefaults, mais rien n'y fait.



Si tu travailles dans le terminal, je ne vois pas bien l'impact que
.Xdefaults pourrait avoir...



Je peux, pourtant, t'affirmer qu'il est bien lu. J'y ai mis :

rxvt.background: yellow
rxvt.foreground: black

! Backspace configuration
rxvt.backspacekey: ^?

et j'ai bien :

- un background en jaune
- le C-h qui marche *sans* devoir utiliser le mode
`normal-erase-is-backspace-mode' (c'est l'autre solution apportée ici par
Luc).



Oui, mais je voulais dire, sur les programme fonctionnant dans le
terminal. Là tu as un effet sur le programme X qu'est rxvt.

.inputrc lui va être utilisé par bash et les autres programmes qui
utilisent la ou les bibliothèques qui se configurent avec .inputrc; mais
celles ci ne vont pas lire .Xdefaults.


Quelqu'un peut-il juste me mettre sur la voie ?



Utiliser emacs sur X!



Pourquoi pas... Mais, comme indiqué plus haut, je serais intéressé d'avoir une
config "terminal" qui marche aussi...



Dans .emacs, tu peux tester le fait de fonctionner dans le terminal
avec: (null window-system)

Pour certaines touches ou combinaisons (touches de fonction, flêches),
on peut ajouter des key bindings dans .emacs spécifique au terminal,
afin d'avoir un comportement similaire.

J'ai ceci dans mon .emacs:

(defun pjb-terminal-key-bindings ()
(interactive)
(global-set-key "OF" (function end-of-buffer))
(global-set-key "OH" (function beginning-of-buffer))
(global-unset-key "[")
(global-set-key "[15~" (function set-justification-left)) ; <f5>
(global-set-key "[17~" (function set-justification-center)) ; <f6>
(global-set-key "[18~" (function set-justification-right)) ; <f7>
(global-set-key "[19~" (lambda()(interactive)(beep))) ; <f8>
(global-set-key "[20~" (lambda()(interactive)(beep))) ; <f9>
(global-set-key "[21~" (lambda()(interactive)(beep))) ; <f10>
(global-set-key "[23~" (lambda()(interactive)(beep))) ; <f11>
(global-set-key "[24~" (lambda()(interactive)(beep))) ; <f12>
)

(unless window-system
(pjb-terminal-key-bindings))


Mais due aux limitations du protocole de communication entre le terminal
et emacs, il y aura des combinaisons de touches qui ne seront pas
transmises.

Dans le cas de Meta, un équivalent est de préfixer un ESC.

M-x = ESC x

Comme ESC fonctionne pareil dans emacs-x11, on peut faire le choix de
prendre l'habitude de toujours utiliser ESC au lieu de Meta.

C-M-f = ESC C-f

D'autre part pour les prefixes de commande numériques, au lieu de
taper:

C-4 C-2

peut taper à la place:

C-u 4 2

ou encore:

ESC 4 ESC 2

M-4 M-2





Un très grand merci pour l'aide !

Seb

Footnotes:
[1] En fait, j'avais oublié d'installer le package Cygwin emacs-X11...



Voilà.

--
__Pascal Bourguignon__ http://www.informatimago.com/
A bad day in () is better than a good day in {}.
pjb
Le #22754541
Sébastien Vauban
Bonjour,

Pour différentes raisons, je veux passer à l'Emacs de Cygwin (en mode
console), en lieu et place de EmacsW32.

Je le lance à partir d'un rxvt, ou urxvt, mais j'ai des tas de problèmes :



Un problème très embêtant, auquel je n'ai toujours pas de solution :

- "S-F12" ne marche pas : si je fais "describe-key", Emacs m'affiche
"M-] 2 4 $". Très différent...



Tu peux ajouter un binding;

Est-ce bien M-] ? Normalement c'est M-[

Si c'est bien M-], il faut l'enlever, car il utilisé pour certaines commandes,

(global-unset-key "]")
(global-set-key "]24$" 'beep)


Sinon seulement:

(global-set-key "[24$" 'beep)

(remplacer beep par la commande que tu veux).


Dans mon xterm, S-F12 produit: "^[[24;2~" (hors double-quotes).
Pour l'insérer utilise C-q qui inhibe l'interprétation de la touche:

" C-q S-F12 "


- Idem, bien que différent, pour "S-F10" par exemple : vu comme "F10"...

Merci pour votre aide,
Seb



--
__Pascal Bourguignon__ http://www.informatimago.com/
A bad day in () is better than a good day in {}.
Sébastien Vauban
Le #23108811
Bonjour Luc et Pascal,

Luc Habert wrote:
- parfois, le "C-c" est vu comme un "C-g"...







Apparament, j'avais modifié l'entrée xterm de terminfo. Je ne s ais plus
quelle modif j'avais faite, je t'indique ci-dessous ce que j'ai
actuellement. C'est à compiler avec tic, et mettre le résultat dans
/lib/terminfo/x/xterm. Bon, c'est pour xterm. Pour rxvt, il va falloir jo uer
avec /lib/terminfo/r/rxvt jusqu'à trouver le bon truc à changer . Tu fais un
"infocmp rxvt" pour extraire en un format éditable, puis tu modifies un
champ, recompile avec tic, et met le résultat dans le bon fichier. P our ne
pas avoir à essayer tous les paramètres un par un, tu peux cher cher les
différences avec les entrées d'xterm, il y a des chances qu'il n'y en aie
pas tant que ça. Tu peux aussi comparer la sortie d'"infocmp xterm" avec la
mienne pour voir ce que j'ai changé. Si tu trouves, ça m'intà ©resse que tu me
le dise.



Je viens de trouver la solution simple : ajouter la variable d'environ nement
CYGWIN avec pour valeur, au moins, "tty" (il peut y avoir d'autres options
supplémentaires).

export CYGWIN=tty

... et ce problème-là est résolu.

Best regards,
Seb

--
Sébastien Vauban
Publicité
Poster une réponse
Anonyme