Encore des photos dans Access

Le
Marsouin_89
Bonsoir à tous,
La semaine dernière, Raymond et Fred, m'ont donnés d'excellents conseils
pour intégrer des images dans Access sans augmenter le volume de la base
(voir article "Phot dans Access"). Toutefois, lorsque ces images se chargent,
il y a une barre de progression avec un bouton annuler. Du fait que ma souris
est paramétrée sur focus, la flèche se déplace systématiquement sur le bouton
annuler engendrant aprfois des mauvaises manip.
Comment puis-je faire pour que cette barre de progression n'apparaisse pas
lors du chargement des images ?
Merci à tous.
Marsouin
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Raymond [mvp]
Le #6277171
Bonjour.

tu peux faire disparaître la barre par une api:
http://www.mvps.org/accessfr/apis/api0038.htm
mais ça ne changera pas ton problème et le curseur devrait se déplacer quand
même.

--
@+
Raymond Access MVP http://OfficeSystem.Access.free.fr/
Pour débuter sur le forum: http://www.mpfa.info/
Le 26 Avril 2007 à 14h assistez à la web TV et faites avancer la recherche
dans votre entreprise
http://www.comscamp.com/Tracker/Redirect.ashx?linkidDb8ed66-f9f8-456a-bdc8-993dda7415fc


"Marsouin_89" de news:
| Bonsoir à tous,
| La semaine dernière, Raymond et Fred, m'ont donnés d'excellents conseils
| pour intégrer des images dans Access sans augmenter le volume de la base
| (voir article "Phot dans Access"). Toutefois, lorsque ces images se
chargent,
| il y a une barre de progression avec un bouton annuler. Du fait que ma
souris
| est paramétrée sur focus, la flèche se déplace systématiquement sur le
bouton
| annuler engendrant aprfois des mauvaises manip.
| Comment puis-je faire pour que cette barre de progression n'apparaisse pas
| lors du chargement des images ?
| Merci à tous.
| Marsouin
Marsouin_89
Le #6277081
Merci Raymond de ce conseil mais je n'arrive à faire fonctionner le code.
J'ai copié le code dans form_timer et défini Intervaltimer sur 200 et 50.
J'ai copié le code start dans un module que j'ai appelé "Import_image" et
j'ai toujours la barre de progression.
A savoir que j'ai jusqu'à 4 images importées dans un formulaire mais comme
le code est sur form_timer cela ne devrait pas poser de problème.
Dans le code start, un message m'intrigue et c'est peut être la raison de ce
non fonctionnement : 'Requis: hWndAccessApp (poignée de référence à
l'application)
Je ne sais pas ce que c'est.
Merci d'avance i tu peux me préciser comment utiliser ce code. Je suis
autodidacte depuis 6 ans mais mes compétences restent limitées.
Raymond [mvp]
Le #6277071
le code ne doit pas être modifié:
tu copies l'api dans un module standard n'importe quel nom.
et tu mets bien, dans ton formulaire:
Private Sub Form_Timer()
Call sHideLoadingImageDialog(hWndAccessApp)
End SubhWndAccessApp est le descripteur de la fenêtre access. on touche pas.

ça doit fonctionner tel quel, sinon on ne peut rien.

--
@+
Raymond Access MVP http://OfficeSystem.Access.free.fr/
Pour débuter sur le forum: http://www.mpfa.info/
Le 26 Avril 2007 à 14h assistez à la web TV et faites avancer la recherche
dans votre entreprise
http://www.comscamp.com/Tracker/Redirect.ashx?linkidDb8ed66-f9f8-456a-bdc8-993dda7415fc


"Marsouin_89" de news:
| Merci Raymond de ce conseil mais je n'arrive à faire fonctionner le code.
| J'ai copié le code dans form_timer et défini Intervaltimer sur 200 et 50.
| J'ai copié le code start dans un module que j'ai appelé "Import_image" et
| j'ai toujours la barre de progression.
| A savoir que j'ai jusqu'à 4 images importées dans un formulaire mais comme
| le code est sur form_timer cela ne devrait pas poser de problème.
| Dans le code start, un message m'intrigue et c'est peut être la raison de
ce
| non fonctionnement : 'Requis: hWndAccessApp (poignée de référence à
| l'application)
| Je ne sais pas ce que c'est.
| Merci d'avance i tu peux me préciser comment utiliser ce code. Je suis
| autodidacte depuis 6 ans mais mes compétences restent limitées.
|
Marsouin_89
Le #6277051
Raymond,
Merci pour tes précisions.
C'est ce que j'avais fais cet après midi mais je ne sais pas pourquoi cela
ne fonctionnait pas. Désormais la barre de progression est quasiment
invisible mais j'ai, comme tu me l'avais dit, toujours le focus de la souris.
Néanmoins, cela est déjà très bien.
Merci encore
Je te souhaite un bon week-end.
Marsouin
Publicité
Poster une réponse
Anonyme