Envoyer la page par courrier électronique

Le
Claude Malesherbes
Je travaille sur un site pour lequel IE (6 ou 7) ne veut pas envoyer les
pages par courrier électronique (le site est www.altance.fr)
Pour un autre site que j'utilise (www.usualsoft.com) le contenu de la page
est envoyé en pièce jointe (je le veux dans le corps du message).
Pour la pluspart des autres sites, tout fonctionne bien, la page se retrouve
bien dans le corps du message .
Quel est le paramètre de la page qui empêche son envoi ou le force en pièce
jointe ??
Merci à tous !
--
Claude Malesherbes
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
hlrNO
Le #12097681
Bonjour Claude,

Je travaille sur un site pour lequel IE (6 ou 7) ne veut pas envoyer les
pages par courrier électronique (le site est www.altance.fr)
Pour un autre site que j'utilise (www.usualsoft.com) le contenu de la page
est envoyé en pièce jointe (je le veux dans le corps du message).
Pour la pluspart des autres sites, tout fonctionne bien, la page se retrouve
bien dans le corps du message ....
Quel est le paramètre de la page qui empêche son envoi ou le force en pièce
jointe ??
Merci à tous !



Mon IE me dit que la page contient des frames et qu'il est obligé
d'envoyer des liens pour chacun des frames.

Amitiés

Hans
Claude Malesherbes
Le #12097671
Merci de ta réponse.
Pourtant il n'y a pas de FrameSet dans le site Altance (mais peut être des
IFRame, ja vais vérifier (je ne suis pas l'auteur original du site).
Il manquait l'attribut charset de la balise Meta Http-Equiv. Depuis que je
l'ai remis la page (www.altance.fr) veut bien partir mais, en pièce jointe,
pas dans le corps du message.

Par contre pour le site UsualSoft.com, pas de FrameSet, pas de IFRame et ça
ne veut pas partir dans le corps du message (toujours en pièce jointe).
--
Claude Malesherbes


"Hans Le Roy" a écrit :

Mon IE me dit que la page contient des frames et qu'il est obligé
d'envoyer des liens pour chacun des frames.

Amitiés

Hans




hlrNO
Le #12097661
Bonjour Claude,


Pourtant il n'y a pas de FrameSet dans le site Altance (mais peut être des
IFRame, ja vais vérifier (je ne suis pas l'auteur original du site).



Si: il y a un frameset dans la DTD.

Il manquait l'attribut charset de la balise Meta Http-Equiv. Depuis que je
l'ai remis la page (www.altance.fr) veut bien partir mais, en pièce jointe,
pas dans le corps du message.



Par contre pour le site UsualSoft.com, pas de FrameSet, pas de IFRame et ça
ne veut pas partir dans le corps du message (toujours en pièce jointe).



Oh si: il suffit d'ouvrir la page pour voir la barre de défilement dans le
frameset.

Pour que la page soit envoyé dans le message même, il suffit sans doute de
mettre le client mail en format HTML. Je le déconseille: beaucoup de gens
(y compris moi) refusent de lire les courriels en format HTML.

Amitiés

Hans
Claude Malesherbes
Le #12097651
Oups ! Pour UsualSoft.com, tu as raison, j'avais oublié que j'y avais utilisé
des Frames !

Pour Altance.fr, merci du tuyau, "des Frames dans la DTD" ... il faut que je
creuse car je vois pas bien ce qu'est la DTD ... (c'est une notion XML non ?)

Il ne suffit pas de mettre le client mail en mode HTML pour que ça marche.
Mon client mail est en mode HTML (malgré les "risques" j'en ai besoin pour
communiquer avec mes partenaires). D'ailleurs pour la grande majorité des
sites (pris au hasard) la page part bien dans le corps du message ...

Merci pour ton aide, cette piste de la DTD me parait bonne.
Amicalement,
Claude Malesherbes
Publicité
Poster une réponse
Anonyme