Erreur dans formule, besoin d'aide pour corriger

Le
Laure
Bonjour !

J'ai créé une formule pour calculer la date de valeur des opérations sur un
document où je gère mon compte bancaire.

Malheureusement, il y a une erreur que je ne parviens pas à repérer.
Quelqu'un peut-il m'aider ?


Voici la formule :

=SI(B6="CHQ";A6+5;SI(B6="CB";SI(JOUR(A6)<27;DATE(ANNEE(A6);MOIS(A6)+1;3);SI(JOUR(A6)>';DATE(ANNEE(A6);MOIS(A6)+2;3);SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))


J'ai donc plusieurs calculs de dates de valeur à partir de la date de
l'opération (en A6)possibles selon le mode de paiement (en B6).

CHQ pour chèque
CB pour carte bancaire
PRV pour prélévement
CREDIT pour toutes les opérations créditrices

La formule fonctionne parfaitement avec CHQ et CB, mais affiche le résultat
"FAUX" pour PRV, CREDIT, et vide ("").

Par contre si je coupe la formule en deux et que je ne garde que les
conditions pour PRV, CREDIT et VIDE, la formule fonctionne, comme ceci :

=SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))

Je ne dépasse pourtant pas les 7 niveaux Pourquoi cela ne fonctionne-t-il
pas ?

Merci d'avance à qui pourra m'aider.

Laure
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal
Le #4354541
A mon avis remplace ton SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))
par SI(OU(B6=credit;B6=prv);A6;"")

"Laure" O%23f$
Bonjour !

J'ai créé une formule pour calculer la date de valeur des opérations sur
un document où je gère mon compte bancaire.

Malheureusement, il y a une erreur que je ne parviens pas à repérer.
Quelqu'un peut-il m'aider ?


Voici la formule :

=SI(B6="CHQ";A6+5;SI(B6="CB";SI(JOUR(A6)<27;DATE(ANNEE(A6);MOIS(A6)+1;3);SI(JOUR(A6)>';DATE(ANNEE(A6);MOIS(A6)+2;3);SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))


J'ai donc plusieurs calculs de dates de valeur à partir de la date de
l'opération (en A6)possibles selon le mode de paiement (en B6).

CHQ pour chèque
CB pour carte bancaire
PRV pour prélévement
CREDIT pour toutes les opérations créditrices

La formule fonctionne parfaitement avec CHQ et CB, mais affiche le
résultat "FAUX" pour PRV, CREDIT, et vide ("").

Par contre si je coupe la formule en deux et que je ne garde que les
conditions pour PRV, CREDIT et VIDE, la formule fonctionne, comme ceci :

=SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))

Je ne dépasse pourtant pas les 7 niveaux... Pourquoi cela ne
fonctionne-t-il pas ?

Merci d'avance à qui pourra m'aider.

Laure



---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 14:49:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:00:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com

Laure
Le #4354511
Merci de ta réponse, que je viens de tester, mais elle me donne exactement
les même résultats, soit

CHQ ça fonctionne
CB ça fonctionne
PRV résultat "FAUX"
CREDIT résultat "FAUX"
VIDE résultat "FAUX"

D'autres pistes ?
Merci d'avance, cordialement,

Laure


"Pascal" 45f016e1$0$25907$
A mon avis remplace ton SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))
par SI(OU(B6=credit;B6=prv);A6;"")

"Laure" O%23f$
Bonjour !

J'ai créé une formule pour calculer la date de valeur des opérations sur
un document où je gère mon compte bancaire.

Malheureusement, il y a une erreur que je ne parviens pas à repérer.
Quelqu'un peut-il m'aider ?


Voici la formule :

=SI(B6="CHQ";A6+5;SI(B6="CB";SI(JOUR(A6)<27;DATE(ANNEE(A6);MOIS(A6)+1;3);SI(JOUR(A6)>';DATE(ANNEE(A6);MOIS(A6)+2;3);SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))


J'ai donc plusieurs calculs de dates de valeur à partir de la date de
l'opération (en A6)possibles selon le mode de paiement (en B6).

CHQ pour chèque
CB pour carte bancaire
PRV pour prélévement
CREDIT pour toutes les opérations créditrices

La formule fonctionne parfaitement avec CHQ et CB, mais affiche le
résultat "FAUX" pour PRV, CREDIT, et vide ("").

Par contre si je coupe la formule en deux et que je ne garde que les
conditions pour PRV, CREDIT et VIDE, la formule fonctionne, comme ceci :

=SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))

Je ne dépasse pourtant pas les 7 niveaux... Pourquoi cela ne
fonctionne-t-il pas ?

Merci d'avance à qui pourra m'aider.

Laure



---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 14:49:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:00:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com






Pascal
Le #4354461
PRV CREDIT sont-ils nommés moi cela marche en les nommant
"Laure" uz3$

Merci de ta réponse, que je viens de tester, mais elle me donne exactement
les même résultats, soit

CHQ ça fonctionne
CB ça fonctionne
PRV résultat "FAUX"
CREDIT résultat "FAUX"
VIDE résultat "FAUX"

D'autres pistes ?
Merci d'avance, cordialement,

Laure


"Pascal" 45f016e1$0$25907$
A mon avis remplace ton
SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))
par SI(OU(B6=credit;B6=prv);A6;"")

"Laure" O%23f$
Bonjour !

J'ai créé une formule pour calculer la date de valeur des opérations sur
un document où je gère mon compte bancaire.

Malheureusement, il y a une erreur que je ne parviens pas à repérer.
Quelqu'un peut-il m'aider ?


Voici la formule :

=SI(B6="CHQ";A6+5;SI(B6="CB";SI(JOUR(A6)<27;DATE(ANNEE(A6);MOIS(A6)+1;3);SI(JOUR(A6)>';DATE(ANNEE(A6);MOIS(A6)+2;3);SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))


J'ai donc plusieurs calculs de dates de valeur à partir de la date de
l'opération (en A6)possibles selon le mode de paiement (en B6).

CHQ pour chèque
CB pour carte bancaire
PRV pour prélévement
CREDIT pour toutes les opérations créditrices

La formule fonctionne parfaitement avec CHQ et CB, mais affiche le
résultat "FAUX" pour PRV, CREDIT, et vide ("").

Par contre si je coupe la formule en deux et que je ne garde que les
conditions pour PRV, CREDIT et VIDE, la formule fonctionne, comme ceci :

=SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))

Je ne dépasse pourtant pas les 7 niveaux... Pourquoi cela ne
fonctionne-t-il pas ?

Merci d'avance à qui pourra m'aider.

Laure



---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 14:49:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:00:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:23:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:24:13
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com



Laure
Le #4354421
Non, ils ne le sont pas...
Je sais nommer une plage mais pas une valeur ?
Peux-tu m'en dire plus sur la marche à suivre ? Ou me dire quoi chercher
dans l'aider excel ? J'ai tapé "nommer" mais je n'ai rien trouvé qui semble
correspondre à ce dont tu parles...

Merci d'avance,

Laure


"Pascal" 45f01c8d$0$25931$
PRV CREDIT sont-ils nommés moi cela marche en les nommant
"Laure" uz3$

Merci de ta réponse, que je viens de tester, mais elle me donne
exactement les même résultats, soit

CHQ ça fonctionne
CB ça fonctionne
PRV résultat "FAUX"
CREDIT résultat "FAUX"
VIDE résultat "FAUX"

D'autres pistes ?
Merci d'avance, cordialement,

Laure


"Pascal" 45f016e1$0$25907$
A mon avis remplace ton
SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))
par SI(OU(B6=credit;B6=prv);A6;"")

"Laure" O%23f$
Bonjour !

J'ai créé une formule pour calculer la date de valeur des opérations
sur un document où je gère mon compte bancaire.

Malheureusement, il y a une erreur que je ne parviens pas à repérer.
Quelqu'un peut-il m'aider ?


Voici la formule :

=SI(B6="CHQ";A6+5;SI(B6="CB";SI(JOUR(A6)<27;DATE(ANNEE(A6);MOIS(A6)+1;3);SI(JOUR(A6)>';DATE(ANNEE(A6);MOIS(A6)+2;3);SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))


J'ai donc plusieurs calculs de dates de valeur à partir de la date de
l'opération (en A6)possibles selon le mode de paiement (en B6).

CHQ pour chèque
CB pour carte bancaire
PRV pour prélévement
CREDIT pour toutes les opérations créditrices

La formule fonctionne parfaitement avec CHQ et CB, mais affiche le
résultat "FAUX" pour PRV, CREDIT, et vide ("").

Par contre si je coupe la formule en deux et que je ne garde que les
conditions pour PRV, CREDIT et VIDE, la formule fonctionne, comme ceci
:

=SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))

Je ne dépasse pourtant pas les 7 niveaux... Pourquoi cela ne
fonctionne-t-il pas ?

Merci d'avance à qui pourra m'aider.

Laure



---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 14:49:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:00:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:23:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:24:13
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








Pascal
Le #4354381
Sur une autre feuille en col a par exemple a2=prv
a3=crédit etc
Ensuite Insertion nom définir et pour A2 tu donnes comme nom prv etc a3 tu
donnes comme nom credit


"Laure" %
Non, ils ne le sont pas...
Je sais nommer une plage mais pas une valeur ?
Peux-tu m'en dire plus sur la marche à suivre ? Ou me dire quoi chercher
dans l'aider excel ? J'ai tapé "nommer" mais je n'ai rien trouvé qui
semble correspondre à ce dont tu parles...

Merci d'avance,

Laure


"Pascal" 45f01c8d$0$25931$
PRV CREDIT sont-ils nommés moi cela marche en les nommant
"Laure" uz3$

Merci de ta réponse, que je viens de tester, mais elle me donne
exactement les même résultats, soit

CHQ ça fonctionne
CB ça fonctionne
PRV résultat "FAUX"
CREDIT résultat "FAUX"
VIDE résultat "FAUX"

D'autres pistes ?
Merci d'avance, cordialement,

Laure


"Pascal" 45f016e1$0$25907$
A mon avis remplace ton
SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))
par SI(OU(B6=credit;B6=prv);A6;"")

"Laure" O%23f$
Bonjour !

J'ai créé une formule pour calculer la date de valeur des opérations
sur un document où je gère mon compte bancaire.

Malheureusement, il y a une erreur que je ne parviens pas à repérer.
Quelqu'un peut-il m'aider ?


Voici la formule :

=SI(B6="CHQ";A6+5;SI(B6="CB";SI(JOUR(A6)<27;DATE(ANNEE(A6);MOIS(A6)+1;3);SI(JOUR(A6)>';DATE(ANNEE(A6);MOIS(A6)+2;3);SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))


J'ai donc plusieurs calculs de dates de valeur à partir de la date de
l'opération (en A6)possibles selon le mode de paiement (en B6).

CHQ pour chèque
CB pour carte bancaire
PRV pour prélévement
CREDIT pour toutes les opérations créditrices

La formule fonctionne parfaitement avec CHQ et CB, mais affiche le
résultat "FAUX" pour PRV, CREDIT, et vide ("").

Par contre si je coupe la formule en deux et que je ne garde que les
conditions pour PRV, CREDIT et VIDE, la formule fonctionne, comme ceci
:

=SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))

Je ne dépasse pourtant pas les 7 niveaux... Pourquoi cela ne
fonctionne-t-il pas ?

Merci d'avance à qui pourra m'aider.

Laure



---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 14:49:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:00:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:23:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:24:13
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:47:09
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-3, 08/03/2007
Analyse le : 08/03/2007 15:48:53
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com





Laure
Le #4354311
Je viens d'essayer mais ça ne fonctionne toujours pas....


"Pascal" 45f02255$0$5100$
Sur une autre feuille en col a par exemple a2=prv
a3=crédit etc
Ensuite Insertion nom définir et pour A2 tu donnes comme nom prv etc a3 tu
donnes comme nom credit


"Laure" %
Non, ils ne le sont pas...
Je sais nommer une plage mais pas une valeur ?
Peux-tu m'en dire plus sur la marche à suivre ? Ou me dire quoi chercher
dans l'aider excel ? J'ai tapé "nommer" mais je n'ai rien trouvé qui
semble correspondre à ce dont tu parles...

Merci d'avance,

Laure


"Pascal" 45f01c8d$0$25931$
PRV CREDIT sont-ils nommés moi cela marche en les nommant
"Laure" uz3$

Merci de ta réponse, que je viens de tester, mais elle me donne
exactement les même résultats, soit

CHQ ça fonctionne
CB ça fonctionne
PRV résultat "FAUX"
CREDIT résultat "FAUX"
VIDE résultat "FAUX"

D'autres pistes ?
Merci d'avance, cordialement,

Laure


"Pascal" 45f016e1$0$25907$
A mon avis remplace ton
SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))
par SI(OU(B6=credit;B6=prv);A6;"")

"Laure" O%23f$
Bonjour !

J'ai créé une formule pour calculer la date de valeur des opérations
sur un document où je gère mon compte bancaire.

Malheureusement, il y a une erreur que je ne parviens pas à repérer.
Quelqu'un peut-il m'aider ?


Voici la formule :

=SI(B6="CHQ";A6+5;SI(B6="CB";SI(JOUR(A6)<27;DATE(ANNEE(A6);MOIS(A6)+1;3);SI(JOUR(A6)>';DATE(ANNEE(A6);MOIS(A6)+2;3);SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))


J'ai donc plusieurs calculs de dates de valeur à partir de la date de
l'opération (en A6)possibles selon le mode de paiement (en B6).

CHQ pour chèque
CB pour carte bancaire
PRV pour prélévement
CREDIT pour toutes les opérations créditrices

La formule fonctionne parfaitement avec CHQ et CB, mais affiche le
résultat "FAUX" pour PRV, CREDIT, et vide ("").

Par contre si je coupe la formule en deux et que je ne garde que les
conditions pour PRV, CREDIT et VIDE, la formule fonctionne, comme
ceci :

=SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))

Je ne dépasse pourtant pas les 7 niveaux... Pourquoi cela ne
fonctionne-t-il pas ?

Merci d'avance à qui pourra m'aider.

Laure



---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 14:49:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:00:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:23:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:24:13
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:47:09
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-3, 08/03/2007
Analyse le : 08/03/2007 15:48:53
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com










Pascal
Le #4354151
jE T4ENVOIE UN CLASSEUR
"Laure"
Je viens d'essayer mais ça ne fonctionne toujours pas....


"Pascal" 45f02255$0$5100$
Sur une autre feuille en col a par exemple a2=prv
a3=crédit etc
Ensuite Insertion nom définir et pour A2 tu donnes comme nom prv etc a3
tu donnes comme nom credit


"Laure" %
Non, ils ne le sont pas...
Je sais nommer une plage mais pas une valeur ?
Peux-tu m'en dire plus sur la marche à suivre ? Ou me dire quoi chercher
dans l'aider excel ? J'ai tapé "nommer" mais je n'ai rien trouvé qui
semble correspondre à ce dont tu parles...

Merci d'avance,

Laure


"Pascal" 45f01c8d$0$25931$
PRV CREDIT sont-ils nommés moi cela marche en les nommant
"Laure" uz3$

Merci de ta réponse, que je viens de tester, mais elle me donne
exactement les même résultats, soit

CHQ ça fonctionne
CB ça fonctionne
PRV résultat "FAUX"
CREDIT résultat "FAUX"
VIDE résultat "FAUX"

D'autres pistes ?
Merci d'avance, cordialement,

Laure


"Pascal" 45f016e1$0$25907$
A mon avis remplace ton
SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))
par SI(OU(B6=credit;B6=prv);A6;"")

"Laure" O%23f$
Bonjour !

J'ai créé une formule pour calculer la date de valeur des opérations
sur un document où je gère mon compte bancaire.

Malheureusement, il y a une erreur que je ne parviens pas à repérer.
Quelqu'un peut-il m'aider ?


Voici la formule :

=SI(B6="CHQ";A6+5;SI(B6="CB";SI(JOUR(A6)<27;DATE(ANNEE(A6);MOIS(A6)+1;3);SI(JOUR(A6)>';DATE(ANNEE(A6);MOIS(A6)+2;3);SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))


J'ai donc plusieurs calculs de dates de valeur à partir de la date
de l'opération (en A6)possibles selon le mode de paiement (en B6).

CHQ pour chèque
CB pour carte bancaire
PRV pour prélévement
CREDIT pour toutes les opérations créditrices

La formule fonctionne parfaitement avec CHQ et CB, mais affiche le
résultat "FAUX" pour PRV, CREDIT, et vide ("").

Par contre si je coupe la formule en deux et que je ne garde que les
conditions pour PRV, CREDIT et VIDE, la formule fonctionne, comme
ceci :

=SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))

Je ne dépasse pourtant pas les 7 niveaux... Pourquoi cela ne
fonctionne-t-il pas ?

Merci d'avance à qui pourra m'aider.

Laure



---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 14:49:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:00:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:23:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:24:13
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:47:09
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-3, 08/03/2007
Analyse le : 08/03/2007 15:48:53
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-3, 08/03/2007
Analyse le : 08/03/2007 17:31:11
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-3, 08/03/2007
Analyse le : 08/03/2007 17:32:54
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







Pascal
Le #4354121
Ici regarde si cela te convient
http://www.cijoint.fr/cij3156509966601.xls

"Laure"
Je viens d'essayer mais ça ne fonctionne toujours pas....


"Pascal" 45f02255$0$5100$
Sur une autre feuille en col a par exemple a2=prv
a3=crédit etc
Ensuite Insertion nom définir et pour A2 tu donnes comme nom prv etc a3
tu donnes comme nom credit


"Laure" %
Non, ils ne le sont pas...
Je sais nommer une plage mais pas une valeur ?
Peux-tu m'en dire plus sur la marche à suivre ? Ou me dire quoi chercher
dans l'aider excel ? J'ai tapé "nommer" mais je n'ai rien trouvé qui
semble correspondre à ce dont tu parles...

Merci d'avance,

Laure


"Pascal" 45f01c8d$0$25931$
PRV CREDIT sont-ils nommés moi cela marche en les nommant
"Laure" uz3$

Merci de ta réponse, que je viens de tester, mais elle me donne
exactement les même résultats, soit

CHQ ça fonctionne
CB ça fonctionne
PRV résultat "FAUX"
CREDIT résultat "FAUX"
VIDE résultat "FAUX"

D'autres pistes ?
Merci d'avance, cordialement,

Laure


"Pascal" 45f016e1$0$25907$
A mon avis remplace ton
SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))
par SI(OU(B6=credit;B6=prv);A6;"")

"Laure" O%23f$
Bonjour !

J'ai créé une formule pour calculer la date de valeur des opérations
sur un document où je gère mon compte bancaire.

Malheureusement, il y a une erreur que je ne parviens pas à repérer.
Quelqu'un peut-il m'aider ?


Voici la formule :

=SI(B6="CHQ";A6+5;SI(B6="CB";SI(JOUR(A6)<27;DATE(ANNEE(A6);MOIS(A6)+1;3);SI(JOUR(A6)>';DATE(ANNEE(A6);MOIS(A6)+2;3);SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))


J'ai donc plusieurs calculs de dates de valeur à partir de la date
de l'opération (en A6)possibles selon le mode de paiement (en B6).

CHQ pour chèque
CB pour carte bancaire
PRV pour prélévement
CREDIT pour toutes les opérations créditrices

La formule fonctionne parfaitement avec CHQ et CB, mais affiche le
résultat "FAUX" pour PRV, CREDIT, et vide ("").

Par contre si je coupe la formule en deux et que je ne garde que les
conditions pour PRV, CREDIT et VIDE, la formule fonctionne, comme
ceci :

=SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))

Je ne dépasse pourtant pas les 7 niveaux... Pourquoi cela ne
fonctionne-t-il pas ?

Merci d'avance à qui pourra m'aider.

Laure



---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 14:49:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:00:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:23:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:24:13
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:47:09
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-3, 08/03/2007
Analyse le : 08/03/2007 15:48:53
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-3, 08/03/2007
Analyse le : 08/03/2007 17:31:11
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-3, 08/03/2007
Analyse le : 08/03/2007 17:44:39
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







Laure
Le #4354081
Merci beaucoup !!

J'ai donc utilisé tes informations, et pour j'ai parfois une réponse,
parfois rien, et des dates qui ne sont pas celles attendues...

Je joins mon fichier, peux-tu jeter un oeil ?

http://cjoint.com/?diskf7UzPx

Grand merci !!


"Pascal" 45f03d77$0$5071$
Ici regarde si cela te convient
http://www.cijoint.fr/cij3156509966601.xls

"Laure"
Je viens d'essayer mais ça ne fonctionne toujours pas....


"Pascal" 45f02255$0$5100$
Sur une autre feuille en col a par exemple a2=prv
a3=crédit etc
Ensuite Insertion nom définir et pour A2 tu donnes comme nom prv etc a3
tu donnes comme nom credit


"Laure" %
Non, ils ne le sont pas...
Je sais nommer une plage mais pas une valeur ?
Peux-tu m'en dire plus sur la marche à suivre ? Ou me dire quoi
chercher dans l'aider excel ? J'ai tapé "nommer" mais je n'ai rien
trouvé qui semble correspondre à ce dont tu parles...

Merci d'avance,

Laure


"Pascal" 45f01c8d$0$25931$
PRV CREDIT sont-ils nommés moi cela marche en les nommant
"Laure" uz3$

Merci de ta réponse, que je viens de tester, mais elle me donne
exactement les même résultats, soit

CHQ ça fonctionne
CB ça fonctionne
PRV résultat "FAUX"
CREDIT résultat "FAUX"
VIDE résultat "FAUX"

D'autres pistes ?
Merci d'avance, cordialement,

Laure


"Pascal" 45f016e1$0$25907$
A mon avis remplace ton
SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))
par SI(OU(B6=credit;B6=prv);A6;"")

"Laure" O%23f$
Bonjour !

J'ai créé une formule pour calculer la date de valeur des
opérations sur un document où je gère mon compte bancaire.

Malheureusement, il y a une erreur que je ne parviens pas à
repérer. Quelqu'un peut-il m'aider ?


Voici la formule :

=SI(B6="CHQ";A6+5;SI(B6="CB";SI(JOUR(A6)<27;DATE(ANNEE(A6);MOIS(A6)+1;3);SI(JOUR(A6)>';DATE(ANNEE(A6);MOIS(A6)+2;3);SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))


J'ai donc plusieurs calculs de dates de valeur à partir de la date
de l'opération (en A6)possibles selon le mode de paiement (en B6).

CHQ pour chèque
CB pour carte bancaire
PRV pour prélévement
CREDIT pour toutes les opérations créditrices

La formule fonctionne parfaitement avec CHQ et CB, mais affiche le
résultat "FAUX" pour PRV, CREDIT, et vide ("").

Par contre si je coupe la formule en deux et que je ne garde que
les conditions pour PRV, CREDIT et VIDE, la formule fonctionne,
comme ceci :

=SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))

Je ne dépasse pourtant pas les 7 niveaux... Pourquoi cela ne
fonctionne-t-il pas ?

Merci d'avance à qui pourra m'aider.

Laure



---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 14:49:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:00:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:23:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:24:13
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-2, 07/03/2007
Analyse le : 08/03/2007 15:47:09
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-3, 08/03/2007
Analyse le : 08/03/2007 15:48:53
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000722-3, 08/03/2007
Analyse le : 08/03/2007 17:31:11
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000722-3, 08/03/2007
Analyse le : 08/03/2007 17:44:39
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com












Eric
Le #4354031
Bonjour,
Dans ton xls tu as oublié les "" pour PRV et CREDIT.
Ton autre erreur est due au 29/02/07 qui n'existe pas (année non bissextile)

Eric


"Laure" O%23f$
Bonjour !

J'ai créé une formule pour calculer la date de valeur des opérations sur
un document où je gère mon compte bancaire.

Malheureusement, il y a une erreur que je ne parviens pas à repérer.
Quelqu'un peut-il m'aider ?


Voici la formule :

=SI(B6="CHQ";A6+5;SI(B6="CB";SI(JOUR(A6)<27;DATE(ANNEE(A6);MOIS(A6)+1;3);SI(JOUR(A6)>';DATE(ANNEE(A6);MOIS(A6)+2;3);SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))))))


J'ai donc plusieurs calculs de dates de valeur à partir de la date de
l'opération (en A6)possibles selon le mode de paiement (en B6).

CHQ pour chèque
CB pour carte bancaire
PRV pour prélévement
CREDIT pour toutes les opérations créditrices

La formule fonctionne parfaitement avec CHQ et CB, mais affiche le
résultat "FAUX" pour PRV, CREDIT, et vide ("").

Par contre si je coupe la formule en deux et que je ne garde que les
conditions pour PRV, CREDIT et VIDE, la formule fonctionne, comme ceci :

=SI(B6="CREDIT";A6;SI(B6="PRV";A6;SI(B6="";"")))

Je ne dépasse pourtant pas les 7 niveaux... Pourquoi cela ne
fonctionne-t-il pas ?

Merci d'avance à qui pourra m'aider.

Laure



Publicité
Poster une réponse
Anonyme