Erreur lors mise à jour du driver nvidia

Le
Petit Louis
Bonjour à tous,

Un problème avec debian cela ne m'était pas arrivé depuis longtemps.

Je voulais ce matin mettre à jour le driver nvidia, hélas pour la
première fois l'installation a échoué.
Dans le journal de l'installeur nvidia je lis :

Kernel configuration is invalid
make oldconfig && make prepare

J'exécute les deux commandes, rien n'y fait, l'installation échoue à
nouveau.
Je me tourne vers vous, si quelqu'un a une piste.

Mon système :

lenny, noyau 2.6.18-rt7 (compilé par mes soins),

Bien sûr j'ai les sources de mon noyau. Je précise que je mets à jour le
driver régulièrement sans problème jusqu'à là.

Merci d'avance.

P'tit Louis

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
David Prévot
Le #20678361
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Petit Louis a écrit :
Bonjour à tous,



Bonjour,

Un problème avec debian cela ne m'était pas arrivé depuis longtemps.



En l'occurrence, c'est plutôt un problème avec l'installateur nvidia
propriétaire non « supporté » par Debian.

Kernel configuration is invalid
make oldconfig && make prepare



Une raison de ne pas utiliser la méthode Debian (m-a a-i nvidia) ? Pas
de raison que ça ne fonctionne pas si tu as compilé ton noyau à la sauce
Debian (quitte à installer les headers de ton noyau après la compilation).

Amicalement

David

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEUEARECAAYFAksWYO4ACgkQ18/WetbTC/oh5gCYzPnfiZ4m+fppaW3md0rfByjD
3ACdGX1Twm1faTqeCSYtwDa/sjEVWoM =mWs+
-----END PGP SIGNATURE-----

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Poustiquet
Le #20678641
David Prévot a écrit :
Petit Louis a écrit :
> Bonjour à tous,

Bonjour,

> Un problème avec debian cela ne m'était pas arrivé depuis longtemps.

En l'occurrence, c'est plutôt un problème avec l'installateur nvidia
propriétaire non « supporté » par Debian.

> Kernel configuration is invalid
> make oldconfig && make prepare

Une raison de ne pas utiliser la méthode Debian (m-a a-i nvidia) ? Pas
de raison que ça ne fonctionne pas si tu as compilé ton noyau à la sauce
Debian (quitte à installer les headers de ton noyau après la compilation).

Amicalement

David



Pas de soucis pour la mise à jour de mon coté
noyau Debian 2.6.26.2-686
et binaire directement de Nvidia

Sur 2 x Geforce 6200 en PCI express (4 écrans de 21 pouces)
auto configuration OK avec le manager nVidia


Quel est le modèle de ta carte ?


Poustiquet


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
mess-mate
Le #20680201
David Prévot wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Petit Louis a écrit :

Bonjour à tous,




Bonjour,


Un problème avec debian cela ne m'était pas arrivé depuis longtemps.




En l'occurrence, c'est plutôt un problème avec l'installateur nvidia
propriétaire non « supporté » par Debian.


Kernel configuration is invalid
make oldconfig && make prepare




Une raison de ne pas utiliser la méthode Debian (m-a a-i nvidia) ? Pas
de raison que ça ne fonctionne pas si tu as compilé ton noyau à la sauce
Debian (quitte à installer les headers de ton noyau après la compilation).

Amicalement

David




Bonjour,
j'ai aucun problème à installer la nvidia proprio sur divers noyaux.
Tout ce qui peut se passer c'est que sa compilation doit se faire avec
le même gcc pour le noyau.
C.à.d. le noyau doit être compilé avec le même gcc que celui de nvidia.
Dans mon cas (le dernier de nvidia) gcc-3.1.

amicalement




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Yo machine
Le #20680461
Bonsoir à tous,

Merci de vos réponses. Voici des éclaircissements

>> Un problème avec debian cela ne m'était pas arrivé depuis longtemps.
>>
>
> En l'occurrence, c'est plutôt un problème avec l'installateur nvidia
> propriétaire non « supporté » par Debian.


Oops au temps pour moi la précision est de taille.
>
>
>> Kernel configuration is invalid
>> make oldconfig && make prepare
>>
>
> Une raison de ne pas utiliser la méthode Debian (m-a a-i nvidia) ? Pas
> de raison que ça ne fonctionne pas si tu as compilé ton noyau à la sauce
> Debian (quitte à installer les headers de ton noyau après la compilation).


Je ne comprends pas, si j'ai les sources du noyau, ai-je besoin des
headers ?
>
> Amicalement


Moi de même
>
> David
>
>
Bonjour,
j'ai aucun problème à installer la nvidia proprio sur divers noyaux.
Tout ce qui peut se passer c'est que sa compilation doit se faire avec
le même gcc pour le noyau.
C.à.d. le noyau doit être compilé avec le même gcc que celui de nvidia.
Dans mon cas (le dernier de nvidia) gcc-3.1.


Cette partie là je l'ai bien faite CC=gcc-4.1 sh
NVIDIAjenesaispaskoi.run --update

amicalement


Tout pareil.

P'tit Louis

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
David Prévot
Le #20680681
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Yo machine a écrit :
Bonsoir à tous,



Bonsoir,

Une raison d'utiliser la méthode Debian (m-a a-i nvidia) ? Pas
de raison que ça ne fonctionne pas si tu as compilé ton noyau à la sauce
Debian (quitte à installer les headers de ton noyau après la compilation).







Je ne comprends pas, si j'ai les sources du noyau, ai-je besoin des
headers ?



Je crois que m-a (module-assistant) utilise les headers. Je viens de
corriger une négation dans ma proposition initiale et reformule ma
question : pourquoi t'embêter avec le script de nvidia alors qu'un
paquet est maintenu dans Debian ?

Amicalement

David

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAksWly0ACgkQ18/WetbTC/pNMgCbBhiYggYh/wjWsiPOIgum840K
4toAnimog/T5ZBlWx0Di5ej4EM8YUvWM
=S7qJ
-----END PGP SIGNATURE-----

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Yo machine
Le #20681691
> Je crois que m-a (module-assistant) utilise les headers. Je viens de
corriger une négation dans ma proposition initiale et reformule ma
question : pourquoi t'embêter avec le script de nvidia alors qu'un
paquet est maintenu dans Debian ?


Vraisemblablement parce que :

j'ai cru comprendre que le paquet maintenu ne permettait pas une
exploitation optimale de la carte.

Peut-être ai-je fais erreur.


Par ailleurs je vais fermer ce post sur le problème, parce qu'ayant
tenté de résoudre le problème, le mal n'a fait qu'empirer. À tout de
suite pour une nouveau post.


Amicalement

David



P'tit Louis

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAksWly0ACgkQ18/WetbTC/pNMgCbBhiYggYh/wjWsiPOIgum840K
4toAnimog/T5ZBlWx0Di5ej4EM8YUvWM
=S7qJ
-----END PGP SIGNATURE-----




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme