L'ERREUR Magique !!

Le
Bonjour à tous,

Je suis sur un taf, je vous dis pas, j'ai pour mission de upgrader une base
Access de 97 à 2003, puis de mettre les tables sur SQL en tables lié, (genre
projet ADP) et c'est pas facile.

Mon message concerne un pbs incompréhensible, j'ai récupérer les bases
97(Appli et data) sur mon portable vista
puis upgrader en access 2003, puis, le DEV avait devellopé des Actives X, je
l'ai ai reconnecté dans VB avec les références manquantes et TOuT va bien
(c'est des fichiers OCX).

Je refais LA MEME manip sur mon fixe (vista pareil, Access 2003 pareil) et
il me trouve les actives X, (ils ne sont pas absents) mais les formulaires
refusent de les afficher

J'ai refais cette manip sur un AUTRE portable Vista même erreur ! les
Actives X ne s'affichent pas

ça fonctionne QUE sur mon 1er portable sans raison

Merci pour vos idées.

Renaud
Dur dur d'être un blaireau
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fred.M.
Le #6322671
Bonjour Renaud,
* Grattement de crâne *
Euh ouais là en effet.. euh.. vive l'informatique... Bon on va commencer par
des questions à la con :
- Tu as simplement un refus d'affichage (contrôle vierge) ou un message
d'erreur ? si tel est le cas quel est ce message d'erreur ?
- Dans tous les cas tes ActiveX sont affichés dans la barre d'outils (en
gros ils sont bien registrés dans la base des registres ?)
- Je doute en revanche de l'impact de ce détail mais la version du MDAC
est-elle la même partout ?

Keep Strong...
Fred.M.



Bonjour tous,

Je suis sur un taf, je vous dis pas, j'ai pour mission de upgrader une base
Access de 97 2003, puis de mettre les tables sur SQL en tables li, (genre
projet ADP) et c'est pas facile.

Mon message concerne un pbs incomprhensible, j'ai rcuprer les bases
97(Appli et data) sur mon portable vista
puis upgrader en access 2003, puis, le DEV avait devellop des Actives X, je
l'ai ai reconnect dans VB avec les rfrences manquantes et TOuT va bien
(c'est des fichiers OCX).

Je refais LA MEME manip sur mon fixe (vista pareil, Access 2003 pareil) et
il me trouve les actives X, (ils ne sont pas absents) mais les formulaires
refusent de les afficher...

J'ai refais cette manip sur un AUTRE portable Vista mme erreur ! les
Actives X ne s'affichent pas

a fonctionne QUE sur mon 1er portable sans raison...

Merci pour vos ides.

Renaud
Dur dur d'tre un blaireau...







Le #6322481
Bonjour Fred, et merci de t'interesser à mon Pbs,

J'ai ET un affichage vierge et un message d'erreur, cad que du VB demande
une valeur au contrôle active X, et le pire, c'est que l'espion (dans le
code) trouve une valeur, mais pourtant y'a un arreêt sur le code...

Ensuite, mes activeX ne sont pas dans la barre de menue, ce sont des
contrôle dans le formulaire (genre curseur gradués)
enfin, je ne sais pas s'ils sont dans la base de registres, comment le
savoir ?

et pour finir, c'est pourquoi ça fonctionne sur mon portable sans raison, et
pas sur mon fixe (si sur le portable neuf du client ?)

Merci à tous, en attendant ta réponse, je continue à pleurer ;)

Renaud

"Fred.M." news:
Bonjour Renaud,
* Grattement de crâne *
Euh ouais là en effet.. euh.. vive l'informatique... Bon on va commencer
par
des questions à la con :
- Tu as simplement un refus d'affichage (contrôle vierge) ou un message
d'erreur ? si tel est le cas quel est ce message d'erreur ?
- Dans tous les cas tes ActiveX sont affichés dans la barre d'outils (en
gros ils sont bien registrés dans la base des registres ?)
- Je doute en revanche de l'impact de ce détail mais la version du MDAC
est-elle la même partout ?

Keep Strong...
Fred.M.



Bonjour tous,

Je suis sur un taf, je vous dis pas, j'ai pour mission de upgrader une
base
Access de 97 2003, puis de mettre les tables sur SQL en tables li,
(genre
projet ADP) et c'est pas facile.

Mon message concerne un pbs incomprhensible, j'ai rcuprer les bases
97(Appli et data) sur mon portable vista
puis upgrader en access 2003, puis, le DEV avait devellop des Actives X,
je
l'ai ai reconnect dans VB avec les rfrences manquantes et TOuT va bien
(c'est des fichiers OCX).

Je refais LA MEME manip sur mon fixe (vista pareil, Access 2003 pareil)
et
il me trouve les actives X, (ils ne sont pas absents) mais les
formulaires
refusent de les afficher...

J'ai refais cette manip sur un AUTRE portable Vista mme erreur ! les
Actives X ne s'affichent pas

a fonctionne QUE sur mon 1er portable sans raison...

Merci pour vos ides.

Renaud
Dur dur d'tre un blaireau...









Pierre CFI [mvp]
Le #6322411
bonjour
tes ocx ont été enregistrés avec regsvr32.exe ??

--
Pierre
MVP Access
***************************************
Conseils MPFA: http://www.mpfa.info/
*********************************************************

Bonjour Fred, et merci de t'interesser à mon Pbs,

J'ai ET un affichage vierge et un message d'erreur, cad que du VB demande
une valeur au contrôle active X, et le pire, c'est que l'espion (dans le
code) trouve une valeur, mais pourtant y'a un arreêt sur le code...

Ensuite, mes activeX ne sont pas dans la barre de menue, ce sont des
contrôle dans le formulaire (genre curseur gradués)
enfin, je ne sais pas s'ils sont dans la base de registres, comment le
savoir ?

et pour finir, c'est pourquoi ça fonctionne sur mon portable sans raison,
et pas sur mon fixe (si sur le portable neuf du client ?)

Merci à tous, en attendant ta réponse, je continue à pleurer ;)

Renaud

"Fred.M." news:
Bonjour Renaud,
* Grattement de crâne *
Euh ouais là en effet.. euh.. vive l'informatique... Bon on va commencer
par
des questions à la con :
- Tu as simplement un refus d'affichage (contrôle vierge) ou un message
d'erreur ? si tel est le cas quel est ce message d'erreur ?
- Dans tous les cas tes ActiveX sont affichés dans la barre d'outils (en
gros ils sont bien registrés dans la base des registres ?)
- Je doute en revanche de l'impact de ce détail mais la version du MDAC
est-elle la même partout ?

Keep Strong...
Fred.M.



Bonjour tous,

Je suis sur un taf, je vous dis pas, j'ai pour mission de upgrader une
base
Access de 97 2003, puis de mettre les tables sur SQL en tables li,
(genre
projet ADP) et c'est pas facile.

Mon message concerne un pbs incomprhensible, j'ai rcuprer les bases
97(Appli et data) sur mon portable vista
puis upgrader en access 2003, puis, le DEV avait devellop des Actives X,
je
l'ai ai reconnect dans VB avec les rfrences manquantes et TOuT va bien
(c'est des fichiers OCX).

Je refais LA MEME manip sur mon fixe (vista pareil, Access 2003 pareil)
et
il me trouve les actives X, (ils ne sont pas absents) mais les
formulaires
refusent de les afficher...

J'ai refais cette manip sur un AUTRE portable Vista mme erreur ! les
Actives X ne s'affichent pas

a fonctionne QUE sur mon 1er portable sans raison...

Merci pour vos ides.

Renaud
Dur dur d'tre un blaireau...












Le #6322371
Bonjour Pierre

Non, ils ne l'ont pas été, mais je maitrise peu les Actives X.

donc j'utilise regsvr32.exe et je les rentre dans la base de registre.

Une procédure à me conseiller ou je cherche l'aide de regsvr32.exe et c'est
assez simple ?

Merci pour vos conseils.

Renaud


"Pierre CFI [mvp]" a écrit dans le message de
news:
bonjour
tes ocx ont été enregistrés avec regsvr32.exe ??

--
Pierre
MVP Access
***************************************
Conseils MPFA: http://www.mpfa.info/
*********************************************************

Bonjour Fred, et merci de t'interesser à mon Pbs,

J'ai ET un affichage vierge et un message d'erreur, cad que du VB demande
une valeur au contrôle active X, et le pire, c'est que l'espion (dans le
code) trouve une valeur, mais pourtant y'a un arreêt sur le code...

Ensuite, mes activeX ne sont pas dans la barre de menue, ce sont des
contrôle dans le formulaire (genre curseur gradués)
enfin, je ne sais pas s'ils sont dans la base de registres, comment le
savoir ?

et pour finir, c'est pourquoi ça fonctionne sur mon portable sans raison,
et pas sur mon fixe (si sur le portable neuf du client ?)

Merci à tous, en attendant ta réponse, je continue à pleurer ;)

Renaud

"Fred.M." news:
Bonjour Renaud,
* Grattement de crâne *
Euh ouais là en effet.. euh.. vive l'informatique... Bon on va commencer
par
des questions à la con :
- Tu as simplement un refus d'affichage (contrôle vierge) ou un message
d'erreur ? si tel est le cas quel est ce message d'erreur ?
- Dans tous les cas tes ActiveX sont affichés dans la barre d'outils (en
gros ils sont bien registrés dans la base des registres ?)
- Je doute en revanche de l'impact de ce détail mais la version du MDAC
est-elle la même partout ?

Keep Strong...
Fred.M.



Bonjour tous,

Je suis sur un taf, je vous dis pas, j'ai pour mission de upgrader une
base
Access de 97 2003, puis de mettre les tables sur SQL en tables li,
(genre
projet ADP) et c'est pas facile.

Mon message concerne un pbs incomprhensible, j'ai rcuprer les bases
97(Appli et data) sur mon portable vista
puis upgrader en access 2003, puis, le DEV avait devellop des Actives
X, je
l'ai ai reconnect dans VB avec les rfrences manquantes et TOuT va bien
(c'est des fichiers OCX).

Je refais LA MEME manip sur mon fixe (vista pareil, Access 2003 pareil)
et
il me trouve les actives X, (ils ne sont pas absents) mais les
formulaires
refusent de les afficher...

J'ai refais cette manip sur un AUTRE portable Vista mme erreur ! les
Actives X ne s'affichent pas

a fonctionne QUE sur mon 1er portable sans raison...

Merci pour vos ides.

Renaud
Dur dur d'tre un blaireau...
















Pierre CFI [mvp]
Le #6322341
dans demarrer/executer tu saisis
regsvr32.exe "c:.....chemin complet et nom de ocx" entre guillemets

--
Pierre
MVP Access
***************************************
Conseils MPFA: http://www.mpfa.info/
*********************************************************

Bonjour Pierre

Non, ils ne l'ont pas été, mais je maitrise peu les Actives X.

donc j'utilise regsvr32.exe et je les rentre dans la base de registre.

Une procédure à me conseiller ou je cherche l'aide de regsvr32.exe et
c'est assez simple ?

Merci pour vos conseils.

Renaud


"Pierre CFI [mvp]" a écrit dans le message de
news:
bonjour
tes ocx ont été enregistrés avec regsvr32.exe ??

--
Pierre
MVP Access
***************************************
Conseils MPFA: http://www.mpfa.info/
*********************************************************

Bonjour Fred, et merci de t'interesser à mon Pbs,

J'ai ET un affichage vierge et un message d'erreur, cad que du VB
demande une valeur au contrôle active X, et le pire, c'est que l'espion
(dans le code) trouve une valeur, mais pourtant y'a un arreêt sur le
code...

Ensuite, mes activeX ne sont pas dans la barre de menue, ce sont des
contrôle dans le formulaire (genre curseur gradués)
enfin, je ne sais pas s'ils sont dans la base de registres, comment le
savoir ?

et pour finir, c'est pourquoi ça fonctionne sur mon portable sans
raison, et pas sur mon fixe (si sur le portable neuf du client ?)

Merci à tous, en attendant ta réponse, je continue à pleurer ;)

Renaud

"Fred.M." news:
Bonjour Renaud,
* Grattement de crâne *
Euh ouais là en effet.. euh.. vive l'informatique... Bon on va
commencer par
des questions à la con :
- Tu as simplement un refus d'affichage (contrôle vierge) ou un message
d'erreur ? si tel est le cas quel est ce message d'erreur ?
- Dans tous les cas tes ActiveX sont affichés dans la barre d'outils
(en
gros ils sont bien registrés dans la base des registres ?)
- Je doute en revanche de l'impact de ce détail mais la version du MDAC
est-elle la même partout ?

Keep Strong...
Fred.M.



Bonjour tous,

Je suis sur un taf, je vous dis pas, j'ai pour mission de upgrader une
base
Access de 97 2003, puis de mettre les tables sur SQL en tables li,
(genre
projet ADP) et c'est pas facile.

Mon message concerne un pbs incomprhensible, j'ai rcuprer les bases
97(Appli et data) sur mon portable vista
puis upgrader en access 2003, puis, le DEV avait devellop des Actives
X, je
l'ai ai reconnect dans VB avec les rfrences manquantes et TOuT va bien
(c'est des fichiers OCX).

Je refais LA MEME manip sur mon fixe (vista pareil, Access 2003
pareil) et
il me trouve les actives X, (ils ne sont pas absents) mais les
formulaires
refusent de les afficher...

J'ai refais cette manip sur un AUTRE portable Vista mme erreur ! les
Actives X ne s'affichent pas

a fonctionne QUE sur mon 1er portable sans raison...

Merci pour vos ides.

Renaud
Dur dur d'tre un blaireau...



















Renaud Roualdès
Le #6321161
Pierre Bonjour,

J'ai suivi tes conseils et enregistré les Actives X, mais maintenant, c'est
pire, j'ai une erreur dans le module Access.exe donc, visiblement, y'a un
truc qui le vexe enormément...

Une piste de recherche ?

---
Renaud Roualdès
Profite, Vivre c'est cool !!!

___

"Pierre CFI [mvp]" a écrit dans le message de
news:%
dans demarrer/executer tu saisis
regsvr32.exe "c:.....chemin complet et nom de ocx" entre guillemets

--
Pierre
MVP Access
***************************************
Conseils MPFA: http://www.mpfa.info/
*********************************************************

Bonjour Pierre

Non, ils ne l'ont pas été, mais je maitrise peu les Actives X.

donc j'utilise regsvr32.exe et je les rentre dans la base de registre.

Une procédure à me conseiller ou je cherche l'aide de regsvr32.exe et
c'est assez simple ?

Merci pour vos conseils.

Renaud


"Pierre CFI [mvp]" a écrit dans le message de
news:
bonjour
tes ocx ont été enregistrés avec regsvr32.exe ??

--
Pierre
MVP Access
***************************************
Conseils MPFA: http://www.mpfa.info/
*********************************************************

Bonjour Fred, et merci de t'interesser à mon Pbs,

J'ai ET un affichage vierge et un message d'erreur, cad que du VB
demande une valeur au contrôle active X, et le pire, c'est que l'espion
(dans le code) trouve une valeur, mais pourtant y'a un arreêt sur le
code...

Ensuite, mes activeX ne sont pas dans la barre de menue, ce sont des
contrôle dans le formulaire (genre curseur gradués)
enfin, je ne sais pas s'ils sont dans la base de registres, comment le
savoir ?

et pour finir, c'est pourquoi ça fonctionne sur mon portable sans
raison, et pas sur mon fixe (si sur le portable neuf du client ?)

Merci à tous, en attendant ta réponse, je continue à pleurer ;)

Renaud

"Fred.M." news:
Bonjour Renaud,
* Grattement de crâne *
Euh ouais là en effet.. euh.. vive l'informatique... Bon on va
commencer par
des questions à la con :
- Tu as simplement un refus d'affichage (contrôle vierge) ou un
message
d'erreur ? si tel est le cas quel est ce message d'erreur ?
- Dans tous les cas tes ActiveX sont affichés dans la barre d'outils
(en
gros ils sont bien registrés dans la base des registres ?)
- Je doute en revanche de l'impact de ce détail mais la version du
MDAC
est-elle la même partout ?

Keep Strong...
Fred.M.



Bonjour tous,

Je suis sur un taf, je vous dis pas, j'ai pour mission de upgrader
une base
Access de 97 2003, puis de mettre les tables sur SQL en tables li,
(genre
projet ADP) et c'est pas facile.

Mon message concerne un pbs incomprhensible, j'ai rcuprer les bases
97(Appli et data) sur mon portable vista
puis upgrader en access 2003, puis, le DEV avait devellop des Actives
X, je
l'ai ai reconnect dans VB avec les rfrences manquantes et TOuT va
bien
(c'est des fichiers OCX).

Je refais LA MEME manip sur mon fixe (vista pareil, Access 2003
pareil) et
il me trouve les actives X, (ils ne sont pas absents) mais les
formulaires
refusent de les afficher...

J'ai refais cette manip sur un AUTRE portable Vista mme erreur ! les
Actives X ne s'affichent pas

a fonctionne QUE sur mon 1er portable sans raison...

Merci pour vos ides.

Renaud
Dur dur d'tre un blaireau...























Publicité
Poster une réponse
Anonyme