Erreur de periphérique, scanner

Le
ROBERT LEFEVRE
Bonjour,
J'essaie d'installer un scanner scsi canon (canoscan 300) sue mon linux
(Debian Etch).
1) La commande "sane-find-scanner" me le trouve bien :
found SCSI scanner "CANON IX-03035B 1.02" at /dev/sg5
# Your SCSI scanner was detected. It may or may not be supported by
SANE. Try
# scanimage -L and read the backend's manpage.
2) Par contre, la commande "scanimage -L" me renvoie:

device `v4l:/dev/video0' is a Noname BT878 video (Pinnacle PCTV Stud
virtual device
3) Si je lance xsane, je me retrouve bien à scanner avec ma carte
Pinnacle studio TV.
Je sais qu'on peut écrire des règles udev, pour qu'à un périphérique
donné ne soit pas attribué un fichier /dev/sg* qui correspond à un
autre, mais je ne sais pas comment faire. J'ai été regarder dans
/etc/udev et j'ai peur de casser quelque chose.
Un coup de main svp, merci!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Vincent Felsch
Le #1912598
"ROBERT LEFEVRE" 47a4281e$0$869$
Bonjour,
J'essaie d'installer un scanner scsi canon (canoscan 300) sue mon linux
(Debian Etch).
1) La commande "sane-find-scanner" me le trouve bien :
found SCSI scanner "CANON IX-03035B 1.02" at /dev/sg5
# Your SCSI scanner was detected. It may or may not be supported by
SANE. Try
# scanimage -L and read the backend's manpage.
2) Par contre, la commande "scanimage -L" me renvoie:

device `v4l:/dev/video0' is a Noname BT878 video (Pinnacle PCTV Stud
virtual device
3) Si je lance xsane, je me retrouve bien à scanner avec... ma carte
Pinnacle studio TV.
Je sais qu'on peut écrire des règles udev, pour qu'à un périphérique
donné ne soit pas attribué un fichier /dev/sg* qui correspond à un autre,
mais je ne sais pas comment faire. J'ai été regarder dans /etc/udev et
j'ai peur de casser quelque chose.
Un coup de main svp, merci!


Bonjour
ça fait longtemps que j'ai plus installé de scanner sous linux mais si j'ai
bonne mémoire il faut récupérer le fichier *.bin des pilotes Windows pour
que le scanner fonctionne.

Cordialement

Vincent F.

Luc.Habert.00__arjf
Le #1912596
ROBERT LEFEVRE :

J'essaie d'installer un scanner scsi canon (canoscan 300) sue mon linux
(Debian Etch).
1) La commande "sane-find-scanner" me le trouve bien :
found SCSI scanner "CANON IX-03035B 1.02" at /dev/sg5
# Your SCSI scanner was detected. It may or may not be supported by
SANE. Try
# scanimage -L and read the backend's manpage.
2) Par contre, la commande "scanimage -L" me renvoie:

device `v4l:/dev/video0' is a Noname BT878 video (Pinnacle PCTV Stud
virtual device


As-tu bien les droits de lecture et écriture sur /dev/sg5?
Est-ce que « scanimage -d canon:/dev/sg5 » fonctionne?

ROBERT LEFEVRE
Le #1912590
ROBERT LEFEVRE :

J'essaie d'installer un scanner scsi canon (canoscan 300) sue mon linux
(Debian Etch).
1) La commande "sane-find-scanner" me le trouve bien :
found SCSI scanner "CANON IX-03035B 1.02" at /dev/sg5
# Your SCSI scanner was detected. It may or may not be supported by
SANE. Try
# scanimage -L and read the backend's manpage.
2) Par contre, la commande "scanimage -L" me renvoie:

device `v4l:/dev/video0' is a Noname BT878 video (Pinnacle PCTV Stud
virtual device


As-tu bien les droits de lecture et écriture sur /dev/sg5?
Est-ce que « scanimage -d canon:/dev/sg5 » fonctionne?
Bonjour et merci pour ta réponse. Oui, cette commande fonctionne

parfaitement "scanimage -d canon:/dev/sg5 > test.pnm" m'a fait un beau
fichier image. Mon problème, c'est que xscanimage et xsane ne "voient"
que le périphérique "video0", c'est à dire ma carte TV. Il y a un truc
qui m'échappe encore...
A+


Luc.Habert.00__arjf
Le #1912587
ROBERT LEFEVRE :

Bonjour et merci pour ta réponse. Oui, cette commande fonctionne
parfaitement "scanimage -d canon:/dev/sg5 > test.pnm" m'a fait un beau
fichier image. Mon problème, c'est que xscanimage et xsane ne "voient"
que le périphérique "video0", c'est à dire ma carte TV. Il y a un truc
qui m'échappe encore...


Tu peux mettre SANE_DEFAULT_DEVICEÊnon:/dev/sg5 dans l'environnement.

ROBERT LEFEVRE
Le #1912571
ROBERT LEFEVRE :

Bonjour et merci pour ta réponse. Oui, cette commande fonctionne
parfaitement "scanimage -d canon:/dev/sg5 > test.pnm" m'a fait un beau
fichier image. Mon problème, c'est que xscanimage et xsane ne "voient"
que le périphérique "video0", c'est à dire ma carte TV. Il y a un truc
qui m'échappe encore...


Tu peux mettre SANE_DEFAULT_DEVICEÊnon:/dev/sg5 dans l'environnement.


Je l'ai déjà fait (page de man de sane) mais le problème vient

d'ailleurs je pense. Au redémarrage, mon scanner est maintenant sur
/dev/sg4 et bien sûr il ne fonctionne pas. C'est pourquoi je pense à
écrire une règle udev. J'ai eu ce type de problème de périphérique avec
mes disques durs qui changeaient de fichier dev, je m'en suis sorti en
faisant des LABEL sur mes disques, mais pour le scanner je sèche encore.
Merci quand même, j'avance.


Marc Dejardin
Le #1912567
Bonjour,
J'essaie d'installer un scanner scsi canon (canoscan 300) sue mon linux
(Debian Etch).
1) La commande "sane-find-scanner" me le trouve bien :
found SCSI scanner "CANON IX-03035B 1.02" at /dev/sg5
# Your SCSI scanner was detected. It may or may not be supported by
SANE. Try
# scanimage -L and read the backend's manpage.
2) Par contre, la commande "scanimage -L" me renvoie:

device `v4l:/dev/video0' is a Noname BT878 video (Pinnacle PCTV Stud
virtual device
3) Si je lance xsane, je me retrouve bien à scanner avec... ma carte
Pinnacle studio TV.
Je sais qu'on peut écrire des règles udev, pour qu'à un périphérique
donné ne soit pas attribué un fichier /dev/sg* qui correspond à un
autre, mais je ne sais pas comment faire. J'ai été regarder dans
/etc/udev et j'ai peur de casser quelque chose.
Un coup de main svp, merci!


Bonjour,
Je vais peut-être persévérer dans l'erreur, mais je viens de faire une
réponse dans le fil SOS du 01/02.
Cette réponse est peut-être valide pour ce problème là aussi.

Sans garantie.

Cordialement
M.D.

JKB
Le #1912566
Le 04-02-2008, à propos de
Re: Erreur de periphérique, scanner,
ROBERT LEFEVRE écrivait dans fr.comp.os.linux.configuration :
ROBERT LEFEVRE :

Bonjour et merci pour ta réponse. Oui, cette commande fonctionne
parfaitement "scanimage -d canon:/dev/sg5 > test.pnm" m'a fait un beau
fichier image. Mon problème, c'est que xscanimage et xsane ne "voient"
que le périphérique "video0", c'est à dire ma carte TV. Il y a un truc
qui m'échappe encore...


Tu peux mettre SANE_DEFAULT_DEVICEÊnon:/dev/sg5 dans l'environnement.


Je l'ai déjà fait (page de man de sane) mais le problème vient

d'ailleurs je pense. Au redémarrage, mon scanner est maintenant sur
/dev/sg4 et bien sûr il ne fonctionne pas. C'est pourquoi je pense à
écrire une règle udev. J'ai eu ce type de problème de périphérique avec
mes disques durs qui changeaient de fichier dev, je m'en suis sorti en
faisant des LABEL sur mes disques, mais pour le scanner je sèche encore.
Merci quand même, j'avance.


Je n'ai pas tout suivi, mais si ma mémoire est bonne, il s'agit d'un
scanner PSC. Le daemon hpoj est-il fonctionnel ? Que donne un
ps auwx | grep ptal ?

JKB

--
Le cerveau, c'est un véritable scandale écologique. Il représente 2% de notre
masse corporelle, mais disperse à lui seul 25% de l'énergie que nous
consommons tous les jours.



Luc.Habert.00__arjf
Le #1912565
ROBERT LEFEVRE :

Je l'ai déjà fait (page de man de sane) mais le problème vient
d'ailleurs je pense. Au redémarrage, mon scanner est maintenant sur
/dev/sg4 et bien sûr il ne fonctionne pas. C'est pourquoi je pense à
écrire une règle udev.


OK, c'est un problème différent. Il y a des chances que tu aies un
/etc/udev/rules.d/*libsane.rules, qui doit contenir une règle qui matche ton
scanner, puisque quelque chose t'a donné les droits de lecture et écriture
dessus. Je pense qu'il suffirait d'à ajouter « ,SYMLINK+="scanner" » au bout
de la ligne en question. Enfin, il serait plus propre de créer un autre
fichier de règle pour ça, en fait.

ROBERT LEFEVRE
Le #1912495
Bonjour,
J'essaie d'installer un scanner scsi canon (canoscan 300) sue mon
linux (Debian Etch).
1) La commande "sane-find-scanner" me le trouve bien :
found SCSI scanner "CANON IX-03035B 1.02" at /dev/sg5
# Your SCSI scanner was detected. It may or may not be supported by
SANE. Try
# scanimage -L and read the backend's manpage.
2) Par contre, la commande "scanimage -L" me renvoie:

device `v4l:/dev/video0' is a Noname BT878 video (Pinnacle PCTV Stud
virtual device
3) Si je lance xsane, je me retrouve bien à scanner avec... ma carte
Pinnacle studio TV.
Je sais qu'on peut écrire des règles udev, pour qu'à un périphérique
donné ne soit pas attribué un fichier /dev/sg* qui correspond à un
autre, mais je ne sais pas comment faire. J'ai été regarder dans
/etc/udev et j'ai peur de casser quelque chose.
Un coup de main svp, merci!


Bonjour,
Je vais peut-être persévérer dans l'erreur, mais je viens de faire une
réponse dans le fil SOS du 01/02.
Cette réponse est peut-être valide pour ce problème là aussi.

Sans garantie.

Cordialement
M.D.
Bonjour,

Je vais essayer d'écrire une règle udev pour mon scanner, c'est ce que
je soupçonne depuis le début, et je la mettrai en sauvegarde.
Merci encore à tous, A+


Publicité
Poster une réponse
Anonyme