Erreur "La référence d'objet n'est pas définie à une instance d'un objet"

Le
J-CLAUDE
Bonjour,

J'ai fais une application avec un WEBBROWSER qui se nomme WEBBROWSER1.
Lors de la navigation, un combobox reçoit les URL visitées avec
ITEMS.ADD()
Au début, ça fonctionnait mais maintenant, lorsque la page de navigation
WEBBROWSER1 est sollicitée, j'ai une erreur :
"La référence d'objet n'est pas définie à une instance d'un objet" au niveau
de ma ligne "ToolStripComboBox1.Items.Add(WebBrowser1.Url.AbsoluteUri)"

et l'application s'arrête sur ce bug.

Que faut-il faire pour "réparer" ?

J'ai essayer aussi avec
" WebBrowser1.Url.OriginalString"
" WebBrowser2.Url.AbsolutePath"

Avant, tout fonctionnait mais maintenant, le bug!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gloops
Le #15351601
Bonsoir,

ToolStripComboBox1, c'est du ASP, ça, non ?.
As-tu vérifié la compatibilité avec VB6 ?

Je cherche AbsoluteUri, sur Google, tu sais ce que je vois, sur la page
Microsoft ?

This page is specific to
.NET Framework 3.0

Peut-être un début de réponse ?


Pour mémoire, la plateforme .Net est traitée dans l'arborescence de
newsgroups microsoft.public.fr.dotnet

Tout fonctionnait dis-tu, mais était-ce sous VB6 ? Sur la même machin e ?
Rien installé de nouveau ni renommé ?

_______________________________________
J-CLAUDE a écrit, le 15/07/2007 17:10 :
Bonjour,

J'ai fais une application avec un WEBBROWSER qui se nomme WEBBROWSER1.
Lors de la navigation, un combobox reçoit les URL visitées avec
....ITEMS.ADD(...)
Au début, ça fonctionnait mais maintenant, lorsque la page de navig ation
WEBBROWSER1 est sollicitée, j'ai une erreur :
"La référence d'objet n'est pas définie à une instance d'un obj et" au niveau
de ma ligne "ToolStripComboBox1.Items.Add(WebBrowser1.Url.AbsoluteUri)"

.... et l'application s'arrête sur ce bug.

Que faut-il faire pour "réparer" ?

J'ai essayer aussi avec
"... WebBrowser1.Url.OriginalString..."
"... WebBrowser2.Url.AbsolutePath..."

Avant, tout fonctionnait mais maintenant, le bug!




Gloops
Le #15351591
Ah oui, au lieu de foncer tête baissée, j'aurais lu le fil suivant,
avant ...
J-CLAUDE
Le #15351571
Merci de ta réponse.
à vrai dire, j'étais sur VB 2005.
je vais effectuer la même recherche que toi.
Dans tous les cas, je te remercie.
-------------------------------------



"Gloops" %
Bonsoir,

ToolStripComboBox1, c'est du ASP, ça, non ?.
As-tu vérifié la compatibilité avec VB6 ?

Je cherche AbsoluteUri, sur Google, tu sais ce que je vois, sur la page
Microsoft ?

This page is specific to
.NET Framework 3.0

Peut-être un début de réponse ?


Pour mémoire, la plateforme .Net est traitée dans l'arborescence de
newsgroups microsoft.public.fr.dotnet

Tout fonctionnait dis-tu, mais était-ce sous VB6 ? Sur la même machine ?
Rien installé de nouveau ni renommé ?

_______________________________________
J-CLAUDE a écrit, le 15/07/2007 17:10 :
Bonjour,

J'ai fais une application avec un WEBBROWSER qui se nomme WEBBROWSER1.
Lors de la navigation, un combobox reçoit les URL visitées avec
....ITEMS.ADD(...)
Au début, ça fonctionnait mais maintenant, lorsque la page de navigation
WEBBROWSER1 est sollicitée, j'ai une erreur :
"La référence d'objet n'est pas définie à une instance d'un objet" au
niveau de ma ligne
"ToolStripComboBox1.Items.Add(WebBrowser1.Url.AbsoluteUri)"

.... et l'application s'arrête sur ce bug.

Que faut-il faire pour "réparer" ?

J'ai essayer aussi avec
"... WebBrowser1.Url.OriginalString..."
"... WebBrowser2.Url.AbsolutePath..."

Avant, tout fonctionnait mais maintenant, le bug!




Publicité
Poster une réponse
Anonyme