Erreur STOP: C0000128 Unknown hardware error

Le
elxav
Bonjour à tous,

Machine DELL datant de 2 ans 1/2.
Windows XP Familial (livré avec le DELL). Tous les SPs sont installés
ainsi que toutes les mises à jour.

Voilà quelques jours, je constate que mon PC est éteint, alors que je
suis persuadé de l'avoir laisser tourner toute la nuit Je suspecte
un crash, mais bon

J'allume donc la machine, et bang! Message d'erreur cité en objet dans
un écran bleu.
J'éteins et rallume, et re.
Je tente un démarrage en mode sans échec, avec support réseau.
Je vois passé le vumètre et le logo windows, puis écran noir, et
curseur clignotant en haut à gauche
30mn plus tard, toujours écran noir. Aucune activité disque.

J'ai recherché longuement des infos sur ce code erreur C0000128.
Mais je n'ai rien trouvé avec le message "Unknown hardware error", qui
puisse correspondre à mon cas.

J'ai testé la mémoire avec MemTest depuis un CD "UltraBoot". RAS.
Idem quelques minutes sur le processeur. RAS

Puis, boot sur le CD de Windows et accés à la console. CHKDSK n'a rien
détecté de particulier.

J'ai finalement lancé l'install de Windows dans un dossier autre que
celui de base. Le système démarre correctement. Me reste à
éventuellement à lancer un defrag.

Mes interrogations:
1) L'erreur C0000128 est-elle toujours liée à un problème lié au
registre?
2) Dois-je m'attendre à un problème matériel sérieux si j'arrive =
à
dépanner WinXP?
3) Puis-je lancer l'install de WinXP "par dessus" le dossier initial
(comme lu dans certains forums, ce qui ramène uniquement Windows à une
install de base), sans perdre l'installation des softs, les profils,
et les données des profils?

D'avance merci pour toutes vos suggestions.
Xav.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JF
Le #6717621
*Bonjour * !

Bonjour à tous,

Machine DELL datant de 2 ans 1/2.
Windows XP Familial (livré avec le DELL). Tous les SPs sont installés
ainsi que toutes les mises à jour.

Voilà quelques jours, je constate que mon PC est éteint, alors que je
suis persuadé de l'avoir laisser tourner toute la nuit... Je suspecte
un crash, mais bon...

J'allume donc la machine, et bang! Message d'erreur cité en objet dans
un écran bleu.
J'éteins et rallume, et re.
Je tente un démarrage en mode sans échec, avec support réseau.
Je vois passé le vumètre et le logo windows, puis écran noir, et
curseur clignotant en haut à gauche...
30mn plus tard, toujours écran noir. Aucune activité disque.

J'ai recherché longuement des infos sur ce code erreur C0000128.
Mais je n'ai rien trouvé avec le message "Unknown hardware error", qui
puisse correspondre à mon cas.

J'ai testé la mémoire avec MemTest depuis un CD "UltraBoot". RAS.
Idem quelques minutes sur le processeur. RAS

Puis, boot sur le CD de Windows et accés à la console. CHKDSK n'a rien
détecté de particulier.

J'ai finalement lancé l'install de Windows dans un dossier autre que
celui de base. Le système démarre correctement. Me reste à
éventuellement à lancer un defrag.

Mes interrogations:
1) L'erreur C0000128 est-elle toujours liée à un problème lié au
registre?
2) Dois-je m'attendre à un problème matériel sérieux si j'arrive à
dépanner WinXP?
3) Puis-je lancer l'install de WinXP "par dessus" le dossier initial
(comme lu dans certains forums, ce qui ramène uniquement Windows à une
install de base), sans perdre l'installation des softs, les profils,
et les données des profils?

D'avance merci pour toutes vos suggestions.
Xav.


Je ne peux pas répondre aux questions 1 et 2.
La réponse à la question 3 est positive
RÉPARATION À L'AIDE DU CD DE WINDOWS
http://support.microsoft.com/kb/315341/fr
Réparation de Windows avec conservation des données en images
www.bellamyjc.org/fr/windows2000.html#repair

Ce que je ferais, puisque tu as un système Windows bis qui fonctionne,
c'est de remettre en place une copie du Registre. Tu n'es pas obligé
de passer par la CDR mais cet article explique le principe
http://fspsa.free.fr/cdr-svi.htm
Il te suffit juste de te donner les droits au dossier
System Volume Information pour y avoir accès.

En ligne de commandes :
CACLS "C:System Volume Information" /T /E /G %USERNAME%:F
(corriger la lettre du lecteur)

ou en mode sans échec, avec un clic droit (Administrateur).


Tu peux aussi te servir d'un BARTPE
http://fspsa.free.fr/ubcd4win.htm

Vérifier ou modifier le BOOT.INI pour avoir un multiboot correct.

--

Salutations, Jean-François.

elxav
Le #6722451
Bonjour JF,

J'ai passé en revue les différents liens que tu m'as donnés.
Je n'avais pas pensé à rechercher les infos sur la récupération du
registre, du fait que le message reçu lors du premier STOP, me faisait
plus penser à un problème matériel.

Pour le coup de la récupération à partir du CD d'install, je ne pense
pas que celà soit possible.
C'est un CD généré par la procédure DELL de création des CDs de r é-
installation (Windows XP Familial SP2).
L'option de réparation ne m'est proposée nulle part :-/

Je me suis frotté à cette procédure de réparation plusieurs fois il y
a 4 ou 5 ans, suite à diverses pannes de WinXP, lié à une défaillanc e
de la CM et du proc.
Mais j'avais le fameux message "... manquant ou corrompu".
Et à chaque réparation (les COPY depuis le dossier REPAIR), je perdais
les logiciels installés!

Je vais donc tenter un rétablissement à partir d'une sauvegarde du
registre depuis le dossier "SVI" (méthode que je ne connaissais pas à
l'époque).
Et si ça ne fonctionne pas, je formatte et je ré-installe. Ca aura au
moins le mérite de repartir sur un système "propre".
Tel que c'est parti, je vais passer plus de temps à essayer de
récupérer mon install qu'à en refaire une.

Je reviens vers le forum dés que le problème aura été réglé.
Merci bien pour toutes ces infos.

Xav.
JF
Le #6722901
*Bonjour * !

Bonjour JF,

J'ai passé en revue les différents liens que tu m'as donnés.
Je n'avais pas pensé à rechercher les infos sur la récupération du
registre, du fait que le message reçu lors du premier STOP, me faisait
plus penser à un problème matériel.


L'idéal eût été de disposer d'une sauvegarde du disque
www.clubic.com/article-83110-1-sauvegarde-restauration-image-ghost.html


Pour le coup de la récupération à partir du CD d'install, je ne pense
pas que celà soit possible.
C'est un CD généré par la procédure DELL de création des CDs de ré-
installation (Windows XP Familial SP2).
L'option de réparation ne m'est proposée nulle part :-/


AZO4 sur ce newsgroup connait bien les Dell. J'avais compris qu'ils
sont livrés normalement avec un CD d'install tout à fait utilisable
pour la réparation standard.



Je me suis frotté à cette procédure de réparation plusieurs fois il y
a 4 ou 5 ans, suite à diverses pannes de WinXP, lié à une défaillance
de la CM et du proc.
Mais j'avais le fameux message "... manquant ou corrompu".
Et à chaque réparation (les COPY depuis le dossier REPAIR), je perdais
les logiciels installés!


Il fallait poursuivre la méthode jusqu'au bout. Quand on restaure une
copie du Registre depuis Repair on perd bien évidemment les écritures
du Registre en relation avec les logiciels installés. En poursuivant la
procédure, on complète en remettant en place une copie récente du
registre récupérée depuis un point de restauration dans le dossier
System Volume Information. La procédure que je décris profite du fait
que ce SVI est accessible depuis la CDR ou un BARTPE pour gagner une
étape.

Une bonne solution à ces tracas est d'utiliser Erunt.



Je vais donc tenter un rétablissement à partir d'une sauvegarde du
registre depuis le dossier "SVI" (méthode que je ne connaissais pas à
l'époque).


Finaliser en récupérant le contenu du SVI était
pourtant bien le but de la méthode avec Repair ==>
Voir les secondes parties de ces articles
http://support.microsoft.com/kb/307545/fr
http://www.d2i.ch/pn/az/symb.html#symb003
(il faut un point de restauration.)



Et si ça ne fonctionne pas, je formatte et je ré-installe. Ca aura au
moins le mérite de repartir sur un système "propre".
Tel que c'est parti, je vais passer plus de temps à essayer de
récupérer mon install qu'à en refaire une.


Mais tu vas en apprendre beaucoup.

Je reviens vers le forum dés que le problème aura été réglé.


N'oublie pas ensuite d'installer Erunt
http://fspsa.free.fr/erunt.htm

Bon courage, et bonne chance.

--
Salutations, Jean-François
Index de la FAQ XP de Panthère Noire : www.d2i.ch/pn/az
Un problème difficile à décrire ? http://fspsa.free.fr/copiecran.htm
USB et virus :
http://fspsa.free.fr/contamination-lecteurs-amovibles.htm

elxav
Le #6723961
Re,

L'idéal eût été de disposer d'une sauvegarde du disquewww.clubic.c om/article-83110-1-sauvegarde-restauration-image-ghost.html
A que oui!!


Sur mon PC assemblé, J'ai effectivement des Ghosts qui me permettent
de repartir trés rapidement suite à un crash.
Mais sur le PC dont je parle, un DELL, livré sans CD, et sans lecteur
de disquette, j'ai créé quelques ghosts, au début, mais j'ai été
incapable de créer un CD de boot contenant Ghost, pour la
restauration. En effet, quand j'arrivais à lancer Ghost, je n'avais
pas accés aux partition contenant mes images.
Je pense que c'est peut être lié à un controleur SATA (j'ai lu pas mal
de chose concernant l'impossibilité d'installer un XP Pro standard sur
un DELL), à confirmer.
Bref, j'ai laisser tombé, bien mal m'en a pris!

AZO4 sur ce newsgroup connait bien les Dell. J'avais compris qu'ils
sont livrés normalement avec un CD d'install tout à fait utilisable
pour la réparation standard.
Bah non!

Le CD en ma possession a été créé à l'aide de l'outil DELL pré-
installé sur la machine. C'est d'ailleurs le seul CD que j'ai pu
créer.
Impossible de le faire pour toutes les autres applications.
En cas de problème, il faut lancer la procédure de restauration
"usine", stockée sur une partition cachée, et qui ne fonctionne
(d'après la doc) qu'à condition que le HD soit dans l'état "usine".
A l'époque, j'ai donc créer le CD WinXP(Dell), puis partitionné le
disque, et lancé l'install depuis ce CD. La pêche aux drivers a
suivi ;-)
Après plusieurs essais, je n'ai vue à aucun moment, la possibilité de
réparer une install existante :-/
Ceci étant, je n'avais pas encore pris connaissance du problème lié au
fichier undo_guimode.txt

Il fallait poursuivre la méthode jusqu'au bout.
Hé oui, mais je n'avais pas trouvé les infos à ce moment.


Une bonne solution à ces tracas est d'utiliser Erunt.
Je vais m'empresser de suivre la procédure en effet.


Mais tu vas en apprendre beaucoup.
J'ai renforcé mes connaissances grâce à tes liens.

Le problème est que je n'ai pas beaucoup de temps à consacrer à ce
dépannage :-/
Il fût un temps où je pouvais passer des nuits sur ce genre de tracas
(vide le célibat!), car j'aime bien creuser sur des problèmes, mais ce
n'est plus d'actualité aujourd'hui (vive la vie de famille) lol.

Je ne manquerai pas de donner les résultats de mes tentatives, d'ici
la fin de la semaine j'espère.

Encore merci.
Xav.

JF
Le #6724961
Salut

Sur mon PC assemblé, J'ai effectivement des Ghosts qui me permettent
de repartir trés rapidement suite à un crash.
Mais sur le PC dont je parle, un DELL, livré sans CD,


Pourtant c'est la procédure chez Dell de réparer avec le CD d'install,
j'en ai déjà eu un en mains, c'était un OEM mais on installait comme
d'habitude réf http://shorterlink.org/4075
je suis persuadé qu'en leur demandant ils envoient le CD.


et sans lecteur de disquette


C'est le drame actuel, et la raison pour laquelle j'ai créé cette CDR
sur CDROM fabriqué à partir des disquettes téléchargeables de démarrage
de l'installation de Windows. Ce CD + la méthode de récupération du
Registre en a sauvé quelques uns.



j'ai créé quelques ghosts, au début, mais j'ai été
incapable de créer un CD de boot contenant Ghost, pour la
restauration. En effet, quand j'arrivais à lancer Ghost, je n'avais
pas accés aux partition contenant mes images.
Je pense que c'est peut être lié à un controleur SATA (j'ai lu pas mal
de chose concernant l'impossibilité d'installer un XP Pro standard sur
un DELL), à confirmer.


Le SATA, un autre drame. Il y a eu des discussions à ce sujet, en
effet. Le contournement le plus pratique serait d'utiliser un BARTPE,
équipé du driver SATA, plus un plugin Ghost je crois. UBCD4WIN doit
faire l'affaire. Ah non, je me suis avancé, il n'est pas dans la liste
www.ubcd4win.com/contents.htm mais on doit le trouver. C'est du
plugin pour DriveImage XML je pense dont on avait parlé, parce qu'il
est gratuit (celui-ci est dans la liste).



AZO4 sur ce newsgroup connait bien les Dell. J'avais compris qu'ils
sont livrés normalement avec un CD d'install tout à fait utilisable
pour la réparation standard.
Bah non!

Le CD en ma possession a été créé à l'aide de l'outil DELL pré-
installé sur la machine. C'est d'ailleurs le seul CD que j'ai pu
créer.


C'est donc effectivement un CD de Réparation, et non un CD
d'installation. Misère.


Impossible de le faire pour toutes les autres applications.
En cas de problème, il faut lancer la procédure de restauration
"usine", stockée sur une partition cachée, et qui ne fonctionne
(d'après la doc) qu'à condition que le HD soit dans l'état "usine".


Oui, c'est-à-dire qu'il ne faut surtout pas l'écraser.
On peut booter dessus je crois en appuyant sur une touche au démarrage.



A l'époque, j'ai donc créer le CD WinXP(Dell), puis partitionné le
disque, et lancé l'install depuis ce CD. La pêche aux drivers a
suivi ;-)
Après plusieurs essais, je n'ai vue à aucun moment, la possibilité de
réparer une install existante :-/


Le drame de tous ces PC de marque qui nous compliquent l'existence.


Ceci étant, je n'avais pas encore pris connaissance du problème lié au
fichier undo_guimode.txt


Je ne connais pas.



Il fallait poursuivre la méthode jusqu'au bout.
Hé oui, mais je n'avais pas trouvé les infos à ce moment.



C'est bizarre, tu connaissais le début et pas la fin ?
C'est sur la même page pourtant, en deux étapes.

Ok Xav, à bientôt !

--
Salutations, Jean-François
Index de la FAQ XP de Panthère Noire : www.d2i.ch/pn/az
Un problème difficile à décrire ? http://fspsa.free.fr/copiecran.htm
USB et virus :
http://fspsa.free.fr/contamination-lecteurs-amovibles.htm


elxav
Le #6728981
Bonjour la communauté,

Me revoilà pour l'épilogue.

Voici ce que j'ai fait, pour les prochains qui se trouveront dans le
même cas.
A noter, qu'à aucun moment, je n'ai eu de message concernant un
problème avec le registre.
Juste un écran bleu et le message "STOP: C0000128 Unknown hardware
error", à deux reprises, et blocage définitif avec un écran noir et le
curseur clignotant en haut à gauche de l'écran, juste après le logo
Windows et le "vu-mètre".

1) Grâce à une seconde installation de Windows (Dans un autre dossier
que celui d'origine, mais à éviter. Préferer une autre partition, en
effet, si les 2 OS sont installés sur la même partition, les dossiers
"Documents and Settings" et "Program Files" seront utilisés par la
nouvelle install), le PC démarrait correctement, ce qui pouvait
laisser penser que le matériel de base fonctionne à peu prés
correctement.

2) J'ai sauvegardé les 5 fichiers du registre (voir les différents
liens dans les messages précédent).
3) J'ai ensuite recopié ces fichiers depuis le dossier REPAIR vers le
dossier CONFIG.
Ceci afin de vérifier que mon Windows d'origine démarre normalement.

4) Reboot, Windows démarre. Mais bien évidemment, dans sa config
d'origine, établie lors du tout premier démarrage suite à la toute
première installation.
Dans ce contexte, effectivement, j'ai constaté que la configuration
des drivers et logiciels étaient "perdues". Normal puisque le registre
rétabli depuis REPAIR est un registre "tout neuf", "sans rien dedans".

5) Reboot sur le CD d'install de Windows et accès à la CDR.
6) J'ai suivi la procédure disponible sur le site de JF (http://
fspsa.free.fr/cdr-svi.htm) pour restaurer un registre depuis un point
de restauration dans le VSI.
7) Reboot
8) Miracle, le système est reparti

Un grand merci à Jean-François pour les liens, où j'ai pu trouver
toutes les infos nécessaires à ce dépannage.
Merci également à toutes les personnes qui maintiennent des sites
expliquant toutes les manips.

Xav.
JF
Le #6729411
*Bonjour elxav* !

Bonjour la communauté,
Me revoilà pour l'épilogue.

Voici ce que j'ai fait, pour les prochains qui se trouveront dans le
même cas.
A noter, qu'à aucun moment, je n'ai eu de message concernant un
problème avec le registre.
Juste un écran bleu et le message "STOP: C0000128 Unknown hardware
error", à deux reprises, et blocage définitif avec un écran noir et le
curseur clignotant en haut à gauche de l'écran, juste après le logo
Windows et le "vu-mètre".

1) Grâce à une seconde installation de Windows (Dans un autre dossier
que celui d'origine, mais à éviter. Préferer une autre partition, en
effet, si les 2 OS sont installés sur la même partition, les dossiers
"Documents and Settings" et "Program Files" seront utilisés par la
nouvelle install)


Excellente observation.
Il arrive souvent qu'un utilisateur installe ainsi un second dossier
Windows en voulant simplement faire une réparation. Si, nous le
rappelons souvent, c'est déconseillé à cause des interactions entre les
deux installations comme explicité, on voit cependant que c'est
utilisable en secours. Si on ne manque pas de place on peut même
conserver ce second Windows à condition de ne s'en servir que comme
secours. Noter également qu'on peut installer la CDR sur le disque dur.


le PC démarrait correctement, ce qui pouvait laisser penser
que le matériel de base fonctionne à peu prés correctement.


Toujours rassurant. On peu aussi utiliser un BARTPE ou un CD Live Linux
pour vérifier le matériel.



2) J'ai sauvegardé les 5 fichiers du registre (voir les différents
liens dans les messages précédent).
3) J'ai ensuite recopié ces fichiers depuis le dossier REPAIR vers le
dossier CONFIG.
Ceci afin de vérifier que mon Windows d'origine démarre normalement.

4) Reboot, Windows démarre. Mais bien évidemment, dans sa config
d'origine, établie lors du tout premier démarrage suite à la toute
première installation.
Dans ce contexte, effectivement, j'ai constaté que la configuration
des drivers et logiciels étaient "perdues". Normal puisque le registre
rétabli depuis REPAIR est un registre "tout neuf", "sans rien dedans".

5) Reboot sur le CD d'install de Windows et accès à la CDR.
6) J'ai suivi la procédure disponible sur le site de JF
http://fspsa.free.fr/cdr-svi.htm
pour restaurer un registre depuis un point
de restauration dans le VSI.
7) Reboot
8) Miracle, le système est reparti

Un grand merci à Jean-François pour les liens, où j'ai pu trouver
toutes les infos nécessaires à ce dépannage.
Merci également à toutes les personnes qui maintiennent des sites
expliquant toutes les manips.

Xav.


Un grand merci pour ce retour d'info.
Bonne continuation !
Et bonnes lectures sur http://fspsa.free.fr :oD

--
Salutations, Jean-François
Index de la FAQ XP de Panthère Noire : www.d2i.ch/pn/az
Un problème difficile à décrire ? http://fspsa.free.fr/copiecran.htm
Les vecteurs d'infection www.libellules.ch/dangers_logiciels.php

Publicité
Poster une réponse
Anonyme