ethtool Advertised link modes

Le
georges
Bonjour,

J'ai une carte Ethernet sur un réseaux gigabit, en autonegociation
elle ce met en 100Full/duplex.


/sbin/ethtool eth0
Settings for eth0:
Supported ports: [ MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 1
Transceiver: external
Auto-negotiation: on
Supports Wake-on: g
Wake-on: g
Link detected: yes

/sbin/ethtool -i eth0
driver: forcedeth
version: 0.62
firmware-version:
bus-info: 0000:00:07.0

Est il possible de la forcer en 1000, ou est ce qu'Advertised link veut
dire qu'elle ne peut monter qu'a 100?

Georges

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Yves F. Barbier
Le #20817831
georges a écrit :
Bonjour,

J'ai une carte Ethernet sur un réseaux gigabit, en autonegociation


^^^^^^^^^^^^^^^
elle Se met en 100Full/duplex.



la réponse est contenue dans la question

Est il possible de la forcer en 1000, ou est ce qu'Advertised link veut
dire qu'elle ne peut monter qu'a 100?



--
As they say about Dungeons and Dragons, "Life's a die, and then you bitch."

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Frédéric Boiteux
Le #20818121
Le Tue, 22 Dec 2009 13:19:39 +0100,
"Jean-Yves F. Barbier"
georges a écrit :
> Bonjour,
>
> J'ai une carte Ethernet sur un réseaux gigabit, en autonegociation
^^^^^^^^^^^^^^^
> elle Se met en 100Full/duplex.

la réponse est contenue dans la question



Ben non, pas vraiment : pourquoi ne publie-t-elle pas lors de la
négociation qu'elle sait faire du 1000/FD ?

En regardant la doc d'ethtool, je vois que tu peux modifier les
vitesses publiées (advertised) :

ethtool -s eth0 advertise 0x2F

devrait rajouter le 1000/FD à la liste

et ethtool -r eth0
devrait relancer une négociation.

la commande : « ethtool -s eth0 advertise 0x3f » est ce nsée repasser
la publication des vitesses en mode automatique…

Maintenant, je ne sais pas pourquoi ta carte a ce comportement…

Fred.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Jean-Yves F. Barbier
Le #20818091
Frédéric Boiteux a écrit :
Le Tue, 22 Dec 2009 13:19:39 +0100,
"Jean-Yves F. Barbier"
georges a écrit :
Bonjour,

J'ai une carte Ethernet sur un réseaux gigabit, en autonegociation


^^^^^^^^^^^^^^^
elle Se met en 100Full/duplex.


la réponse est contenue dans la question



Ben non, pas vraiment : pourquoi ne publie-t-elle pas lors de la
négociation qu'elle sait faire du 1000/FD ?



oops, lû trop vite.

maintenant comme c'est du forcedeth, y'a différentes poss.
si mes souvenirs sont bons, on peut rencontrer 2 types de PB:
un PHY non-gigabit (ou détecté comme tel), et là rien à faire,
ou une incompatibilité avec le switch (privilégier une "grosse"
marque plutôt que du noname ayant le chip véreux habituel de gestion)


--
An Army travels on her stomach.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
georges
Le #20819561
Ben quand même merci a tous pour les réponses, mais le comportement de la
carte est bizarre, elle refuse le 1000 Full, oui elle est direct sur un
gros switch cisco 2960G (non c'est pas lui).

Je pense a un problème avec le driver, j'ai 2 cartes avec le même chip et
le même problème.

Fréderic ton idée était bonne, mais "advertise 0x2F", ethtool -r
ne lui fait rien du tout, elle reste en 100.

Bon en ce momment elle fonctionne en 100 au moins, je vais laisser comme ca.
A moins de trouver une solution je crois qu'il ne me reste plus qu'a en
acheter une autre si je veux vraiment du gigabit.

Georges

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme