eviter le calcul dans une cellule vide

Le
Pascal
bonjour à tous

j'ai une liste de plus de 700 noms et prénoms avec dans la cellule d'en face
leur date de naissance et celle d'à coté leur age se met automatiquement
avec la formule ÚTEDIF(D17;MAINTENANT();"y")

soit :
A1 = nom et prenom - B1 = date de naissance - C1 = age

Il y a des personnes pour qui je n'ai pas la date de naissance donc dans
cette cellule je met un "?". Et evidemment dans la cellule age je ne met
rien et elle reste vide.

Ce qui donne :
A1 = Albert XXXX >>>> B1 = 6 septembre 1956 >>>> C1 = age
A2 = Jean YYYYY >>>> B2 = ?? >>>> C2 = (vide)
A3 = Martine ZZZZ >>>> B3 = 23 mars 1980 >>>> C3 = age
A4 = Eric WWWW >>>> B4 = ?? >>>> C4 = (vide)
A5 = Laura VVVV >>>> B5 = 18 decembre 1922 >>>> C5 = age

Sur une autre feuille "statistique" il ya la moyenne d'age de ma liste sauf
qu'elle est faussée car elle prend en compte les cellules vides.

Ce qui me donne le chiffre de 33,6 ans au lieu de 56 ans

Quelle serait la formule à mettre dans ma cellule statistique pour qu'elle
ne prenne pas en compte les cellules vides ?
du genre
=SOMME(données!E3:E700)/B1 "sauf les cellules vides"

B1 étant le nombre de personne total de ma liste

merci a tous et toutes pour votre aide
Pascal
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Xavier
Le #20414191
Salut pascal
en B1 fait le calcul du nombre de gens qui ont un age par
=NB(données!C1:C700)

Xavier

Pascal a écrit :
bonjour à tous

j'ai une liste de plus de 700 noms et prénoms avec dans la cellule d'en face
leur date de naissance et celle d'à coté leur age se met automatiquement
avec la formule ÚTEDIF(D17;MAINTENANT();"y")

soit :
A1 = nom et prenom - B1 = date de naissance - C1 = age

Il y a des personnes pour qui je n'ai pas la date de naissance donc dans
cette cellule je met un "?". Et evidemment dans la cellule age je ne met
rien et elle reste vide.

Ce qui donne :
A1 = Albert XXXX >>>> B1 = 6 septembre 1956 >>>> C1 = age
A2 = Jean YYYYY >>>> B2 = ?? >>>> C2 = (vide)
A3 = Martine ZZZZ >>>> B3 = 23 mars 1980 >>>> C3 = age
A4 = Eric WWWW >>>> B4 = ?? >>>> C4 = (vide)
A5 = Laura VVVV >>>> B5 = 18 decembre 1922 >>>> C5 = age

Sur une autre feuille "statistique" il ya la moyenne d'age de ma liste sauf
qu'elle est faussée car elle prend en compte les cellules vides.

Ce qui me donne le chiffre de 33,6 ans au lieu de 56 ans

Quelle serait la formule à mettre dans ma cellule statistique pour qu'elle
ne prenne pas en compte les cellules vides ?
du genre
=SOMME(données!E3:E700)/B1 "sauf les cellules vides"

B1 étant le nombre de personne total de ma liste

merci a tous et toutes pour votre aide
Pascal




Daniel.C
Le #20414291
Bonjour.
=SOMME(C3:C700)/NB.SI(B3:B700;"<>??")
Les données correspondant à la première feuille, il faut peut-être
ajuster les plages.
Cordialement.
Daniel

bonjour à tous

j'ai une liste de plus de 700 noms et prénoms avec dans la cellule d'en face
leur date de naissance et celle d'à coté leur age se met automatiquement avec
la formule ÚTEDIF(D17;MAINTENANT();"y")

soit :
A1 = nom et prenom - B1 = date de naissance - C1 = age

Il y a des personnes pour qui je n'ai pas la date de naissance donc dans
cette cellule je met un "?". Et evidemment dans la cellule age je ne met rien
et elle reste vide.

Ce qui donne :
A1 = Albert XXXX >>>> B1 = 6 septembre 1956 >>>> C1 = age
A2 = Jean YYYYY >>>> B2 = ?? >>>> C2 = (vide)
A3 = Martine ZZZZ >>>> B3 = 23 mars 1980 >>>> C3 = age
A4 = Eric WWWW >>>> B4 = ?? >>>> C4 = (vide)
A5 = Laura VVVV >>>> B5 = 18 decembre 1922 >>>> C5 = age

Sur une autre feuille "statistique" il ya la moyenne d'age de ma liste sauf
qu'elle est faussée car elle prend en compte les cellules vides.

Ce qui me donne le chiffre de 33,6 ans au lieu de 56 ans

Quelle serait la formule à mettre dans ma cellule statistique pour qu'elle ne
prenne pas en compte les cellules vides ?
du genre
=SOMME(données!E3:E700)/B1 "sauf les cellules vides"

B1 étant le nombre de personne total de ma liste

merci a tous et toutes pour votre aide
Pascal


PolareBear
Le #20414281
Bonjour,

Et la fonction MOYENNE, t'as essayé ?

cordialement

Raimond


Pascal a écrit :
bonjour à tous

j'ai une liste de plus de 700 noms et prénoms avec dans la cellule d'en face
leur date de naissance et celle d'à coté leur age se met automatiquement
avec la formule ÚTEDIF(D17;MAINTENANT();"y")

soit :
A1 = nom et prenom - B1 = date de naissance - C1 = age

Il y a des personnes pour qui je n'ai pas la date de naissance donc dans
cette cellule je met un "?". Et evidemment dans la cellule age je ne met
rien et elle reste vide.

Ce qui donne :
A1 = Albert XXXX >>>> B1 = 6 septembre 1956 >>>> C1 = age
A2 = Jean YYYYY >>>> B2 = ?? >>>> C2 = (vide)
A3 = Martine ZZZZ >>>> B3 = 23 mars 1980 >>>> C3 = age
A4 = Eric WWWW >>>> B4 = ?? >>>> C4 = (vide)
A5 = Laura VVVV >>>> B5 = 18 decembre 1922 >>>> C5 = age

Sur une autre feuille "statistique" il ya la moyenne d'age de ma liste sauf
qu'elle est faussée car elle prend en compte les cellules vides.

Ce qui me donne le chiffre de 33,6 ans au lieu de 56 ans

Quelle serait la formule à mettre dans ma cellule statistique pour qu'elle
ne prenne pas en compte les cellules vides ?
du genre
=SOMME(données!E3:E700)/B1 "sauf les cellules vides"

B1 étant le nombre de personne total de ma liste

merci a tous et toutes pour votre aide
Pascal




isabelle
Le #20414381
bonjour Pascal,

en cellule B1
=NB.SI(E1:E1000;"<>0")

isabelle

Pascal a écrit :
bonjour à tous

j'ai une liste de plus de 700 noms et prénoms avec dans la cellule d'en face
leur date de naissance et celle d'à coté leur age se met automatiquement
avec la formule ÚTEDIF(D17;MAINTENANT();"y")

soit :
A1 = nom et prenom - B1 = date de naissance - C1 = age

Il y a des personnes pour qui je n'ai pas la date de naissance donc dans
cette cellule je met un "?". Et evidemment dans la cellule age je ne met
rien et elle reste vide.

Ce qui donne :
A1 = Albert XXXX >>>> B1 = 6 septembre 1956 >>>> C1 = age
A2 = Jean YYYYY >>>> B2 = ?? >>>> C2 = (vide)
A3 = Martine ZZZZ >>>> B3 = 23 mars 1980 >>>> C3 = age
A4 = Eric WWWW >>>> B4 = ?? >>>> C4 = (vide)
A5 = Laura VVVV >>>> B5 = 18 decembre 1922 >>>> C5 = age

Sur une autre feuille "statistique" il ya la moyenne d'age de ma liste sauf
qu'elle est faussée car elle prend en compte les cellules vides.

Ce qui me donne le chiffre de 33,6 ans au lieu de 56 ans

Quelle serait la formule à mettre dans ma cellule statistique pour qu'elle
ne prenne pas en compte les cellules vides ?
du genre
=SOMME(données!E3:E700)/B1 "sauf les cellules vides"

B1 étant le nombre de personne total de ma liste

merci a tous et toutes pour votre aide
Pascal





isabelle
Le #20414541
correction:
en cellule B1
=NBVAL(E1:E1000)

isabelle

isabelle a écrit :
bonjour Pascal,

en cellule B1
=NB.SI(E1:E1000;"<>0")

isabelle

Pascal a écrit :
bonjour à tous

j'ai une liste de plus de 700 noms et prénoms avec dans la cellule
d'en face leur date de naissance et celle d'à coté leur age se met
automatiquement avec la formule ÚTEDIF(D17;MAINTENANT();"y")

soit :
A1 = nom et prenom - B1 = date de naissance - C1 = age

Il y a des personnes pour qui je n'ai pas la date de naissance donc
dans cette cellule je met un "?". Et evidemment dans la cellule age
je ne met rien et elle reste vide.

Ce qui donne :
A1 = Albert XXXX >>>> B1 = 6 septembre 1956 >>>> C1 = age
A2 = Jean YYYYY >>>> B2 = ?? >>>> C2 = (vide)
A3 = Martine ZZZZ >>>> B3 = 23 mars 1980 >>>> C3 = age
A4 = Eric WWWW >>>> B4 = ?? >>>> C4 = (vide)
A5 = Laura VVVV >>>> B5 = 18 decembre 1922 >>>> C5 = age

Sur une autre feuille "statistique" il ya la moyenne d'age de ma
liste sauf qu'elle est faussée car elle prend en compte les cellules
vides.

Ce qui me donne le chiffre de 33,6 ans au lieu de 56 ans

Quelle serait la formule à mettre dans ma cellule statistique pour
qu'elle ne prenne pas en compte les cellules vides ?
du genre
=SOMME(données!E3:E700)/B1 "sauf les cellules vides"

B1 étant le nombre de personne total de ma liste

merci a tous et toutes pour votre aide
Pascal






Pascal
Le #20416841
CA MARCHE
Merci et bon dimanche
Pascal


"Pascal" 4ae2d000$0$431$
bonjour à tous

j'ai une liste de plus de 700 noms et prénoms avec dans la cellule d'en
face leur date de naissance et celle d'à coté leur age se met
automatiquement avec la formule ÚTEDIF(D17;MAINTENANT();"y")

soit :
A1 = nom et prenom - B1 = date de naissance - C1 = age

Il y a des personnes pour qui je n'ai pas la date de naissance donc dans
cette cellule je met un "?". Et evidemment dans la cellule age je ne met
rien et elle reste vide.

Ce qui donne :
A1 = Albert XXXX >>>> B1 = 6 septembre 1956 >>>> C1 = age
A2 = Jean YYYYY >>>> B2 = ?? >>>> C2 = (vide)
A3 = Martine ZZZZ >>>> B3 = 23 mars 1980 >>>> C3 = age
A4 = Eric WWWW >>>> B4 = ?? >>>> C4 = (vide)
A5 = Laura VVVV >>>> B5 = 18 decembre 1922 >>>> C5 = age

Sur une autre feuille "statistique" il ya la moyenne d'age de ma liste
sauf qu'elle est faussée car elle prend en compte les cellules vides.

Ce qui me donne le chiffre de 33,6 ans au lieu de 56 ans

Quelle serait la formule à mettre dans ma cellule statistique pour qu'elle
ne prenne pas en compte les cellules vides ?
du genre
=SOMME(données!E3:E700)/B1 "sauf les cellules vides"

B1 étant le nombre de personne total de ma liste

merci a tous et toutes pour votre aide
Pascal



Publicité
Poster une réponse
Anonyme