Excel et champs HTML

Le
Roumegou Eric
Bonjour,

j'ai développé un programme d'intégration de données à partir de
feuilles excel dans ma base.
Pour cela, je charge le fichier Excel dans un champs HTML, juste pour
que l'utilisateur puisse l'avoir sous les yeux, puis je travaille
ensuite le fichier avec les ordres XLSOuvre.

Mon problème est que si la personne clique plusieurs fois sur le bouton
charger, j'ai une erreur d'excel qui me dit que le fichier est déjà
chargé etc et surtout cela fait échouer mes tentatives avec les fns
XLS.
Je suis meme obligé pour retrouver la main sur mon fichier excel de le
rappeler depuis le vrai Excel (enfin directement) puis d'en sortir.

Donc ma question : comment monitorer ce genre d'erreur et l'éviter ? ou
y'a-t-il un moyen d'ouvrir ce fichier excel (totalement inconnu à
postériori bien sûr) dans un champs Windev, sans qu'il soit verrouillé
?

Merci de vos réponses.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Yves BURLOT
Le #14533301
Roumegou Eric a couché sur son écran :
Bonjour,

j'ai développé un programme d'intégration de données à partir de feuilles
excel dans ma base.
Pour cela, je charge le fichier Excel dans un champs HTML, juste pour que
l'utilisateur puisse l'avoir sous les yeux, puis je travaille ensuite le
fichier avec les ordres XLSOuvre.

Mon problème est que si la personne clique plusieurs fois sur le bouton
charger, j'ai une erreur d'excel qui me dit que le fichier est déjà chargé
etc ... et surtout cela fait échouer mes tentatives avec les fns XLS.
Je suis meme obligé pour retrouver la main sur mon fichier excel de le
rappeler depuis le vrai Excel (enfin directement) puis d'en sortir.

Donc ma question : comment monitorer ce genre d'erreur et l'éviter ? ou
y'a-t-il un moyen d'ouvrir ce fichier excel (totalement inconnu à postériori
bien sûr) dans un champs Windev, sans qu'il soit verrouillé ?

Merci de vos réponses.



// dans le code du bouton avant d'ouvrir excel

bResultat¾xeLance("EXCEL.EXE",iNbLance,Vrai)
TANTQUE bResultat
ExeTermine("EXCEL.EXE")
bResultat=C_excel::bExeLance("EXCEL.EXE",iNbLance,Vrai)
FIN

// ensuite tu peux ouvrir excel



La fonction de test si plusieurs instances du programme ouvert

FONCTION bEXELance(LOCAL Executable, iNbLance, bErreurúux)
bRetour est booléen

iNbLance=ExeLancé(fExtraitChemin(Executable, fFichier+fExtension))
SI iNbLance > 0 ALORS
SI bErreur ALORS
//Erreur(fExtraitChemin(Executable, fFichier)+" est déjà
//ouvert.","Veuillez fermer l'application
//"+fExtraitChemin(Executable, fFichier)+" avant de
//poursuivre.")
FIN
bRetour=Vrai
FIN
RENVOYER bRetour

bon dev

--
Jean-Yves BURLOT
suivre ce lien pour répondre :
http://cerbermail.com/?zbQ7wrKUbu
;-)
--
Roumegou Eric
Le #14533261
Jean-Yves BURLOT a couché sur son écran :
Roumegou Eric a couché sur son écran :
Bonjour,

j'ai développé un programme d'intégration de données à partir de feuilles
excel dans ma base.
Pour cela, je charge le fichier Excel dans un champs HTML, juste pour que
l'utilisateur puisse l'avoir sous les yeux, puis je travaille ensuite le
fichier avec les ordres XLSOuvre.

Mon problème est que si la personne clique plusieurs fois sur le bouton
charger, j'ai une erreur d'excel qui me dit que le fichier est déjà chargé
etc ... et surtout cela fait échouer mes tentatives avec les fns XLS.
Je suis meme obligé pour retrouver la main sur mon fichier excel de le
rappeler depuis le vrai Excel (enfin directement) puis d'en sortir.

Donc ma question : comment monitorer ce genre d'erreur et l'éviter ? ou
y'a-t-il un moyen d'ouvrir ce fichier excel (totalement inconnu à
postériori bien sûr) dans un champs Windev, sans qu'il soit verrouillé ?

Merci de vos réponses.



// dans le code du bouton avant d'ouvrir excel

bResultat¾xeLance("EXCEL.EXE",iNbLance,Vrai)
TANTQUE bResultat
ExeTermine("EXCEL.EXE")
bResultat=C_excel::bExeLance("EXCEL.EXE",iNbLance,Vrai)
FIN

// ensuite tu peux ouvrir excel



La fonction de test si plusieurs instances du programme ouvert

FONCTION bEXELance(LOCAL Executable, iNbLance, bErreurúux)
bRetour est booléen

iNbLance=ExeLancé(fExtraitChemin(Executable, fFichier+fExtension))
SI iNbLance > 0 ALORS
SI bErreur ALORS
//Erreur(fExtraitChemin(Executable, fFichier)+" est déjà
//ouvert.","Veuillez fermer l'application
//"+fExtraitChemin(Executable, fFichier)+" avant de
//poursuivre.")
FIN
bRetour=Vrai
FIN
RENVOYER bRetour

bon dev

--
Jean-Yves BURLOT
suivre ce lien pour répondre :
http://cerbermail.com/?zbQ7wrKUbu
;-)



je te remercie beaucoup de ta réponse, je vais tester cela bientôt.
Roumegou Eric
Le #14533181
Roumegou Eric avait prétendu :


je te remercie beaucoup de ta réponse, je vais tester cela bientôt.



A 1 ou 2 adaptation prêt, cela marche impec.
Merci beaucoup.
Jean-Yves BURLOT
Le #14533111
Roumegou Eric avait énoncé :
Roumegou Eric avait prétendu :


je te remercie beaucoup de ta réponse, je vais tester cela bientôt.



A 1 ou 2 adaptation prêt, cela marche impec.
Merci beaucoup.



Oui effectivement, la procédure bExeLance faisait partie d'une classe
Utilitaire

Bon dev à toi

PS : c'est toi qui développe (ou à développé sur AS400)
car si c'est le cas j'aurai quelques questions à te poser

--
Jean-Yves BURLOT
suivre ce lien pour répondre :
http://cerbermail.com/?zbQ7wrKUbu
;-)
--
Roumegou Eric
Le #14533101
Après mûre réflexion, Jean-Yves BURLOT a écrit :


PS : c'est toi qui développe (ou à développé sur AS400)
car si c'est le cas j'aurai quelques questions à te poser



oui mais cela remonte quand mème à près de 8 ans et presque pas en WD
(avec easycom)
Nos dev étaient en synon2 qui était un AGL as400.
Mais si tu as des questions, j'essaierai de raviver mes souvenirs.
Romain PETIT
Le #14533091
Roumegou Eric a formulé ce mercredi :

PS : c'est toi qui développe (ou à développé sur AS400)
car si c'est le cas j'aurai quelques questions à te poser





oui mais cela remonte quand mème à près de 8 ans et presque pas en WD (avec
easycom)
Nos dev étaient en synon2 qui était un AGL as400.
Mais si tu as des questions, j'essaierai de raviver mes souvenirs.



Sinon, pour le l'AS400 pur et dur (je veux dire sans Easycom), il y a
toujours
ou
Accessible également via plateforme web ici :
http://newsportal.niouzenet.eu.org/thread_frameset.php?group=nzn.fr.as400

A+

--
Romain PETIT
http://cerbermail.com/?O16kfXOFcq
(cliquez sur le lien ci-dessus pour me contacter en privé)
Publicité
Poster une réponse
Anonyme