extraire des adresses mails

Le
Philippe MERY
Bonjour.
xl 97

J'ai dans la colonne A un joyeux ^%£*
mr x
04.42 xxx
adresse postale
xx@xx.fr
portable
fax
infos diverses..

le tout sans aucune organisation ni régularité

je voudrais dans ma colonne B extraire toutes les adresses mail..
Je cherche une fonction qui puisse me faire cela, "recherche" me donne
parfois des aberrations- je dois louper quelque chose-


merci

--
Cordialement.
Philippe MERY
**pour m'ecrire perso**
mery-ph -serveur- ifrance.com
www.freymille.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Youky
Le #5027761
ceci recopie l'email en colonne 5 donc à changer "5" en conséquence
Youky

Sub Rechercher()
With Feuil1.[A1:A10000]
Set c = .Find("@", LookIn:=xlValues)
If Not c Is Nothing Then
firstAddress = c.Address
Do
lig = lig + 1
Cells(lig, 5) = c.Value
Set c = .FindNext(c)
Loop While Not c Is Nothing And c.Address <> firstAddress
End If
End With
End Sub


"Philippe MERY" news: 4732ceb3$0$5100$
Bonjour.
xl 97

J'ai dans la colonne A un joyeux ^%£*
mr x
04.42 xxx
adresse postale

portable
fax
infos diverses..

le tout sans aucune organisation ni régularité

je voudrais dans ma colonne B extraire toutes les adresses mail..
Je cherche une fonction qui puisse me faire cela, "recherche" me donne
parfois des aberrations- je dois louper quelque chose-


merci

--
Cordialement.
Philippe MERY
**pour m'ecrire perso**
mery-ph -serveur- ifrance.com
www.freymille.com



Philippe MERY
Le #5027741
"Youky"
ceci recopie l'email en colonne 5 donc à changer "5" en conséquence
Youky

Sub Rechercher()
With Feuil1.[A1:A10000]
Set c = .Find("@", LookIn:=xlValues)
If Not c Is Nothing Then
firstAddress = c.Address
Do
lig = lig + 1
Cells(lig, 5) = c.Value
Set c = .FindNext(c)
Loop While Not c Is Nothing And c.Address <> firstAddress
End If
End With
End Sub


oups, merci...
là je seche sur ce genre de manip
on a pas une fonction qui puisse faire cela?
genre si A1 contient "@" mettre en C1?
merci

Daniel.C
Le #5027731
Bonjur.
Essaie :

Sub test()
Dim hl As Hyperlink, Ligne As Long
For Each hl In [A:A].Hyperlinks
If InStr(1, hl.Address, "@") > 0 Then
Ligne = Ligne + 1
Cells(Ligne, 2) = Range(hl.Parent.Address)
End If
Next
End Sub

Cordialement.
Daniel
"Philippe MERY" news: 4732ceb3$0$5100$
Bonjour.
xl 97

J'ai dans la colonne A un joyeux ^%£*
mr x
04.42 xxx
adresse postale

portable
fax
infos diverses..

le tout sans aucune organisation ni régularité

je voudrais dans ma colonne B extraire toutes les adresses mail..
Je cherche une fonction qui puisse me faire cela, "recherche" me donne
parfois des aberrations- je dois louper quelque chose-


merci

--
Cordialement.
Philippe MERY
**pour m'ecrire perso**
mery-ph -serveur- ifrance.com
www.freymille.com



Daniel.C
Le #5027721
Oups.

Sub test()
Dim hl As Hyperlink, Ligne As Long
For Each hl In [A:A].Hyperlinks
If InStr(1, hl.Address, "@") > 0 Then
Ligne = Ligne + 1
Range(hl.Parent.Address).Copy Cells(Ligne, 2)
End If
Next
End Sub

Daniel
"Daniel.C" uF%
Bonjur.
Essaie :

Sub test()
Dim hl As Hyperlink, Ligne As Long
For Each hl In [A:A].Hyperlinks
If InStr(1, hl.Address, "@") > 0 Then
Ligne = Ligne + 1
Cells(Ligne, 2) = Range(hl.Parent.Address)
End If
Next
End Sub

Cordialement.
Daniel
"Philippe MERY" news: 4732ceb3$0$5100$
Bonjour.
xl 97

J'ai dans la colonne A un joyeux ^%£*
mr x
04.42 xxx
adresse postale

portable
fax
infos diverses..

le tout sans aucune organisation ni régularité

je voudrais dans ma colonne B extraire toutes les adresses mail..
Je cherche une fonction qui puisse me faire cela, "recherche" me donne
parfois des aberrations- je dois louper quelque chose-


merci

--
Cordialement.
Philippe MERY
**pour m'ecrire perso**
mery-ph -serveur- ifrance.com
www.freymille.com







Daniel.C
Le #5027711
Tu peux mettre :
=SI(ESTNUM(TROUVE("@";A11;1));A11;"")
Seulement tu récupéreras le texte de l'adresse mail, pas le lien, donc tu ne
pourras pas cliquer dessus.
Daniel

"Philippe MERY" news: 4732d3d3$0$27410$


"Youky"
ceci recopie l'email en colonne 5 donc à changer "5" en conséquence
Youky

Sub Rechercher()
With Feuil1.[A1:A10000]
Set c = .Find("@", LookIn:=xlValues)
If Not c Is Nothing Then
firstAddress = c.Address
Do
lig = lig + 1
Cells(lig, 5) = c.Value
Set c = .FindNext(c)
Loop While Not c Is Nothing And c.Address <> firstAddress
End If
End With
End Sub


oups, merci...
là je seche sur ce genre de manip
on a pas une fonction qui puisse faire cela?
genre si A1 contient "@" mettre en C1?
merci




Youky
Le #5027691
par formules..si tu veux
=SI(ESTERREUR(TROUVE("@";A1));"";A1)
Youky
"Philippe MERY" news: 4732d3d3$0$27410$


"Youky"
ceci recopie l'email en colonne 5 donc à changer "5" en conséquence
Youky

Sub Rechercher()
With Feuil1.[A1:A10000]
Set c = .Find("@", LookIn:=xlValues)
If Not c Is Nothing Then
firstAddress = c.Address
Do
lig = lig + 1
Cells(lig, 5) = c.Value
Set c = .FindNext(c)
Loop While Not c Is Nothing And c.Address <> firstAddress
End If
End With
End Sub


oups, merci...
là je seche sur ce genre de manip
on a pas une fonction qui puisse faire cela?
genre si A1 contient "@" mettre en C1?
merci




Philippe MERY
Le #5027481
ok merci à tous.
Publicité
Poster une réponse
Anonyme