extraire des données d'un classeur vers un autre

Le
AB
Bonjour à tous.
Dans un classeur 1, j'ai 18 feuilles.
Dans chaque feuille, figurent en colonne A un libellé (ex : "la valeur en
douane"), et en colonne B une référence (ex : F01001)
Dans un classeur 2, j'ai une seule feuille.
En colonne C, figure une référence du même type que sur les feuilles du
classeur 1, et des données en colonnes D et E.
A noter qu'on peut retrouver ces valeurs sur plusieurs lignes.
Ce que j'aimerais :
Lire la référence sur chaque ligne du classeur 1, aller chercher pour cette
référence, dans le classeur 2, les valeurs qui figurent en colonnes D et E,
et les ajouter en colonne C du classeur 1 (et cela pour chaque feuille du
classeur 1).
Pas sûr d'avoir été clair. J'espère que oui.
Toute aide sera la bienvenue.
AB
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4675391
Bonsoir,

En C2: =RECHERCHEV(B2;[Classeur2.xls]Feuil1!$C$1:$E$10000;2;FAUX)
En D2: =RECHERCHEV(B2;[Classeur2.xls]Feuil1!$C$1:$E$10000;3;FAUX)

JB

On 1 sep, 12:45, "AB"
Bonjour à tous.
Dans un classeur 1, j'ai 18 feuilles.
Dans chaque feuille, figurent en colonne A un libellé (ex : "la valeur en
douane"), et en colonne B une référence (ex : F01001)
Dans un classeur 2, j'ai une seule feuille.
En colonne C, figure une référence du même type que sur les feuille s du
classeur 1, et des données en colonnes D et E.
A noter qu'on peut retrouver ces valeurs sur plusieurs lignes.
Ce que j'aimerais :
Lire la référence sur chaque ligne du classeur 1, aller chercher pour cette
référence, dans le classeur 2, les valeurs qui figurent en colonnes D et E,
et les ajouter en colonne C du classeur 1 (et cela pour chaque feuille du
classeur 1).
Pas sûr d'avoir été clair. J'espère que oui.
Toute aide sera la bienvenue.
AB


AB
Le #4675381
JB avait écrit le 01/09/2007 :
Bonsoir,

En C2: =RECHERCHEV(B2;[Classeur2.xls]Feuil1!$C$1:$E$10000;2;FAUX)
En D2: =RECHERCHEV(B2;[Classeur2.xls]Feuil1!$C$1:$E$10000;3;FAUX)

JB

On 1 sep, 12:45, "AB"
Bonjour à tous.
Dans un classeur 1, j'ai 18 feuilles.
Dans chaque feuille, figurent en colonne A un libellé (ex : "la valeur en
douane"), et en colonne B une référence (ex : F01001)
Dans un classeur 2, j'ai une seule feuille.
En colonne C, figure une référence du même type que sur les feuilles du
classeur 1, et des données en colonnes D et E.
A noter qu'on peut retrouver ces valeurs sur plusieurs lignes.
Ce que j'aimerais :
Lire la référence sur chaque ligne du classeur 1, aller chercher pour cette
référence, dans le classeur 2, les valeurs qui figurent en colonnes D et E,
et les ajouter en colonne C du classeur 1 (et cela pour chaque feuille du
classeur 1).
Pas sûr d'avoir été clair. J'espère que oui.
Toute aide sera la bienvenue.
AB



Ok, Merci beaucoup.
AB


JB
Le #4675371
Qq explications sur Recherchev()

http://boisgontierjacques.free.fr/pages_site/recherchev.htm

JB
http://boisgontierjacques.free.fr/

On 1 sep, 22:27, AB
JB avait écrit le 01/09/2007 :





Bonsoir,

En C2: =RECHERCHEV(B2;[Classeur2.xls]Feuil1!$C$1:$E$10000;2;FAUX)
En D2: =RECHERCHEV(B2;[Classeur2.xls]Feuil1!$C$1:$E$10000;3;FAUX)

JB

On 1 sep, 12:45, "AB"
Bonjour à tous.
Dans un classeur 1, j'ai 18 feuilles.
Dans chaque feuille, figurent en colonne A un libellé (ex : "la vale ur en
douane"), et en colonne B une référence (ex : F01001)
Dans un classeur 2, j'ai une seule feuille.
En colonne C, figure une référence du même type que sur les feui lles du
classeur 1, et des données en colonnes D et E.
A noter qu'on peut retrouver ces valeurs sur plusieurs lignes.
Ce que j'aimerais :
Lire la référence sur chaque ligne du classeur 1, aller chercher p our cette
référence, dans le classeur 2, les valeurs qui figurent en colonne s D et E,
et les ajouter en colonne C du classeur 1 (et cela pour chaque feuille du
classeur 1).
Pas sûr d'avoir été clair. J'espère que oui.
Toute aide sera la bienvenue.
AB



Ok, Merci beaucoup.
AB- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -




AB
Le #4675171
Il se trouve que JB a formulé :
Qq explications sur Recherchev()

http://boisgontierjacques.free.fr/pages_site/recherchev.htm

JB
http://boisgontierjacques.free.fr/

On 1 sep, 22:27, AB
JB avait écrit le 01/09/2007 :





Bonsoir,

En C2: =RECHERCHEV(B2;[Classeur2.xls]Feuil1!$C$1:$E$10000;2;FAUX)
En D2: =RECHERCHEV(B2;[Classeur2.xls]Feuil1!$C$1:$E$10000;3;FAUX)
JB

On 1 sep, 12:45, "AB"
Bonjour à tous.
Dans un classeur 1, j'ai 18 feuilles.
Dans chaque feuille, figurent en colonne A un libellé (ex : "la valeur en
douane"), et en colonne B une référence (ex : F01001)
Dans un classeur 2, j'ai une seule feuille.
En colonne C, figure une référence du même type que sur les feuilles du
classeur 1, et des données en colonnes D et E.
A noter qu'on peut retrouver ces valeurs sur plusieurs lignes.
Ce que j'aimerais :
Lire la référence sur chaque ligne du classeur 1, aller chercher pour
cette référence, dans le classeur 2, les valeurs qui figurent en colonnes
D et E, et les ajouter en colonne C du classeur 1 (et cela pour chaque
feuille du classeur 1).
Pas sûr d'avoir été clair. J'espère que oui.
Toute aide sera la bienvenue.
AB



Ok, Merci beaucoup.
AB- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -



Particulièrement utile. Merci
AB




Publicité
Poster une réponse
Anonyme