Extraire la première série de chiffres

Le
Apitos
Bonsoir à tous,

Quelle formule, me permettra d'extraire la première série de chiffres d=
'une chaine de caractères.

Exemples :

EDFT2-0&&-63 => 0

EDFT2-64&&-127 => 64

Merci.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacquouille
Le #24778472
Bonsoir
Données en A1
=SI(STXT(A1;CHERCHE("-";A1;1)+1;2)*1>10;STXT(A1;CHERCHE("-";A1;1)+1;2)*1;0)

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Apitos" a écrit dans le message de groupe de discussion :



Bonsoir à tous,

Quelle formule, me permettra d'extraire la première série de chiffres d'une
chaine de caractères.

Exemples :

EDFT2-0&&-63 => 0

EDFT2-64&&-127 => 64

Merci.
MichD
Le #24778462
Bonjour,

Dans un module standard, tu copies cette fonction personnalisée :
Elle suppose que la première chaîne de chiffre débute après le
premier symbole "-"

Si ta chaîne est dans la cellule A1, dans la cellule de ton choix, tu écris
:
=Extraire_Chiffres(A1)

'------------------------
Function Extraire_Chiffres(Rg As Range)
Dim T As Variant
If InStr(1, Rg.Value, "-", vbTextCompare) > 0 Then
T = Split(Rg, "-")
Extraire_Chiffres = Replace(T(1), "&", "")
Else
Extraire_Chiffres = ""
End If
End Function
'------------------------





"Apitos" a écrit dans le message de groupe de discussion :



Bonsoir à tous,

Quelle formule, me permettra d'extraire la première série de chiffres d'une
chaine de caractères.

Exemples :

EDFT2-0&&-63 => 0

EDFT2-64&&-127 => 64

Merci.
MichD
Le #24778522
Dans la fonction, j'ai omis le *1 sur cette ligne
Extraire_Chiffres = Replace(T(1), "&", "") * 1

à toi de l'ajouter!
Apitos
Le #24779262
Bonjour Jaquouille,

Avec la formule :

=SI(STXT(A1;CHERCHE("-";A1;1)+1;2)*1>10;STXT(A1;CHERCHE("-";A1;1)+1;2)*1; 0)

Voila les résultats obtenus :

EDFT2-0&&-63 #VALEUR!
EDFT2-64&&-127 64
EDFT2-128&&-192 12
EDFT2-5011&&-5074 50

Et voila les résultats attendus :

EDFT2-0&&-63 0
EDFT2-64&&-127 64
EDFT2-128&&-192 128
EDFT2-5011&&-5074 5011

Merci.
Apitos
Le #24779252
Bonjour MichD,

Merci pour la fonction.

Ça marche.
Jacky
Le #24779302
Bonjour,

En formule

=STXT(A1;CHERCHE("_";SUBSTITUE($A1;"-";"_";1))+1;CHERCHE("_";SUBSTITUE($A1;"&";"_";1))-CHERCHE("_";SUBSTITUE($A1;"-";"_";1))-1)

--
Salutations
JJ


"Apitos"

Bonsoir à tous,

Quelle formule, me permettra d'extraire la première série de chiffres d'une chaine de caractères.

Exemples :

EDFT2-0&&-63 => 0

EDFT2-64&&-127 => 64

Merci.
Apitos
Le #24779322
Bonjour Jacky,

Excellent. Ca marche aussi.

En plus un *1 pour rendre le résultat numérique comme l'a spécifié notre ami Denis.

Merci pour vous tous.
Jacky
Le #24779332
Excellent. Ca marche aussi.


Il y a une limite :o(
A condition qu'il y ait toujours une esperluette en fin de chiffre

--
Salutations
JJ


"Apitos"
Bonjour Jacky,

Excellent. Ca marche aussi.

En plus un *1 pour rendre le résultat numérique comme l'a spécifié notre ami Denis.

Merci pour vous tous.
Jacky
Le #24779382
Sinon cela rallonge un peu :o)

=STXT(A1;CHERCHE("_";SUBSTITUE($A1;"-";"_";1))+1;SI(ESTNUM(CHERCHE("_";SUBSTITUE($A1;"&";"_";1)));CHERCHE("_";SUBSTITUE($A1;"&";"_";1));CHERCHE("_";SUBSTITUE($A1;"-";"_";2)))-CHERCHE("_";SUBSTITUE($A1;"-";"_";1))-1)*1

--
Salutations
JJ


"Jacky"
>Excellent. Ca marche aussi.
Il y a une limite :o(
A condition qu'il y ait toujours une esperluette en fin de chiffre

--
Salutations
JJ


"Apitos"
Bonjour Jacky,

Excellent. Ca marche aussi.

En plus un *1 pour rendre le résultat numérique comme l'a spécifié notre ami Denis.

Merci pour vous tous.


Jacquouille
Le #24779472
"Apitos" a écrit dans le message de groupe de discussion :

Bonjour Jacky,

En plus un *1 pour rendre le résultat numérique comme l'a spécifié notre ami
Denis.

..... déjà précisé 13 heures plus tôt, mais ne semble pas avoir été
. -))))


Jacquouille,

" Le vin est au repas ce que le parfum est à la femme."
Publicité
Poster une réponse
Anonyme