Extraire du texte par une formule

Le
Bruno
Bonjour ,
J'ai une série de sociétés que je veux classer en 3 catégories :
Codes actifs, codes "rachetés" et codes clos.
Chacune de ces sociétés peut être identifiés par le code (en comparant la
liste des codes actifs et le code de la société en question. pour les codes
rachetés, je dois isoler dans le nom de la société un prefixe litteral de
type "Abcdef" qui se trouve présent dans toutes les dénominations des
sociètés rachetées.
Les codes sont dans un champ (colonne E), les noms des sociétés dans un
autre (Colonne F) . Je voudrais par une seule formule renvoyer dans une
colonne x, les infos suivantes :
Si le code est actif = actif, si le nom de la société comporte le préfixe
"Abcdef" = Abcdef, sinon Autres. Je sais utiliser la fonction recherche v et
retrouver mes concordances sur les codes actifs, mais Je bute sur la
condition qui implique une interprétation du libellé de la société ?
Y-a-t-il une bonne âme qui pourrait m'aider ?
Merci d'avance,
Bruno
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ellimac
Le #5386871
Bonjour,

=SI(E2="actif";"actif";si(non(esterreur(cherche("abcdef";F2)));"abcdef";"autres"))

Camille


Bonjour ,
J'ai une série de sociétés que je veux classer en 3 catégories :
Codes actifs, codes "rachetés" et codes clos.
Chacune de ces sociétés peut être identifiés par le code (en comparant la
liste des codes actifs et le code de la société en question. pour les codes
rachetés, je dois isoler dans le nom de la société un prefixe litteral de
type "Abcdef" qui se trouve présent dans toutes les dénominations des
sociètés rachetées.
Les codes sont dans un champ (colonne E), les noms des sociétés dans un
autre (Colonne F) . Je voudrais par une seule formule renvoyer dans une
colonne x, les infos suivantes :
Si le code est actif = actif, si le nom de la société comporte le préfixe
"Abcdef" = Abcdef, sinon Autres. Je sais utiliser la fonction recherche v et
retrouver mes concordances sur les codes actifs, mais Je bute sur la
condition qui implique une interprétation du libellé de la société ?
Y-a-t-il une bonne âme qui pourrait m'aider ?
Merci d'avance,
Bruno



Bruno
Le #5386761
Merci Camille,
Mais la formule me renvoie , dans le cas ou elle devrait renvoyer "Autres"
le message #N/A ? Je ne comprends pas pourquoi ?
Merci de ton aide.
Bruno


Bonjour,

=SI(E2="actif";"actif";si(non(esterreur(cherche("abcdef";F2)));"abcdef";"autres"))

Camille


Bonjour ,
J'ai une série de sociétés que je veux classer en 3 catégories :
Codes actifs, codes "rachetés" et codes clos.
Chacune de ces sociétés peut être identifiés par le code (en comparant la
liste des codes actifs et le code de la société en question. pour les codes
rachetés, je dois isoler dans le nom de la société un prefixe litteral de
type "Abcdef" qui se trouve présent dans toutes les dénominations des
sociètés rachetées.
Les codes sont dans un champ (colonne E), les noms des sociétés dans un
autre (Colonne F) . Je voudrais par une seule formule renvoyer dans une
colonne x, les infos suivantes :
Si le code est actif = actif, si le nom de la société comporte le préfixe
"Abcdef" = Abcdef, sinon Autres. Je sais utiliser la fonction recherche v et
retrouver mes concordances sur les codes actifs, mais Je bute sur la
condition qui implique une interprétation du libellé de la société ?
Y-a-t-il une bonne âme qui pourrait m'aider ?
Merci d'avance,
Bruno





Ellimac
Le #5386731
Bonjour,

Peux-tu aller sur le site cjoint.com et mettre un extarit de ton fichier ?

Camille


Merci Camille,
Mais la formule me renvoie , dans le cas ou elle devrait renvoyer "Autres"
le message #N/A ? Je ne comprends pas pourquoi ?
Merci de ton aide.
Bruno


Bonjour,

=SI(E2="actif";"actif";si(non(esterreur(cherche("abcdef";F2)));"abcdef";"autres"))

Camille


Bonjour ,
J'ai une série de sociétés que je veux classer en 3 catégories :
Codes actifs, codes "rachetés" et codes clos.
Chacune de ces sociétés peut être identifiés par le code (en comparant la
liste des codes actifs et le code de la société en question. pour les codes
rachetés, je dois isoler dans le nom de la société un prefixe litteral de
type "Abcdef" qui se trouve présent dans toutes les dénominations des
sociètés rachetées.
Les codes sont dans un champ (colonne E), les noms des sociétés dans un
autre (Colonne F) . Je voudrais par une seule formule renvoyer dans une
colonne x, les infos suivantes :
Si le code est actif = actif, si le nom de la société comporte le préfixe
"Abcdef" = Abcdef, sinon Autres. Je sais utiliser la fonction recherche v et
retrouver mes concordances sur les codes actifs, mais Je bute sur la
condition qui implique une interprétation du libellé de la société ?
Y-a-t-il une bonne âme qui pourrait m'aider ?
Merci d'avance,
Bruno







Bruno
Le #5386641
Comment je fais pour aller sur ce site ?
Est-ce Ci-joint.com ou cijoint.com et dans quelle rubrique dois déposer mon
bout de fichier ?
Merci de ton aide,
Bruno


Bonjour,

Peux-tu aller sur le site cjoint.com et mettre un extarit de ton fichier ?

Camille


Merci Camille,
Mais la formule me renvoie , dans le cas ou elle devrait renvoyer "Autres"
le message #N/A ? Je ne comprends pas pourquoi ?
Merci de ton aide.
Bruno


Bonjour,

=SI(E2="actif";"actif";si(non(esterreur(cherche("abcdef";F2)));"abcdef";"autres"))

Camille


Bonjour ,
J'ai une série de sociétés que je veux classer en 3 catégories :
Codes actifs, codes "rachetés" et codes clos.
Chacune de ces sociétés peut être identifiés par le code (en comparant la
liste des codes actifs et le code de la société en question. pour les codes
rachetés, je dois isoler dans le nom de la société un prefixe litteral de
type "Abcdef" qui se trouve présent dans toutes les dénominations des
sociètés rachetées.
Les codes sont dans un champ (colonne E), les noms des sociétés dans un
autre (Colonne F) . Je voudrais par une seule formule renvoyer dans une
colonne x, les infos suivantes :
Si le code est actif = actif, si le nom de la société comporte le préfixe
"Abcdef" = Abcdef, sinon Autres. Je sais utiliser la fonction recherche v et
retrouver mes concordances sur les codes actifs, mais Je bute sur la
condition qui implique une interprétation du libellé de la société ?
Y-a-t-il une bonne âme qui pourrait m'aider ?
Merci d'avance,
Bruno









Ellimac
Le #5386611
Re,

C'est cjoint.com sans i
Après il n'y a qu'à suivre...
Camille


Comment je fais pour aller sur ce site ?
Est-ce Ci-joint.com ou cijoint.com et dans quelle rubrique dois déposer mon
bout de fichier ?
Merci de ton aide,
Bruno


Bonjour,

Peux-tu aller sur le site cjoint.com et mettre un extarit de ton fichier ?

Camille


Merci Camille,
Mais la formule me renvoie , dans le cas ou elle devrait renvoyer "Autres"
le message #N/A ? Je ne comprends pas pourquoi ?
Merci de ton aide.
Bruno


Bonjour,

=SI(E2="actif";"actif";si(non(esterreur(cherche("abcdef";F2)));"abcdef";"autres"))

Camille


Bonjour ,
J'ai une série de sociétés que je veux classer en 3 catégories :
Codes actifs, codes "rachetés" et codes clos.
Chacune de ces sociétés peut être identifiés par le code (en comparant la
liste des codes actifs et le code de la société en question. pour les codes
rachetés, je dois isoler dans le nom de la société un prefixe litteral de
type "Abcdef" qui se trouve présent dans toutes les dénominations des
sociètés rachetées.
Les codes sont dans un champ (colonne E), les noms des sociétés dans un
autre (Colonne F) . Je voudrais par une seule formule renvoyer dans une
colonne x, les infos suivantes :
Si le code est actif = actif, si le nom de la société comporte le préfixe
"Abcdef" = Abcdef, sinon Autres. Je sais utiliser la fonction recherche v et
retrouver mes concordances sur les codes actifs, mais Je bute sur la
condition qui implique une interprétation du libellé de la société ?
Y-a-t-il une bonne âme qui pourrait m'aider ?
Merci d'avance,
Bruno











Bruno
Le #5386571
http://cjoint.com/?meqEL5IVsc
Merci
Bruno


Re,

C'est cjoint.com sans i
Après il n'y a qu'à suivre...
Camille


Comment je fais pour aller sur ce site ?
Est-ce Ci-joint.com ou cijoint.com et dans quelle rubrique dois déposer mon
bout de fichier ?
Merci de ton aide,
Bruno


Bonjour,

Peux-tu aller sur le site cjoint.com et mettre un extarit de ton fichier ?

Camille


Merci Camille,
Mais la formule me renvoie , dans le cas ou elle devrait renvoyer "Autres"
le message #N/A ? Je ne comprends pas pourquoi ?
Merci de ton aide.
Bruno


Bonjour,

=SI(E2="actif";"actif";si(non(esterreur(cherche("abcdef";F2)));"abcdef";"autres"))

Camille


Bonjour ,
J'ai une série de sociétés que je veux classer en 3 catégories :
Codes actifs, codes "rachetés" et codes clos.
Chacune de ces sociétés peut être identifiés par le code (en comparant la
liste des codes actifs et le code de la société en question. pour les codes
rachetés, je dois isoler dans le nom de la société un prefixe litteral de
type "Abcdef" qui se trouve présent dans toutes les dénominations des
sociètés rachetées.
Les codes sont dans un champ (colonne E), les noms des sociétés dans un
autre (Colonne F) . Je voudrais par une seule formule renvoyer dans une
colonne x, les infos suivantes :
Si le code est actif = actif, si le nom de la société comporte le préfixe
"Abcdef" = Abcdef, sinon Autres. Je sais utiliser la fonction recherche v et
retrouver mes concordances sur les codes actifs, mais Je bute sur la
condition qui implique une interprétation du libellé de la société ?
Y-a-t-il une bonne âme qui pourrait m'aider ?
Merci d'avance,
Bruno













Ellimac
Le #5386561
Re,

En B1 :
=SI(ESTERREUR(A1);"";SI(A1ñ;"Actif";""))

Camille


http://cjoint.com/?meqEL5IVsc
Merci
Bruno


Re,

C'est cjoint.com sans i
Après il n'y a qu'à suivre...
Camille


Comment je fais pour aller sur ce site ?
Est-ce Ci-joint.com ou cijoint.com et dans quelle rubrique dois déposer mon
bout de fichier ?
Merci de ton aide,
Bruno


Bonjour,

Peux-tu aller sur le site cjoint.com et mettre un extarit de ton fichier ?

Camille


Merci Camille,
Mais la formule me renvoie , dans le cas ou elle devrait renvoyer "Autres"
le message #N/A ? Je ne comprends pas pourquoi ?
Merci de ton aide.
Bruno


Bonjour,

=SI(E2="actif";"actif";si(non(esterreur(cherche("abcdef";F2)));"abcdef";"autres"))

Camille


Bonjour ,
J'ai une série de sociétés que je veux classer en 3 catégories :
Codes actifs, codes "rachetés" et codes clos.
Chacune de ces sociétés peut être identifiés par le code (en comparant la
liste des codes actifs et le code de la société en question. pour les codes
rachetés, je dois isoler dans le nom de la société un prefixe litteral de
type "Abcdef" qui se trouve présent dans toutes les dénominations des
sociètés rachetées.
Les codes sont dans un champ (colonne E), les noms des sociétés dans un
autre (Colonne F) . Je voudrais par une seule formule renvoyer dans une
colonne x, les infos suivantes :
Si le code est actif = actif, si le nom de la société comporte le préfixe
"Abcdef" = Abcdef, sinon Autres. Je sais utiliser la fonction recherche v et
retrouver mes concordances sur les codes actifs, mais Je bute sur la
condition qui implique une interprétation du libellé de la société ?
Y-a-t-il une bonne âme qui pourrait m'aider ?
Merci d'avance,
Bruno















Bruno
Le #5386531
Merci , Merci !
Je ne comprends pas pourquoi il faut utiliser le formaule S(ESTERREUR ? Afin
de remettre la cellule à blanc ? Mais quel est la raison logique ou technique
excel ?

Merci de ta reponse,
Cordialement,
Bruno


Re,

En B1 :
=SI(ESTERREUR(A1);"";SI(A1ñ;"Actif";""))

Camille


http://cjoint.com/?meqEL5IVsc
Merci
Bruno


Re,

C'est cjoint.com sans i
Après il n'y a qu'à suivre...
Camille


Comment je fais pour aller sur ce site ?
Est-ce Ci-joint.com ou cijoint.com et dans quelle rubrique dois déposer mon
bout de fichier ?
Merci de ton aide,
Bruno


Bonjour,

Peux-tu aller sur le site cjoint.com et mettre un extarit de ton fichier ?

Camille


Merci Camille,
Mais la formule me renvoie , dans le cas ou elle devrait renvoyer "Autres"
le message #N/A ? Je ne comprends pas pourquoi ?
Merci de ton aide.
Bruno


Bonjour,

=SI(E2="actif";"actif";si(non(esterreur(cherche("abcdef";F2)));"abcdef";"autres"))

Camille


Bonjour ,
J'ai une série de sociétés que je veux classer en 3 catégories :
Codes actifs, codes "rachetés" et codes clos.
Chacune de ces sociétés peut être identifiés par le code (en comparant la
liste des codes actifs et le code de la société en question. pour les codes
rachetés, je dois isoler dans le nom de la société un prefixe litteral de
type "Abcdef" qui se trouve présent dans toutes les dénominations des
sociètés rachetées.
Les codes sont dans un champ (colonne E), les noms des sociétés dans un
autre (Colonne F) . Je voudrais par une seule formule renvoyer dans une
colonne x, les infos suivantes :
Si le code est actif = actif, si le nom de la société comporte le préfixe
"Abcdef" = Abcdef, sinon Autres. Je sais utiliser la fonction recherche v et
retrouver mes concordances sur les codes actifs, mais Je bute sur la
condition qui implique une interprétation du libellé de la société ?
Y-a-t-il une bonne âme qui pourrait m'aider ?
Merci d'avance,
Bruno

















Publicité
Poster une réponse
Anonyme