Faire avancer une somme ???

Le
LE TROLL
Bonjour,

Je fais la somme d'une plage, et je récupère
cette info dans un autre classeur.

Toutefois, si la plage de la somme s'agrandit,
je dois à chaque fois rajouter dans la somme, la
nouvelle cellule de fin de plage (verticale)

Y aurait-il, sans mettre en somme toutes la
colonne, la possibilité de déterminer une plage
qui avance ?

Exemple:
a1
a2 b2=somme(a1:a2)

Si j'écris en a3, il faudrait que ma formule
change et avance, ainsi:

a1
a2 b2=""
a3 b3=somme(a1:a3)

Ou, au moins,
que somme(a1:a2),
se transforme si a+1 <> "" en somme(a1:a3)

Est-ce possible sans macro ?

--
Merci beaucoup, au revoir et à bientôt :o)

Romans, logiciels, email, site personnel
http://irolog.free.fr/joe.htm
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ellimac
Le #6404991
Bonjour,

=SOMME(DECALER(A2;0;0;NBVAL(A:A)-1);1)

Camille

"LE TROLL"
Bonjour,

Je fais la somme d'une plage, et je récupère
cette info dans un autre classeur.

Toutefois, si la plage de la somme s'agrandit,
je dois à chaque fois rajouter dans la somme, la
nouvelle cellule de fin de plage (verticale)...

Y aurait-il, sans mettre en somme toutes la
colonne, la possibilité de déterminer une plage
qui avance ?

Exemple:
a1
a2 b2=somme(a1:a2)

Si j'écris en a3, il faudrait que ma formule
change et avance, ainsi:

a1
a2 b2=""
a3 b3=somme(a1:a3)

Ou, au moins,
que somme(a1:a2),
se transforme si a+1 <> "" en somme(a1:a3)

Est-ce possible sans macro ?

--
Merci beaucoup, au revoir et à bientôt :o)
------
Romans, logiciels, email, site personnel
http://irolog.free.fr/joe.htm
------------------------------------------------------------------------------------





LE TROLL
Le #6404971
Ah, bonjour, merci, un peu ésotérique, mais je
vais essayer :o)

--
Merci beaucoup, au revoir et à bientôt :o)
------
Romans, logiciels, email, site personnel
http://irolog.free.fr/joe.htm
------------------------------------------------------------------------------------
"Ellimac" dans le message de news:

| Bonjour,
|
| =SOMME(DECALER(A2;0;0;NBVAL(A:A)-1);1)
|
| Camille
|
| "LE TROLL" message de news:
|
| > Bonjour,
| >
| > Je fais la somme d'une plage, et je
récupère
| > cette info dans un autre classeur.
| >
| > Toutefois, si la plage de la somme
s'agrandit,
| > je dois à chaque fois rajouter dans la somme,
la
| > nouvelle cellule de fin de plage
(verticale)...
| >
| > Y aurait-il, sans mettre en somme toutes la
| > colonne, la possibilité de déterminer une
plage
| > qui avance ?
| >
| > Exemple:
| > a1
| > a2 b2=somme(a1:a2)
| >
| > Si j'écris en a3, il faudrait que ma formule
| > change et avance, ainsi:
| >
| > a1
| > a2 b2=""
| > a3 b3=somme(a1:a3)
| >
| > Ou, au moins,
| > que somme(a1:a2),
| > se transforme si a+1 <> "" en somme(a1:a3)
| >
| > Est-ce possible sans macro ?
| >
| > --
| > Merci beaucoup, au revoir et à bientôt :o)
| > ------
| > Romans, logiciels, email, site personnel
| > http://irolog.free.fr/joe.htm
|
------------------------------------------------------------------------------------
| >

| >
| >
|
|

Publicité
Poster une réponse
Anonyme