Faire du ménage

Le
Charlubert
Bonjour,
A l'approche de la nouvelle année, je voudrais faire ub peu de ménage
dans mon ordi. J'ai entre autre 2 programmes en multiples exemplaires:
- Microsoft net.framework: versions1.1 3.0 3.5SP1 4Client ptofile
4extended
- Microsoft visual C++ 2005 2008 2010

Puis je supprimer les plus anciennes ou se complètent elles?

Merci pour vos lumières.
JCE
Et Joyeuses fêtes.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Herser
Le #25086472
Bonjour

Ne pas supprimer !

Les programmes qui en ont besoin demandent une version précise de
.NETFrameworks ou de VisualC++
Les versions ne sont pas cumulatives.

Il se peut toutefois que tu ais déjà désinstallé les programmes qui avaient
besoin de telle version.
La désinstallation conserve les versions de .NF ou Visual C++, car d'autres
programmes peuvent les exiger.

Dans le doute abstiens toi.

Herser
Laurent Jumet
Le #25086522
Hello Charlubert !

"Charlubert"
A l'approche de la nouvelle année, je voudrais faire ub peu de ménage...
dans mon ordi. J'ai entre autre 2 programmes en multiples exemplaires:
- Microsoft net.framework: versions1.1 3.0 3.5SP1 4Client ptofile
4extended



...non, car les applis sont écrites pour une version spécifique.

- Microsoft visual C++ 2005 2008 2010



...je ne sais pas.

--
Laurent Jumet - Point de Chat, Liège, BELGIUM
KeyID: 0xCFAF704C
[Restore address to laurent.jumet for e-mail reply.]
Le Novice °¿°
Le #25086512
Charlubert a écrit :

Bonjour,
A l'approche de la nouvelle année, je voudrais faire ub peu de
ménage... dans mon ordi. J'ai entre autre 2 programmes en multiples
exemplaires: - Microsoft net.framework: versions1.1 3.0 3.5SP1
4Client ptofile 4extended
- Microsoft visual C++ 2005 2008 2010

Puis je supprimer les plus anciennes ou se complètent elles?

Merci pour vos lumières.
JCE
Et Joyeuses fêtes.



Salut Charlubert

Tout a fait d'accord avec Herser que je salue !

Il n'y a pas nécessairement de compatibilité ascendante entre les
différentes versions de .Net Framework
Effectivement, certains programmes/logiciels/applications peuvent exiger
une version (même ancienne !) de .Net Framework
Tout simplement parce que ces programmes/logiciels/applications n'ont
pas été développés avec une autre version plus récente de .Net Framework
Pour plus d'infos, voir ici :
http://www.concordance-informatique.com/blog/2011/02/le-framework-microsoft-net-et-ses-differentes-versions/

Et voir plus particuliérement ce chapitre :
"Prise en compte des différentes versions"
L'auteur de l'article parle bien de compatibilité (ascendante et
descendante) aléatoire

Supprimer une ancienne version de .Net Framework, c'est donc prendre le
risque d'avoir certaines applications ne pouvant plus fonctionner
correctement !
(Sans compter tous les problémes récurrents que l'on peut rencontrer
avec la désinstallation, l'installation ou la réinstallation des .Net
Framework)

Il n'est pas non plus raisonnable de vouloir désinstaller une ancienne
version de .NET Framework, sous prétexte de gagner un peu d'espace de
sotckage sur le Disque Dur de son pc
(L'espace ainsi récupéré sera dérisoire, et donc sans réel intérêt !)

Conclusion :
Si tu ne constates aucun problème de dysfonctionnement lié aux
différentes versions de .NET Framework installées sur votre pc, le mieux
est encore de laisser toutes ces versions en paix
(Ne vas pas mettre inutilement tes mains dans le cambouis !)

JOYEUX NOEL A TOI ET A HERSER
Ainsi qu'à tous ceux qui passeront par là !

--
Le Novice °¿°
Herser
Le #25086912
Le Novice °¿° a écrit dans le message de
news:50d86987$0$1387$

JOYEUX NOEL A TOI ET A HERSER
Ainsi qu'à tous ceux qui passeront par là !



Joyeux Noël à toi aussi, ainsi qu'à tous les nostalgiques des m.p.f !

Herser
Publicité
Poster une réponse
Anonyme