Faire une somme de la meilleure valeur

Le
Philippe
bonjour

j'ai une ligne avec 6 colonnes . Ces colonnes sont associés 2 par 2 et je
voudrais faire la somme de la ligne en prenant la meilleure valeur de ces 2
colonnes. Merci de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sam
Le #21445481
Bonjour,
pour la ligne 2
=MAX(A2:B2)+MAX(C2:D2)+MAX(E2:F2)
Cordialement
Michel dit "Sam"

"Philippe"
bonjour

j'ai une ligne avec 6 colonnes . Ces colonnes sont associés 2 par 2 et je
voudrais faire la somme de la ligne en prenant la meilleure valeur de ces
2 colonnes. Merci de votre aide

Philippe
Le #21445591
Quelle rapidité et encore merci
mais si ce n'est pas abusé j'ai une colonne de 12 lignes pour laquelle je
voudrais faire la somme des 9 meilleures valeurs
cordialement

"Sam" 4bad1a27$0$15838$


Bonjour,
pour la ligne 2
=MAX(A2:B2)+MAX(C2:D2)+MAX(E2:F2)
Cordialement
Michel dit "Sam"

"Philippe"
bonjour

j'ai une ligne avec 6 colonnes . Ces colonnes sont associés 2 par 2 et je
voudrais faire la somme de la ligne en prenant la meilleure valeur de ces
2 colonnes. Merci de votre aide





Sam
Le #21445671
Bonjour, pour la colonne A
=SOMMEPROD(A1:A12*(A1:A12>GRANDE.VALEUR(A1:A12;10)))
devrait convenir
Cordialement
Michel dit "Sam"

"Philippe" %
Quelle rapidité et encore merci
mais si ce n'est pas abusé j'ai une colonne de 12 lignes pour laquelle je
voudrais faire la somme des 9 meilleures valeurs
cordialement

"Sam" 4bad1a27$0$15838$


Bonjour,
pour la ligne 2
=MAX(A2:B2)+MAX(C2:D2)+MAX(E2:F2)
Cordialement
Michel dit "Sam"

"Philippe"
bonjour

j'ai une ligne avec 6 colonnes . Ces colonnes sont associés 2 par 2 et
je voudrais faire la somme de la ligne en prenant la meilleure valeur de
ces 2 colonnes. Merci de votre aide









Sam
Le #21445731
re Bonjour,
nota : je n'ai pas traité le cas où plusieurs valeurs sont identiques en
9eme ou 10eme position
Cordialement
Michel dit "Sam"

"Sam" 4bad239d$0$15843$

Bonjour, pour la colonne A
=SOMMEPROD(A1:A12*(A1:A12>GRANDE.VALEUR(A1:A12;10)))
devrait convenir
Cordialement
Michel dit "Sam"

"Philippe" %
Quelle rapidité et encore merci
mais si ce n'est pas abusé j'ai une colonne de 12 lignes pour laquelle je
voudrais faire la somme des 9 meilleures valeurs
cordialement

"Sam" 4bad1a27$0$15838$


Bonjour,
pour la ligne 2
=MAX(A2:B2)+MAX(C2:D2)+MAX(E2:F2)
Cordialement
Michel dit "Sam"

"Philippe"
bonjour

j'ai une ligne avec 6 colonnes . Ces colonnes sont associés 2 par 2 et
je voudrais faire la somme de la ligne en prenant la meilleure valeur
de ces 2 colonnes. Merci de votre aide













michdenis
Le #21446361
Bonjour,

Il y a aussi ceci :

Validation matricielle :

=SOMME(GRANDE.VALEUR($A$1:$A$12;LIGNE(INDIRECT("1:9"))))




"Philippe" #
Quelle rapidité et encore merci
mais si ce n'est pas abusé j'ai une colonne de 12 lignes pour laquelle je
voudrais faire la somme des 9 meilleures valeurs
cordialement

"Sam" 4bad1a27$0$15838$


Bonjour,
pour la ligne 2
=MAX(A2:B2)+MAX(C2:D2)+MAX(E2:F2)
Cordialement
Michel dit "Sam"

"Philippe"
bonjour

j'ai une ligne avec 6 colonnes . Ces colonnes sont associés 2 par 2 et je
voudrais faire la somme de la ligne en prenant la meilleure valeur de ces
2 colonnes. Merci de votre aide





Philippe
Le #21481371
bonjour
J'ai un petit soucis lors de l'application des formules que vous m'avez
donné. Si les valeurs sont égales la somme ne se fait plus pour la 1ere
formule (Sam) et pour la derniere je n'ai que la plus grande qui est dans la
somme. Merci de votre aide car je dois utiliser cette formule avant demain
matin
cordialement
Philippe

"michdenis"
Bonjour,

Il y a aussi ceci :

Validation matricielle :

=SOMME(GRANDE.VALEUR($A$1:$A$12;LIGNE(INDIRECT("1:9"))))




"Philippe" discussion :
#
Quelle rapidité et encore merci
mais si ce n'est pas abusé j'ai une colonne de 12 lignes pour laquelle je
voudrais faire la somme des 9 meilleures valeurs
cordialement

"Sam" 4bad1a27$0$15838$


Bonjour,
pour la ligne 2
=MAX(A2:B2)+MAX(C2:D2)+MAX(E2:F2)
Cordialement
Michel dit "Sam"

"Philippe"
bonjour

j'ai une ligne avec 6 colonnes . Ces colonnes sont associés 2 par 2 et
je
voudrais faire la somme de la ligne en prenant la meilleure valeur de
ces
2 colonnes. Merci de votre aide








Caetera
Le #21483702
"Philippe" %23ADWI%
bonjour
J'ai un petit soucis lors de l'application des formules que vous m'avez donné.
Si les valeurs sont égales la somme ne se fait plus pour la 1ere formule (Sam)
et pour la derniere je n'ai que la plus grande qui est dans la somme.



*******************

Tout dépend du résultat que tu veux obtenir !
Avec cette série :
20;20;20;20;20;20;20;20;20;20;19;18;17;16;15;14;13;12;11;10

=SOMMEPROD(Série*(Série>GRANDE.VALEUR(Série;10)))
résultat 0

=SOMME(GRANDE.VALEUR(Série;LIGNE(INDIRECT("1:9"))))
(matricielle) donne 180 car les doublons ne sont pas pris en compte

=SOMME(GRANDE.VALEUR(SI((EQUIV(Série;Série;0)=LIGNE(INDIRECT("1:"&LIGNES(Série))));Série;"");{1;2;3;4;5;6;7;8;9}))
(matricielle) donne 144 car les doublons sont pris en compte (ne comptent qu'une
fois)

http://www.cijoint.fr/cjlink.php?file=cj201004/cijcSakU5v.xls

Etc
Sam
Le #21485282
Bonjour,
celle de Michdenis semble convenir mais c'est une formule matricielle, il
faut la valider en appuyant sur 3 touches: Ctrl Majuscule Entrée
Cordialement
Michel dit "Sam"

"Philippe" %23ADWI%
bonjour
J'ai un petit soucis lors de l'application des formules que vous m'avez
donné. Si les valeurs sont égales la somme ne se fait plus pour la 1ere
formule (Sam) et pour la derniere je n'ai que la plus grande qui est dans
la somme. Merci de votre aide car je dois utiliser cette formule avant
demain matin
cordialement
Philippe

"michdenis"
Bonjour,

Il y a aussi ceci :

Validation matricielle :

=SOMME(GRANDE.VALEUR($A$1:$A$12;LIGNE(INDIRECT("1:9"))))




"Philippe" discussion :
#
Quelle rapidité et encore merci
mais si ce n'est pas abusé j'ai une colonne de 12 lignes pour laquelle je
voudrais faire la somme des 9 meilleures valeurs
cordialement

"Sam" 4bad1a27$0$15838$


Bonjour,
pour la ligne 2
=MAX(A2:B2)+MAX(C2:D2)+MAX(E2:F2)
Cordialement
Michel dit "Sam"

"Philippe"
bonjour

j'ai une ligne avec 6 colonnes . Ces colonnes sont associés 2 par 2 et
je
voudrais faire la somme de la ligne en prenant la meilleure valeur de
ces
2 colonnes. Merci de votre aide












Philippe
Le #21485652
bonjour
je suis débutant mais je pense qu'il faut faire quelque chose avec Série
pour que la formule fonctionne

"Caetera" %
"Philippe" %23ADWI%
bonjour
J'ai un petit soucis lors de l'application des formules que vous m'avez
donné. Si les valeurs sont égales la somme ne se fait plus pour la 1ere
formule (Sam) et pour la derniere je n'ai que la plus grande qui est dans
la somme.



*******************

Tout dépend du résultat que tu veux obtenir !
Avec cette série :
20;20;20;20;20;20;20;20;20;20;19;18;17;16;15;14;13;12;11;10

=SOMMEPROD(Série*(Série>GRANDE.VALEUR(Série;10)))
résultat 0

=SOMME(GRANDE.VALEUR(Série;LIGNE(INDIRECT("1:9"))))
(matricielle) donne 180 car les doublons ne sont pas pris en compte

=SOMME(GRANDE.VALEUR(SI((EQUIV(Série;Série;0)=LIGNE(INDIRECT("1:"&LIGNES(Série))));Série;"");{1;2;3;4;5;6;7;8;9}))
(matricielle) donne 144 car les doublons sont pris en compte (ne comptent
qu'une fois)

http://www.cijoint.fr/cjlink.php?file=cj201004/cijcSakU5v.xls

Etc

Caetera
Le #21487962
"Philippe"
bonjour
je suis débutant mais je pense qu'il faut faire quelque chose avec Série pour
que la formule fonctionne



*************

Regarde donc le fichier joint et/ou les exemples fournis

Etc
Publicité
Poster une réponse
Anonyme