Ce fameux 'Si'

Le
Dominique Delos
Bonjour à tous !

Sur Excel 2003, j'ai un tableau reprenant une colonne "article", puis l2
colonnes (1 par mois comprenant le "prix") , une colonne "Quantité", et
enfin une colonne "Total" (qui multiplie la "Quantité" par le "prix")
Je me régalais à l'avance en utilisant la fonction 'Si' pour faire en sorte
que le total prenne en compte le dernier prix saisi. Ainsi si un prix avait
été saisi dans la colonne "Décembre", c'est ce prix qui était multiplié par
la quantité, si la cellule était vide ou à zéro, j'allais multiplié la
quantité par le prix de novembre et ainsi de suite, voir ci après
=SI(N2>0;O2*N2;SI(M2>0;O2*M2;SI(L2>0;O2*L2;SI(K2>0;O2*K2;SI(J2>0;O2*J2;SI(I2>0;O2*I2;SI(H2>0;O2*H2;SI(G2>0;O2*G2))))))))
mais ça coince, le nombre de conditions étant limité, un peu comme moi sur
Excel ;-)
Auriez-vous une solution pour me dépanner ? merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #5108571
Bonjour,
=O2*(G2*(H2="")+H2*(I2="")+I2*(J2="")+J2*(K2="")+K2*(L2="")+L2*(M2="")+M2*(N2="")+N2*(N2>0))
convient il ?
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"Dominique Delos" <Non précisée> a écrit dans le message de
news:
Bonjour à tous !

Sur Excel 2003, j'ai un tableau reprenant une colonne "article", puis l2
colonnes (1 par mois comprenant le "prix") , une colonne "Quantité", et
enfin une colonne "Total" (qui multiplie la "Quantité" par le "prix")
Je me régalais à l'avance en utilisant la fonction 'Si' pour faire en
sorte que le total prenne en compte le dernier prix saisi. Ainsi si un
prix avait été saisi dans la colonne "Décembre", c'est ce prix qui était
multiplié par la quantité, si la cellule était vide ou à zéro, j'allais
multiplié la quantité par le prix de novembre et ainsi de suite, voir ci
après
=SI(N2>0;O2*N2;SI(M2>0;O2*M2;SI(L2>0;O2*L2;SI(K2>0;O2*K2;SI(J2>0;O2*J2;SI(I2>0;O2*I2;SI(H2>0;O2*H2;SI(G2>0;O2*G2))))))))
mais ça coince, le nombre de conditions étant limité, un peu comme moi sur
Excel ;-)
Auriez-vous une solution pour me dépanner ? merci



Ellimac
Le #5108561
Bonjour,

S'il n'y a pas de trous dans les colonnes :
=O2*INDEX(C2:N2;1;NBVAL(C2:N2))

Camille


Bonjour à tous !

Sur Excel 2003, j'ai un tableau reprenant une colonne "article", puis l2
colonnes (1 par mois comprenant le "prix") , une colonne "Quantité", et
enfin une colonne "Total" (qui multiplie la "Quantité" par le "prix")
Je me régalais à l'avance en utilisant la fonction 'Si' pour faire en sorte
que le total prenne en compte le dernier prix saisi. Ainsi si un prix avait
été saisi dans la colonne "Décembre", c'est ce prix qui était multiplié par
la quantité, si la cellule était vide ou à zéro, j'allais multiplié la
quantité par le prix de novembre et ainsi de suite, voir ci après
=SI(N2>0;O2*N2;SI(M2>0;O2*M2;SI(L2>0;O2*L2;SI(K2>0;O2*K2;SI(J2>0;O2*J2;SI(I2>0;O2*I2;SI(H2>0;O2*H2;SI(G2>0;O2*G2))))))))
mais ça coince, le nombre de conditions étant limité, un peu comme moi sur
Excel ;-)
Auriez-vous une solution pour me dépanner ? merci





Dominique Delos
Le #5108551
Merci à vous 2, j'essaie ça de suite !!

"Ellimac" news:
Bonjour,

S'il n'y a pas de trous dans les colonnes :
=O2*INDEX(C2:N2;1;NBVAL(C2:N2))

Camille


Bonjour à tous !

Sur Excel 2003, j'ai un tableau reprenant une colonne "article", puis l2
colonnes (1 par mois comprenant le "prix") , une colonne "Quantité", et
enfin une colonne "Total" (qui multiplie la "Quantité" par le "prix")
Je me régalais à l'avance en utilisant la fonction 'Si' pour faire en
sorte
que le total prenne en compte le dernier prix saisi. Ainsi si un prix
avait
été saisi dans la colonne "Décembre", c'est ce prix qui était multiplié
par
la quantité, si la cellule était vide ou à zéro, j'allais multiplié la
quantité par le prix de novembre et ainsi de suite, voir ci après
=SI(N2>0;O2*N2;SI(M2>0;O2*M2;SI(L2>0;O2*L2;SI(K2>0;O2*K2;SI(J2>0;O2*J2;SI(I2>0;O2*I2;SI(H2>0;O2*H2;SI(G2>0;O2*G2))))))))
mais ça coince, le nombre de conditions étant limité, un peu comme moi
sur
Excel ;-)
Auriez-vous une solution pour me dépanner ? merci







Dominique Delos
Le #5108541
Ca marche nickel !!! merci et bonnes fêtes de fin d'année.....


"Dominique Delos" <Non précisée> a écrit dans le message de news:

Merci à vous 2, j'essaie ça de suite !!

"Ellimac" news:
Bonjour,

S'il n'y a pas de trous dans les colonnes :
=O2*INDEX(C2:N2;1;NBVAL(C2:N2))

Camille


Bonjour à tous !

Sur Excel 2003, j'ai un tableau reprenant une colonne "article", puis l2
colonnes (1 par mois comprenant le "prix") , une colonne "Quantité", et
enfin une colonne "Total" (qui multiplie la "Quantité" par le "prix")
Je me régalais à l'avance en utilisant la fonction 'Si' pour faire en
sorte
que le total prenne en compte le dernier prix saisi. Ainsi si un prix
avait
été saisi dans la colonne "Décembre", c'est ce prix qui était multiplié
par
la quantité, si la cellule était vide ou à zéro, j'allais multiplié la
quantité par le prix de novembre et ainsi de suite, voir ci après
=SI(N2>0;O2*N2;SI(M2>0;O2*M2;SI(L2>0;O2*L2;SI(K2>0;O2*K2;SI(J2>0;O2*J2;SI(I2>0;O2*I2;SI(H2>0;O2*H2;SI(G2>0;O2*G2))))))))
mais ça coince, le nombre de conditions étant limité, un peu comme moi
sur
Excel ;-)
Auriez-vous une solution pour me dépanner ? merci











Jacquouille
Le #5106251
Bonjour
Ne serait-il pas plus enrichissant de prendre le max de la ligne, plutôt que
le dernier prix inscrit? -)

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Dominique Delos" <Non précisée> a écrit dans le message de news:
%
Ca marche nickel !!! merci et bonnes fêtes de fin d'année.....


"Dominique Delos" <Non précisée> a écrit dans le message de news:

Merci à vous 2, j'essaie ça de suite !!

"Ellimac" news:
Bonjour,

S'il n'y a pas de trous dans les colonnes :
=O2*INDEX(C2:N2;1;NBVAL(C2:N2))

Camille


Bonjour à tous !

Sur Excel 2003, j'ai un tableau reprenant une colonne "article", puis
l2
colonnes (1 par mois comprenant le "prix") , une colonne "Quantité", et
enfin une colonne "Total" (qui multiplie la "Quantité" par le "prix")
Je me régalais à l'avance en utilisant la fonction 'Si' pour faire en
sorte
que le total prenne en compte le dernier prix saisi. Ainsi si un prix
avait
été saisi dans la colonne "Décembre", c'est ce prix qui était multiplié
par
la quantité, si la cellule était vide ou à zéro, j'allais multiplié la
quantité par le prix de novembre et ainsi de suite, voir ci après
=SI(N2>0;O2*N2;SI(M2>0;O2*M2;SI(L2>0;O2*L2;SI(K2>0;O2*K2;SI(J2>0;O2*J2;SI(I2>0;O2*I2;SI(H2>0;O2*H2;SI(G2>0;O2*G2))))))))
mais ça coince, le nombre de conditions étant limité, un peu comme moi
sur
Excel ;-)
Auriez-vous une solution pour me dépanner ? merci















Dominique Delos
Le #5105801
Bah, c'est un peu risqué, des fois que le prix viendrait à baisser... ;-)
En cette période, on peut toujours rêver !!
"Jacquouille" news:
Bonjour
Ne serait-il pas plus enrichissant de prendre le max de la ligne, plutôt
que le dernier prix inscrit? -)

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Dominique Delos" <Non précisée> a écrit dans le message de news:
%
Ca marche nickel !!! merci et bonnes fêtes de fin d'année.....


"Dominique Delos" <Non précisée> a écrit dans le message de news:

Merci à vous 2, j'essaie ça de suite !!

"Ellimac" news:
Bonjour,

S'il n'y a pas de trous dans les colonnes :
=O2*INDEX(C2:N2;1;NBVAL(C2:N2))

Camille


Bonjour à tous !

Sur Excel 2003, j'ai un tableau reprenant une colonne "article", puis
l2
colonnes (1 par mois comprenant le "prix") , une colonne "Quantité",
et
enfin une colonne "Total" (qui multiplie la "Quantité" par le "prix")
Je me régalais à l'avance en utilisant la fonction 'Si' pour faire en
sorte
que le total prenne en compte le dernier prix saisi. Ainsi si un prix
avait
été saisi dans la colonne "Décembre", c'est ce prix qui était
multiplié par
la quantité, si la cellule était vide ou à zéro, j'allais multiplié la
quantité par le prix de novembre et ainsi de suite, voir ci après
=SI(N2>0;O2*N2;SI(M2>0;O2*M2;SI(L2>0;O2*L2;SI(K2>0;O2*K2;SI(J2>0;O2*J2;SI(I2>0;O2*I2;SI(H2>0;O2*H2;SI(G2>0;O2*G2))))))))
mais ça coince, le nombre de conditions étant limité, un peu comme moi
sur
Excel ;-)
Auriez-vous une solution pour me dépanner ? merci



















Publicité
Poster une réponse
Anonyme