Fenêtre interne invisible

Le
A13R
Bonjour et bonne année !

J'ai une fenêtre interne qui ne veut pas s'afficher ; en effet elle
n'est jamais visible (en WD15 et 16) dans les 2 circonstances ou je
l'affiche, et je n'arrive pas à trouver la raison ; j'ai vérifié qu'i=
l
n'y avait pas de problème de plan, d'onglet, ou d'ancrage.
Lorsque j'affiche en exécution les propriétés "visible" et "état" d=
e
la fenêtre interne ET du champ conteneur, les deux sont à 0 (non
visible) et 2 (invisible), malgré qu'aucune propriété n'ait été
définie de la sorte à la conception.
J'ai forcé les 2 propriétés dans le code d'initialisation des
fenêtres, sans succès. La lecture des propriétés avant et après l=
e
forçage renvoie toujours les mêmes valeurs.

Finalement, je ne sais plus quoi faire ce système fonctionnait bien
dans une version précédente de mon logiciel et ce problème est apparu
lorsque je suis reparti sur une copie du dossier du projet, mais sans
modification.

J'ai lu et relu l'aide, les forums, sans trouver de solution

Avez-vous une idée de tests à réaliser, une solution, ou une autre
possibilité de champ?

Merci !
-- André
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal F
Le #22990501
A13R a écrit :
Bonjour et bonne année !

J'ai une fenêtre interne qui ne veut pas s'afficher ; en effet elle
n'est jamais visible (en WD15 et 16) dans les 2 circonstances ou je
l'affiche, et je n'arrive pas à trouver la raison ; j'ai vérifié qu'il
n'y avait pas de problème de plan, d'onglet, ou d'ancrage.
Lorsque j'affiche en exécution les propriétés "visible" et "état" de
la fenêtre interne ET du champ conteneur, les deux sont à 0 (non
visible) et 2 (invisible), malgré qu'aucune propriété n'ait été
définie de la sorte à la conception.
J'ai forcé les 2 propriétés dans le code d'initialisation des
fenêtres, sans succès. La lecture des propriétés avant et après le
forçage renvoie toujours les mêmes valeurs.

Finalement, je ne sais plus quoi faire... ce système fonctionnait bien
dans une version précédente de mon logiciel et ce problème est apparu
lorsque je suis reparti sur une copie du dossier du projet, mais sans
modification.

J'ai lu et relu l'aide, les forums, sans trouver de solution...

Avez-vous une idée de tests à réaliser, une solution, ou une autre
possibilité de champ?

Merci !
-- André



J'ai eu ce problème dès que je changeait la fenetre interne avec
ChangeFenetreSource(), en version 12. Je n'ai jamais trouvé la
solution. malgré l'envoi de mini projet au ST soi-disant non
reproductible. Ma seule solution a été de faire trois fenetres avec
chacune une fenetre iinterne différente (bonjour l'économie!).
Je n'ai pas testé ni en WD15, ni en WD16.

--
Pascal

Ne garder que le prénom pour me joindre
André STASZEWSKI
Le #22993081
Il se trouve que A13R a formulé :
Bonjour et bonne année !

J'ai une fenêtre interne qui ne veut pas s'afficher ; en effet elle
n'est jamais visible (en WD15 et 16) dans les 2 circonstances ou je
l'affiche, et je n'arrive pas à trouver la raison ; j'ai vérifié qu'il
n'y avait pas de problème de plan, d'onglet, ou d'ancrage.
Lorsque j'affiche en exécution les propriétés "visible" et "état" de
la fenêtre interne ET du champ conteneur, les deux sont à 0 (non
visible) et 2 (invisible), malgré qu'aucune propriété n'ait été
définie de la sorte à la conception.
J'ai forcé les 2 propriétés dans le code d'initialisation des
fenêtres, sans succès. La lecture des propriétés avant et après le
forçage renvoie toujours les mêmes valeurs.

Finalement, je ne sais plus quoi faire... ce système fonctionnait bien
dans une version précédente de mon logiciel et ce problème est apparu
lorsque je suis reparti sur une copie du dossier du projet, mais sans
modification.

J'ai lu et relu l'aide, les forums, sans trouver de solution...

Avez-vous une idée de tests à réaliser, une solution, ou une autre
possibilité de champ?

Merci !
-- André



Bonsoir
J'ai eu un pb similaire avec un autre champ une fois (je sais plus
lequel).
J'ai renommé le fichier physique de la fenêtre à pb, puis j'ai recréé
une fenêtre du même nom, ai recréé tous les champs et j'ai fais un
copié collé du code de chaque champ de la fenêtre à pb avec la nouvelle
et là c'est reparti. Ensuite seulement, j'ai viré la fenêtre renommée
qui posait pb.
Bon courage !

--
Cordialement,
André STASZEWSKI
http://www.SoftSolution.fr

Pour me répondre en privé :
http://cerbermail.com/?Apg89a6853
A13R
Le #23005791
Bonjour,

Merci à vous deux pour vos suggestions, je ne vois que la recréation
d'une nouvelle fenêtre en effet...

Cordialement,
-- André


On 6 jan, 00:00, André STASZEWSKI wrote:

Bonsoir
J'ai eu un pb similaire avec un autre champ une fois (je sais plus
lequel).
J'ai renommé le fichier physique de la fenêtre à pb, puis j'ai recr éé
une fenêtre du même nom, ai recréé tous les champs et j'ai fais u n
copié collé du code de chaque champ de la fenêtre à pb avec la no uvelle
et là c'est reparti. Ensuite seulement, j'ai viré la fenêtre renomm ée
qui posait pb.
Bon courage !

--
Cordialement,
André STASZEWSKIhttp://www.SoftSolution.fr

Pour me répondre en privé :http://cerbermail.com/?Apg89a6853
A13R
Le #23020541
Bonjour,

Pour info, après avoir recréé la fenêtre interne et ses champs, ain si
que les champs fenêtre interne, toujours pas moyen d'obtenir que la
fenêtre interne apparaisse.

J'ai changé d'optique et ai créé un superchamp ; mais l'objectif ét ait
de n'utiliser qu'une seule fois le code de la fenêtre et d'en
faciliter la maintenance, il faudra que je pense à reporter les
modifications dans toutes les instances du superchamp.

Je vais aussi étudier les modèles de champ...

Bonne journée

Cordialement,
-- André

On 10 jan, 10:52, A13R
Bonjour,

Merci à vous deux pour vos suggestions, je ne vois que la recréation
d'une nouvelle fenêtre en effet...

Cordialement,
-- André

JeAn-PhI
Le #23021011
A13R a présenté l'énoncé suivant :
Bonjour,

Pour info, après avoir recréé la fenêtre interne et ses champs, ainsi
que les champs fenêtre interne, toujours pas moyen d'obtenir que la
fenêtre interne apparaisse.

J'ai changé d'optique et ai créé un superchamp ; mais l'objectif était
de n'utiliser qu'une seule fois le code de la fenêtre et d'en
faciliter la maintenance, il faudra que je pense à reporter les
modifications dans toutes les instances du superchamp.

Je vais aussi étudier les modèles de champ...

Bonne journée

Cordialement,
-- André

On 10 jan, 10:52, A13R
Bonjour,

Merci à vous deux pour vos suggestions, je ne vois que la recréation
d'une nouvelle fenêtre en effet...

Cordialement,
-- André





n'avez vous pas mis par inadvertance vos champs sur un plan autre que 0

--
Cordialement JeAn-PhI
A13R
Le #23028351
Bonjour,

Merci pour la suggestion mais comme je l'indiquais dans mon premier
post, j'ai vérifié une éventuelle problématique de plan, d'onglet o u
d'ancrage...

Bonne journée

-- André

> On 10 jan, 10:52, A13R >> Bonjour,

>> Merci à vous deux pour vos suggestions, je ne vois que la recréati on
>> d'une nouvelle fenêtre en effet...

>> Cordialement,
>> -- André

n'avez vous pas mis par inadvertance vos champs sur un plan autre que 0

--
Cordialement JeAn-PhI
Publicité
Poster une réponse
Anonyme