fglrx encore et toujours ...(rendu saccadé)

Le
fabrice régnier
salut la liste ;)

glxgears a un rendu saccadé: arret toutes les 1 secondes pendant 0.2
seconde.

J'ai donc le même problème pour la lecture des vidéos.
Je pense que j'ai ça depuis un update du kernel 2.6-21 et du driver
proprio mais je n'en suis pas sur.

J'ai testé sur ubuntu avec le driver xserver-xorg-video-ati et je n'ai
pas de saccade.
J'ai voulu testé ce même driver sur la lenny mais impossible de démarrer
X: (EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM

Ma question: est-ce que quelqu'un rencontre ce problème de saccade avec
fglrx 8.38.6-2 ?

merci et a+

f.

voici ma config:

fabricer@FR-PORT:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON X700
OpenGL version string: 2.0.6474 (8.38.6)


FR-PORT:~# dpkg -al | grep fglrx
fglrx-control 8.38.6-2 ii
fglrx-driver 8.38.6-2
fglrx-driver-dev 8.38.6-2
fglrx-kernel-2.6.21-2-686 8.38.6-2+2.6.21-6
fglrx-kernel-src 8.38.6-2

FR-PORT:/# cat /proc/version
Linux version 2.6.21-2-686 (Debian 2.6.21-6) (waldi@debian.org) (gcc
version 4.1.3 20070629 (prerelease) (Debian 4.1.2-13)) #1 SMP Wed Jul 11
03:53:02 UTC 2007

FR-PORT:/# cat /etc/X11/xorg.conf

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Écran générique"
Option "DPMS"
HorizSync 30-70
VertRefresh 50-160
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
Monitor "Écran générique"
DefaultDepth 24
SubSection "Display"
Modes "1280x800" "800x600"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "Extensions"
Option "Composite" "Disable"
Option "RENDER" "Enable"
EndSection


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Hugues LARRIVE
Le #9764581
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig3250741E91D3D2C7A7EB799C
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

fabrice régnier a écrit :
salut la liste ;)

glxgears a un rendu saccadé: arret toutes les 1 secondes pendant 0.2
seconde.

J'ai donc le même problème pour la lecture des vidéos.
Je pense que j'ai ça depuis un update du kernel 2.6-21 et du driver
proprio mais je n'en suis pas sur.

J'ai testé sur ubuntu avec le driver xserver-xorg-video-ati et je n'a i
pas de saccade.
J'ai voulu testé ce même driver sur la lenny mais impossible de
démarrer X: (EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open
the DRM

Ma question: est-ce que quelqu'un rencontre ce problème de saccade
avec fglrx 8.38.6-2 ?


Non, j'ai jamais pu faire fonctionner quoi que ce soit avec fglrx, pour
moi le driver libre est meilleur !
Peut-être que les deux problème ont la même cause...
Pour que ça fonction avec le driver libre il faut recompiler ton noyau
en activant :
Device Drivers -> Character devices -> Direct Rendering Manager
et Device Drivers -> Character devices -> Direct Rendering Manager ->
ATI Radeon

@+

merci et a+

f.

voici ma config:

:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON X700
OpenGL version string: 2.0.6474 (8.38.6)


FR-PORT:~# dpkg -al | grep fglrx
fglrx-control 8.38.6-2 i i
fglrx-driver 8.38.6-2
fglrx-driver-dev 8.38.6-2
fglrx-kernel-2.6.21-2-686 8.38.6-2+2.6.21-6
fglrx-kernel-src 8.38.6-2

FR-PORT:/# cat /proc/version
Linux version 2.6.21-2-686 (Debian 2.6.21-6) () (gcc
version 4.1.3 20070629 (prerelease) (Debian 4.1.2-13)) #1 SMP Wed Jul 1 1
03:53:02 UTC 2007

FR-PORT:/# cat /etc/X11/xorg.conf

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "ATI Technologies Inc Radeon Mobility X700
(PCIE)"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Écran générique"
Option "DPMS"
HorizSync 30-70
VertRefresh 50-160
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc Radeon Mobility X700
(PCIE)"
Monitor "Écran générique"
DefaultDepth 24
SubSection "Display"
Modes "1280x800" "800x600"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "Extensions"
Option "Composite" "Disable"
Option "RENDER" "Enable"
EndSection







--------------enig3250741E91D3D2C7A7EB799C
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGytEqNdTZuHWpgVIRApHSAKCFD7S/gs++8m/sjO0doqS7c7Lk5ACdGQVA
XlO+EiLunMZGeLp9H13a1Cc =wEhz
-----END PGP SIGNATURE-----

--------------enig3250741E91D3D2C7A7EB799C--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
fabrice régnier
Le #9764571
salut,

Pour que ça fonction avec le driver libre il faut recompiler ton noyau
en activant :
Device Drivers -> Character devices -> Direct Rendering Manager
et Device Drivers -> Character devices -> Direct Rendering Manager ->
ATI Radeon


sans recompiler le noyau, j'ai:
FR-PORT:/boot# grep DRM config-2.6.21-2-686
CONFIG_DRM=m
CONFIG_DRM_RADEON=m

donc, je pense que le problème pour faire fonctionner le driver libre
est ailleurs, tout comme la vérité ;) ?

a+

f.



@+
merci et a+

f.

voici ma config:

:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON X700
OpenGL version string: 2.0.6474 (8.38.6)


FR-PORT:~# dpkg -al | grep fglrx
fglrx-control 8.38.6-2 ii
fglrx-driver 8.38.6-2
fglrx-driver-dev 8.38.6-2
fglrx-kernel-2.6.21-2-686 8.38.6-2+2.6.21-6
fglrx-kernel-src 8.38.6-2

FR-PORT:/# cat /proc/version
Linux version 2.6.21-2-686 (Debian 2.6.21-6) () (gcc
version 4.1.3 20070629 (prerelease) (Debian 4.1.2-13)) #1 SMP Wed Jul 11
03:53:02 UTC 2007

FR-PORT:/# cat /etc/X11/xorg.conf

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "ATI Technologies Inc Radeon Mobility X700
(PCIE)"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Écran générique"
Option "DPMS"
HorizSync 30-70
VertRefresh 50-160
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc Radeon Mobility X700
(PCIE)"
Monitor "Écran générique"
DefaultDepth 24
SubSection "Display"
Modes "1280x800" "800x600"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "Extensions"
Option "Composite" "Disable"
Option "RENDER" "Enable"
EndSection










--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Christophe Alonso
Le #9764541
Le mardi 21 août 2007 à 14:13 +0200, fabrice régnier a écrit :
salut,



Bonjour,

> Pour que ça fonction avec le driver libre il faut recompiler ton noyau
> en activant :
> Device Drivers -> Character devices -> Direct Rendering Manager
> et Device Drivers -> Character devices -> Direct Rendering Manager ->
> ATI Radeon
sans recompiler le noyau, j'ai:
FR-PORT:/boot# grep DRM config-2.6.21-2-686
CONFIG_DRM=m
CONFIG_DRM_RADEON=m

donc, je pense que le problème pour faire fonctionner le driver libre
est ailleurs, tout comme la vérité ;) ?



Probablement
As-tu au moins supprimé le pilote d'ATI (fglrx) ?

>> voici ma config:
>>
>> :~$ fglrxinfo
>> display: :0.0 screen: 0
>> OpenGL vendor string: ATI Technologies Inc.
>> OpenGL renderer string: ATI MOBILITY RADEON X700
>> OpenGL version string: 2.0.6474 (8.38.6)
>>
>>
>> FR-PORT:~# dpkg -al | grep fglrx
>> fglrx-control 8.38.6-2 ii
>> fglrx-driver 8.38.6-2
>> fglrx-driver-dev 8.38.6-2
>> fglrx-kernel-2.6.21-2-686 8.38.6-2+2.6.21-6
>> fglrx-kernel-src 8.38.6-2



On dirait que non. Pas bien :-)

>> FR-PORT:/# cat /proc/version
>> Linux version 2.6.21-2-686 (Debian 2.6.21-6) () (gcc
>> version 4.1.3 20070629 (prerelease) (Debian 4.1.2-13)) #1 SMP Wed Jul 11
>> 03:53:02 UTC 2007
>>
>> FR-PORT:/# cat /etc/X11/xorg.conf
>>
>> Section "InputDevice"
>> Identifier "Generic Keyboard"
>> Driver "kbd"
>> Option "CoreKeyboard"
>> Option "XkbRules" "xorg"
>> Option "XkbModel" "pc105"
>> Option "XkbLayout" "fr"
>> EndSection
>>
>> Section "InputDevice"
>> Identifier "Configured Mouse"
>> Driver "mouse"
>> Option "CorePointer"
>> Option "Device" "/dev/input/mice"
>> Option "Protocol" "ImPS/2"
>> EndSection
>>
>> Section "InputDevice"
>> Identifier "Synaptics Touchpad"
>> Driver "synaptics"
>> Option "SendCoreEvents" "true"
>> Option "Device" "/dev/psaux"
>> Option "Protocol" "auto-dev"
>> Option "HorizScrollDelta" "0"
>> EndSection
>>
>> Section "Device"
>> Identifier "ATI Technologies Inc Radeon Mobility X700
>> (PCIE)"
>> Driver "fglrx"
>> BusID "PCI:1:0:0"
>> EndSection



Ah, changer fglrx pour ati ou radeon (ça revient au même).

>> Section "Monitor"
>> Identifier "Écran générique"
>> Option "DPMS"
>> HorizSync 30-70
>> VertRefresh 50-160
>> EndSection
>>
>> Section "Screen"
>> Identifier "Default Screen"
>> Device "ATI Technologies Inc Radeon Mobility X700
>> (PCIE)"
>> Monitor "Écran générique"
>> DefaultDepth 24
>> SubSection "Display"
>> Modes "1280x800" "800x600"
>> EndSubSection
>> EndSection
>>
>> Section "ServerLayout"
>> Identifier "Default Layout"
>> Screen "Default Screen"
>> InputDevice "Generic Keyboard"
>> InputDevice "Configured Mouse"
>> InputDevice "Synaptics Touchpad"
>> EndSection
>>
>> Section "DRI"
>> Mode 0666
>> EndSection
>>
>> Section "ServerFlags"
>> Option "AIGLX" "off"
>> EndSection



Pourquoi off ?

>> Section "Extensions"
>> Option "Composite" "Disable"
>> Option "RENDER" "Enable"
>> EndSection



Gné, qu'est-ce ?

Mes 2 sous.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Geoffroy
Le #9764531
Christophe Alonso a écrit :
Section "DRI"
Mode 0666
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection







Pourquoi off ?

Section "Extensions"
Option "Composite" "Disable"
Option "RENDER" "Enable"
EndSection







Gné, qu'est-ce ?



Ma carte avec le module fglrx ne supporte pas aiglx.
Par défaut avec les dernières version de xorg composite est "enable".

Geoff


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Geoffroy
Le #9764521
fabrice régnier a écrit :
salut la liste ;)

glxgears a un rendu saccadé: arret toutes les 1 secondes pendant 0.2
seconde.

J'ai donc le même problème pour la lecture des vidéos.
Je pense que j'ai ça depuis un update du kernel 2.6-21 et du driver
proprio mais je n'en suis pas sur.

J'ai testé sur ubuntu avec le driver xserver-xorg-video-ati et je n'ai
pas de saccade.
J'ai voulu testé ce même driver sur la lenny mais impossible de démarrer
X: (EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM

Ma question: est-ce que quelqu'un rencontre ce problème de saccade avec
fglrx 8.38.6-2 ?


Je l'utilise pour un x1400 et je n'ai pas de problème.

Dans tous les cas le module ati ne supporte pas la 3D pour ta carte il
me semble. Ceci dit la 2D devrait fonctionner correctement.
http://dri.freedesktop.org/wiki/ATIRadeon?highlight=%28CategoryHardware%29

si ça peut aider.

Geoff


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Eric DECORNOD
Le #9764501
--nextPart1547702.Ege2by9m5g
Content-Type: text/plain;
charset="utf-8"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le mardi 21 août 2007 15:41, Christophe Alonso a écrit :
Le mardi 21 août 2007 à 14:13 +0200, fabrice régnier a à ©crit :
> salut,
Bonjour,


Bonjour,

Il y a deux pilotes pour les ATI :
- libre :
Driver "radeon", apt-get install xserver-xorg-ati
pas de 3D, mais 2D accélérée et AIGLX/Composite pour co mpiz,beryl,...
- propriétaire :
Driver "fglrx", module-assistant auto-install fglrx-kernel-src
3D accélérée, mais ni AIGLX, ni Composite.

Chacun a son propre module DRM que Xorg charge automatiquement dans le noya u,
il vaut donc mieux redémarrer quand on veut changer de l'un à l'a utre.

> >> Option "AIGLX" "off"
Pourquoi off ?
> >> Option "Composite" "Disable"
> >> Option "RENDER" "Enable"
Gné, qu'est-ce ?


C'est une config typique pour Driver "fglrx"

XRender sert au lissage de polices et aux transparences je crois.

PS: personnellement, j'ai essayé les deux et j'utilise radeon
(c'est une machine au bureau en dual-head, pas besoin de la 3D)

Cordialement,
--
Eric DÉCORNOD

--nextPart1547702.Ege2by9m5g
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQBGywzUfI0nA934YcoRAnizAJwK9TLYFPujudQy5Hgx7XBNX8XzbQCgwtcE
8OmUsqFS8mm+hgpuIH1lYMU =6MxO
-----END PGP SIGNATURE-----

--nextPart1547702.Ege2by9m5g--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean
Le #9764171
Geoffroy a écrit :

fabrice régnier a écrit :



salut la liste ;)











glxgears a un rendu saccadé: arret toutes les 1 secondes pendant 0.2





seconde.











J'ai donc le même problème pour la lecture des vidéos.





Je pense que j'ai ça depuis un update du kernel 2.6-21 et du driver





proprio mais je n'en suis pas sur.











J'ai testé sur ubuntu avec le driver xserver-xorg-video-ati et je n'ai





pas de saccade.





J'ai voulu testé ce même driver sur la lenny mais impossible de démarrer





X: (EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM











Ma question: est-ce que quelqu'un rencontre ce problème de saccade avec





fglrx 8.38.6-2 ?





Je l'utilise pour un x1400 et je n'ai pas de problème.







Dans tous les cas le module ati ne supporte pas la 3D pour ta carte il



me semble. Ceci dit la 2D devrait fonctionner correctement.



http://dri.freedesktop.org/wiki/ATIRadeon?highlight=%28CategoryHardware%29







si ça peut aider.







Geoff











Bonjour,





J'ai cette carte: ATI Technologies Inc RV280 [Radeon 9200 SE] et j'ai eu

ce problème de saccade avec le driver fglrx que j'ai réglé en installant

le driver xserver-xorg-video-ati.



Jean


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme