fglrx et kernel 2.6.21

Le
Guy Roussin
Bonjour,

Sur une etch, est-il possible de compiler le driver fglrx avec un kernel =
2.6.21
de etch-backport (sans recompiler ce dernier et donc, sans commenter l'op=
tion
CONFIG_PARAVIRT=y) ?
Est-ce possible en utilisant m-a, un peu à la manière de ce qui se fa=
it avec
le driver proprio nvidia :
http://www.everlong.org/blog/index.php/2007/05/13/307-le-module-binaire-n=
vidia-avec-les-noyaux-linux-recents

Merci.

--
Guy Roussin
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Émile CARRY
Le #9581511
Le Wed, 04 Jul 2007 10:02:30 +0200,
Guy Roussin a écrit :

Bonjour,

Sur une etch, est-il possible de compiler le driver fglrx avec un
kernel 2.6.21 de etch-backport (sans recompiler ce dernier et donc,
sans commenter l'option CONFIG_PARAVIRT=y) ?
Est-ce possible en utilisant m-a, un peu à la manière de ce qui se
fait avec le driver proprio nvidia :
http://www.everlong.org/blog/index.php/2007/05/13/307-le-module-binaire-n vidia-avec-les-noyaux-linux-recents



Je l'ai fait il y a peu en utilisant le tout petit patch ici :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bugB0842
et ensuite, j'ai utilisé m-a sans télécharger une nouvelle fois les
sources (sinon, il écrase ta version patchée) avec l'option "-O"

mil
--
L'intelligence est la capacité de résoudre... des problèmes nouveaux.
-+- Edouard Claparède, L'éducation fonctionnelle -+-
Guy Roussin
Le #9581491
Merci beaucoup Emile, effectivement le patch suivi d'un
"m-a -O -f buil,install fglrx-kernel" fonctionne bien ...

Malheureusement pour moi, je me rend compte que
la R250 (Mobility FireGL 9000] n'est plus supporté par
les drivers ATI/AMD récents ...

Guy


Sur une etch, est-il possible de compiler le driver fglrx avec un
kernel 2.6.21 de etch-backport (sans recompiler ce dernier et donc,
sans commenter l'option CONFIG_PARAVIRT=y) ?
Est-ce possible en utilisant m-a, un peu à la manière de ce qui se
fait avec le driver proprio nvidia :
http://www.everlong.org/blog/index.php/2007/05/13/307-le-module-binair e-nvidia-avec-les-noyaux-linux-recents



Je l'ai fait il y a peu en utilisant le tout petit patch ici :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bugB0842
et ensuite, j'ai utilisé m-a sans télécharger une nouvelle fois l es
sources (sinon, il écrase ta version patchée) avec l'option "-O"

mil


Christophe Alonso
Le #9581481
Le mercredi 04 juillet 2007 à 11:06 +0200, Guy Roussin a écrit :
Merci beaucoup Emile, effectivement le patch suivi d'un
"m-a -O -f buil,install fglrx-kernel" fonctionne bien ...

Malheureusement pour moi, je me rend compte que
la R250 (Mobility FireGL 9000] n'est plus supporté par
les drivers ATI/AMD récents ...

Guy



Bonjour,

pourquoi exactement as-tu besoin des pilotes propriétaires ? J'ai
moi-même une mobility radeon 9000 (M9) qui marche très bien avec le
pilote xorg (2150 FPS env.). Elle tourne même mieux qu'elle n'a jamais
tourné avec les anciens pilotes d'ATI (8.24.X.X sont les derniers qui
marchaient à peu près ; 1800 FPS env.).
Je pense que c'est une bonne idée d'utiliser le pilote xorg pour les
cartes anciennes (la mienne à bientôt 4 ans).
Bien sûr si on est hardgamer...



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Guy Roussin
Le #9581451
> Malheureusement pour moi, je me rend compte que
la R250 (Mobility FireGL 9000] n'est plus supporté par
les drivers ATI/AMD récents ...
pourquoi exactement as-tu besoin des pilotes propriétaires ? J'ai
moi-même une mobility radeon 9000 (M9) qui marche très bien avec le
pilote xorg (2150 FPS env.). Elle tourne même mieux qu'elle n'a j amais
tourné avec les anciens pilotes d'ATI (8.24.X.X sont les derniers qui
marchaient à peu près ; 1800 FPS env.).
Je pense que c'est une bonne idée d'utiliser le pilote xorg pour les
cartes anciennes (la mienne à bientôt 4 ans).
Bien sûr si on est hardgamer...




Dans ton cas, tu mets quoi dans le ligne Driver de la section Device
de xorg.conf ?
Comment mesures-tu les fps ?

Je ne suis pas un hardgamer mais j'aimerai faire fonctionner
googleearth sur ce portable ...

Merci,

Guy
Christophe Alonso
Le #9581441
Le mercredi 04 juillet 2007 à 12:13 +0200, Guy Roussin a écrit :

Dans ton cas, tu mets quoi dans le ligne Driver de la section Device
de xorg.conf ?



Extraits de mon xorg.conf :

[...]
Section "Device"
Identifier "ATI Technologies Inc Radeon R250 [Mobility FireGL 9000]"
Driver "ati"
BusID "PCI:1:0:0"
Option "AGPMode" "4"
Option "EnablePageFlip" "true"
EndSection
[...]

À noter que man radeon donne plusieurs autres options à essayer ;-)

Comment mesures-tu les fps ?



$ glxgears -printfps

Je ne suis pas un hardgamer mais j'aimerai faire fonctionner
googleearth sur ce portable ...



Je n'ai pas essayé.

Merci,



De rien

Guy



Christophe


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Guy Roussin
Le #9581411
> $ glxgears -printfps


Je viens de mettre le driver "ati" et les options.
J'ai autour de 220 - 250 FPS, le cpu est utilisé à 100% (Pentiu m M 1600)
googleearth ne démarre pas: il reste bloqué sur le logo initial ...
Le petit jeu 3d "briquolo" est injouable tellement il est lent.

Y a peut-etre un peu de tuning à faire ?
Je ne vois pas grand chose d'anormal dans les log de Xorg.

Merci,

--
Guy
David Soulayrol
Le #9581401
Le mercredi 04 juillet 2007 à 15:26 +0200, Guy Roussin a écrit :
> $ glxgears -printfps
Je viens de mettre le driver "ati" et les options.
J'ai autour de 220 - 250 FPS, le cpu est utilisé à 100% (Pentium M 1600)
googleearth ne démarre pas: il reste bloqué sur le logo initial ...
Le petit jeu 3d "briquolo" est injouable tellement il est lent.

Y a peut-etre un peu de tuning à faire ?
Je ne vois pas grand chose d'anormal dans les log de Xorg.



Il te faut observer les lignes commençant par "WW" éventuellement, et
chercher les références à DRI. Plus simplement, glxinfo doit te
retourner une ligne: "direct rendering: Yes"

Dans le cas où tu aurais No, la 3D est prise en charge logiciellement,
et il t'est impossible d'utiliser des applications trop gourmandes dans
ce genre de ressources.

Merci,



--
David.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Christophe Alonso
Le #9581391
Le mercredi 04 juillet 2007 à 15:26 +0200, Guy Roussin a écrit :
> $ glxgears -printfps
Je viens de mettre le driver "ati" et les options.
J'ai autour de 220 - 250 FPS, le cpu est utilisé à 100% (Pentium M 1600)
googleearth ne démarre pas: il reste bloqué sur le logo initial ...
Le petit jeu 3d "briquolo" est injouable tellement il est lent.



Je crois que ça ne change pas grand chose au problème, mais certains
recommandent de mettre radeon en lieu et place de ati pour le pilote.
Sinon, j'ai testé briquolo (rigolo au passage :-)). J'ai 57% du cpu
(pentium M 1300) soit ce que prennent à peu près tous les jeux 3D
(ppracer, neverball principalement), je ne joue jamais en plein écran
ceci dit.

Y a peut-etre un peu de tuning à faire ?
Je ne vois pas grand chose d'anormal dans les log de Xorg.



Là effectivement, ça risque d'être galère. C'est bien une radeon
mobility 9000 que tu as ? Que dit glxinfo |grep rendering ?

Merci,



Si ça peut aider


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Guy Roussin
Le #9581361
> Là effectivement, ça risque d'être galère. C'est bi en une radeon
mobility 9000 que tu as ? Que dit glxinfo |grep rendering ?


Merci, j'avais oublié de desinstaller fglrx-driver ...

Guy
Publicité
Poster une réponse
Anonyme