float, no-warp,ellipsis et compagnie

Le
Etienne SOBOLE
salut.

j'ai le code suivant

<div style='float:left;'>
<div style='float:left; width:200px; height:32px;'>hop</div>
<div style='float:left; width:200px; height:32px;'>hop</div>
<div style='float:left; width:200px; height:32px;'>hop</div>
</div>

comment puis-je faire pour que lorsque je réduis la largeur du navigateur
les hop ne passent pas les uns en dessous des autres mais sorte de l'ecran
et ne soient plus affiché ? De la meme manière que lorsqu'on spécifie
overflow:hidden; white-space:nowrap; text-overflow:ellipsis;

dans un div pour eviter que le text ne retourne a la ligne.

c'est possible de faire ca pour un ensemble de div?

merci
Etienne
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
yamo'
Le #18460271
Salut,
Etienne SOBOLE a tapoté, le 22.01.2009 21:19:
comment puis-je faire pour que lorsque je réduis la largeur du navigateur
les hop ne passent pas les uns en dessous des autres mais sorte de l'ecran
et ne soient plus affiché ?



Comme ça?

Mais, je pense que tu devrais aussi poser ta question sur :
fr.comp.infosystemes.www.auteurs

Stéphane
--
Etienne SOBOLE
Le #18460781
> Comme ça?



nan.
moi je veux ques les div soit les uns a coté des autres et qu'ils y reste
lorsque je réduis la page en largeur...
en gros je voudrai qu'ils sortent par la droite du navigateur.

Etienne
yamo'
Le #18461591
Salut,
Etienne SOBOLE a tapoté, le 22.01.2009 23:53:
moi je veux ques les div soit les uns a coté des autres et qu'ils y reste
lorsque je réduis la page en largeur...



Alors ce n'est pas des div qu'il faut :

Stéphane
--
Yamo'
Le #18466391
Salut,
Le 23/01/2009 08:20, yamo' a écrit:
Salut,
Etienne SOBOLE a tapoté, le 22.01.2009 23:53:
moi je veux ques les div soit les uns a coté des autres et qu'ils y reste
lorsque je réduis la page en largeur...



Alors ce n'est pas des div qu'il faut :

Stéphane



Avec Seamonkey 2.0 a2 (équivalent de Firefox 3.1) ça fonctionne mais pas
avec Seamonkey 1.1.14(équivalent de Firefox 2.0) et non plus avec
Firefox 3.0 !
Et avec IE6 c'est encore pire!
Comme je t'avais dit dans le premier message il vaut mieux demander sur
fr.comp.infosystemes.www.auteurs où je met une copie et un Fu2.

--
Stéphane
Publicité
Poster une réponse
Anonyme