Fonction DECALER

Le
Cucky
Bonjour,
je recherche la solution au problème suivant:
Colonne A (remplie de Chiffres) - colonne B (doit afficher un
chiffre).
Colonne A colonne B
100 1 (puisque c'est le 1er chiffre de la colonne)
200 2 (puisque c'est le 2ème chiffre différent de
la colonne)
vide ne rien afficher
300 3 (puisque c'est le 3ème chiffre différent de
la colonne)
100 1 (puisque c'est la position du même chiffre
100 déjà rencontré dans colonne A)
200 2 (puisque c'est la position du même chiffre
200 déjà rencontré dans colonne A)
200 2 (puisque c'est la position du même chiffre
200 déjà rencontré dans colonne A)
350 4 (puisque c'est la position du même chiffre
déjà rencontré dans colonne A)
350 5
400 6
200 2
etc.

Quelle est la fonction que je dois mettre dans la colonne B ?
Merci de votre aide, parce que là ma tête commence à fumer
Ciao,
Corinne
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Filochard
Le #4858831
350 4 (puisque c'est la position du même chiffre
déjà rencontré dans colonne A)


Il y a une incohérence entre l'énoncé les données fournies

Cucky
Le #4858801
Oui, en effet ici il fallait lire:
350 4 (c'est le quatrième chiffre différent) - petite
erreur de COPIER/COLLER... Sorry,





On 26 sep, 23:42, "Filochard"
350 4 (puisque c'est la position du même chiffre
déjà rencontré dans colonne A)


Il y a une incohérence entre l'énoncé les données fournies



Filochard
Le #4858781
Oui, en effet ici il fallait lire:
350 4 (c'est le quatrième chiffre différent) - petite
erreur de COPIER/COLLER... Sorry,


Pour respecter une certaine logique, 400 devrait donner 5 (5° chiffre différent)
et non 6
???

Daniel.C
Le #4858751
Bonjour.
Les nombres en colonne A
en B1 : 1
en B2, à recopier vers le bas :
=SI(A2="";"";SI(NB.SI($A$1:A1;A2)>0;INDEX(B:B;EQUIV(A2;A:A;0));MAX($B$1:B1)+1))
Cordialement.
Daniel
"Cucky"
Bonjour,
je recherche la solution au problème suivant:
Colonne A (remplie de Chiffres) - colonne B (doit afficher un
chiffre).
Colonne A colonne B
100 1 (puisque c'est le 1er chiffre de la colonne)
200 2 (puisque c'est le 2ème chiffre différent de
la colonne)
vide ne rien afficher
300 3 (puisque c'est le 3ème chiffre différent de
la colonne)
100 1 (puisque c'est la position du même chiffre
100 déjà rencontré dans colonne A)
200 2 (puisque c'est la position du même chiffre
200 déjà rencontré dans colonne A)
200 2 (puisque c'est la position du même chiffre
200 déjà rencontré dans colonne A)
350 4 (puisque c'est la position du même chiffre
déjà rencontré dans colonne A)
350 5
400 6
200 2
etc.

Quelle est la fonction que je dois mettre dans la colonne B ?
Merci de votre aide, parce que là ma tête commence à fumer...
Ciao,
Corinne
Cucky
Le #4858151
Cela marche, super génial !! Trop FORT !
Merci - merci - merci - vous êtes formidable...
Corinne



On 27 sep, 00:28, "Daniel.C"
Bonjour.
Les nombres en colonne A
en B1 : 1
en B2, à recopier vers le bas :
=SI(A2="";"";SI(NB.SI($A$1:A1;A2)>0;INDEX(B:B;EQUIV(A2;A:A;0));MAX($B $1:B1)­+1))
Cordialement.
Daniel
"Cucky"
Bonjour,
je recherche la solution au problème suivant:
Colonne A (remplie de Chiffres) - colonne B (doit afficher un
chiffre).
Colonne A colonne B
100 1 (puisque c'est le 1er chiffre de la colonne)
200 2 (puisque c'est le 2ème chiffre différent de
la colonne)
vide ne rien afficher
300 3 (puisque c'est le 3ème chiffre différent de
la colonne)
100 1 (puisque c'est la position du même chiffre
100 déjà rencontré dans colonne A)
200 2 (puisque c'est la position du même chiffre
200 déjà rencontré dans colonne A)
200 2 (puisque c'est la position du même chiffre
200 déjà rencontré dans colonne A)
350 4 (puisque c'est la position du même chiffre
déjà rencontré dans colonne A)
350 5
400 6
200 2
etc.

Quelle est la fonction que je dois mettre dans la colonne B ?
Merci de votre aide, parce que là ma tête commence à fumer...
Ciao,
Corinne


Publicité
Poster une réponse
Anonyme