Fonction feuille de calcul dans VBA

Le
Chacalou13
Bonjour à tous,

Je souhaite écrire, via VBA, une formule dans un feuillet Excel.
La formule est la suivante:
=SI(ESTERR(V2/Q2);"NS";V2/Q2) , tout simplement .

Dans VBA, j'ai bien assimilé le passage en anglais et les virgules .
Cependant, je n'arrive pas à écrire la chaine de caractère "NS"..

J'ai essayé ceci:
Cells(x, y + 1).Formula = "=IF(ISERR(V2/Q2),"NS",V2/Q2)"
mais cela génère une erreur (ce que je peux comprendre à cause des guillemets)
puis tenté une feinte avec ceci :
Message = "NS"
Cells(x, y + 1).Formula = "=IF(ISERR(V2/Q2)," & Message & ",V2/Q2)"
mais le résultat est le suivant dans Excel :
=SI(ESTERR(V2/Q2);NS;V2/Q2), et donc pas de chaine de caractère mais une
variable

Merci d'avance de m'apporter de l'aide

Chacalou13
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4324231
Bonjour.
Mets :
"=IF(ISERR(V2/Q2),""NS"",V2/Q2)"
Cordialement.
Daniel
"Chacalou13" de news:
Bonjour à tous,

Je souhaite écrire, via VBA, une formule dans un feuillet Excel.
La formule est la suivante:
=SI(ESTERR(V2/Q2);"NS";V2/Q2) , tout simplement .

Dans VBA, j'ai bien assimilé le passage en anglais et les virgules ....
Cependant, je n'arrive pas à écrire la chaine de caractère "NS".....

J'ai essayé ceci:
Cells(x, y + 1).Formula = "=IF(ISERR(V2/Q2),"NS",V2/Q2)"
mais cela génère une erreur (ce que je peux comprendre à cause des
guillemets)
puis tenté une feinte avec ceci :
Message = "NS"
Cells(x, y + 1).Formula = "=IF(ISERR(V2/Q2)," & Message & ",V2/Q2)"
mais le résultat est le suivant dans Excel :
=SI(ESTERR(V2/Q2);NS;V2/Q2), et donc pas de chaine de caractère mais une
variable ...

Merci d'avance de m'apporter de l'aide ...

Chacalou13



Chacalou13
Le #4324171
Bonjour Daniel,

A là fois si simple et pourtant si incohérent ... dans ma logique et mon
raisonnement
Merci beaucoup, je me sens stupide de n'avoir pas su trouver tout seul mais
on apprend de ses erreurs alors ...

Merci encore et Bonne journée ...

Chacalou13




Bonjour.
Mets :
"=IF(ISERR(V2/Q2),""NS"",V2/Q2)"
Cordialement.
Daniel
"Chacalou13" de news:
Bonjour à tous,

Je souhaite écrire, via VBA, une formule dans un feuillet Excel.
La formule est la suivante:
=SI(ESTERR(V2/Q2);"NS";V2/Q2) , tout simplement .

Dans VBA, j'ai bien assimilé le passage en anglais et les virgules ....
Cependant, je n'arrive pas à écrire la chaine de caractère "NS".....

J'ai essayé ceci:
Cells(x, y + 1).Formula = "=IF(ISERR(V2/Q2),"NS",V2/Q2)"
mais cela génère une erreur (ce que je peux comprendre à cause des
guillemets)
puis tenté une feinte avec ceci :
Message = "NS"
Cells(x, y + 1).Formula = "=IF(ISERR(V2/Q2)," & Message & ",V2/Q2)"
mais le résultat est le suivant dans Excel :
=SI(ESTERR(V2/Q2);NS;V2/Q2), et donc pas de chaine de caractère mais une
variable ...

Merci d'avance de m'apporter de l'aide ...

Chacalou13








Publicité
Poster une réponse
Anonyme