fonction nb.si dans une macro

Le
jcp66
Bonsoir
Dans une macro je voudrais mettre dans une cellule
=NB.SI(H6:H62;1)
de façon à compter le nombre de "1"
Je veux également que la plage soit fonction d'une variable (62 n'étant pas
fixe)

Cette formule se traduit dans ma macro par:
ActiveCell.FormulaR1C1 = "=COUNTIF(R[-60]C[3]:R[-4]C[3],1)"
Je n'en comprends pas la syntaxe et je ne vois pas comment je peux faire
varier la plage.

Si quelqu'un peut m'aider, par avance merci

Cordialement
jcp
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #4908281
Bonsoir,
Ceci peut-être
'----------
ActiveCell.Formula = "=COUNTIF(H6:H" & [h65536].End(xlUp).Row & ",1)"
'----------
L'adresse de début de la plage étant: H6
L'adresse de fin de plage calculée par:
[h65536].End(xlUp).Row
Soit la dernière ligne non vide de la colonne H
--
Salutations
JJ



"jcp66" 468429d2$0$25912$
Bonsoir
Dans une macro je voudrais mettre dans une cellule
=NB.SI(H6:H62;1)
de façon à compter le nombre de "1"
Je veux également que la plage soit fonction d'une variable (62 n'étant
pas fixe)

Cette formule se traduit dans ma macro par:
ActiveCell.FormulaR1C1 = "=COUNTIF(R[-60]C[3]:R[-4]C[3],1)"
Je n'en comprends pas la syntaxe et je ne vois pas comment je peux faire
varier la plage.

Si quelqu'un peut m'aider, par avance merci

Cordialement
jcp




Jacky
Le #4908271
Re...

Et pour une cellule précise, remplacer AcvtiveCell par l'adresse de la
cellule
Pour A1
[A1] = "=COUNTIF(H6:H" & [h65536].End(xlUp).Row & ",1)"
--
Salutations
JJ



"Jacky" eU2x3$
Bonsoir,
Ceci peut-être
'----------
ActiveCell.Formula = "=COUNTIF(H6:H" & [h65536].End(xlUp).Row & ",1)"
'----------
L'adresse de début de la plage étant: H6
L'adresse de fin de plage calculée par:
[h65536].End(xlUp).Row
Soit la dernière ligne non vide de la colonne H
--
Salutations
JJ



"jcp66" 468429d2$0$25912$
Bonsoir
Dans une macro je voudrais mettre dans une cellule
=NB.SI(H6:H62;1)
de façon à compter le nombre de "1"
Je veux également que la plage soit fonction d'une variable (62 n'étant
pas fixe)

Cette formule se traduit dans ma macro par:
ActiveCell.FormulaR1C1 = "=COUNTIF(R[-60]C[3]:R[-4]C[3],1)"
Je n'en comprends pas la syntaxe et je ne vois pas comment je peux faire
varier la plage.

Si quelqu'un peut m'aider, par avance merci

Cordialement
jcp








jcp66
Le #4907091
Merci.
Mais cela ne marche pas parce qu'il y a dans la colonne des cellules vides
et il s'arrete à la 1ere.
cdlt
jcp

"Jacky" %
Re...

Et pour une cellule précise, remplacer AcvtiveCell par l'adresse de la
cellule
Pour A1
[A1] = "=COUNTIF(H6:H" & [h65536].End(xlUp).Row & ",1)"
--
Salutations
JJ



"Jacky" eU2x3$
Bonsoir,
Ceci peut-être
'----------
ActiveCell.Formula = "=COUNTIF(H6:H" & [h65536].End(xlUp).Row & ",1)"
'----------
L'adresse de début de la plage étant: H6
L'adresse de fin de plage calculée par:
[h65536].End(xlUp).Row
Soit la dernière ligne non vide de la colonne H
--
Salutations
JJ



"jcp66" 468429d2$0$25912$
Bonsoir
Dans une macro je voudrais mettre dans une cellule
=NB.SI(H6:H62;1)
de façon à compter le nombre de "1"
Je veux également que la plage soit fonction d'une variable (62 n'étant
pas fixe)

Cette formule se traduit dans ma macro par:
ActiveCell.FormulaR1C1 = "=COUNTIF(R[-60]C[3]:R[-4]C[3],1)"
Je n'en comprends pas la syntaxe et je ne vois pas comment je peux faire
varier la plage.

Si quelqu'un peut m'aider, par avance merci

Cordialement
jcp













Jacky
Le #4906981
Re...
Mais cela ne marche pas .......
Etonnant....
Exemple ici:
http://cjoint.com/?gEvITrAzU1
--
Salutations
JJ



"jcp66" 4686897c$0$5090$
Merci.
Mais cela ne marche pas parce qu'il y a dans la colonne des cellules vides
et il s'arrete à la 1ere.
cdlt
jcp

"Jacky" %
Re...

Et pour une cellule précise, remplacer AcvtiveCell par l'adresse de la
cellule
Pour A1
[A1] = "=COUNTIF(H6:H" & [h65536].End(xlUp).Row & ",1)"
--
Salutations
JJ



"Jacky" eU2x3$
Bonsoir,
Ceci peut-être
'----------
ActiveCell.Formula = "=COUNTIF(H6:H" & [h65536].End(xlUp).Row & ",1)"
'----------
L'adresse de début de la plage étant: H6
L'adresse de fin de plage calculée par:
[h65536].End(xlUp).Row
Soit la dernière ligne non vide de la colonne H
--
Salutations
JJ



"jcp66" 468429d2$0$25912$
Bonsoir
Dans une macro je voudrais mettre dans une cellule
=NB.SI(H6:H62;1)
de façon à compter le nombre de "1"
Je veux également que la plage soit fonction d'une variable (62 n'étant
pas fixe)

Cette formule se traduit dans ma macro par:
ActiveCell.FormulaR1C1 = "=COUNTIF(R[-60]C[3]:R[-4]C[3],1)"
Je n'en comprends pas la syntaxe et je ne vois pas comment je peux
faire varier la plage.

Si quelqu'un peut m'aider, par avance merci

Cordialement
jcp

















Publicité
Poster une réponse
Anonyme