Fonction ou VBA : date du prochain mardi

Le
Souriane
Bonjour,

Je voudrais créer une macro qui me donne comme résultat, la date du
prochain mardi.

Si on est mardi lorsqu’on active la macro, je veux qu’elle donne la
date d’aujourd’hui.

Et est-ce possible d’aller encore plus en détail comme suit?
Si on est mardi lorsqu’on active la macro et
qu’il est avant 15h : date d’aujourd’hui
qu’il est après 15h01 : date de mardi prochain.

Vous pouvez m’aider?

Souriane
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Corto
Le #19271081
Bonjour Souriane,
Sans VBA, : =AUJOURDHUI()-JOURSEM(AUJOURDHUI())+3

Public Function MardiProchain() As Date
Application.Volatile
If Weekday(Date) = 3 And Time > TimeValue("15:00:00") Then
MardiProchain = Date - Weekday(Date) + 10
Else
MardiProchain = Date - Weekday(Date) + 3
End If
End Function

Corto

Souriane a écrit :
Bonjour,

Je voudrais créer une macro qui me donne comme résultat, la date du
prochain mardi.

Si on est mardi lorsqu’on active la macro, je veux qu’elle donne la
date d’aujourd’hui.

Et est-ce possible d’aller encore plus en détail comme suit?
Si on est mardi lorsqu’on active la macro et
qu’il est avant 15h : date d’aujourd’hui
qu’il est après 15h01 : date de mardi prochain.

Vous pouvez m’aider?

Souriane




L.MAITRE
Le #19277261
ou ... en formule

date en A1

=SI(JOURSEM(A1;2)>2;A1+8-JOURSEM(A1;2)+1;A1-JOURSEM(A1;2)+2)

:-D

Louis

"Souriane"
Bonjour,

Je voudrais créer une macro qui me donne comme résultat, la date du
prochain mardi.

Si on est mardi lorsqu’on active la macro, je veux qu’elle donne la
date d’aujourd’hui.

Et est-ce possible d’aller encore plus en détail comme suit?
Si on est mardi lorsqu’on active la macro et
qu’il est avant 15h : date d’aujourd’hui
qu’il est après 15h01 : date de mardi prochain.

Vous pouvez m’aider?

Souriane
Souriane
Le #19277351
Merci tous, ça fonctionne super bien!

Énorme merci!!

Souriane

On 6 mai, 07:19, "L.MAITRE"
ou ...  en formule



Publicité
Poster une réponse
Anonyme