Forcé 3 caractères

Le
Gaspareau
Bonjour vous tous

J'ai une colonne avec plusieurs entrées à 1, 2 ou 3 caractères

Je voudrais que tous soit composé de 3 caractères

exemple j'ai dans mes données

1
10
100

et je voudrais avoir

001
010
100

Est-ce possible de le faire avec une formule afin que je puisse faire un
copier-coller la valeur
et ensuite ramener cela dans mon application dans le format 3 caractères ?
Bien sûr c'est du format texte et non pas du numérique

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #18626881
bonjour Gaspareau,

=SI(NBCAR(A1)=1;"00"&A1;SI(NBCAR(A1)=2;"0"&DROITE(A1;2);A1))

isabelle

Gaspareau a écrit :
Bonjour vous tous

J'ai une colonne avec plusieurs entrées à 1, 2 ou 3 caractères

Je voudrais que tous soit composé de 3 caractères

exemple j'ai dans mes données

1
10
100

et je voudrais avoir

001
010
100

Est-ce possible de le faire avec une formule afin que je puisse faire un
copier-coller la valeur
et ensuite ramener cela dans mon application dans le format 3 caractères ?
Bien sûr c'est du format texte et non pas du numérique

Merci





Gaspareau
Le #18627051
Merci beaucoup Isabelle

Grace à toi problème règlé et environ 4-5 de sauvées

Très efficace encore une fois




"isabelle" a écrit dans le message de news:

bonjour Gaspareau,

=SI(NBCAR(A1)=1;"00"&A1;SI(NBCAR(A1)=2;"0"&DROITE(A1;2);A1))

isabelle

Gaspareau a écrit :
Bonjour vous tous

J'ai une colonne avec plusieurs entrées à 1, 2 ou 3 caractères

Je voudrais que tous soit composé de 3 caractères

exemple j'ai dans mes données

1
10
100

et je voudrais avoir

001
010
100

Est-ce possible de le faire avec une formule afin que je puisse faire un
copier-coller la valeur
et ensuite ramener cela dans mon application dans le format 3 caractères
?
Bien sûr c'est du format texte et non pas du numérique

Merci






Publicité
Poster une réponse
Anonyme