Format numérique personnalisé

Le
Nito
Bonjour à tous,

Excel 2000, Windows XP

Je voudrais assigner à des cellules un format numérique monétaire dont le
nombre négatif serait entre parenthèses : ex: ( 1 234,56 $)

Les seuls choix qui s'offrent à moi quand je veux attribuer un format
numérique monétaire négatif, c'est en rouge ou précédé du signe -

Je sais qu'on peut faire un format personnalisé mais je ne sais trop comment
faire. Je voudrais aussi que ce format personnalisé soit
disponible quel que soit le fichier Excel utilisé.

Quelqu'un pourrait-il m'aider SVP?

Merci à l'avance

Nito
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
RGI
Le #4322611
Bonjour

ceci peut-il faire votre affaire

=SI(A1<0;"("&TEXTE(DROITE(A1;NBCAR(A1)-1);"### ##0,00")&"$)";A1)

Salutations

RGI

Bonjour à tous,

Excel 2000, Windows XP

Je voudrais assigner à des cellules un format numérique monétaire dont le
nombre négatif serait entre parenthèses : ex: ( 1 234,56 $)

Les seuls choix qui s'offrent à moi quand je veux attribuer un format
numérique monétaire négatif, c'est en rouge ou précédé du signe -

Je sais qu'on peut faire un format personnalisé mais je ne sais trop comment
faire. Je voudrais aussi que ce format personnalisé soit
disponible quel que soit le fichier Excel utilisé.

Quelqu'un pourrait-il m'aider SVP?

Merci à l'avance

Nito





RGI
Le #4322581
ou format / cellule / personnalisé

type

# ##0,00 $;[Rouge](# ##0,00 $)

Salutations

RGI


Bonjour

ceci peut-il faire votre affaire

=SI(A1<0;"("&TEXTE(DROITE(A1;NBCAR(A1)-1);"### ##0,00")&"$)";A1)

Salutations

RGI

Bonjour à tous,

Excel 2000, Windows XP

Je voudrais assigner à des cellules un format numérique monétaire
dont le nombre négatif serait entre parenthèses : ex: ( 1 234,56 $)

Les seuls choix qui s'offrent à moi quand je veux attribuer un format
numérique monétaire négatif, c'est en rouge ou précédé du signe -

Je sais qu'on peut faire un format personnalisé mais je ne sais trop
comment faire. Je voudrais aussi que ce format personnalisé soit
disponible quel que soit le fichier Excel utilisé.

Quelqu'un pourrait-il m'aider SVP?

Merci à l'avance

Nito






Starwing
Le #4322481
Salut Nito,

Essaie ceci :
Aller dans: Panneau de configuration
à : Paramètres régionaux
Dans l'onglet : Symbole monétaire
Au champ : Format de nombre négatif:
Changement pour : (1,1)

Starwing
Nito
Le #4321261
Merci Starwing et TGI,
Malheureusement Starwig, le fait de modifier le format de nombre négatif
(nombres et symbole monétaire) ne fonctionne pas (même après avoir redémarré
mon ordi).
La 2e solution de RGI fonctionne pour un fichier seulement. Je n'arrive pas
à sauvegarder ce format dans Excel pour pouvoir l'utiliser dans d'autres
fichiers.

Est-il possible de conserver ce format de façon permanente dans Excel?

Merci à l'avance.

Nito
RGI
Le #4257551
faire une macro complémentaire

avec :
Selection.NumberFormat = "#,##0.00 $;[Red](#,##0.00 $) "

voilà le code de la macro complémentaire à sauvegarder en xla

Public Const NOMFORMAT As String = "MonFormat"


Sub Auto_Open()
Dim mBar As CommandBarControl

On Error Resume Next
Set mBar = Application.CommandBars("Cell").Controls(NOMFORMAT)
On Error GoTo 0
If mBar Is Nothing Then
With Application.CommandBars("Cell")
With .Controls.Add(msoControlButton)
.Caption = NOMFORMAT
.OnAction = "Monformat"
.FaceId = 65
End With
End With
End If
End Sub

Sub Auto_Close()

On Error Resume Next
Application.CommandBars("Cell").Controls(NOMFORMAT).Delete
End Sub

Sub Monformat()
Selection.NumberFormat = "#,##0.00 $;[Red](#,##0.00 $) "
End Sub


la mise au format sera disponible au clic droit de la souris sous MonFormat
revenir si besoin

salutations

RGI

Merci Starwing et TGI,
Malheureusement Starwig, le fait de modifier le format de nombre négatif
(nombres et symbole monétaire) ne fonctionne pas (même après avoir redémarré
mon ordi).
La 2e solution de RGI fonctionne pour un fichier seulement. Je n'arrive pas
à sauvegarder ce format dans Excel pour pouvoir l'utiliser dans d'autres
fichiers.

Est-il possible de conserver ce format de façon permanente dans Excel?

Merci à l'avance.

Nito





Nito
Le #4257201
Public Const NOMFORMAT As String = "MonFormat"

Merci de ton aide RGI,

Ton idée est excellente.
Mais j'essaie de l'appliquer mais il y a une erreur de syntaxe lorsque je
veux exécuter la macro complémentaire.
Comme je ne suis pas très avancé en Excel, pourrais-tu regarder ce qui ne va
pas, SVP.


Merci

Nito



Sub Auto_Open()
Dim mBar As CommandBarControl

On Error Resume Next
Set mBar = Application.CommandBars("Cell").Controls(NOMFORMAT)
On Error GoTo 0
If mBar Is Nothing Then
With Application.CommandBars("Cell")
With .Controls.Add(msoControlButton)
.Caption = NOMFORMAT
.OnAction = "Monformat"
.FaceId = 65
End With
End With
End If
End Sub

Sub Auto_Close()

On Error Resume Next
Application.CommandBars("Cell").Controls(NOMFORMAT).Delete
End Sub

Sub Monformat()
Selection.NumberFormat = "#,##0.00 $;[Red](#,##0.00 $) "
End Sub
Publicité
Poster une réponse
Anonyme