format personalisé

Le
eneric
Bonjour, à tous les benevoles
qui font le maximum pour nous aider
je voudrais savoir si dans un format personalisé
je peux faire reference à une cellule
j'ai "X" participants sur: [AJ13] (valeur cellule)
j'ai essayé pas mal de formats du genre :
0" /" & [AJ13] a chaque fois il me prends cela pour du texte
ou suis je obligé de passer par VBA
merci

--
eneric
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Modeste
Le #5330211
Bonsour® eneric avec ferveur ;o))) vous nous disiez :

Bonjour, à tous les benevoles
qui font le maximum pour nous aider
je voudrais savoir si dans un format personalisé
je peux faire reference à une cellule
j'ai "X" participants sur: [AJ13] (valeur cellule)
j'ai essayé pas mal de formats du genre :
0" /" & [AJ13] a chaque fois il me prends cela pour du texte
ou suis je obligé de passer par VBA


=TEXTE(X/AJ13;"???/"&AJ13)&" participants"


--
--
@+
;o)))

eneric
Le #5330071
eneric
Bonsour® eneric avec ferveur ;o))) vous nous disiez :

Bonjour, à tous les benevoles
qui font le maximum pour nous aider
je voudrais savoir si dans un format personalisé
je peux faire reference à une cellule
j'ai "X" participants sur: [AJ13] (valeur cellule)
j'ai essayé pas mal de formats du genre :
0" /" & [AJ13] a chaque fois il me prends cela pour du texte
ou suis je obligé de passer par VBA


=TEXTE(X/AJ13;"???/"&AJ13)&" participants"
Merci de t'interrer a mon cas modeste

donc je considere que je dois mettre cette formule dans la cellule
mais ca ne colle pas car je mets le resultat par cette ligne de code :
Sheets("Sorties").Range("G9").Offset((Nm_Sortie - 1), 0).Value = _
Sheets("B-D").[C2:E2].Value
donc je voudrais juste voir apparaitre le nbre de participants (AJ13)
apres se nombre

--
eneric


Modeste
Le #5330021
Bonsour® Modeste avec ferveur ;o))) vous nous disiez :

=TEXTE(X/AJ13;"???/"&AJ13)&" participants"
ne pas tenir compte de cette réponse rapide non testée



--
--
@+
;o)))

Modeste
Le #5329951
Bonsour® eneric avec ferveur ;o))) vous nous disiez :

Merci de t'interrer a mon cas modeste
donc je considere que je dois mettre cette formule dans la cellule


Surtout ne pas tenir compte de ma réponse précédente qui n'a pas été testée et
qui est totalement érronée...

mais ca ne colle pas car je mets le resultat par cette ligne de code :
Sheets("Sorties").Range("G9").Offset((Nm_Sortie - 1), 0).Value = _
Sheets("B-D").[C2:E2].Value
donc je voudrais juste voir apparaitre le nbre de participants (AJ13)
apres se nombre


qu'est censé contenir la plage Sheets("B-D").[C2:E2] ??????

Sheets("Sorties").Range("G9").Offset((Nm_Sortie - 1), 0).Value = _
application.Sum(Sheets("B-D").[C2:E2]) & " sur " & [AJ13]

ou bien ????
Sheets("Sorties").Range("G9").Offset((Nm_Sortie - 1), 0).Value = _
application.CountA(Sheets("B-D").[C2:E2]) & " sur " & [AJ13]



--
--
@+
;o)))

eneric
Le #5329931
eneric vous demande
Bonsour® Modeste avec ferveur ;o))) vous nous disiez :

=TEXTE(X/AJ13;"???/"&AJ13)&" participants"
ne pas tenir compte de cette réponse rapide non testée

j'ai essayé avec & la cellule comme ceci

[C2:E2].Value & [AJ13]
ca bug

--
eneric


eneric
Le #5329801
eneric vous demande


qu'est censé contenir la plage Sheets("B-D").[C2:E2] ??????
elle contient le nombre d' inscrits sur une sortie

formule dans cellule "=NB.SI(D4:E404;"<>") & " " & "inscrit (s)""

Sheets("Sorties").Range("G9").Offset((Nm_Sortie - 1), 0).Value = _
application.Sum(Sheets("B-D").[C2:E2]) & " sur " & [AJ13]

ou bien ????
Sheets("Sorties").Range("G9").Offset((Nm_Sortie - 1), 0).Value = _
application.CountA(Sheets("B-D").[C2:E2]) & " sur " & [AJ13]
je vais tester ton code car je vsouhaite rajouter : "sur X "Adherents"

avec mon essai : & [AJ13] ca bugue

--


--
eneric

Philippe.R
Le #5329791
Bonsoir,
il me semble que tu gagnerais à remplacer : "=NB.SI(D4:E404;"<>") & " " &
"inscrit (s)""
par =NB.SI(D4:E404;"<>")
avec une cellule au format personnalisé : # ##0" inscrit(s)"
Tu pourrais ainsi continuer à utiliser le résultat de la formule comme un
nombre, alors qu'actuellement tu obtiens du texte.
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"eneric" news:
eneric vous demande


qu'est censé contenir la plage Sheets("B-D").[C2:E2] ??????
elle contient le nombre d' inscrits sur une sortie

formule dans cellule "=NB.SI(D4:E404;"<>") & " " & "inscrit (s)""

Sheets("Sorties").Range("G9").Offset((Nm_Sortie - 1), 0).Value = _
application.Sum(Sheets("B-D").[C2:E2]) & " sur " & [AJ13]

ou bien ????
Sheets("Sorties").Range("G9").Offset((Nm_Sortie - 1), 0).Value = _
application.CountA(Sheets("B-D").[C2:E2]) & " sur " & [AJ13]
je vais tester ton code car je vsouhaite rajouter : "sur X "Adherents"

avec mon essai : & [AJ13] ca bugue

--


--
eneric





Modeste
Le #5329781
Bonsour® eneric avec ferveur ;o))) vous nous disiez :

qu'est censé contenir la plage Sheets("B-D").[C2:E2] ??????
elle contient le nombre d' inscrits sur une sortie

il s'agit d'une plage de 3 cellules, ce ne peut donc etre "le nombre"

c'est pourquoi j'ai proposé plus loin : application.Sum(Sheets("B-D").[C2:E2])


formule dans cellule "=NB.SI(D4:E404;"<>") & " " & "inscrit (s)""

Sheets("Sorties").Range("G9").Offset((Nm_Sortie - 1), 0).Value = _
application.Sum(Sheets("B-D").[C2:E2]) & " sur " & [AJ13]


je vais tester ton code car je vsouhaite rajouter : "sur X
"Adherents" avec mon essai : & [AJ13] ca bugue


oui [AJ13] fait référence à la feuille active
il faudrait peut-etre alors qualifier cette référence
Sheets("Sorties").Range("G9").Offset((Nm_Sortie - 1), 0).Value = _
application.Sum(Sheets("B-D").[C2:E2]) & " sur " &
Sheets("Sorties").Range("AJ13") & " adhérents"



--
--
@+
;o)))


eneric
Le #5329761
eneric vous dit
oui ca marche modeste
il fallait que je reprecise pour la concatenation d'aller sur la
feuille "B-D" et j'ai bien "X" inscrits sur "X"Adherents
merci bonne nuit

--
eneric
Publicité
Poster une réponse
Anonyme