formatage du résultat d'une cellule par une mcro

Le
Manu Puig
Bonjour

je voudrais savoir comment faire pour appliquer un formatage fait par une
macro au résultat d'une cellule :

je voudrais que la cellule qui contient le résultat du calcul
=SOMME(A1;B1;C1) -donc un nombre- soit formatée avec la macro que je vais
essayer de créer qui s'appellera POPAPC(str_in)

merci de votre aide et des pistes que vous pourrez me proposer.

Manuel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4605871
Bonsoir.
Dans la macro suivante, deux paramètres sont passés :
- c : adresse de la cellule
- str_in format désiré

Sub POPAPC(c As Range, str_in As String)
If IsNumeric(c.Value) Then
c.NumberFormat = str_in
Else
MsgBox "la valeur de la cellule " & _
c.Address & " n'est pas numérique"
End If
End Sub

Cordialement.
Daniel
"Manu Puig" %23fk3T%
Bonjour

je voudrais savoir comment faire pour appliquer un formatage fait par une
macro au résultat d'une cellule :

je voudrais que la cellule qui contient le résultat du calcul
=SOMME(A1;B1;C1) -donc un nombre- soit formatée avec la macro que je vais
essayer de créer qui s'appellera POPAPC(str_in)

merci de votre aide et des pistes que vous pourrez me proposer.

Manuel





Manu Puig
Le #4605611
Merci pour cette réponse, mais je cherche plutôt à savoir comment utiliser
une fonction dans une cellule :

=POPAPC(SOMME(M2:M7)) où la somme de M2 à M7 est affectée par la fonction
POPAPC(str_in)

Cordialement,
Manuel


"Daniel" news:%
Bonsoir.
Dans la macro suivante, deux paramètres sont passés :
- c : adresse de la cellule
- str_in format désiré

Sub POPAPC(c As Range, str_in As String)
If IsNumeric(c.Value) Then
c.NumberFormat = str_in
Else
MsgBox "la valeur de la cellule " & _
c.Address & " n'est pas numérique"
End If
End Sub

Cordialement.
Daniel
"Manu Puig" %23fk3T%
Bonjour

je voudrais savoir comment faire pour appliquer un formatage fait par
une


macro au résultat d'une cellule :

je voudrais que la cellule qui contient le résultat du calcul
=SOMME(A1;B1;C1) -donc un nombre- soit formatée avec la macro que je
vais


essayer de créer qui s'appellera POPAPC(str_in)

merci de votre aide et des pistes que vous pourrez me proposer.

Manuel









Daniel
Le #4605501
Pourquoi ne pas écrire simplement :
=SOMME(M2:M7)
?
Daniel
"Manu Puig" %
Merci pour cette réponse, mais je cherche plutôt à savoir comment utiliser
une fonction dans une cellule :

=POPAPC(SOMME(M2:M7)) où la somme de M2 à M7 est affectée par la fonction
POPAPC(str_in)

Cordialement,
Manuel


"Daniel" news:%
Bonsoir.
Dans la macro suivante, deux paramètres sont passés :
- c : adresse de la cellule
- str_in format désiré

Sub POPAPC(c As Range, str_in As String)
If IsNumeric(c.Value) Then
c.NumberFormat = str_in
Else
MsgBox "la valeur de la cellule " & _
c.Address & " n'est pas numérique"
End If
End Sub

Cordialement.
Daniel
"Manu Puig" %23fk3T%
Bonjour

je voudrais savoir comment faire pour appliquer un formatage fait par
une


macro au résultat d'une cellule :

je voudrais que la cellule qui contient le résultat du calcul
=SOMME(A1;B1;C1) -donc un nombre- soit formatée avec la macro que je
vais


essayer de créer qui s'appellera POPAPC(str_in)

merci de votre aide et des pistes que vous pourrez me proposer.

Manuel














Manu Puig
Le #4605461
parce que je veux mettre en forme le résultat de SOMME(M2:M7) en utilisant
la fonction POPAPC()
voilà pourquoi.
Manuel

"Daniel" news:u%
Pourquoi ne pas écrire simplement :
=SOMME(M2:M7)
?
Daniel
"Manu Puig" %
Merci pour cette réponse, mais je cherche plutôt à savoir comment
utiliser


une fonction dans une cellule :

=POPAPC(SOMME(M2:M7)) où la somme de M2 à M7 est affectée par la
fonction


POPAPC(str_in)

Cordialement,
Manuel


"Daniel" news:%
Bonsoir.
Dans la macro suivante, deux paramètres sont passés :
- c : adresse de la cellule
- str_in format désiré

Sub POPAPC(c As Range, str_in As String)
If IsNumeric(c.Value) Then
c.NumberFormat = str_in
Else
MsgBox "la valeur de la cellule " & _
c.Address & " n'est pas numérique"
End If
End Sub

Cordialement.
Daniel
"Manu Puig" %23fk3T%
Bonjour

je voudrais savoir comment faire pour appliquer un formatage fait par
une


macro au résultat d'une cellule :

je voudrais que la cellule qui contient le résultat du calcul
=SOMME(A1;B1;C1) -donc un nombre- soit formatée avec la macro que je
vais


essayer de créer qui s'appellera POPAPC(str_in)

merci de votre aide et des pistes que vous pourrez me proposer.

Manuel


















Daniel
Le #4605371
"Manu Puig"
parce que je veux mettre en forme le résultat de SOMME(M2:M7) en utilisant
la fonction POPAPC()
voilà pourquoi.
Manuel


Bonjour.
Une fonction renvoie une valeur. Elle ne te permet pas de formater la
cellule.
Cordialement.
Daniel

Manu Puig
Le #4605131
Bonjour,
bon, comment puis-je arriver à mes fins ???
Cordialement,
Manuel

"Daniel" news:OLL%

"Manu Puig"
parce que je veux mettre en forme le résultat de SOMME(M2:M7) en
utilisant


la fonction POPAPC()
voilà pourquoi.
Manuel


Bonjour.
Une fonction renvoie une valeur. Elle ne te permet pas de formater la
cellule.
Cordialement.
Daniel





Daniel
Le #4605081
Avec une macro (voir mon post du 04/07 20:17)
Daniel
"Manu Puig"
Bonjour,
bon, comment puis-je arriver à mes fins ???
Cordialement,
Manuel

"Daniel" news:OLL%

"Manu Puig"
parce que je veux mettre en forme le résultat de SOMME(M2:M7) en
utilisant


la fonction POPAPC()
voilà pourquoi.
Manuel


Bonjour.
Une fonction renvoie une valeur. Elle ne te permet pas de formater la
cellule.
Cordialement.
Daniel









Publicité
Poster une réponse
Anonyme