Formula en vba

Le
Gen
Bonjour,

Je voudrais créer une macro qui me permettrais de changer une formule dans
une cellule. La cellule contient déjà une formule, mais je voudrais la
remplacer. La nouvelle formule serait de la forme suivante:

=SI($F$88=1;RECHERCHEV($A$88;Feuil1$A$5:$C$8;2;FAUX);SI(ESTNA(RECHERCHEV($A$88-1;Feuil1!$A$5:$C$8;2;FAUX)*(1+$A$91));RECHERCHEV($A$88-2;Feuil1$A$5:$C$8;2;FAUX)*(1+$A$91)*(1+$A$91);RECHERCHEV($A$88-1;Feuil1!$A$5:$C$8;2;FAUX)*(1+$A$91)))

est-ce que quelqu'un pourrait m'aider ?

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4262381
Bonsoir.

Sub test()
ActiveCell.FormulaLocal = _
"=SI($F$88=1;RECHERCHEV($A$88;Feuil1!$A$5:$C$8;2;FAUX)" & _
";SI(ESTNA(RECHERCHEV($A$88-1;Feuil1!$A$5:$C$8;2;FAUX)" & _
"*(1+$A$91));RECHERCHEV($A$88-2;Feuil1!$A$5:$C$8;2;FAUX)" & _
"*(1+$A$91)*(1+$A$91);RECHERCHEV($A$88-1;Feuil1!$A$5:$C$8;2;FAUX)" & _
"*(1+$A$91)))"
End Sub

Cordialement.
Daniel
"Gen"
Bonjour,

Je voudrais créer une macro qui me permettrais de changer une formule dans
une cellule. La cellule contient déjà une formule, mais je voudrais la
remplacer. La nouvelle formule serait de la forme suivante:

=SI($F$88=1;RECHERCHEV($A$88;Feuil1$A$5:$C$8;2;FAUX);SI(ESTNA(RECHERCHEV($A$88-1;Feuil1!$A$5:$C$8;2;FAUX)*(1+$A$91));RECHERCHEV($A$88-2;Feuil1$A$5:$C$8;2;FAUX)*(1+$A$91)*(1+$A$91);RECHERCHEV($A$88-1;Feuil1!$A$5:$C$8;2;FAUX)*(1+$A$91)))

est-ce que quelqu'un pourrait m'aider ?

Merci




cousinhub
Le #4262351
Bonsoir, dans ton usine à gaz, il y aurait pas la place pour une éolienne?
A mon avis, un petit fichier exemple, exempt de toutes données
confidentielles, et posté sur ce forum, permettrait à tous le
contributeurs de pouvoir t'aider.
pour un lien :
http://www.cjoint.com/
Dans ton fichier, tu remplis les cellules, et tu mets le résultat désiré
dans la cellule cible, en explicitant tes conditions.
Bon courage

Bonjour,

Je voudrais créer une macro qui me permettrais de changer une formule dans
une cellule. La cellule contient déjà une formule, mais je voudrais la
remplacer. La nouvelle formule serait de la forme suivante:

=SI($F$88=1;RECHERCHEV($A$88;Feuil1$A$5:$C$8;2;FAUX);SI(ESTNA(RECHERCHEV($A$88-1;Feuil1!$A$5:$C$8;2;FAUX)*(1+$A$91));RECHERCHEV($A$88-2;Feuil1$A$5:$C$8;2;FAUX)*(1+$A$91)*(1+$A$91);RECHERCHEV($A$88-1;Feuil1!$A$5:$C$8;2;FAUX)*(1+$A$91)))

est-ce que quelqu'un pourrait m'aider ?

Merci




Publicité
Poster une réponse
Anonyme